Algoritmos e Programação - 2013.1 - Aula 5

767 views

Published on

Algoritmos e Programação - 2013.1 - Aula 5

Published in: Technology
0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
767
On SlideShare
0
From Embeds
0
Number of Embeds
2
Actions
Shares
0
Downloads
43
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Algoritmos e Programação - 2013.1 - Aula 5

  1. 1. Algoritmos e Programação Prof. Thyago Prof.º Thyago Maia 2013.1
  2. 2. Aula 5Objetivos • Apresentar as estruturas  ( ç ) condicionais (continuação) 2
  3. 3. Estruturas CondicionaisEstruturas Condicionais
  4. 4. Estruturas Condicionais• Também podemos implementar estruturas  condicionais com mais de uma condição (expressão);• Subexpressões podem formar uma única expressão a Subexpressões podem formar uma única expressão a  partir do uso dos operadores E ou OU;• Para sabermos se determinada expressão será  verdadeira ou falsa, seguimos a mesma lógica vista  verdadeira ou falsa seguimos a mesma lógica vista nas aulas de linearização e modularização; 4
  5. 5. Estruturas CondicionaisAlgoritmo “exemplo_genero”Var sexo: literal idade: inteiroInicio escreva(“Digite seu sexo (M ou F): ”) leia(sexo) escreva(“Digite sua idade: ”) leia(idade) ( ) se((sexo=“M”) e (idade=18))entao escreva( Você escreva(“Você já se alistou nasforças armadas?”) fimsefimalgoritmo 5
  6. 6. Estruturas CondicionaisAlgoritmo “exemplo_genero” _Var estado: literalInicio escreva(“Digite seu estado (PE, PB, RJ ou SP):”) leia(estado) se((estado=“PE”) ou (estado=“PB”))entao escreva(“Você é nordestino”) (“V ê d ti ”) fimse se((estado=“RJ”) ou (estado=“SP”))entao escreva(“Você é do sudeste”) fimsefimalgoritmo 6
  7. 7. Exercícios
  8. 8. Exercícios• Faça um algoritmo que lê um número inteiro e  p g verifica se o mesmo é positivo ou negativo; 8
  9. 9. Exercícios• Faça um algoritmo que verifica quanto cada  p pessoa deverá pagar para entrar em um  p g p cinema. O algoritmo deverá solicitar o sexo e a  idade do indivíduo. As condições de  idade do indivíduo As condições de pagamento são as seguintes: • Oi O ingresso custa R$ 10,00 para pessoas com idade  R$ 10 00 id d maior ou igual a 17 anos; • Mulheres menores de 17 anos pagam meia  entrada; • Homens menores de 17 anos pagam R$ 7,00; 9
  10. 10. Exercícios• Faça um algoritmo para controle de entrada  g em uma boate. Tal algoritmo deverá avisar se  uma pessoa pode entrar ou não, e quanto  deverá pagar para entrar. deverá pagar para entrar • Homens e mulheres abaixo de 18 anos não podem  entrar; • Mulheres pagam R$ 10,00; • Homens pagam R$ 20 00; Homens pagam R$ 20,00;  10
  11. 11. Comando de Seleção MúltiplaComando de Seleção Múltipla
  12. 12. Comando de Seleção Múltipla• Em algumas situações, nossos algoritmos  p dependem da análise de duas ou mais  condições;• O comando se nos permite implementar tais O comando se nos permite implementar tais  situações, porém de forma limitada e, em  alguns casos, ineficiente: l f • Imagine implementar 100 estruturas se para 100  g p p condições diferentes! • Tal comando obriga o programador a escrever Tal comando obriga o programador a escrever  várias linhas de código; 12
  13. 13. Comando de Seleção Múltipla• Para várias condições, podemos utilizar o  ç p comando de seleção múltipla escolha;• Sintaxe:escolha (variavel)Caso valor_1 // Instruções que serão executadas caso // a condição seja verdadeiraCaso valor_2 // Instruções que serão executadas caso // a condição seja falsaOutrocaso // Instruções que serão executadas se // nenhuma condição anterior seja atendidafimescolha 13
  14. 14. Comando de Seleção Múltipla• As palavras reservadas escolha e fimescolha g delimitam a região da estrutura condicional;• Tal estrutura seleciona uma variável que será  comparada com os valores especificados ao  comparada com os valores especificados ao lado da palavra reservada caso;• O caso tem funcionamento similar ao se;• O outrocaso tem funcionamento similar ao O outrocaso tem funcionamento similar ao  senao, visto anteriormente; 14
  15. 15. Comando de Seleção MúltiplaAlgoritmo “exemplo_caso”Var sexo: literalInicio escreval(“Digite seu sexo (M ou F): ”) leia(sexo) escolha(idade) caso “M” escreval(“O usuário é homem”) caso “F” escreval(“O usuário é mulher”) ( ) outrocaso escreval(“Erro de caractere!”) fimescolhafimalgoritmo 15
  16. 16. Comando de Seleção MúltiplaAlgoritmo “exemplo caso 2” exemplo_caso_2Var time: literalInicio escreval(“Digite seu time: ”) leia(time) l i ( i ) escolha(time) caso “sport” escreval(“Parabéns!!!”) outrocaso escreval(“Meus pêsames!”) fimescolhafimalgoritmo 16
  17. 17. Exercícios
  18. 18. Exercícios• Faça um algoritmo que lê um número de 1 a 7  p e informa o dia da semana correspondente,  sendo domingo o número 1. Caso o número  esteja fora da faixa, o algoritmo deverá exibir  esteja fora da faixa o algoritmo deverá exibir uma mensagem de erro. 18
  19. 19. Exercícios• Faça um algoritmo que receba dois números,  q p p ç um caractere que representa uma operação  matemática (+, ‐, *, /) e efetue o cálculo  matemático baseado na escolha do usuário. O  matemático baseado na escolha do usuário O resultado deverá ser exibido em seguida. 19
  20. 20. Explore o assunto!Explore o assunto!
  21. 21. Explore o assunto! p• Referências – Introdução aos  ç algoritmos(TONET, B.,  KOLIVER, C.): Tópico 10 e  , ) p Exercícios da Página 42; – Disponível em Disponível em   http://www.claudiorodol fo.com/ftc/ap/manual_vi fo com/ftc/ap/manual vi sualg.pdf 21
  22. 22. Explore o assunto! p• Referências – Fundamentos da  programação de  computadores  p (ASCENCIO, A. F. G.,  CAMPOS, E. A. V.):  , ) Exercícios Propostos,  p g páginas 88, 89, 90, 91,  , , , , 92; 22

×