Cumulus networks conversion guide

Scott Suehle
Scott SuehleCommunity Manager at Cumulus Networks
v
Cumulus Linux Conversion Guides
Cumulus Networks
May 24, 2016
Evolution of the CLI
§Where did things move?
cumulusnetworks.com 2
interfaces {
ge-0/1/1 {
unit 0 {
family bridge {
interface-mode access;
vlan-id 100;
}
}
}
ge-0/1/2 {
unit 0 {
family bridge {
interface-mode access;
vlan-id 200;
}
}
}
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports swp1 swp2
bridge-vids 100 200
auto swp1
iface swp1
bridge-access 100
auto swp2
iface swp2
bridge-access 200
▪ Cisco ▪ Juniper ▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode access
switchport access vlan 100
interface ethernet 1/2
switchport mode access
switchport access vlan 200
Defining a Switch Port
cumulusnetworks.com 3
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
auto bridge
iface bridge
bridge-ports swp1
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport
Adding an IP Address
cumulusnetworks.com 4
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
address [ipv4-address/subnet-mask]
address [ipv6-address/subnet-mask]
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# no switchport
switch(config-if)# ip address [ipv4-address/subnet-mask]
switch(config-if)# ipv6 address [ipv6-address/subnet-mask]
Setting Speed, Duplex, MTU, and Auto-negotiation for an Interface
cumulusnetworks.com 5
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
link-speed [speed]
link-duplex [full|half]
mtu [1500 - 9216]
link-autoneg [on|off]
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# speed [speed]
switch(config-if)# duplex [full|half]
switch(config-if)# mtu [1500 - 9216]
switch(config-if)# [no] negotiate auto
Configuring Trunks
cumulusnetworks.com 6
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode trunk
interface ethernet 1/2
switchport mode trunk
Cisco
Pruning a Trunk
cumulusnetworks.com 7
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
auto swp1
iface swp1
bridge-vids 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode trunk
switchport trunk allowed vlan 200
interface ethernet 1/2
switchport mode trunk
Cisco
Configuring Access Ports
cumulusnetworks.com 8
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
auto swp1
iface swp1
bridge-access 100
auto swp2
iface swp2
bridge-access 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode access
switchport access vlan 100
interface ethernet 1/2
switchport mode access
switchport access vlan 200
Cisco
Changing the Native (Untagged) VLAN for a Single Trunk
cumulusnetworks.com 9
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 1-200
auto swp1
iface swp1
bridge-pvid 100
auto swp2
iface swp2
bridge-pvid 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 1-200
interface ethernet 1/1-2
switchport mode trunk
switchport trunk allowed vlan 1-200
interface ethernet 1/1
switchport trunk native vlan 100
interface ethernet 1/2
switchport trunk native vlan 200
Cisco
EtherChannels/Bonds
cumulusnetworks.com 10
vlan 10
!
interface GigabitEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan10
ip address 10.10.10.10 255.255.255.0
Cisco WS-C3560X-24 12.2(55)SE5
auto bond1
iface bond1
bond-slaves glob swp19-20
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan10
iface vlan10
bridge-ports bond1.10
address 10.10.10.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Cisco
EtherChannels/Bonds
cumulusnetworks.com 11
interface Ethernet37
switchport mode trunk
channel-group 2 mode active
interface Ethernet38
switchport mode trunk
channel-group 2 mode active
interface Port-Channel2
switchport trunk allowed vlan 12
switchport mode trunk
interface Vlan12
ip address 12.12.12.12/24
Arista DCS-7148S-R 4.13.5F
auto bond2
iface bond2
bond-slaves glob swp37-38
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan12
iface vlan12
bridge-ports bond2.12
address 12.12.12.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Arista
EtherChannels/Bonds
cumulusnetworks.com 12
feature interface-vlan
feature lacp
vlan 14
interface Ethernet1/39
switchport mode trunk
channel-group 3 mode active
interface Ethernet1/40
switchport mode trunk
channel-group 3 mode active
interface port-channel3
switchport mode trunk
interface Vlan14
no shutdown
ip address 14.14.14.14/24
Cisco Nexus3064 5.0(3)U2(2c)
auto bond3
iface bond3
bond-slaves glob swp39-40
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan14
iface vlan14
bridge-ports bond3.14
address 14.14.14.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Cisco
Spanning Tree Configuration
cumulusnetworks.com 13
auto swp1
iface swp1
mstpctl-portadminedge yes
interface Gigabit0/0
spanning-tree portfast
Immediately bring an interface configured as an access or trunk port to the forwarding state.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 14
auto swp1
iface swp1
mstpctl-bpduguard yes
!
spanning-tree portfast bpduguard default
!
interface Gigabit0/0
spanning-tree portfast
Enabling/disabling the BPDU guard configuration.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 15
auto swp1
iface swp1
mstpctl-portbpdufilter yes
!
spanning-tree portfast bpdufilter default
!
interface Gigabit0/0
spanning-tree portfast
Enables BPDU filter on a switch port, which filters BPDUs in both directions.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 16
auto swp1
iface swp1
mstpctl-treeportprio 128
interface Gigabit0/0
spanning-tree port-priority 128
Configure the port priority for an interface. The default for both operating systems is 128.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 17
auto vlan1
iface vlan1
mstpctl-treeprio 32768
bridge-ports swp1
spanning-tree vlan 1 priority 32768
Configure the switch's priority for a bridge/VLAN. The default for both operating systems is 32768.
▪ Cumulus Linux Cisco
More Spanning Tree Info (Conversion Guide)
cumulusnetworks.com 18
https://support.cumulusnetworks.com/hc/en-us/articles/206908397
Spanning Tree
Industry-standard Loop Prevention for L2
Access Lists
cumulusnetworks.com 19
iptables -A {FORWARD | INPUT | OUTPUT} -j {ACCEPT | DROP | POLICE | SPAN | ERSPAN} | -p <protocol>
-s <source> --sport [<ports>] -d destination> --dport [<ports>] [<options>]
iptables -A FORWARD -j ACCEPT -p tcp -s 10.10.10.0/24 -d 3.3.3.3/24 --dport 80
iptables/netfilter (including Cumulus Linux)
access-list <number> {permit | deny} <protocol> <source> [<ports>] <destination> [<ports>] [<options>]
IOS Standard Syntax
ip access-list extended {<number> | <name>}
[<sequence>] {permit | deny} <protocol> <source> [<ports>]<destination> [<ports>] [<options>]
IOS Extended Syntax (including NX-OS)
ip access-list extended allow_http
10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www
access-list 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www
(Example permit http port 80 traffic to 10.10.10.0/24 subnet)
Block ICMP Echo Requests on the Specified Switch Port
cumulusnetworks.com 20
iptables -A FORWARD -j DROP -i swp1 -p icmp --icmp-type echo-request
ip access-list extended block_icmp
deny icmp any any echo
interface g0/0
ip access-group block_icmp in
Cumulus Linux
Cisco
Block SSH Trafficfrom the Specified Subnet (5.5.5.0/24)
cumulusnetworks.com 21
iptables -A INPUT -j DROP -p tcp -s 5.5.5.0/24 --dport 22
ip access-list extended block_ssh
deny tcp 5.5.5.0 0.0.0.255 192.50.50.0 0.0.0.255 eq 22
interface g0/0
ip access-group block_ssh in
Cumulus Linux
Cisco
Allow NTP Traffic to Transitthe Switch (UDP Port 123)
cumulusnetworks.com 22
iptables -A FORWARD -j ACCEPT -p udp -s 192.168.1.0/24 --dport 123
ip access-list extended allow_ntp
permit udp 192.168.1.0 0.0.0.255 any eq ntp
interface g0/0
ip access-group allow_ntp in
Cumulus Linux
Cisco
Policing a Physical Interface
cumulusnetworks.com 23
-A FORWARD --in-interface swp1 -j POLICE --set-mode KB --set-rate 125000 --set-burst 2000
Cumulus Linux
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp1
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp1 any anywhere anywhere POLICE mode:KB rate:125000 burst:2000
Output
policy-map sean
class class-default
police cir 1000000000 interface
TenGigabitEthernet1/13
service-policy input sean
Cisco
Policing DSCP Values
cumulusnetworks.com 24
-A FORWARD --in-interface swp2 -m dscp --dscp 10 -j POLICE --set-mode KB --set-rate 31250 --set-burst 2000
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp2
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp2 any anywhere anywhere DSCP match 0x0a POLICE mode:KB rate:31250 burst:2000
Cumulus Linux
Output
class-map match-all dscp10
match dscp af11
!
policy-map sean2
class dscp10
police cir 250000000
!
interface TenGigabitEthernet1/14
service-policy input sean2
Cisco
Policing by Source Traffic
cumulusnetworks.com 25
-A FORWARD --in-interface swp3 -j POLICE --set-mode KB --set-rate 12500 --set-burst 2000 -s 3.3.3.0/24
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp3
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp3 any 3.3.3.0/24 anywhere POLICE mode:KB rate:12500 burst:2000
Cumulus Linux
access-list 100 permit ip 3.3.3.0 0.0.0.255 any
!
class-map match-all heller
match access-group 100
!
policy-map heller
class heller
police cir 100000000
!
interface TenGigabitEthernet1/15
service-policy input heller
Cisco
Output
Time Zone Configuration
cumulusnetworks.com 26
switch# configure terminal
switch(config)# clock timezone PST -8 0
switch(config)# exit
switch# show clock
switch# copy running-config startup-config
Cumulus Linux
Cisco
cumulus@switch:~$ sudo tzconfg
cumulus@switch:~$ sudo hwclock
NTP
cumulusnetworks.com 27
switch# clock protocol ntp vdc 1
Cumulus Linux
Cisco
Set NTP (e.g. to VDC 1)
cumulus@switch:~$ sudo vi /etc/ntp.conf
cumulus@switch:~$ ntpd –q
Show Management Interface Current Configuration
cumulusnetworks.com 28
switch# show interface mgmt 0
Cumulus Linux
Cisco
cumulus@switch:~$ ifquery eth0
DHCP Relay
cumulusnetworks.com 29
cumulus@switch:~$ sudo vi /etc/default/isc-dhcp-relay
SERVERS="192.168.123.4"
INTERFACES="bridge swp4 swp5"
cumulus@switch:~$ sudo /etc/init.d/isc-dhcp-relay restart
Cumulus Linux
Cisco
switch# configure terminal switch(config)# ip dhcp relay
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# ip dhcp relay address 192.168.123.4
CLI Basics
cumulusnetworks.com 30
Show command history
cumulus@switch:~$ history switch# show cli history
Cumulus Linux Cisco
Send message to all logged on users
cumulus@switch:~$ echo message | sudo wall switch# send message
Send message to specific user
cumulus@switch:~$ sudo write user-id switch# show users
switch# send session line message
CLI Basics
cumulusnetworks.com 31
Show SPROM information
cumulus@switch:~$ decode-syseeprom switch# show sprom
Cumulus Linux Cisco
Show hardware states (temperature, fan, power)
cumulus@switch:~$ sudo smonctl switch# show environment
Show memory allocation
cumulus@switch:~$ vmstat switch# show processes memory
Show real-time memory usage
cumulus@switch:~$ vmstat 1
Alternative command
cumulus@switch:~$ free
cumulus@switch:~$ sudo sensors
CLI Basics
cumulusnetworks.com 32
Show CPU processes and utilization
cumulus@switch:~$ ps aux switch# show processes
Cumulus Linux Cisco
Show hardware information
cumulus@switch:~$ dmidecode switch# show inventory
Show high level port state
cumulus@switch:~$ netshow interface switch# show ip int br
cumulus@switch:~$ top switch# show processes cpu
cumulus@switch:~$ netshow system
CLI Basics
cumulusnetworks.com 33
Show interface neighbors
cumulus@switch:~$ lldpctl switch# show lldp neigbhors
Cumulus Linux Cisco
Show interface connector information
cumulus@switch:~$ sudo ethtool –m swp1 switch# show interface ethernet 1/1 transceiver
Reboot switch
cumulus@switch:~$ sudo reboot switch# reload
cumulus@switch:~$ netshow lldp
Show ARP Table
cumulusnetworks.com 34
root@leaf01:~# arp –n
Address HWtype HWaddress Flags Mask Iface
10.2.0.254 ether 44:38:39:00:00:29 C eth0
169.254.1.2 ether 44:38:39:00:00:30 C peerlink.4094
169.254.0.1 ether 44:38:39:00:00:08 CM swp49
169.254.0.1 ether 44:38:39:00:00:14 CM swp50
Cumulus Linux
Cisco
switch# show ip arp
IP ARP Table for context default
Total number of entries: 1
Address Age MAC Address Interface
90.10.10.2 00:03:11 000d.ece7.df7c Vlan900
Configure SNMP (Net-SNMP)
cumulusnetworks.com 35
cumulus@switch:~$ sudo vi /etc/snmp/snmpd.conf
cumulus@switch:~$ sudo vi /etc/snmp/snmptrapd.conf
switch# configure terminal
switch(config)# snmp-server host ip-address traps version 2c public
Cumulus Linux
Cisco
https://docs.cumulusnetworks.com/display/DOCS/Monitoring+System+Hardware
Detailed Info
© 2016 Cumulus Networks. CUMULUS, the Cumulus Logo, CUMULUS NETWORKS, and the Rocket Turtle Logo (the “Marks”) are trademarks and service marks of
Cumulus Networks, Inc. in the U.S. and other countries. You are not permitted touse the Marks without theprior written consent of Cumulus Networks. The registered
trademark Linux® is used pursuant to a sublicense from LMI, the exclusive licensee of Linus Torvalds, owner of the mark on a world-wide basis. All other marks are used
under fair use or license from their respective owners.
§Thank You!
cumulusnetworks.com 36
Bringing the Linux Revolution to Networking
1 of 36

Recommended

Deploying CloudStack and Ceph with flexible VXLAN and BGP networking by
Deploying CloudStack and Ceph with flexible VXLAN and BGP networking Deploying CloudStack and Ceph with flexible VXLAN and BGP networking
Deploying CloudStack and Ceph with flexible VXLAN and BGP networking ShapeBlue
1.3K views39 slides
Ibm spectrum scale fundamentals workshop for americas part 4 Replication, Str... by
Ibm spectrum scale fundamentals workshop for americas part 4 Replication, Str...Ibm spectrum scale fundamentals workshop for americas part 4 Replication, Str...
Ibm spectrum scale fundamentals workshop for americas part 4 Replication, Str...xKinAnx
1.6K views52 slides
Building DataCenter networks with VXLAN BGP-EVPN by
Building DataCenter networks with VXLAN BGP-EVPNBuilding DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPNCisco Canada
12.4K views153 slides
DevConf 2014 Kernel Networking Walkthrough by
DevConf 2014   Kernel Networking WalkthroughDevConf 2014   Kernel Networking Walkthrough
DevConf 2014 Kernel Networking WalkthroughThomas Graf
8.3K views20 slides
How VXLAN works on Linux by
How VXLAN works on LinuxHow VXLAN works on Linux
How VXLAN works on LinuxEtsuji Nakai
26.7K views22 slides
PNETLab.pdf by
PNETLab.pdfPNETLab.pdf
PNETLab.pdfRigobertoZarate4
344 views20 slides

More Related Content

What's hot

Cisco asa active,active failover configuration by
Cisco asa active,active failover configurationCisco asa active,active failover configuration
Cisco asa active,active failover configurationIT Tech
6.3K views8 slides
OpenvSwitch Deep Dive by
OpenvSwitch Deep DiveOpenvSwitch Deep Dive
OpenvSwitch Deep Diverajdeep
63.9K views41 slides
Cisco commands List for Beginners (CCNA, CCNP) by
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)DH Da Lat
27.8K views12 slides
Open vSwitch 패킷 처리 구조 by
Open vSwitch 패킷 처리 구조Open vSwitch 패킷 처리 구조
Open vSwitch 패킷 처리 구조Seung-Hoon Baek
11.9K views21 slides
Performance Wins with BPF: Getting Started by
Performance Wins with BPF: Getting StartedPerformance Wins with BPF: Getting Started
Performance Wins with BPF: Getting StartedBrendan Gregg
2K views24 slides
Ifupdown2: Network Interface Manager by
Ifupdown2: Network Interface ManagerIfupdown2: Network Interface Manager
Ifupdown2: Network Interface ManagerCumulus Networks
2.5K views39 slides

What's hot(20)

Cisco asa active,active failover configuration by IT Tech
Cisco asa active,active failover configurationCisco asa active,active failover configuration
Cisco asa active,active failover configuration
IT Tech6.3K views
OpenvSwitch Deep Dive by rajdeep
OpenvSwitch Deep DiveOpenvSwitch Deep Dive
OpenvSwitch Deep Dive
rajdeep63.9K views
Cisco commands List for Beginners (CCNA, CCNP) by DH Da Lat
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
DH Da Lat27.8K views
Open vSwitch 패킷 처리 구조 by Seung-Hoon Baek
Open vSwitch 패킷 처리 구조Open vSwitch 패킷 처리 구조
Open vSwitch 패킷 처리 구조
Seung-Hoon Baek11.9K views
Performance Wins with BPF: Getting Started by Brendan Gregg
Performance Wins with BPF: Getting StartedPerformance Wins with BPF: Getting Started
Performance Wins with BPF: Getting Started
Brendan Gregg2K views
Ifupdown2: Network Interface Manager by Cumulus Networks
Ifupdown2: Network Interface ManagerIfupdown2: Network Interface Manager
Ifupdown2: Network Interface Manager
Cumulus Networks2.5K views
Service Function Chaining with SRv6 by Ahmed AbdelSalam
Service Function Chaining with SRv6Service Function Chaining with SRv6
Service Function Chaining with SRv6
Ahmed AbdelSalam2.3K views
VLANs in the Linux Kernel by Kernel TLV
VLANs in the Linux KernelVLANs in the Linux Kernel
VLANs in the Linux Kernel
Kernel TLV11.5K views
Linux Networking Explained by Thomas Graf
Linux Networking ExplainedLinux Networking Explained
Linux Networking Explained
Thomas Graf25.6K views
DPDK: Multi Architecture High Performance Packet Processing by Michelle Holley
DPDK: Multi Architecture High Performance Packet ProcessingDPDK: Multi Architecture High Performance Packet Processing
DPDK: Multi Architecture High Performance Packet Processing
Michelle Holley9.1K views
Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015) by Thomas Graf
Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)
Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)
Thomas Graf4.3K views
Red Hat Global File System (GFS) by Schubert Zhang
Red Hat Global File System (GFS)Red Hat Global File System (GFS)
Red Hat Global File System (GFS)
Schubert Zhang9.3K views
Boosting I/O Performance with KVM io_uring by ShapeBlue
Boosting I/O Performance with KVM io_uringBoosting I/O Performance with KVM io_uring
Boosting I/O Performance with KVM io_uring
ShapeBlue1.4K views
DPDK in Containers Hands-on Lab by Michelle Holley
DPDK in Containers Hands-on LabDPDK in Containers Hands-on Lab
DPDK in Containers Hands-on Lab
Michelle Holley10.3K views

Viewers also liked

20ten final presentation-Cumulus by
20ten final presentation-Cumulus20ten final presentation-Cumulus
20ten final presentation-Cumulusjulianasur
697 views27 slides
Cumulus Networks Overview by
Cumulus Networks OverviewCumulus Networks Overview
Cumulus Networks OverviewAdam Lorts
638 views12 slides
Cumulus Linux 2.5 Overview by
Cumulus Linux 2.5 OverviewCumulus Linux 2.5 Overview
Cumulus Linux 2.5 OverviewCumulus Networks
3.1K views19 slides
ONIE / Cumulus Networks Webinar by
ONIE / Cumulus Networks WebinarONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks WebinarCumulus Networks
2.1K views29 slides
Open Hardware for All - Webinar March 25, 2015 by
Open Hardware for All - Webinar March 25, 2015Open Hardware for All - Webinar March 25, 2015
Open Hardware for All - Webinar March 25, 2015Cumulus Networks
577 views21 slides
OCP Switch Overview by
OCP Switch OverviewOCP Switch Overview
OCP Switch OverviewSeung-Hoon Baek
2.8K views32 slides

Viewers also liked(9)

20ten final presentation-Cumulus by julianasur
20ten final presentation-Cumulus20ten final presentation-Cumulus
20ten final presentation-Cumulus
julianasur697 views
Cumulus Networks Overview by Adam Lorts
Cumulus Networks OverviewCumulus Networks Overview
Cumulus Networks Overview
Adam Lorts638 views
Open Hardware for All - Webinar March 25, 2015 by Cumulus Networks
Open Hardware for All - Webinar March 25, 2015Open Hardware for All - Webinar March 25, 2015
Open Hardware for All - Webinar March 25, 2015
Cumulus Networks577 views
Ansible & Cumulus Networks - Simplify Network Automation by Cumulus Networks
Ansible & Cumulus Networks - Simplify Network AutomationAnsible & Cumulus Networks - Simplify Network Automation
Ansible & Cumulus Networks - Simplify Network Automation
Cumulus Networks8K views
VMware NSX + Cumulus Networks: Software Defined Networking by Cumulus Networks
VMware NSX + Cumulus Networks: Software Defined NetworkingVMware NSX + Cumulus Networks: Software Defined Networking
VMware NSX + Cumulus Networks: Software Defined Networking
Cumulus Networks5.7K views
現代 IT 人一定要知道的 Ansible 自動化組態技巧 by Chu-Siang Lai
現代 IT 人一定要知道的 Ansible 自動化組態技巧現代 IT 人一定要知道的 Ansible 自動化組態技巧
現代 IT 人一定要知道的 Ansible 自動化組態技巧
Chu-Siang Lai28.1K views

Similar to Cumulus networks conversion guide

Day 14.2 configuringvla ns by
Day 14.2 configuringvla nsDay 14.2 configuringvla ns
Day 14.2 configuringvla nsCYBERINTELLIGENTS
983 views29 slides
Cisco data center support by
Cisco data center supportCisco data center support
Cisco data center supportKrunal Shah
4.8K views47 slides
Day 13.1..1 catalyst switch by
Day 13.1..1 catalyst switchDay 13.1..1 catalyst switch
Day 13.1..1 catalyst switchCYBERINTELLIGENTS
325 views27 slides
Icnd210 s02l01 by
Icnd210 s02l01Icnd210 s02l01
Icnd210 s02l01computerlenguyen
363 views32 slides
Configuracion EIGRP by
Configuracion EIGRPConfiguracion EIGRP
Configuracion EIGRPalexis marck Huiza Canchanya
299 views11 slides
CCN3Switching_lab_5_5_2 by
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2alan moreno
883 views15 slides

Similar to Cumulus networks conversion guide(20)

Cisco data center support by Krunal Shah
Cisco data center supportCisco data center support
Cisco data center support
Krunal Shah4.8K views
CCN3Switching_lab_5_5_2 by alan moreno
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
alan moreno883 views
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample by Faisal Khan
VoiceBootcamp Ccnp collaboration lab guide v1.0 sampleVoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
Faisal Khan1.1K views
Hardware accelerated switching with Linux @ SWLUG Talks May 2014 by Nat Morris
Hardware accelerated switching with Linux @ SWLUG Talks May 2014Hardware accelerated switching with Linux @ SWLUG Talks May 2014
Hardware accelerated switching with Linux @ SWLUG Talks May 2014
Nat Morris3.8K views
Thebasicintroductionofopenvswitch by Ramses Ramirez
ThebasicintroductionofopenvswitchThebasicintroductionofopenvswitch
Thebasicintroductionofopenvswitch
Ramses Ramirez102 views
ACIT - CCNA Training Course Topic - Switch Stp ACIT by Sleek International
ACIT - CCNA Training Course Topic - Switch Stp ACITACIT - CCNA Training Course Topic - Switch Stp ACIT
ACIT - CCNA Training Course Topic - Switch Stp ACIT
Sleek International1.3K views
Openstack openswitch basics by nshah061
Openstack openswitch basicsOpenstack openswitch basics
Openstack openswitch basics
nshah061553 views
Free CCNP switching workbook by networkershome pdf by Networkershome
Free CCNP switching workbook by networkershome pdfFree CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdf
Networkershome959 views

Recently uploaded

DSD-INT 2023 Dam break simulation in Derna (Libya) using HydroMT_SFINCS - Prida by
DSD-INT 2023 Dam break simulation in Derna (Libya) using HydroMT_SFINCS - PridaDSD-INT 2023 Dam break simulation in Derna (Libya) using HydroMT_SFINCS - Prida
DSD-INT 2023 Dam break simulation in Derna (Libya) using HydroMT_SFINCS - PridaDeltares
18 views9 slides
DSD-INT 2023 Delft3D FM Suite 2024.01 1D2D - Beta testing programme - Geertsema by
DSD-INT 2023 Delft3D FM Suite 2024.01 1D2D - Beta testing programme - GeertsemaDSD-INT 2023 Delft3D FM Suite 2024.01 1D2D - Beta testing programme - Geertsema
DSD-INT 2023 Delft3D FM Suite 2024.01 1D2D - Beta testing programme - GeertsemaDeltares
17 views13 slides
DSD-INT 2023 Baseline studies for Strategic Coastal protection for Long Islan... by
DSD-INT 2023 Baseline studies for Strategic Coastal protection for Long Islan...DSD-INT 2023 Baseline studies for Strategic Coastal protection for Long Islan...
DSD-INT 2023 Baseline studies for Strategic Coastal protection for Long Islan...Deltares
11 views30 slides
Software testing company in India.pptx by
Software testing company in India.pptxSoftware testing company in India.pptx
Software testing company in India.pptxSakshiPatel82
7 views9 slides
DSD-INT 2023 FloodAdapt - A decision-support tool for compound flood risk mit... by
DSD-INT 2023 FloodAdapt - A decision-support tool for compound flood risk mit...DSD-INT 2023 FloodAdapt - A decision-support tool for compound flood risk mit...
DSD-INT 2023 FloodAdapt - A decision-support tool for compound flood risk mit...Deltares
13 views34 slides
WebAssembly by
WebAssemblyWebAssembly
WebAssemblyJens Siebert
33 views18 slides

Recently uploaded(20)

DSD-INT 2023 Dam break simulation in Derna (Libya) using HydroMT_SFINCS - Prida by Deltares
DSD-INT 2023 Dam break simulation in Derna (Libya) using HydroMT_SFINCS - PridaDSD-INT 2023 Dam break simulation in Derna (Libya) using HydroMT_SFINCS - Prida
DSD-INT 2023 Dam break simulation in Derna (Libya) using HydroMT_SFINCS - Prida
Deltares18 views
DSD-INT 2023 Delft3D FM Suite 2024.01 1D2D - Beta testing programme - Geertsema by Deltares
DSD-INT 2023 Delft3D FM Suite 2024.01 1D2D - Beta testing programme - GeertsemaDSD-INT 2023 Delft3D FM Suite 2024.01 1D2D - Beta testing programme - Geertsema
DSD-INT 2023 Delft3D FM Suite 2024.01 1D2D - Beta testing programme - Geertsema
Deltares17 views
DSD-INT 2023 Baseline studies for Strategic Coastal protection for Long Islan... by Deltares
DSD-INT 2023 Baseline studies for Strategic Coastal protection for Long Islan...DSD-INT 2023 Baseline studies for Strategic Coastal protection for Long Islan...
DSD-INT 2023 Baseline studies for Strategic Coastal protection for Long Islan...
Deltares11 views
Software testing company in India.pptx by SakshiPatel82
Software testing company in India.pptxSoftware testing company in India.pptx
Software testing company in India.pptx
SakshiPatel827 views
DSD-INT 2023 FloodAdapt - A decision-support tool for compound flood risk mit... by Deltares
DSD-INT 2023 FloodAdapt - A decision-support tool for compound flood risk mit...DSD-INT 2023 FloodAdapt - A decision-support tool for compound flood risk mit...
DSD-INT 2023 FloodAdapt - A decision-support tool for compound flood risk mit...
Deltares13 views
DSD-INT 2023 3D hydrodynamic modelling of microplastic transport in lakes - J... by Deltares
DSD-INT 2023 3D hydrodynamic modelling of microplastic transport in lakes - J...DSD-INT 2023 3D hydrodynamic modelling of microplastic transport in lakes - J...
DSD-INT 2023 3D hydrodynamic modelling of microplastic transport in lakes - J...
Deltares9 views
Roadmap y Novedades de producto by Neo4j
Roadmap y Novedades de productoRoadmap y Novedades de producto
Roadmap y Novedades de producto
Neo4j50 views
2023-November-Schneider Electric-Meetup-BCN Admin Group.pptx by animuscrm
2023-November-Schneider Electric-Meetup-BCN Admin Group.pptx2023-November-Schneider Electric-Meetup-BCN Admin Group.pptx
2023-November-Schneider Electric-Meetup-BCN Admin Group.pptx
animuscrm13 views
Mark Simpson - UKOUG23 - Refactoring Monolithic Oracle Database Applications ... by marksimpsongw
Mark Simpson - UKOUG23 - Refactoring Monolithic Oracle Database Applications ...Mark Simpson - UKOUG23 - Refactoring Monolithic Oracle Database Applications ...
Mark Simpson - UKOUG23 - Refactoring Monolithic Oracle Database Applications ...
marksimpsongw76 views
Cycleops - Automate deployments on top of bare metal.pptx by Thanassis Parathyras
Cycleops - Automate deployments on top of bare metal.pptxCycleops - Automate deployments on top of bare metal.pptx
Cycleops - Automate deployments on top of bare metal.pptx
Elevate your SAP landscape's efficiency and performance with HCL Workload Aut... by HCLSoftware
Elevate your SAP landscape's efficiency and performance with HCL Workload Aut...Elevate your SAP landscape's efficiency and performance with HCL Workload Aut...
Elevate your SAP landscape's efficiency and performance with HCL Workload Aut...
HCLSoftware6 views
Fleet Management Software in India by Fleetable
Fleet Management Software in India Fleet Management Software in India
Fleet Management Software in India
Fleetable11 views
Geospatial Synergy: Amplifying Efficiency with FME & Esri ft. Peak Guest Spea... by Safe Software
Geospatial Synergy: Amplifying Efficiency with FME & Esri ft. Peak Guest Spea...Geospatial Synergy: Amplifying Efficiency with FME & Esri ft. Peak Guest Spea...
Geospatial Synergy: Amplifying Efficiency with FME & Esri ft. Peak Guest Spea...
Safe Software412 views
SUGCON ANZ Presentation V2.1 Final.pptx by Jack Spektor
SUGCON ANZ Presentation V2.1 Final.pptxSUGCON ANZ Presentation V2.1 Final.pptx
SUGCON ANZ Presentation V2.1 Final.pptx
Jack Spektor22 views
What Can Employee Monitoring Software Do?​ by wAnywhere
What Can Employee Monitoring Software Do?​What Can Employee Monitoring Software Do?​
What Can Employee Monitoring Software Do?​
wAnywhere21 views
.NET Developer Conference 2023 - .NET Microservices mit Dapr – zu viel Abstra... by Marc Müller
.NET Developer Conference 2023 - .NET Microservices mit Dapr – zu viel Abstra....NET Developer Conference 2023 - .NET Microservices mit Dapr – zu viel Abstra...
.NET Developer Conference 2023 - .NET Microservices mit Dapr – zu viel Abstra...
Marc Müller38 views
DSD-INT 2023 Modelling litter in the Yarra and Maribyrnong Rivers (Australia)... by Deltares
DSD-INT 2023 Modelling litter in the Yarra and Maribyrnong Rivers (Australia)...DSD-INT 2023 Modelling litter in the Yarra and Maribyrnong Rivers (Australia)...
DSD-INT 2023 Modelling litter in the Yarra and Maribyrnong Rivers (Australia)...
Deltares9 views

Cumulus networks conversion guide

  • 1. v Cumulus Linux Conversion Guides Cumulus Networks May 24, 2016
  • 2. Evolution of the CLI §Where did things move? cumulusnetworks.com 2 interfaces { ge-0/1/1 { unit 0 { family bridge { interface-mode access; vlan-id 100; } } } ge-0/1/2 { unit 0 { family bridge { interface-mode access; vlan-id 200; } } } auto bridge iface bridge bridge-vlan-aware yes bridge-ports swp1 swp2 bridge-vids 100 200 auto swp1 iface swp1 bridge-access 100 auto swp2 iface swp2 bridge-access 200 ▪ Cisco ▪ Juniper ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode access switchport access vlan 100 interface ethernet 1/2 switchport mode access switchport access vlan 200
  • 3. Defining a Switch Port cumulusnetworks.com 3 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 auto bridge iface bridge bridge-ports swp1 Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# switchport
  • 4. Adding an IP Address cumulusnetworks.com 4 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 address [ipv4-address/subnet-mask] address [ipv6-address/subnet-mask] Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# no switchport switch(config-if)# ip address [ipv4-address/subnet-mask] switch(config-if)# ipv6 address [ipv6-address/subnet-mask]
  • 5. Setting Speed, Duplex, MTU, and Auto-negotiation for an Interface cumulusnetworks.com 5 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 link-speed [speed] link-duplex [full|half] mtu [1500 - 9216] link-autoneg [on|off] Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# speed [speed] switch(config-if)# duplex [full|half] switch(config-if)# mtu [1500 - 9216] switch(config-if)# [no] negotiate auto
  • 6. Configuring Trunks cumulusnetworks.com 6 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode trunk interface ethernet 1/2 switchport mode trunk Cisco
  • 7. Pruning a Trunk cumulusnetworks.com 7 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 auto swp1 iface swp1 bridge-vids 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode trunk switchport trunk allowed vlan 200 interface ethernet 1/2 switchport mode trunk Cisco
  • 8. Configuring Access Ports cumulusnetworks.com 8 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 auto swp1 iface swp1 bridge-access 100 auto swp2 iface swp2 bridge-access 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode access switchport access vlan 100 interface ethernet 1/2 switchport mode access switchport access vlan 200 Cisco
  • 9. Changing the Native (Untagged) VLAN for a Single Trunk cumulusnetworks.com 9 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 1-200 auto swp1 iface swp1 bridge-pvid 100 auto swp2 iface swp2 bridge-pvid 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 1-200 interface ethernet 1/1-2 switchport mode trunk switchport trunk allowed vlan 1-200 interface ethernet 1/1 switchport trunk native vlan 100 interface ethernet 1/2 switchport trunk native vlan 200 Cisco
  • 10. EtherChannels/Bonds cumulusnetworks.com 10 vlan 10 ! interface GigabitEthernet0/19 switchport trunk encapsulation dot1q switchport mode trunk channel-group 1 mode active interface GigabitEthernet0/20 switchport trunk encapsulation dot1q switchport mode trunk channel-group 1 mode active interface Port-channel1 switchport trunk encapsulation dot1q switchport mode trunk interface Vlan10 ip address 10.10.10.10 255.255.255.0 Cisco WS-C3560X-24 12.2(55)SE5 auto bond1 iface bond1 bond-slaves glob swp19-20 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan10 iface vlan10 bridge-ports bond1.10 address 10.10.10.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Cisco
  • 11. EtherChannels/Bonds cumulusnetworks.com 11 interface Ethernet37 switchport mode trunk channel-group 2 mode active interface Ethernet38 switchport mode trunk channel-group 2 mode active interface Port-Channel2 switchport trunk allowed vlan 12 switchport mode trunk interface Vlan12 ip address 12.12.12.12/24 Arista DCS-7148S-R 4.13.5F auto bond2 iface bond2 bond-slaves glob swp37-38 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan12 iface vlan12 bridge-ports bond2.12 address 12.12.12.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Arista
  • 12. EtherChannels/Bonds cumulusnetworks.com 12 feature interface-vlan feature lacp vlan 14 interface Ethernet1/39 switchport mode trunk channel-group 3 mode active interface Ethernet1/40 switchport mode trunk channel-group 3 mode active interface port-channel3 switchport mode trunk interface Vlan14 no shutdown ip address 14.14.14.14/24 Cisco Nexus3064 5.0(3)U2(2c) auto bond3 iface bond3 bond-slaves glob swp39-40 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan14 iface vlan14 bridge-ports bond3.14 address 14.14.14.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Cisco
  • 13. Spanning Tree Configuration cumulusnetworks.com 13 auto swp1 iface swp1 mstpctl-portadminedge yes interface Gigabit0/0 spanning-tree portfast Immediately bring an interface configured as an access or trunk port to the forwarding state. ▪ Cumulus Linux Cisco
  • 14. Spanning Tree Configuration cumulusnetworks.com 14 auto swp1 iface swp1 mstpctl-bpduguard yes ! spanning-tree portfast bpduguard default ! interface Gigabit0/0 spanning-tree portfast Enabling/disabling the BPDU guard configuration. ▪ Cumulus Linux Cisco
  • 15. Spanning Tree Configuration cumulusnetworks.com 15 auto swp1 iface swp1 mstpctl-portbpdufilter yes ! spanning-tree portfast bpdufilter default ! interface Gigabit0/0 spanning-tree portfast Enables BPDU filter on a switch port, which filters BPDUs in both directions. ▪ Cumulus Linux Cisco
  • 16. Spanning Tree Configuration cumulusnetworks.com 16 auto swp1 iface swp1 mstpctl-treeportprio 128 interface Gigabit0/0 spanning-tree port-priority 128 Configure the port priority for an interface. The default for both operating systems is 128. ▪ Cumulus Linux Cisco
  • 17. Spanning Tree Configuration cumulusnetworks.com 17 auto vlan1 iface vlan1 mstpctl-treeprio 32768 bridge-ports swp1 spanning-tree vlan 1 priority 32768 Configure the switch's priority for a bridge/VLAN. The default for both operating systems is 32768. ▪ Cumulus Linux Cisco
  • 18. More Spanning Tree Info (Conversion Guide) cumulusnetworks.com 18 https://support.cumulusnetworks.com/hc/en-us/articles/206908397 Spanning Tree Industry-standard Loop Prevention for L2
  • 19. Access Lists cumulusnetworks.com 19 iptables -A {FORWARD | INPUT | OUTPUT} -j {ACCEPT | DROP | POLICE | SPAN | ERSPAN} | -p <protocol> -s <source> --sport [<ports>] -d destination> --dport [<ports>] [<options>] iptables -A FORWARD -j ACCEPT -p tcp -s 10.10.10.0/24 -d 3.3.3.3/24 --dport 80 iptables/netfilter (including Cumulus Linux) access-list <number> {permit | deny} <protocol> <source> [<ports>] <destination> [<ports>] [<options>] IOS Standard Syntax ip access-list extended {<number> | <name>} [<sequence>] {permit | deny} <protocol> <source> [<ports>]<destination> [<ports>] [<options>] IOS Extended Syntax (including NX-OS) ip access-list extended allow_http 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www access-list 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www (Example permit http port 80 traffic to 10.10.10.0/24 subnet)
  • 20. Block ICMP Echo Requests on the Specified Switch Port cumulusnetworks.com 20 iptables -A FORWARD -j DROP -i swp1 -p icmp --icmp-type echo-request ip access-list extended block_icmp deny icmp any any echo interface g0/0 ip access-group block_icmp in Cumulus Linux Cisco
  • 21. Block SSH Trafficfrom the Specified Subnet (5.5.5.0/24) cumulusnetworks.com 21 iptables -A INPUT -j DROP -p tcp -s 5.5.5.0/24 --dport 22 ip access-list extended block_ssh deny tcp 5.5.5.0 0.0.0.255 192.50.50.0 0.0.0.255 eq 22 interface g0/0 ip access-group block_ssh in Cumulus Linux Cisco
  • 22. Allow NTP Traffic to Transitthe Switch (UDP Port 123) cumulusnetworks.com 22 iptables -A FORWARD -j ACCEPT -p udp -s 192.168.1.0/24 --dport 123 ip access-list extended allow_ntp permit udp 192.168.1.0 0.0.0.255 any eq ntp interface g0/0 ip access-group allow_ntp in Cumulus Linux Cisco
  • 23. Policing a Physical Interface cumulusnetworks.com 23 -A FORWARD --in-interface swp1 -j POLICE --set-mode KB --set-rate 125000 --set-burst 2000 Cumulus Linux cumulus@leaf1$ sudo cl-acltool -L ip | grep swp1 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp1 any anywhere anywhere POLICE mode:KB rate:125000 burst:2000 Output policy-map sean class class-default police cir 1000000000 interface TenGigabitEthernet1/13 service-policy input sean Cisco
  • 24. Policing DSCP Values cumulusnetworks.com 24 -A FORWARD --in-interface swp2 -m dscp --dscp 10 -j POLICE --set-mode KB --set-rate 31250 --set-burst 2000 cumulus@leaf1$ sudo cl-acltool -L ip | grep swp2 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp2 any anywhere anywhere DSCP match 0x0a POLICE mode:KB rate:31250 burst:2000 Cumulus Linux Output class-map match-all dscp10 match dscp af11 ! policy-map sean2 class dscp10 police cir 250000000 ! interface TenGigabitEthernet1/14 service-policy input sean2 Cisco
  • 25. Policing by Source Traffic cumulusnetworks.com 25 -A FORWARD --in-interface swp3 -j POLICE --set-mode KB --set-rate 12500 --set-burst 2000 -s 3.3.3.0/24 cumulus@leaf1$ sudo cl-acltool -L ip | grep swp3 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp3 any 3.3.3.0/24 anywhere POLICE mode:KB rate:12500 burst:2000 Cumulus Linux access-list 100 permit ip 3.3.3.0 0.0.0.255 any ! class-map match-all heller match access-group 100 ! policy-map heller class heller police cir 100000000 ! interface TenGigabitEthernet1/15 service-policy input heller Cisco Output
  • 26. Time Zone Configuration cumulusnetworks.com 26 switch# configure terminal switch(config)# clock timezone PST -8 0 switch(config)# exit switch# show clock switch# copy running-config startup-config Cumulus Linux Cisco cumulus@switch:~$ sudo tzconfg cumulus@switch:~$ sudo hwclock
  • 27. NTP cumulusnetworks.com 27 switch# clock protocol ntp vdc 1 Cumulus Linux Cisco Set NTP (e.g. to VDC 1) cumulus@switch:~$ sudo vi /etc/ntp.conf cumulus@switch:~$ ntpd –q
  • 28. Show Management Interface Current Configuration cumulusnetworks.com 28 switch# show interface mgmt 0 Cumulus Linux Cisco cumulus@switch:~$ ifquery eth0
  • 29. DHCP Relay cumulusnetworks.com 29 cumulus@switch:~$ sudo vi /etc/default/isc-dhcp-relay SERVERS="192.168.123.4" INTERFACES="bridge swp4 swp5" cumulus@switch:~$ sudo /etc/init.d/isc-dhcp-relay restart Cumulus Linux Cisco switch# configure terminal switch(config)# ip dhcp relay switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# ip dhcp relay address 192.168.123.4
  • 30. CLI Basics cumulusnetworks.com 30 Show command history cumulus@switch:~$ history switch# show cli history Cumulus Linux Cisco Send message to all logged on users cumulus@switch:~$ echo message | sudo wall switch# send message Send message to specific user cumulus@switch:~$ sudo write user-id switch# show users switch# send session line message
  • 31. CLI Basics cumulusnetworks.com 31 Show SPROM information cumulus@switch:~$ decode-syseeprom switch# show sprom Cumulus Linux Cisco Show hardware states (temperature, fan, power) cumulus@switch:~$ sudo smonctl switch# show environment Show memory allocation cumulus@switch:~$ vmstat switch# show processes memory Show real-time memory usage cumulus@switch:~$ vmstat 1 Alternative command cumulus@switch:~$ free cumulus@switch:~$ sudo sensors
  • 32. CLI Basics cumulusnetworks.com 32 Show CPU processes and utilization cumulus@switch:~$ ps aux switch# show processes Cumulus Linux Cisco Show hardware information cumulus@switch:~$ dmidecode switch# show inventory Show high level port state cumulus@switch:~$ netshow interface switch# show ip int br cumulus@switch:~$ top switch# show processes cpu cumulus@switch:~$ netshow system
  • 33. CLI Basics cumulusnetworks.com 33 Show interface neighbors cumulus@switch:~$ lldpctl switch# show lldp neigbhors Cumulus Linux Cisco Show interface connector information cumulus@switch:~$ sudo ethtool –m swp1 switch# show interface ethernet 1/1 transceiver Reboot switch cumulus@switch:~$ sudo reboot switch# reload cumulus@switch:~$ netshow lldp
  • 34. Show ARP Table cumulusnetworks.com 34 root@leaf01:~# arp –n Address HWtype HWaddress Flags Mask Iface 10.2.0.254 ether 44:38:39:00:00:29 C eth0 169.254.1.2 ether 44:38:39:00:00:30 C peerlink.4094 169.254.0.1 ether 44:38:39:00:00:08 CM swp49 169.254.0.1 ether 44:38:39:00:00:14 CM swp50 Cumulus Linux Cisco switch# show ip arp IP ARP Table for context default Total number of entries: 1 Address Age MAC Address Interface 90.10.10.2 00:03:11 000d.ece7.df7c Vlan900
  • 35. Configure SNMP (Net-SNMP) cumulusnetworks.com 35 cumulus@switch:~$ sudo vi /etc/snmp/snmpd.conf cumulus@switch:~$ sudo vi /etc/snmp/snmptrapd.conf switch# configure terminal switch(config)# snmp-server host ip-address traps version 2c public Cumulus Linux Cisco https://docs.cumulusnetworks.com/display/DOCS/Monitoring+System+Hardware Detailed Info
  • 36. © 2016 Cumulus Networks. CUMULUS, the Cumulus Logo, CUMULUS NETWORKS, and the Rocket Turtle Logo (the “Marks”) are trademarks and service marks of Cumulus Networks, Inc. in the U.S. and other countries. You are not permitted touse the Marks without theprior written consent of Cumulus Networks. The registered trademark Linux® is used pursuant to a sublicense from LMI, the exclusive licensee of Linus Torvalds, owner of the mark on a world-wide basis. All other marks are used under fair use or license from their respective owners. §Thank You! cumulusnetworks.com 36 Bringing the Linux Revolution to Networking