TECHNICKÉ VÝPOČTYKontingenční tabulky, ověření datpráce se souborem dat, maticové funkce<br />Ing. Pavel Smutný, Ph.D.H305...
Kontingenční tabulka<br />Kontingenční tabulka je interaktivní tabulka, která rychle kombinuje a porovnává velká množství ...
Kontingenční tabulka- požadavky na zdrojová data<br />Zdrojová data musí mít minimálně jedno početní pole, které lze jakým...
Kontingenční tabulka – seznam polí<br />Filtr sestavy – pole je umístěno nad tabulkou, obsahuje celkové filtry a dle jejic...
Kontingenční tabulka - praktická ukázka<br />
Ověření dat<br />Ověřování dat se používá k řízení typu dat nebo hodnot, které do buněk zadává uživatel.<br />Vkládání dat...
Kdy použít ověření dat?<br />Omezit data na předdefinované položky v seznamu<br />Omezení čísel mimo určený rozsah (18 – 6...
Ověření dat - zprávy<br />Zpráva pro zadávání<br />Zpráva s upozorněním<br />Stop<br />Varování<br />Informace<br />
Google DokumentyFormuláře<br />http://www.youtube.com/watch?v=IzgaUOW6GIs<br />
Funkce pro práci se souborem dat<br />=SVYHLEDAT(hledat;tabulka;sloupec)<br />Pomocí funkce SVYHLEDAT se prohledává první ...
Tabulka:  Jedná se o oblast buněk obsahující data. Lze použít odkaz na oblast (například A2:D8)
Upcoming SlideShare
Loading in …5
×

Tv 04 2011

3,696 views

Published on

0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
3,696
On SlideShare
0
From Embeds
0
Number of Embeds
3,069
Actions
Shares
0
Downloads
0
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Tv 04 2011

  1. 1. TECHNICKÉ VÝPOČTYKontingenční tabulky, ověření datpráce se souborem dat, maticové funkce<br />Ing. Pavel Smutný, Ph.D.H305, pavel.smutny@vsb.cz<br />
  2. 2. Kontingenční tabulka<br />Kontingenční tabulka je interaktivní tabulka, která rychle kombinuje a porovnává velká množství dat.<br />Řádky a sloupce tabulky lze otáčet a zobrazit tak různé souhrny zdrojových dat.<br />Před sestavením kontingenční tabulky je potřeba:<br />rozhodnout, na jaké otázky mají data odpovědět;<br />připravitdata pro sestavu;<br />rozvrhnout sestavu přetažením polí do oblasti rozložení a získat tak požadovanou sestavu kontingenční tabulky.<br />
  3. 3. Kontingenční tabulka- požadavky na zdrojová data<br />Zdrojová data musí mít minimálně jedno početní pole, které lze jakýmkoliv způsobem sčítat, průměrovat atd.<br />1. řádek musí obsahovat záhlaví jednotlivých sloupců. <br />V oblasti dat nesmí být žádné prázdné řádky nebo sloupce. <br />Každý sloupec by měl obsahovat pouze jeden druh dat. Texty budou například v jednom sloupci a číselné hodnoty v jiném sloupci.<br />Zdrojová data nesmí obsahovat automatické souhrny a celkové součty vytvořené pomocí příkazu Souhrny v nabídce Data.<br />
  4. 4. Kontingenční tabulka – seznam polí<br />Filtr sestavy – pole je umístěno nad tabulkou, obsahuje celkové filtry a dle jejich nastavení zobrazuje data v tabulce.<br />Popisky řádků – pole můžete mezi sebou přesouvat, čím výše je pole umístěno, tím vyšší prioritu seskupení získává.<br />Popisky sloupců – jakmile přesunete jedno z polí do této sekce, celá tabulka změní svůj tvar, vybraná přesunutá pole pak automaticky mění svou pozici a zobrazují se na pozici sloupce.<br />Hodnoty – v tomto místě jsou umístěna výpočtová pole. Tedy pole určená k nejrůznějším druhům funkcí, jakými jsou např. suma, průměr, počet, maximum, minimum, součiny či rozptyly.<br />
  5. 5. Kontingenční tabulka - praktická ukázka<br />
  6. 6. Ověření dat<br />Ověřování dat se používá k řízení typu dat nebo hodnot, které do buněk zadává uživatel.<br />Vkládání dat lze ovlivnit:<br />poskytnout zprávu před vložením definující očekávaný vstup buňky a pokyny, které uživatelům usnadní odstranění případných chyb<br />při pokusu o zadání neplatných dat do buňky se zobrazí upozornění<br />
  7. 7. Kdy použít ověření dat?<br />Omezit data na předdefinované položky v seznamu<br />Omezení čísel mimo určený rozsah (18 – 60 let)<br />Omezení kalendářních dat mimo určené časové rozmezí (1.1.1950 – 31.12.2011)<br />Omezení časových údajů mimo určené časové rozmezí (9:00 – 18:00)<br />Omezení počtu textových znaků (160 znaků)<br />Ověření dat založených na vzorcích nebo hodnotách v jiných buňkách<br />
  8. 8. Ověření dat - zprávy<br />Zpráva pro zadávání<br />Zpráva s upozorněním<br />Stop<br />Varování<br />Informace<br />
  9. 9. Google DokumentyFormuláře<br />http://www.youtube.com/watch?v=IzgaUOW6GIs<br />
  10. 10. Funkce pro práci se souborem dat<br />=SVYHLEDAT(hledat;tabulka;sloupec)<br />Pomocí funkce SVYHLEDAT se prohledává první sloupec oblasti buněk a potom lze vrátit hodnotu z libovolné buňky, která se v dané oblasti nachází na stejném řádku<br /><ul><li>Hledat: Jedná se o hodnotu, kterou chcete najít v prvním sloupci tabulky nebo oblasti. Argumentem hledat může být hodnota nebo odkaz.
  11. 11. Tabulka: Jedná se o oblast buněk obsahující data. Lze použít odkaz na oblast (například A2:D8)
  12. 12. Sloupec: Jedná se o číslo sloupce v oblasti určené argumentem tabulka, z něhož chcete vrátit odpovídající hodnotu (například 1, 5, …). </li></li></ul><li>Maticové funkce<br />=INVERZE(pole)<br />Vrátí matici inverzní k matici obsažené v zadaném poli.<br />Inverzní matice k dané matici je taková matice, která po vynásobení s původní maticí dá jednotkovou matici (čtvercová matice, která má na hlavní diagonále jedničky a všechny ostatní prvky rovny nule).<br />Inverzní matice jsou nejčastěji používány při řešení soustav matematických rovnic.<br />Aktivace se provádí přes CTRL+SHIFT+ENTER<br /><ul><li>Pole: je matice se stejným počtem řádků a sloupců.</li>

×