Ejercicios pseint omar web technology

7,908 views

Published on

Published in: Education
1 Comment
2 Likes
Statistics
Notes
No Downloads
Views
Total views
7,908
On SlideShare
0
From Embeds
0
Number of Embeds
3
Actions
Shares
0
Downloads
182
Comments
1
Likes
2
Embeds 0
No embeds

No notes for slide

Ejercicios pseint omar web technology

  1. 1. PSEUDOCODIGO Proceso tienda_de_descuento Escribir "Estimado Cliente, por favor ingrese el monto de la compra"; Leer Compra; Si Compra<500 Entonces Escribir "No hay Descuento"; Sino Si Compra>500<1000 Entonces Descuento1<-Compra*0.5; Monto1<-Compra-Descuento1; Escribir "Por el gasto comprendido entre los 500 y 1000, el 5% dedescuento es:", Monto1; Si Compra>1000<7000 Entonces Descuento2<-Compra*0.11; Monto2<-Compra-Descuento2; Escribir "Por el gasto comprendido entre los 1000 y 7000, el 11% dedescuento es:", Monto2; Si Compra>7000<15000 Entonces Descuento3<-Compra*0.18; Monto3<-Compra-Descuento3; Escribir "Por el gasto comprendido entre los 7000 y 15000, el 18% dedescuento es:", Monto3; Si Compra>15000 Entonces Descuento4<-Compra*0.25; Monto4<-Compra-Descuento4; Escribir "Por el gasto comprendido entre 15000 y mas, el 25% dedescuento es:", Monto4; Escribir "Gracias por usar este programa, Desarrollado EN Pseint"; FinSi FinSi FinSi
  2. 2. PSEUDOCODIGOProceso suma_media Escribir "Bienvenidos, por favor ingrese el primer numero"; Leer J; Escribir "Ahora ingrese el segundo numero"; Leer C; Escribir "Por favor, ingrese el tercer numero"; Leer L; Media<-(J+C+L)/3; Escribir "La media de los tres numeros introducidos por usted es:",Media; Suma<-J+C+L; Escribir "La Suma de los tres numeros Introducidos por usted es:",Suma; Escribir "Gracias por usar nuestro programa, desarrollado EN Pseint";FinProceso
  3. 3. PSEUDOCODIGOProceso resolver_ecuacion Escribir "Bienvenido, por favor, ingrese el valor de X"; Leer X; F<-((X-2)^2)/2 + ((X+4)^4)/4 + ((X+6)^6)/6; Escribir "El valor que se obtiene ingresando X es:", F; Escribir "Gracias por Usar Nuestro Programa Desarrollado en Pseint";FinProceso
  4. 4. PSEUDOCODIGOProceso Promedio Escribir "Ingrese Su nombre"; Leer Nombre; Escribir "Dime tu numero de Carnet"; Leer Carnet; Escribir "Ingrese la cantidad de Materias:"; Leer n; acum<-0; Para i<-1 Hasta n Hacer Escribir "Ingrese la Calificacion ",i,":"; Leer Calificacion; acum<-acum+Calificacion; FinPara promedio<-acum/n; Escribir "El nombre del Estudiante es:", Nombre; Escribir "El numero de Carnet es:", Carnet; Escribir "El promedio es: ",promedio;FinProceso
  5. 5. PSEUDOCODIGOProceso par_impar Escribir "Escribir un numero"; Leer J; Si J mod 2=0 Entonces Escribir "Es par", J; Sino Escribir "Es impar", J; FinSiFinProceso
  6. 6. PSEUDOCÓDIGOProceso nomina_de_empleados Continuar<-"s" Mientras Continuar="s" Hacer Escribir "Por favor ingrese el monto de la tarifa"; Leer tarifa; Escribir "ahora ingrese el total de Horas trabajadas"; Leer Horas; Escribir "Por favor ingrese el nombre del Trabajador"; Leer nombre; Sueldo<-Horas*Tarifa; Si Horas<=35 Entonces Sueldo<-Horas*Tarifa Escribir "El valor de su sueldo es:", Sueldo; Sino Si Horas>35 Entonces Extra<-Horas*Tarifa*1.5 Escribir "El valor de su Sueldo es:", Sueldo; Escribir "El Total con horas extra es de:", Extra; Total<-Extra+Sueldo; Escribir "El total mas la suma de horas extra es de:", Total; Sino Escribir "Esta excendo de impuesto"; FinSi FinSi Si Sueldo<=2000 Entonces Escribir "El nombre del Empleado es:", nombre; Escribir "Esta libre de impuesto"; Sino Si Sueldo=3500 Entonces Impuesto<-Sueldo*0.20; Salario1<-Sueldo-Impuesto; Escribir "El nombre del Empleado es:", nombre; Escribir "Su Salario neto es de:", Salario1; Sino Si Sueldo>3500 Entonces Impuesto<-Sueldo*0.30; Salario2<-Sueldo-Impuesto; Escribir "El nombre del Empleado es:", nombre; (continúa la siguiente pagina)
  7. 7. Escribir "Su Salario neto es de:", Salario2; Sino Escribir "El nombre del Empleado es:", nombre; Escribir "Su Salario es:", Salario1; Escribir "Su Salario es:", Salario2; FinSi FinSi FinSi Escribir "Desea continuar s/n"; Leer Continuar; FinMientrasFinProceso
  8. 8. PSEUDOCÓDIGOProceso mayor_menor X<-0; Z<-0;Escribir "Ingrese el primer Numero";Leer X;Escribir "Ahora ingrese el segundo";Leer Z;Si X>Z Entonces Escribir "Es mayor", X;Sino Si X<Z Entonces Escribir "Es menor", X; Sino Escribir "Es mayor", Z; FinSiFinSiFinProceso
  9. 9. PSEUDOCÓDIGOProceso mayor_de_tres_numeros Escribir "Bienvenidos, por favor ingrese el primer numero"; Leer a; Escribir "Ahora ingrese el segundo numero"; Leer b; Escribir "Para finalizar, ingrese el tercer numero"; Leer c; Si a=b Entonces Escribir "Los numeros a y b y c son iguales"; Repetir Escribir "Bienvenidos, por favor ingrese el primer numero"; Leer a; Escribir "Ahora ingrese el segundo numero"; Leer b; Escribir "Para finalizar, ingrese el tercer numero"; Leer c; Hasta Que a>b y b>c FinSi Si a>b Entonces Escribir "El numero mayor es:", a; Sino Si b>c Entonces Escribir "El numero mayor es:", b; Sino Si c>a Entonces Escribir "El numero mayor es:", c; Sino FinSi FinSi FinSiFinProceso
  10. 10. PSEUDOCÓDIGOProceso presupuesto_hospital Continuar<-"si";Mientras Continuar="si" Hacer Escribir "Por favor ingrese el presupuesto del Hospital"; Leer presupuesto; Escribir "Si desea ver cuanto toca al Area de Ginecologia presione 1"; Escribir "Si desea ver cuanto toca al Area de Trumatologia presione 2"; Escribir "Si desea ver cuanto toca al Area de Pediatria presione 3"; Leer Opcion; Segun Opcion Hacer 1: Total<- presupuesto*0.40; Escribir "El monto que corresponde al Area de Ginecologiaes de:", Total; 2: Total<-presupuesto*0.30; Escribir "El monto que corresponde al Area deTraumatologia es de:", Total; 3: Total<-presupuesto*0.30; Escribir "El monto que corresponde al Area de Pediatria esde:", Total; FinSegun Escribir "¿Desea Continuar? si/no"; Leer Continuar;FinMientrasEscribir "Gracias por Usar un programa desarrollado por Omar Landaeta";FinProceso
  11. 11. PSEUDOCÓDIGOProceso hombre_mujer sexo<-"hombre"; sexo<-"mujer"; Continuar<-"s" Mientras Continuar="s" Hacer Escribir "ingrese el nombre"; Leer nombre; Escribir "Ingrese su Edad"; Leer edad; Escribir "Ingrese que sexo es usted, hombre o mujer"; Leer sexo; Escribir "Estado Civil"; Leer Ec; Si sexo="hombre" y edad>40 Entonces Escribir "Su nombre es:", nombre; Escribir "Su estado civil es:", Ec; Escribir "Tiene la edad de:", edad; FinSi Si sexo="mujer" y edad<50 Entonces Escribir "Su nombre es:", nombre; Escribir "Su estado civil es:", Ec; Escribir "Tiene la edad de:", edad; FinSiEscribir "Desea continuar s/n";Leer Continuar;FinMientrasFinProceso
  12. 12. PSEUDOCÓDIGOProceso fibonacci Continuar<-"s"; Mientras Continuar="s" Hacer Escribir "Ingrese el numero de Terminos"; Escribir "Que desee ver en la Sucesion de Fibonacci"; Leer nt; X1<-0; X2<-1; Para i<-1 Hasta nt Hacer X1<-X1+X2; X2<-X1-X2; Escribir " ", X1; FinPara Escribir "Desea Continuar s/n"; Leer Continuar; FinMientras Escribir "Gracias por Usar nuestro Programa de Sucecion de Fibonacci";FinProceso
  13. 13. PSEUDOCÓDIGOProceso calculo_superficies Opcion<-0; Escribir "CALCULO DE SUPERFICIES (version 1.0)"; Escribir "Para hallar el Area de un Cuadrado presione 1"; Escribir "Para hallar el Area de un Circulo presione 2"; Escribir "Para hallar el Area de un Rectangulo presione 3"; Escribir "Para hallar el Area de un Trapecio presione 4"; Escribir "Para hallar el Area de un Triangulo presione 5"; Leer Opcion; Mientras Opcion>=6 Hacer Escribir "CALCULO DE SUPERFICIES (version 1.0)"; Escribir "Para hallar el Area de un Cuadrado presione 1"; Escribir "Para hallar el Area de un Circulo presione 2"; Escribir "Para hallar el Area de un Rectangulo presione 3"; Escribir "Para hallar el Area de un Trapecio presione 4"; Escribir "Para hallar el Area de un Triangulo presione 5"; Leer Opcion; FinMientras Segun Opcion Hacer 1: Escribir "Para calcular el area de un Cuadrado, ingrese el valordel lado"; Leer lado; Areacuadrado<-lado*lado; Escribir "El valor del Area del cuadrado es de:", Areacuadrado; 2: Escribir "Para hallar el area de un circulo, ingrese el valor delradio"; Leer radio; Areacirculo<-3.14*radio*radio; Escribir "El area de un circulo es de:", Areacirculo;
  14. 14. (Continua en la siguiente pagina) 3: Escribir "Para hallar el valor del Rectangulo, ingrese el valor de labase"; Leer base; Escribir "Ahora ingrese la altura"; Leer altura; Arearectangulo<-base*altura; Escribir "El Area del Rectangulo es", Arearectangulo; Escribir "Gracias por usar nuestro programa, desarrollado porPseint y el estudiante Omar"; 4: Escribir "Para encontrar el Area de un Trapecio, ingrese el valorde la base1"; Leer base1; Escribir "Ingrese ahora la base2"; Leer base2; Escribir "Finalmente ingrese el valor de la altura"; Leer altura; Areatrapecio<-(base1+base2)*altura/2; Escribir "El area de un trapecio es de:", Areatrapecio; 5: Escribir "Para hallar el valor del area de un triangulo, por favoringrese el valor de la base"; Leer base; Escribir "Ahora ingrese el valor de la altura"; Leer altura; Areatriangulo<-(base*altura)/2; Escribir "El area del Triangulo es de:", Areatriangulo; FinSegunFinProceso
  15. 15. PSEUDOCÓDIGOProceso obreros_empresa_arreglos Dimension Obrero (200); Escribir "Ingrese el precio del salario pagado por horas trabajadas"; Leer Sph; Escribir "ingrese la Cantidad de Obreros de su empresa"; Leer Cant_obreros; Para i<-1 Hasta Cant_obreros Hacer Escribir "Ingrese el nombre del Obrero"; Leer Obrero (i); Escribir "Ingrese la cantidad de horas trabajadas"; Leer Ht; Si Ht>40 y Ht<=48 Entonces Tp<-Sph^2*Ht; Escribir "El nombre del trabajador::",i; Escribir " ", Obrero(i); Escribir "El precio a pagar por horas extras es de:", Tp; FinSi Si Ht>48 Entonces Tp<-Sph^3*Ht; Escribir "El nombre del trabajador::",i; Escribir " ", Obrero(i); Escribir "El precio a pagar por horas extras es de:", Tp; FinSi Si Ht<=40 Entonces Tp<-Sph*Ht; Escribir "El nombre del trabajador::",i; Escribir " ", Obrero(i); Escribir "El precio a pagar es de:", Tp; FinSi FinPara Escribir "Gracias por Usar un programa desarrollado por OmarLandaeta";FinProceso
  16. 16. PSEUDOCÓDIGOProceso ecuación_segundo_grado Escribir "Bienvenido, por favor ingrese un valor para a"; Leer a; Escribir "Ahora ingrese un valor para b"; Leer b; Escribir "Ingrese un valor para c"; Leer c; J<- b^2-(4*a*c); Si J<0 Entonces Escribir "No procesa"; Sino X1<- -b + RC (J)/2*a; X2<- -b - RC (J)/2*a; Escribir "El Valor de X1 es:", X1; Escribir "El Valor de X2 es:", X2; FinSiFinProceso
  17. 17. PSEUDOCÓDIGOProceso cuadrado_de_un_vector Dimension V1(500), V2(500) Escribir "Por favor ingrese la cantidad de vectores a almacenar" Leer Cant_vect; Para i<-1 Hasta Cant_vect Hacer Escribir "Ingrese el valor del vector", i; Leer V1 (i); FinPara Para i<-1 Hasta Cant_vect Hacer V2(i)<- V1(i)^2; Escribir "El valor al cuadrado de la posicion:", i; Escribir "Es de:", V2(i); Escribir "Y el valor Original es de:", V1(i); FinParaFinProceso
  18. 18. PSEUDOCÓDIGO.Proceso positivos_y_se_detiene_en_negativos numero<-0; contador<-0; Escribir "Ingrese el numero"; Leer numero; Mientras numero>0 Hacer contador<-contador+1; Escribir "Ingrese el numero"; Leer numero; FinMientras Escribir "El numero es:", contador;FinProceso
  19. 19. PSEUDOCÓDIGO.Proceso contador N<-0; contador<-0; sumador<-0; Mientras contador<=8 Hacer contador<-contador+2; sumador<-sumador+contador; FinMientras Escribir "El valor de los numeros impares es:", sumador;FinProceso
  20. 20. PSEUDOCÓDIGOProceso clínica_hospitalizacion Continuar<-"s"; Mientras Continuar= "s" Hacer Escribir "Estimado Usuario, ingrese El nombre del Paciente"; Leer Nombre; Escribir "Ingrese el Numero de Dias Hospitalizado"; Leer Dh; Escribir "Que tipo de Enfermedad posee segun las opciones"; Escribir "Presione 1 Fiebre Costo/Paciente/Dias = 1500"; Escribir "Presione 2 Dengue Costo/Paciente/Dias = 1700"; Escribir "Presione 3 Influenza Costo/Paciente/Dias = 1900"; Leer Opcion; Segun Opcion Hacer 1: Total<-Dh*1500; Escribir "Paciente:", Nombre; Escribir "Dias Hospitalizado:", Dh; Escribir "Tipo de Enfermedad:", Opcion; Escribir "Total a Pagar", Total; 2: Total<-Dh*1700; Escribir "Paciente:", Nombre; Escribir "Dias Hospitalizado:", Dh; Escribir "Tipo de Enfermedad:", Opcion; Escribir "Total a Pagar", Total; 3: Total<-Dh*1900; Escribir "Paciente:", Nombre; Escribir "Dias Hospitalizado:", Dh; Escribir "Tipo de Enfermedad:", Opcion; Escribir "Total a Pagar:", Total; FinSegun Si Opcion>3 Entonces Escribir "Error, cierre y vuelva abrir el programa" FinSi Escribir "¿Desea Continuar?"; Leer Continuar FinMientrasFinProceso
  21. 21. PSEUDOCÓDIGOProceso calificacion_aprobado Escribir "Bienvenido Estimado Docente"; Escribir "Por favor, Ingrese la Calificacion del Estudiante"; Leer Calificacion; Si Calificacion>8 Entonces Escribir "El Alumno, Aprobo el Examen"; Sino Escribir "El Alumno, No Aprobo el Examen"; FinSi Escribir "Gracias por Usar Nuestro Programa Desarrollado por Pseint";FinProceso
  22. 22. PSEUDOCÓDIGOProceso calculo_de_superficies opcion<-0; Escribir "CALCULO DE SUPERFICIES (version 1.0)"; Escribir "Para hallar el Area de un Cuadrado presione 1"; Escribir "Para hallar el Area de un Circulo presione 2"; Escribir "Para hallar el Area de un Rectangulo presione 3"; Escribir "Para hallar el Area de un Trapecio presione 4"; Escribir "Para hallar el Area de un Triangulo presione 5"; Leer opcion; Si opcion=1 Entonces Escribir "Para calcular el area de un Cuadrado, ingrese el valordel lado"; Leer lado; Areacuadrado<-lado*lado; Escribir "El valor del Area del cuadrado es de:", Areacuadrado; Sino Si opcion=2 Entonces Escribir "Para hallar el area de un circulo, ingrese el valor delradio"; Leer radio; Areacirculo<-3.14*radio*radio; Escribir "El area de un circulo es de:", Areacirculo; Sino Si opcion=3 Entonces Escribir "Para hallar el valor del Rectangulo, ingrese el valor de labase"; Leer base; Escribir "Ahora ingrese la altura"; Leer altura; Arearectangulo<-base*altura; Escribir "El Area del Rectangulo es", Arearectangulo; Sino
  23. 23. (Continua la siguiente pagina) Si opcion=4 Entonces Escribir "Para encontrar el Area de un Trapecio, ingrese el valor de la base1"; Leer base1; Escribir "Ingrese ahora la base2"; Leer base2; Escribir "Finalmente ingrese el valor de la altura"; Areatrapecio<-(base1+base2)*altura/2; Escribir "El area de un trapecio es de:", Areatrapecio; Sino Si opcion=5 Entonces Escribir "Para hallar el valor del area de un triangulo, por favoringrese el valor de la base"; Leer base; Escribir "Ahora ingrese el valor de la altura"; Leer altura; Areatriangulo<-(base*altura)/2; Escribir "El area del Triangulo es de:", Areatriangulo; FinSi FinSi FinSi FinSi FinSiFinProceso
  24. 24. PSEUDOCÓDIGO.Proceso sueldo_de_empleados Escribir "Bienvenidos, por favor ingrese el sueldo del primerEmpleado"; Leer Empleado1; Escribir "Ahora por favor ingrese el sueldo del segundo Empleado"; Leer Empleado2; Escribir "Para finalizar ingrese el sueldo del tercer Empleado"; Leer Empleado3; Aumento1<-Empleado1*0.10; Salario1<-Empleado1+Aumento1; Escribir "El Sueldo con un aumento del 10% al Primer Empleado esde:", Salario1; Aumento2<-Empleado2*0.12; Salario2<-Empleado2+Aumento2; Escribir "El sueldo con un aumento del 12% al Segundo Empleado esde:", Salario2; Aumento3<-Empleado3*0.15; Salario3<-Empleado3+Aumento3; Escribir "El sueldo con un aumento del 15% al Tercer Empleado es de:",Salario3; Escribir "Gracias por usar nuestro programa, desarrollado por Pseint";FinProceso
  25. 25. PSEUDOCÓDIGOProceso arreglo_viviendasContinuar<-"si";Mientras Continuar="si" Hacer Dimension C[100], P[100], G[100]; Escribir "Ingrese la Cantidad de Viviendas que se alquilanactualmente"; Leer Cant_vivi; Para i<-1 Hasta Cant_vivi Hacer Escribir "Ingrese Cuanto se Paga mensualmente por laVivienda,",i, ":"; Leer C[i]; FinPara Para i<-1 Hasta Cant_vivi Hacer Escribir "Ingrese que porcentaje se obtiene de ganancia por laVivienda,",i, ":"; Leer P[i]; Porcentaje<-P[i]/100; FinPara Para i<-1 Hasta Cant_vivi Hacer G[i]<-C[i]*Porcentaje; Escribir "La Ganancia que se obtiene de la Casa,",i, ":"; Escribir "Es de:", G[i]; FinPara Si Cant_vivi>100 Entonces Escribir "Cantidad de Viviendas no disponible"; FinSi Escribir "¿Desea continuar?"; Leer Continuar;FinMientrasFinProceso

×