Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.

Short introduction - .net core and .net standard 2.0

1,915 views

Published on

Short introduction - .net core and .net standard 2.0

Published in: Software
  • Be the first to comment

Short introduction - .net core and .net standard 2.0

  1. 1. Short Introduction .NET Core and .NET Standard 2.0 MARK LECHTERMANN HTTPS://TWITTER.COM/MARKLECHTERMANN
  2. 2. Influences on .NET Full Framework
  3. 3. What is the problem with. NET Full Framework?  Not Platform Independent  win32, user32, …  WPF  Forms  COM  monolithic  legacy stuff
  4. 4. We need a new framework!  A modular framework and platform-independent framework  Linux, MacOS, Container!, Cloud!  … but we want c#!  A simple, modern, general-purpose, object-oriented programming language  … but we want roslyn!  … but we want VS and VSC!  … but we want CLI-Tools
  5. 5. .NET Core  fast and lightweight  cross platform  open source  modular  nuget  But …  no WPF!  no WinForms!
  6. 6. Another incompatible framework?
  7. 7. .NET Standard
  8. 8. Happy Again!
  9. 9. .NET Standard 1.0 - 2.0
  10. 10. .NET Standard - API  https://docs.microsoft.com/en-us/dotnet/standard/net-standard  http://immo.landwerth.net/netstandard-versions/  https://apisof.net
  11. 11. .NET FF 4.7.1 build in support for .NET Standard 2.0  https://blogs.msdn.microsoft.com/dotnet/2017/09/28/net-framework-4-7-1- runtime-and-compiler-features/  .NET Framework 4.7.1 has built-in support for .NET Standard 2.0. .NET Framework 4.7.1 adds about 200 missing APIs that were part of .NET Standard 2.0 but not actually implemented by .NET Framework 4.6.1, 4.6.2 or 4.7. You can refer to details on .NET Standard on .NET Standard Microsoft docs. While libraries targeting .NET Standard 2.0 can be consumed by applications and libraries targeting .NET Framework 4.6.1 and higher, not all files that are required for .NET Standard libraries were part of .NET Framework 4.6.1. In fact, .NET Framework 4.6.1 was shipped before .NET Standard 2.0 was even designed. That’s why building an application targeting .NET Framework 4.6.1, as well as .NET Framework 4.6.2 and 4.7, will have to deploy additional .NET Standard 2.0 support files.
  12. 12. Demos  https://github.com/marklechtermann/dnug_dotnetstandarddemo

×