Successfully reported this slideshow.

More Related Content

Related Books

Free with a 14 day trial from Scribd

See all

Related Audiobooks

Free with a 14 day trial from Scribd

See all

Διαγώνισμα 1ο και 2ο κεφ ΑΕΠΠ

  1. 1. ΔΙΑΓΩΝΙΣΜΑ1o – 2o κεφ ΑΝΑΠΤΥΞΗ ΕΦΑΡ ΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΘΕΜΑ 1ο Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1 -10 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη. 1. Αριστερά της εντολής εκχώρησης δεν μπορεί να υπάρχει η μεταβλητή που βρίσκεται και δεξιά. 2. Ο τύπος μιας μεταβλητής μεταβάλλεται κατά τη διάρκεια εκτέλεσης ενός αλγορίθμου. 3. Ένα από τα στάδια αντιμετώπισης ενός προβλήματος είναι η ανάλυση. 4. Στη δομή ακολουθίας μπορεί μία ή περισσότερες εντολές να μην εκτελεστούν ποτέ. 5. Στις δομές πολλαπλών επιλογών Αν… Αλλιώς_Αν… Τέλος_Αν, δεν υπάρχει περιορισμός στον αριθμό των συνθηκών που μπορούν να ελε γχθούν. 6. Η εντολή Για x από 3 μέχρι 1000 με_βήμα 3 δίνει στο x τιμές που είναι πολλαπλάσια του 3 και ανήκουν στο διάστημα [3, 1000]. 7. Το πλάγιο παραλληλόγραμμο χρησιμοποιείται για αρχή και τέλος αλγορίθμου. 8. Όταν το βήμα είναι 0 στην Για..από..μέχρι..με_βήμα παραβιάζεται το κριτήριο της καθοριστικότητας. 9. Η τελική τιμή μιας έκφρασης εξαρτάται από την ιεραρχία των πράξεων και τη χρήση των παρενθέσεων. Μονάδες 9 Β. Να μετατραπούν οι παρακάτω εκφράσεις (συνθήκες): προτάσεις σε σύνθετες 1. Ο χ είναι μεγαλύτερος από το -1 και μικρότερος ή ίσος του 10. 2. Ο χ είναι ίσος με 1 ή με 5 ή με -40. 3. Ο χ είναι μεγαλύτερος του 50 αλλά όχι ίσος με 100. 4. Ο ακέραιος χ είναι θετικός αριθμός πολλαπλάσιος του 3. 5. Ο ακέραιος χ διαιρείται ακριβώς με το 4 αλλά όχι με το 100. Μονάδες 5 1
  2. 2. Γ. Αλγόριθμος Άθροισμα Διάβασε Χ1, Χ2 Π ← 0 Όσο Χ2 > 0 επανάλαβε Αν Χ2 mod 2=1 τότε Π←Π+Χ1 Τέλος_αν Χ1←Χ1 * 2 Χ2←Χ2 div 2 Τέλος_επανάληψης Εκτύπωσε Π Τέλος Άθροισμα 1) Τι θα εκτυπωθεί Αναγνωρίζεται τη αλγόριθμου; για τιμές εισόδου 45 και 19; λειτουργία του συγκεκριμένου Μονάδες 2 2) Να χαρακτηρίσετε τον τύπο κάθε μεταβλητής. Μπορεί ο αλγόριθμος να εκτελεστεί για πραγματικούς αριθμούς; Να δικαιολογήσετε την απάντησή σας. Μονάδες 2 3) Πως θα τροποποιούσατε τον παραπάνω αλγόριθμο αν οι τιμές εισόδου ήταν πραγματικοί αρ ιθμοί με ένα δεκαδικό ψηφίο, ώστε να εκτελεί την ίδια λειτουργία; Μονάδες 3 Δ. Δίνεται ο παρακάτω αλγόριθμος Αλγόριθµος Eμφάνιση x  2 Αρχή_ επανάληψης Αν x<>8 ή x<>17 τότε Εμφάνισε x Αλλιώς y x mod 3 Εμφάνισε y Τέλος _αν x  x +3 Μέχρις_ότου x >=20 Τέλος Eµφάνιση 2
  3. 3. 1. Πόσες φορές θα εκτελεστεί η εντολή Εμφ άνισε x και πόσες η εντολή Εμφ άνισε y Μονάδες 4 2. Να μετατραπεί ο παραπάνω αλγόριθμος σε ισοδύναμο με τη χρήση της εντολής Όσο … επανάλαβε Μονάδες 4 3. Να μετατραπεί ο παραπάνω αλγόριθμος σε ισοδύναμο με τη χρήση της εντολής Για …από …μέχρι Μονάδες 4 Ε. Να γράψετε στο τετράδιό σας τους αριθμούς της Στήλης Α και δίπλα τα γράμματα της Στήλης Β που αντιστοιχούν σωστά. Στήλη Α Στήλη Β 1.Περατότητα α. Κατηγορία προβλημάτων 2.Αληθής β. Κριτήριο Αλγορίθμου 3.“Αληθής” γ. Τρόπος αναπαράστασης αλγορίθμων 4.Επιλύσιμο δ. Είδος σταθεράς 5.Αλφαριθμητική ε. Λογική τιμή 6.Β+4 > α^2 στ. Αλφαριθμητική τιμή 7.Φυσική γλώσσα ζ. Λογική συνθήκη Μονάδες 7 ΘΕΜΑ 2ο Α. Δίνεται το παρακάτω τμήμα αλγορίθμου με αριθμημένες εντολές για εύκολη αναφορά σε αυτές. Κάθε εντολή περιέχει ένα ή δύο κενά (σημειωμένα με …), που το καθένα αντιστοιχεί σε μία σταθερά ή μία μεταβλητή ή έναν τελεστή. Επίσης δίνεται πίνακας όπου κάθε γραμμή αντιστοιχεί σε μία εντολή του τμήματος αλγορίθμου και κάθε στήλη σε μία θέση μνήμης (μεταβλητή). Η κάθε γραμμή του πίνακα παρουσιάζει το αποτέλεσμα που έχει η εκτέλεση της αντίστοιχης εντολής στη μνήμη: συγκεκριμένα, δείχνει την τιμή της μεταβλητής την οποία επηρεάζει η εντολή. Αν κατά την εκτέλεση της εντολής η μεταβλητή αλλάζει τιμή περισσότερες από μια φορές τότε φαίνονται όλες οι τιμές με την 3
  4. 4. αντίστοιχη σειρά. Δηλαδή η τελευταία εντολή είναι και η τελική τιμή της μεταβλητής. Εντολές 1 2 3 4 5 6 A  B  Γ  X  Αν … τότε … … … … Α 13 – 12 mo d … Ψε υδή ς < > Ψ ευ δή ς …  0 …  10 αλλι ώς Α  10 Τέλο ς_Α ν Σ  1 i  … Όσο i < = … ε πα νάλα βε Σ  Σ + i i  i + … Τέλο ς_Ε παν άλη ψη ς Β Γ Μνήμη Χ Επανάληψη Υ Σ 10 0 1 0 Αληθής 5 1η 13 2η 25 3η Μονάδες 6 Β. Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου Α, Μ θετικές ακέραιες σταθερές Για I από A μέχρι M με_βήμα 2 Εμφάνισε i Τέλος_Επανάληψης i) Πόσες φορές θα εκτελεστεί η παραπάνω επανάληψη αν α. M = A + 3 β. Μ = Α + 4 γ. Α = Μ + 3 δ. Α = Μ ii) Ποια σχέση πρέπει να έχουν οι αριθμοί Α, Μ έτσι ώστε η εντολή Εμφ άνισε i να εκτελεστεί a. Τουλάχιστον μια (1) φορά. b. Τουλάχιστον 10 (δέκα) φορές. c. Το πολύ τρεις (3) φορές. d. Ακριβώς επτά (7) φορές. Μονάδες 8 Γ. Για την προσομοίωση ενός σηματοδότη της κυκλοφοράς των αυτοκινήτων δόθηκαν τα εξής 3 τμήματα αλγορίθμου: 4
  5. 5. Α κ0 κόκκινοψευδής φανάρικόκκινο Όσο φανάρι=κόκκινο επανάλαβε κκ+1 Αν κ=10 τότε Γράψε ¨Έτοιμος να φύγεις¨ φανάριαληθής Τέλος_αν Τέλος_επανάληψης Εμφάνισε ¨Περίμενες¨, κ, ¨ Μονάδες του χρόνου¨ Β κ0 πράσινοψευδής φανάριπράσινο Αρχή_επανάληψης κκ+1 Αν κ>10 τότε Γράψε ¨Έτοιμος να φύγεις¨ φανάριαληθής Τέλος_αν Μέχρις_ότου φανάρι=αληθής Εμφάνισε ¨Περίμενες¨, κ, ¨ Μονάδες του χρόνου¨ Γ κ0 πράσινοαληθής φανάριπράσινο Αρχή_επανάληψης κκ+1 Αν κ=10 τότε Γράψε ¨Έτοιμος να φύγεις¨ φανάριψευδής Τέλος_αν Μέχρις_ότου φανάρι<>ψευδής Εμφάνισε ¨Περίμενες¨, κ, ¨ Μονάδες του χρόνου¨ Πόσες μονάδες του χρόνου θα περιμένει σε κάθε φανάρι; Μονάδες 6 ΘΕΜΑ 3ο 3Α. Σε μια δανειστική βιβλιοθήκη υπάρχουν 158 δανείζονται βιβλία. Να γραφεί αλγόριθμος που : μέλη που Α) για κάθε μέλος θα διαβάζει το φύλο («Α»=άνδρας και «Γ»=γυναίκα) και τον αριθμό των βιβλίων που δανείστηκαν σε ένα χρόνο. Να πραγματοποιείται έλεγχος εγκυρότητας στο φύλο και στον αριθμό των βιβλίων ότι είναι θετικός. Μονάδες 6 Β) να υπολογίζει το συνολικό αριθμό βιβλίων που δανείστηκαν οι άντρες σε ένα χρόν ο. Μονάδες 4 Γ) να υπολογίζει το συνολικό αριθμό βιβλίων που δανείστηκαν οι γυναίκες σε ένα χρόνο. Μονάδες 4 Δ) να εμφανίζει κατάλληλο μήνυμα που δείχνει αν οι άντρες ή οι γυναίκες έχουν δανειστεί τα περισσότερα βιβλία. Σε περίπτωση ίσων συνολικών αριθμών βιβλίων να εμφανίζει το μήνυμα «ΙΣΟΣ ΑΡΙΘΜΟΣ ΒΙΒΛΙΩΝ». Μονάδες 2 5
  6. 6. 3B Σε ένα λογαριασμό καταθέσεων τοποθετήσατε αρχικό κεφάλαιο 1000 ευρώ. Με δεδομένο ότι κάθε χρόνο το ποσό αυξάνεται κατά 3%, να υπολογιστεί σε πόσα χρόνια θα έχετε διπλασιάσει το αρχικό σας κεφάλαιο. Στο τέλος του αλγορίθμου να εμφανιστεί επεξηγηματικό μήνυμα. Μονάδες 4 ΘΕΜΑ 4ο Σε ΚΤΕΟ της χώρας το 2010 προσέρχονται οχήματα για έλεγχο. Τα οχήματα είναι τριών κατηγοριών ΦΟΡΤΗΓΟ, ΕΠΙΒΑΤΙΚΟ, ΔΙΚΥΚΛΟ και πληρώνουν 60€, 40€ και 20€ αντίστοιχα. Ένα όχημα χαρακτηρίζεται ως προς την προσέλευσή του «ΕΜΠΡΟΘΕΣΜΟ» ή «ΕΚΠΡΟΘΕΣΜΟ». Τα οχήματα που προσέρχονται εκπρόθεσμα επιβαρύνονται με πρόστιμο 15,80 €. Να γίνει αλγόριθμος ο οποίος: 1) Για κάθε όχημα το οποίο προσέρχεται στο ΚΤΕΟ για έλεγχο: Α) διαβάζει την κατηγορία του, το έτος της πρώτης κυκλοφορίας και τον τύπο προσέλευσης, χωρίς να κάνετε καμία εγκυρότητα τιμής. Β) υπολογίζει και εμφανίζει, με βάση την κατηγορία του και την εμπρόθεσμη ή εκπρόθεσμη προσέλευσή του, το ποσό πληρωμής. Η διαδικασία εισαγωγής δεδομένων τερματίζει όταν δοθεί η τιμή «Τ» σαν κατηγορία οχήματος. Μονάδες 6 2) Εμφανίζει το πλήθος των φορτηγών που προσήλθαν στο ΚΤΕΟ. Μονάδες 4 3) Εμφανίζει την κατηγορία του παλαιότερου οχήματος. Μονάδες 6 4) Εμφανίζει το συνολικό ποσό προστίμου. Μονάδες 4 Καλή Επιτυχία Ελένη Κοκκίνου 6

×