Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.

Aula 05 Vetores

20,129 views

Published on

  • Be the first to comment

Aula 05 Vetores

  1. 1. Algoritmo 2 – Aula 5Variáveis Compostas Homogêneas<br />MA12N <br />Prof Eder SamaniegoVillalba<br />http://eder.villalba.com.br<br />
  2. 2. O problema<br />Leia o nome de 500 pessoas e imprima seus nomes em ordem alfabética.<br />
  3. 3. Forma Inviável<br />1. algoritmo "Inviável"<br />2. var<br />3. nome1, nome2, nome3, nome4, nome5,..., nome499, nome500: literal<br />4. inicio<br />5. leia (nome1,nome2,...,nome500)<br />6. ...<br />7. Fimalgoritmo<br />
  4. 4. Variáveis indexadas<br />A declaração de uma variável indexada corresponde, na verdade, à declaração de várias variáveis cujo identificador difere apenas por um índice. <br />O índice corresponde a um valor numérico começando por 1. <br />Cada variável indexada pode receber valores no decorrer do algoritmo como se fosse uma variável comum.<br />
  5. 5. Vetores<br />Variáveis indexadas com uma única dimensão, também conhecidas como vetores, são referenciadas por um único índice.<br />Nomes<br />
  6. 6. Forma de Representação Portugol<br /><identificador> : vetor [<tamanho>] de < tipo ><br />Tamanho [VI..VF]=> Vi= Valor inicial e VF valor Final<br />Exemplos<br />IDADE: VETOR [1..5] DE INTEIRO<br />NOMES: VETOR [1..5] DE CARACTERE<br />IDADE<br />NOMES<br />
  7. 7. Forma de Representação Portugol<br />IDADE: VETOR [1..5] DE INTEIRO<br />NOMES: VETOR [1..5] DE CARACTERE<br />NOMES[1], NOMES[2], NOMES[3], NOMES[4], NOMES[5]<br />IDADE[1], IDADE[2], IDADE[3], IDADE[4], IDADE[5]<br />IDADE<br />NOMES<br />IDADE[2] = 12<br />IDADE[4] = 18<br />NOMES[3] = José<br />
  8. 8. Atividade Exemplo<br />Algoritmo que lê um vetor NUMERO de 6 posições e o escreve. A seguir, ele conta quantos valores de NUMERO são negativos e escreva esta informação.<br />
  9. 9. Resolução<br />2<br />conta_neg = 0<br />1<br />5<br />2<br />4<br />6<br />5<br />4<br />2<br />i = <br />1<br />3<br />6<br />1<br />3<br />Algoritmo "vetores"<br />VAR<br />NUMERO: VETOR [1..6] DE REAL<br />I, conta_neg: INTEIRO<br />inicio<br />conta_neg<- 0<br />para i de 1 ate 6 faca<br />leia (NUMERO[i])<br />se NUMERO[i] < 0 entao<br />conta_neg<- conta_neg + 1<br />fimse<br />fimpara<br />para i de 1 ate 6 faca<br />escreval(NUMERO[i])<br />fimpara<br />escreva ("Total de números negativos: ", conta_neg)<br />fimalgoritmo<br />NUMERO<br />12<br />1<br />26<br />2<br />-2<br />3<br />-5<br />4<br />8<br />5<br />10<br />NUMERO[3]<br />6<br />NUMERO[1]<br />NUMERO[2]<br />NUMERO[4]<br />NUMERO[6]<br />NUMERO[5]<br />12<br />26<br />-2<br />-5<br />8<br />10<br />Total de números negativos: 2<br />
  10. 10. Exercicio Nível 1<br />Escreva um algoritmo que lê um vetor A(10) e escreva a posição de cada elemento igual a 10 deste vetor.<br />Escrever um algoritmo que lê um vetor X(100) e o escreve. Substitua, a seguir, todos os valores nulos de X por 1 e escreva novamente o vetor X.<br />Faça um algoritmo que leia 100 valores e os escreva na ordem contrária à que foram digitados.<br />Escrever um algoritmo que lê um vetor N(80) e o escreve. Encontre, a seguir, o menor elemento e a sua posição no vetor N e escreva: "O menor elemento de N é = ... e a sua posição é ... ".<br />
  11. 11. Exercicio Nível 1I<br />Faça um algoritmo para calcular a média aritmética de uma quantidade 10 de valores numéricos lidos. <br />Escrever um algoritmo que lê um vetor N(20) e o escreve. Troque, a seguir, o 1* elemento com o último, o 2* com o penúltimo, etc até o 10* com o 11* e escreva o vetor N assim modificado.<br />Um armazém trabalha com 50 mercadorias diferentes. O dono do armazém anota a descrição, a quantidade de cada mercadoria vendida durante o mês e o seu preço unitário. Faça um algoritmo para calcular o faturamento mensal do armazém. <br />Faça um algoritmo para ler um vetor de 10 elementos numéricos e verificar se existem elementos iguais a 30. Se existirem, escreva as posições em que estão armazenados. <br />
  12. 12. Exercicio Nível 1I1<br />Escreva um algoritmo que gera os 10 primeiros números primos acima de 100 e os armazena em um vetor X(10) escrevendo, no final, o vetor X.<br />Escrever um algoritmo que lê um vetor G(13) que é o gabarito de um teste de loteria esportiva, contendo os valores 1(coluna 1), 2(coluna 2) e 3(coluna do meio). Ler, a seguir, para cada apostador, o número de seu cartão e um vetor Resposta R(13). Verificar para cada apostador o número de acertos e escrever o número do apostador e seu número de acertos. Se tiver 13 acertos, acrescentar a mensagem: "GANHADOR, PARABENS".<br />Escrever um algoritmo que lê um vetor A(15) e o escreve. Ordene a seguir os elementos de A em ordem crescente e escreva novamente A.<br />
  13. 13. Exercício Ninja<br />Escrever um algoritmo que lê, para um vetor V(30), vinte valores que ocuparão as 20 primeiras posições do vetor V. <br />Ordene, a seguir, os elementos de V em ordem crescente. <br />Leia, a seguir 10 valores A, um por vez, e insira-os nas posições adequadas do vetor V, de forma que o mesmo continue ordenado em ordem crescente. <br />Escreva o vetor V assim formado.<br />

×