Lazy Techs Knowledgebase ..

3,390 views

Published on

Published in: Technology
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
3,390
On SlideShare
0
From Embeds
0
Number of Embeds
1
Actions
Shares
0
Downloads
4
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Lazy Techs Knowledgebase ..

  1. 1. Lazy Techs - Knowledgebase: #19 Unidentified Network or 'Local Only' ... http://lazytechs.com/viewarticle.php?id=19&cat=2 Home News Knowledge Base Downloads Forums About Cable Boxes Cable Modems Network Tools Error Codes Screenshots Support Numbers Login Knowledge Base Main Page > Windows Vista > Categories Unidentified Network or 'Local Only' Network Windows XP Last Update: Nov 20, 2008, 8:59AM - Author: bdizzel Windows Vista Windows 9x/ME Unidentified Network Issue In Microsoft Windows Vista or "Local Only" Windows 2000 Windows Networking Author: BDizzel, Roger_Smith Mac OS X About this article: Mac OS 9.x This is a document that we have put together keeping track of the progress of troubleshooting the "Unidentified Network" or iPod "Local Only" issue with Vista. Gaming Things we have put together so far: Internet Firefox 1. Computer with issue uses a 169 address which causes the "Local Only" message. Internet Explorer 1. Computer doesn't seem to even request a DHCP address according to the DHCP server logs. Motorola Cable Boxes 2. When attempting to Renew Address it timesout eventually SA Cable Boxes 3. When trying to release 169 address, computer will not fall back to 0.0.0.0 for some reason. When releasing IP Cable TV should always go to 0.0.0.0, then apon renewing IP or failure to do so, shoudl be an IP or a 169 IP address. Ubuntu 2. This particular Computer worked PRIOR to installing SP1. 1. NIC in computer worked again after uninstalling SP1 Search 3. This is NOT an issue with SP1 specifically. 4. 64-bit or 32-bit both seem to be affected 5. In our case the NIC is getting the non-routable ip address of 169.xxx.xxx.xxx. When trying to disable/enable the NIC it jumps right to the 169 address. Normally you should see an IP 0.0.0.0 when DHCP request is being sent until it timesout, which it defaults to 169, or receives an IP from the DHCP server. 6. Even if the computer gets a 169 address it should say "Limited Connectivity" in the Network and Sharing center Registry One thing that we have noticed is that this error has MANY causes. Not just one or two. There are many things that can Cleaners cause this problem, from running Windows Update, to having Symantec installed. This is just one case in the many of them Exposed out there, this one just seems to be unique because everything we have tried doesn't seem to work. It could be dirver Don't Risk Your Data With We have noticed that Microsoft has acknolwedge this issue now and that their site says there isn't a fix for it at this time. Registry Cleaners While this may be a step in the right direction, its kind of sad its been since launch that this error could be generated by Until You've Read something. In our case, SP1 seems to cause the issue. If you have any ideas or suggestions, please feel free to email us at rogersmith@lazytechs.com or bdizzel@lazytechs.com. This. registrytools.org/registry-c You can also post in the forums any ideas that you may have. Forum Link Here Repair Windows UPDATE #7: We found a few recommendations to delete the 0.0.0.0 route with or without cable unplugged. Tried both Explorer ® with no luck. Even restarted after it and still nothing. Another command that was recommended was "netsh int ip reset Free Download logfile.txt" which didn't help either. We have had luck with these commands though in other cases, so its definitely That Fixes something to try. Here are the commands: Explorer ® Get Rid of Internet 1. route delete 0.0.0.0 in the command prompt (Admin privilages) then reboot Problems And… IE-Internet-Explorer.com 2. netsh int ip reset logfile.txt (Admin privilages) You can try these, but no guarantees that either one will work, but definitely worth a try. Windows Xp Sharing UPDATE #6: We have found a few sites suggestions to diable the autotuning in the global TCP settings in Vista, or even setting it to "highlyrestricted". Both settings both resulted in a 169 address to be assigned to the Network Card right Share printers and away(No DHCP Request seems to be even sent by the PC through this NIC), and was unable to release the IP. When trying files on your to renewing the IP it times out. Have verified on the DHCP server that there are no issues. When viewing log on DHCP network - easily. server not even seeing a DHCP request from the NIC with the issue. So it seems that communication all together on the Free Download NIC that isn't working is not working. www.NetworkMagic.com UPDATE #5: Well after more hunting and finding no answers why a perfectly good NIC would quit working we installed Download - Vista another NIC(Generic Realtek NIC) and it fired up just fine. But still the orginal issue isn't resolved, why the NIC onboard would work pre-SP1 and not after it was installed. We'll see if we can find anything out on the internet to find any answers, Repair but I don't think going to find much. Fix Errors and Speed Up Vista So far the only viable options we have found to work so far are putting in a new NIC, or formatting reload. Either one is not Now. Free guaranteed to work to solve it at this time. In this case replacing the NIC did work, for now. The orginal NIC still does not Download. 100% work. Guaranteed! www.Fix-Vista-Errors.com UPDATE #4: Well after installing all the Pre-SP1 updates we once again have the Unidentified Network issue after installing SP1. Assigning the MAC Address in the device manager under Network Address in Advance Properties of the NIC. Found this on a few forums while reading into this some more. Just rebooted and that didn't help as well. So back to square one trying to figure out what exactly changed that Pre-SP1 worked, but Post-SP1 doesn't. But this still doesn't help identify the issue, or even the randomness of this issue due to viewing many complaints prior to the release SP1 in forums on Microsoft's own site. UPDATE #3: Uninstalled SP1, and now we have network connectivity again. Will try to update all drivers, and reinstall SP1 afterwords to see if it is related to any of them. UPDATE #2: Correction. After a reload of the system with a fresh install of Vista, installing SP1 right away, the "Unidentified Network" issue has come back. So to recap, fresh format and install of Windows Vista, first time to desktop, installed SP1 standalone, and issue has returned. SP1 on previous, was done via Windows Update. UPDATE: After troubleshooting this issue on one of our systems that got the "Unidentified Network" notice for 4 hours, the information in this document has proven to be worthless and DOES NOT WORK. Sorry to the people out there who disagree with us on this one, but this was a fresh install and until SP1 was installed, all updates prior to SP1 were installed as well. Granted SP1 did not cause the issue due to us seeing this issue happen on Pre-SP1 and Post-SP1 installs. No other 3rd party software was installed at the time, other than Firefox 3.0 and Thunderbird 2.x. No 3rd party Internet Security or 1 of 6 6/24/2009 4:48 PM
  2. 2. Lazy Techs - Knowledgebase: #19 Unidentified Network or 'Local Only' ... http://lazytechs.com/viewarticle.php?id=19&cat=2 3rd pary AV software was installed. This confirms that it is strictly an issue with Microsoft Windows Vista only, and not caused by any other software. There may be similar cases that are caused by said software, but this particular issue is NOT. We went through registry keys, importing from a functional system, to reinstalling different chipset drivers, network card drivers, netsh commands, using STATIC IP Address, reinstalling NIC drivers, Safe Mode Removal of hardware devices, and nothing improved the situation. Currently Microsoft has failed to acknowledge this as an serious issue with their software, but don't let the deter you from purchasing Windows Vista. Windows Vista as a whole is a good Operating System, offering better features over XP, but someting as simple as this happening randomly is a good example of the reasons why people have a bad impression of Vista in general. While some in the tech industry may not see this as a serous issue, this is a RANDOM issue that people might experience. If you are one of the unfortunate people that has this happen to you, you will end up having to format the system and loosing the information on your computer without properly backing it up, if that is an immediate option for you. Not all users of Windows Vista will experience this glitch in the networking code of Vista due to the randomness of it. We have yet to been able to reproduce it more than once in a row with fresh installs, but we have been able to prove that it can happen at any given time without warning or direct cause. We have contacted both Microsoft insiders and Microsoft Technical Support, with no answers yet. We have also reached out to certain tech podcast celeberties asking for outside opinions, but have yet to receive any feedback. If you have feedback about this document please feel free to use the comment button above, or email bdizzel@lazytechs.com or rogersmith@lazytechs.com Disclaimer: The information in this document has come both the MS knowledge base along with a number of online forums where users have combined there knowledge and skill to try and resolve this ever growing issue. Most items listed are safe to do, except for the registry changes. Use at your own risk. There is no guarantee that any of the fixes listed below will work or not. WARNING: Editing the Registry can potentially be dangerous if you delete or change the wrong items! Use your own discresion. . If you have problems connecting to the internet, you will want to make sure that you check out the network and sharing center. If Vista is properly detecting the connection, you will get a screen such as the one shown above. If you go into Network and Sharing Center and see one like this: You will probably not be able to browse. You can try the following steps to correct the issue: 2 of 6 6/24/2009 4:48 PM
  3. 3. Lazy Techs - Knowledgebase: #19 Unidentified Network or 'Local Only' ... http://lazytechs.com/viewarticle.php?id=19&cat=2 The First step you are going to want to do is click on the customize button on the left and change the network from a public network to a private network. This will try and reset the network connection along with changing it to a private network which is where it should have been set by default. During the install of vista if you tell it your using your network at home it normally automatically sets it to private on its own look at the below photo for a better understanding of the customize screen. Now if the computer does not detect the new network connection after doing this I would suggest a reboot to force the settings to take effect and then check the network and sharing center again to see if this change actually worked. IF that still did not fix the issue the next thing you are going to want to try and do is turn off the IPV6 Protocol. This can be done by clicking on Manage Network Connections from with in the network and sharing center it should bring you to a screen that looks something like the one below. From here you are going to want to right click on the network adapter and from the drop down menu select properties. This will take you to the next screen. 3 of 6 6/24/2009 4:48 PM
  4. 4. Lazy Techs - Knowledgebase: #19 Unidentified Network or 'Local Only' ... http://lazytechs.com/viewarticle.php?id=19&cat=2 On this screen your going to want to remove the check mark from “Internet Protocol Version 6 (TCP/IPv6)” protocol is not currently used in the US at this time but will be used in the near future. Next we will want to go back to control panel and select the windows firewall. In here we are going to want to click on change settings link, which is circled in the photo above. When you click on the change settings link it should open up a new window from which your going to want to go to the advance tab. On this tab you’re going to want to click on the restore defaults button so that we can reset any changes that the system may have made to the windows firewall. After doing this you will want to go back to the general tab and actually turn off the windows firewall. 4 of 6 6/24/2009 4:48 PM
  5. 5. Lazy Techs - Knowledgebase: #19 Unidentified Network or 'Local Only' ... http://lazytechs.com/viewarticle.php?id=19&cat=2 After doing this you will once again want to restart the computer, and check the Network & Sharing Center it should now be able to detect the network connection and now be online and look similar to the photo below. If its not you can try the following TCP/IP stack repair options for use with Windows Vista. Once again open up a command prompt by typing “CMD” into the start search box but this time you will need to right click on the “CMD” icon and select “Run as Administrator” this will open up the administrator command window where you will want to type the following commands. Reset WINSOCK entries to installation defaults: netsh winsock reset catalog Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log Reboot the machine. Microsoft Knowledge Base Documents: Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers View products that this article applies to. Article ID : 928233 Last Review : June 17, 2008 Revision : 3.0 SYMPTOMS Consider the following scenario: • You connect a Windows Vista-based computer to a network. • A router or other device that is configured as a Dynamic Host Configuration Protocol (DHCP) server is configured on the network. • The router or the other device does not support the DHCP BROADCAST flag. In this scenario, Windows Vista cannot obtain an IP address. CAUSE This issue occurs because of a difference in design between Windows Vista and Microsoft Windows XP Service Pack 2 (SP2). Specifically, in Windows XP SP2, the BROADCAST flag in DHCP discovery packets is set to 0 (disabled). In Windows Vista, the BROADCAST flag in DHCP discovery packets is not disabled. Therefore, some routers and some non-Microsoft DHCP servers cannot process the DHCP discovery packets. RESOLUTION Important This section, method, or task contains steps that tell you how to modify the registry. However, serious 5 of 6 6/24/2009 4:48 PM
  6. 6. Lazy Techs - Knowledgebase: #19 Unidentified Network or 'Local Only' ... http://lazytechs.com/viewarticle.php?id=19&cat=2 problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows To resolve this issue, disable the DHCP BROADCAST flag in Windows Vista. To do this, follow these steps: 1. Click Start, type regedit in the Start Search box, and then click regedit in the Programs list. If you are prompted for an administrator password or for confirmation, type your password, or click Continue. 2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersInterfaces{GUID} In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network. 3. On the Edit menu, point to New, and then click DWORD (32-bit) Value. 4. In the New Value #1 box, type DhcpConnEnableBcastFlagToggle, and then press ENTER. 5. Right-click DhcpConnEnableBcastFlagToggle, and then click Modify. 6. In the Value data box, type 1, and then click OK. 7. Close Registry Editor. By setting this registry key to 1, Windows Vista will first try to obtain an IP address by using the BROADCAST flag in DHCP Discover packets. If that fails, it will try to obtain an IP address without using the BROADCAST flag in DHCP Discover packets MORE INFORMATION If you know the router or the non-Microsoft DHCP server does not support the DHCP BROADCAST flag, you can set the following registry entry as follows instead of using the DhcpConnEnableBcastFlagToggle registry key. HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersInterfaces{GUID} Value name: DhcpConnForceBroadcastFlag Value type: REG_DWORD Value data: 0 If your still not able to get online after trying these steps your going to want to have them contact MS for further support as they are well aware of this issue and are working to come up with a fix. Microsoft Support 1-800-936-5700 www.microsoft.com/support Also make sure to check back for updates and other possible fixes as we come across them at: www.lazytechs.com Site Designed by LTDesigns 6 of 6 6/24/2009 4:48 PM

×