Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.

EJERCICIOS DE ALGORITMOS

238,494 views

Published on

Published in: Technology, Education
  • @Junior Avellaneda Vicente resultado de dividir el numero entre 2 es igual a 0. quiere decir que es verdadero por eso da zero si no es divisible por 2 dara 1 o sea falso. como es divisible por 2 el resultado es 0 verdadero jejeje
       Reply 
    Are you sure you want to  Yes  No
    Your message goes here
  • en el que se necesita saber si es impar o no tengo dudas, se supone que si el resultado de dividir el numero entre dos es igual a cero, el numero es par...y si no, es impar..........haciendo el ejemplo con el numero 4...dividiendolo entre 2, su restuda es 2..no es cero, osea que el 4 es un numero impar?????
       Reply 
    Are you sure you want to  Yes  No
    Your message goes here
  • hola qui en me ayuda a leer catidades
       Reply 
    Are you sure you want to  Yes  No
    Your message goes here
  • Gracias. Buen aporte. ;)
       Reply 
    Are you sure you want to  Yes  No
    Your message goes here
  • hola quien me ayuda a resolver este algoritmo, crear un pseudocódigo que proporcione el volumen de un cilindro, conociendo su altura y diámetro, volumen: pix( radio)2 x altura.
       Reply 
    Are you sure you want to  Yes  No
    Your message goes here

EJERCICIOS DE ALGORITMOS

  1. 1. Ejercicios de algoritmos<br />
  2. 2. Hecho por: <br />Liz brigitte bustos escobar<br />Ivon johana Carvajal<br />1002<br />
  3. 3. 1. haga el algoritmo en pseudocodigo que, dada una variable cuyo es leido desde teclado imprima por pantalla si el numero es o no mayor que 0:<br />algoritmo mayor que 0 <br />Variable <br />entero: n<br />Inicio <br />Escribe: “escribe un numero” <br />Leer n <br />Si ( n >o) entonces <br />Escribe “el numero es mayor que 0”<br />Sino <br />Escribe “el numero no es mayor que 0”<br />FinSi<br />fin<br />
  4. 4. 2. Haga el algoritmo en pseudocodigo que dada una variable cuyo valor es leido desde teclado imprima por pantalla si el numero es o no es mayor que 0 y si el numero es par o impar: <br />Algoritmo mayor que 0 par<br />Variable <br />Entero: n<br />Inicio <br />Escribe “escribe un numero”<br />Leer n:<br />Si ( n >o) entonces <br />Escribe “el numero es mayor que 0”<br />Sino <br />Escribe “el numero no es mayor que 0”<br />FinSi<br />Si (resto de ( n/2) =0) entonces<br />Escribe “y es un numero par”<br />Sino<br />Escribe “y es un numero impar”<br />Finsi<br />fin<br />
  5. 5. 3.Hacer un pseudocodigo que imprima los numeros del 100 al 0, en orden<br />decreciente.<br />PROGRAMA contador2<br />ENTORNO:<br /> c <- 100<br />ALGORITMO:<br />Borrar_pantalla( )<br /> MIENTRAS c <= 0 HACER<br /> ESCRIBIR c<br /> c <- c - 1<br /> FINMIENTRAS<br />FIN<br />
  6. 6. 4.Hacer un pseudocodigo que imprima los numeros pares entre 0 y 100.<br /> <br />PROGRAMA pares<br />ENTORNO:<br /> c <- 2<br />ALGORITMO:<br />Borrar_pantalla( )<br /> MIENTRAS c < 101 HACER<br /> ESCRIBIR c<br /> c <- c + 2<br /> FINMIENTRAS<br />FIN<br />
  7. 7. 5.Desarrolle un algoritmo que permita calcular Promedio de Notas; finaliza cuando N = 0.<br />1. Inicio<br />2. Declaración de Variables:<br />N = 0, Promedio = 0, Acumula= 0<br />3. Leer N<br />4. Mientras N <> 0 hacer<br />5. Cuenta = Cuenta + 1<br />6. Acumula = Acumula + N<br />7. Fin Mientras<br />8. Promedio = Acumula/Cuenta<br />9. Imprimir “Promedio:”; Promedio<br />10. Fin<br />
  8. 8.  <br />6.Introducir una frase por teclado. Imprimirla en el centro de la pantalla.<br /> <br />PROGRAMA centro<br />ENTORNO:<br /> res <- "S"<br /> frase <- Espacios( 40 )<br />ALGORITMO:<br /> MIENTRAS res = "S" HACER<br />Borrar_pantalla( )<br /> EN 5,15 ESCRIBIR "Frase: "<br /> EN 5,22 LEER frase<br /> EN 12,40 - Int( Longitud( frase ) / 2 ) ESCRIBIR frase<br /> HACER Mas<br /> FINMIENTRAS<br />FIN<br /> <br />
  9. 9. 7.Introducir tantas frases como queramos y contarlas.<br /> <br />PROGRAMA frases<br />ENTORNO:<br /> res <- "S"<br /> frase <- Espacios( 30 )<br /> c <- 0<br />ALGORITMO:<br />Borrar_pantalla( )<br /> MIENTRAS res = "S" HACER<br /> ESCRIBIR "Frase: "<br /> LEER frase<br /> c <- c + 1<br /> ESCRIBIR "Deseas introducir m s frases (S/N): "<br /> LEER res<br /> FINMIENTRAS<br /> ESCRIBIR "El n£mero de frases introducidas son: "<br /> ESCRIBIR c<br />FIN<br /> <br />
  10. 10. 8.Introducir un numero por teclado. Que nos diga si es par o impar.<br /> <br />PROGRAMA paridad<br />ENTORNO:<br />num <- 0<br />ALGORITMO:<br />Borrar_pantalla( )<br /> ESCRIBIR "Introduce un n£mero: "<br /> LEER num<br /> SI num = int( num / 2 ) * 2 ENTONCES<br /> ESCRIBIR "es par"<br /> SINO<br /> ESCRIBIR "es impar"<br /> FINSI<br />FIN<br /> <br />
  11. 11. 9.mprimir y contar los multiplos de 3 desde la unidad hasta un numero que<br />introducimos por teclado.<br />PROGRAMA multiplo3<br />ENTORNO:<br />i <- 3<br /> n <- 0<br /> c <- 0<br />ALGORITMO:<br />Borrar_pantalla( )<br /> ESCRIBIR "N£mero: "<br /> LEER n<br /> MIENTRAS i <= n HACER<br /> SI i = int( i / 3 ) * 3 ENTONCES<br /> ESCRIBIR i<br />c <- c + 1<br /> FINSI<br />i <- i + 1<br />FINMIENTRAS<br /> ESCRIBIR "El n£mero de m£ltiplos de 3 son: "<br /> ESCRIBIR c<br />FIN<br /> <br />
  12. 12.  <br />10.Imprimir y contar los numeros que son multiplos de 2 o de 3 que hay entre1 y 100.<br />PROGRAMA multiplo_2_3<br />ENTORNO:<br /> i <- 1<br /> c <- 0<br />ALGORITMO:<br />Borrar_pantalla( )<br /> MIENTRAS i < 101 HACER<br /> SI i = int( i / 2 ) * 2 O i = int( i / 3 ) * 3 ENTONCES<br /> c <- c + 1<br /> ESCRIBIR i<br />FINSI<br />i <- i + 1<br />FINMIENTRAS<br /> ESCRIBIR "El n£mero de m£ltiplos es de: "<br /> ESCRIBIR c<br />FIN<br /> <br />
  13. 13. 11.Determinar cual de 2 números es mayor:<br />1. algoritmo mayor<br />2. var<br />3. a,b: entero;<br />4. inicio<br />5.Escriba(“Por Favor entre un número”);<br />6.Lea(a);<br />7.Escriba(“por favor entre el segundo número”);<br />8.lea (b);<br />9.si (a>b)<br />10.escriba(“El mayor de los números es: ”,a);<br />11. sin_no<br />12.escriba(“El mayor de los números es: ”,b);<br />13. fin_si<br />14. fin<br />
  14. 14. 12.Realizar un algoritmo que sume los 10 primeros números naturales e imprima<br />su resultado.<br />Solución<br />1. algoritmo suma10<br />2. var<br />3. k,suma : entero;<br />4. inicio<br />5. suma=0;<br />6. Para (k=1 hasta 10 hacer)<br />7.suma=suma+k;<br />8. fin_para<br />9. Escriba(“la suma es: ”,suma);<br />10. fin<br />
  15. 15. 13.Una pequeña variación al ejercicio anterior Realizar la suma de 10 números cualesquiera e imprimir su resultado<br />algoritmo suma10_1<br />var<br />k, numero, suma : entero;<br />inicio<br />suma=0;<br />Para (k=1 hasta 10 hacer)<br />Escriba(“por Favor Ingrese número”);<br />lea(numero)<br />suma=suma+numero;<br />fin_para<br />Escriba(“la suma es: ”,suma);<br />fin<br />
  16. 16. 14.Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar.<br />1. Inicio<br />2. Declaración de variables: N<br />3. Leer un número<br />4. Asignarlo a la variable N<br />5. Si el residuo de dividir a N entre 2 es<br />igual a cero<br />6. Si es Si: Entonces: Escribir “ Es par”<br />7. Sino: Escribir “Es impar”<br />8. Fin_Si<br />9. Fin<br />
  17. 17. 15.Retomado el primer ejercicio de los diagramas, Leer dos números, sumarlos y<br />obtener su resultado<br />1. Algoritmo Suma;<br />2. Var<br />3. a,b,suma: entero;<br />4. inicio<br />5. escriba(“por favor ingrese un número”);<br />6. lea (a);<br />7. escriba(“por favor ingrese otro número”);<br />8. lea (b);<br />9. suma = a+b;<br />10. escriba (“el resultado es: ”,suma)<br />11. fin<br />
  18. 18. 16.Introducir una frase por teclado. Imprimirla cinco veces en filas<br />consecutivas, pero cada impresion ir  desplazada cuatro columnas hacia laderecha.<br /> <br />PROGRAMA frase<br />ENTORNO:<br /> frase <- Espacios( 30 )<br />ALGORITMO:<br />Borrar_pantalla( )<br /> EN 5,15 ESCRIBIR "Frase: "<br /> EN 5,22 LEER frase<br /> fi <- 8<br />co <- 15<br /> veces <- 0<br /> MIENTRAS veces <= 5 HACER<br /> EN fi,co ESCRIBIR frase<br /> veces <- veces + 1<br />co <- co + 4<br /> fi <- fi + 1<br /> FINMIENTRAS<br />FIN<br />
  19. 19. 17.Introducir una frase por teclado. Imprimirla en el centro de la pantalla.<br /> <br />PROGRAMA centro<br />ENTORNO:<br /> res <- "S"<br /> frase <- Espacios( 40 )<br />ALGORITMO:<br /> MIENTRAS res = "S" HACER<br />Borrar_pantalla( )<br /> EN 5,15 ESCRIBIR "Frase: "<br /> EN 5,22 LEER frase<br /> EN 12,40 - Int( Longitud( frase ) / 2 ) ESCRIBIR frase<br /> HACER Mas<br /> FINMIENTRAS<br />FIN<br />
  20. 20. 18.Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor, si es el caso.<br />1. Inicio<br />2. Declaración de Variables:<br />A = 0, B = 0, Temporal = 0<br />3. Leer A y B<br />4. Si A<B Entonces<br />5. Asignar a Temporal = B<br />6. Asignar a B = A<br />7. Asignar a A = Temporal<br />8. Si no (De lo contrario)<br />9. Fin_Si<br />10 Escribir “Orden = “, A, B<br />11. Fin<br />
  21. 21. 19.Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H).<br />1. Inicio<br />2. Declaración de variables: R = 0, H = 0<br />3. Leer el valor de Radio (R) y Altura (H)<br />4. Calcular el Volumen aplicando la fórmula<br />5. Calcular el valor del área aplicando la<br />fórmula respectiva<br />6. Escribir el valor del Área y del Volumen<br />7. Fin<br />
  22. 22. 20.Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil, expresada en kilómetros por hora, proporcione la velocidad en metros por segundo.<br />1. Inicio<br />2. Declaración de Variables:<br />Vel = 0<br />3. Leer Datos: Vel<br />4. Versal = (Vel * 1000) / 3600<br />5. Imprimir resultado<br />6. Fin<br />
  23. 23. 21.Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. Desarrolle el algoritmo correspondiente.<br />1. Inicio<br />2. Declaración de Variables: CatA= 0, CatB=0<br />3. Leer el valor de cada cateto<br />4. Almacenarlo en la variable CatAy CatB<br />5. Calcular el valor de Hip con la formula indicada<br />6. Escribir el valor de la Hipotenusa<br />7. Fin<br />
  24. 24. 22.Desarrolle un algoritmo que permita leer dos valores distintos, determinar cual de los dos valores es el<br />mayor y escribirlo.<br />1. Inicio<br />2. Inicializar variables: A = 0, B = 0<br />3. Solicitar la introducción de dos valores distintos<br />4. Leer los dos valores<br />5. Asignarlos a las variables A y B<br />6. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos<br />7. Si A>B Entonces Escribir A, “Es el mayor”<br />8. De lo contrario: Escribir B, “Es el mayor”<br />9. Fin_Si<br />fin<br />
  25. 25. 23.Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C respectivamente. El algoritmo debe imprimir cual es el mayor y cual es el menor. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.<br />1. inicio<br />2. Inicializar las variables A, B y C<br />3. Leer los tres valores<br />4. Almacenar en las variables A, B y C<br />5. Si A > B y A > C Entonces<br />6. Escribir A “Es el mayor”<br />7. Sino<br />8. Si B > A y B > C Entonces<br />9. Escribir B “Es el mayor”<br />10. Sino<br />11. Escribir C “Es el mayor”<br />12. Fin_Si<br />13. Fin_Si<br />14. Fin<br />
  26. 26. 24.Hacer un programa que imprima la suma de los 100 primeros numeros.<br /> <br />PROGRAMA suma<br />ENTORNO:<br /> c <- 1<br /> suma <- 0<br />ALGORITMO:<br />Borrar_pantalla( )<br /> MIENTRAS c <= 100 HACER<br /> suma <- suma + c<br /> c <- c + 1<br /> FINMIENTRAS<br /> ESCRIBIR "La suma de los 100 primeros n£meros es: "<br /> ESCRIBIR suma<br />FIN <br /> <br />
  27. 27. 25.Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10, es decir, 1 + 2 + 3 + …. + 10.<br />1. Inicio<br />2. Declaración de variables:<br />N= 0, Suma = 0<br />3. Asignación Contador :<br />N = N + 1<br />4. Asignación Acumulador:<br />Suma = Suma + N<br />5. Si N = 10 Entonces<br />6. Escribir Suma<br />7. De lo contrario, Repetir desde el<br />paso 3<br />8. Fin_Si<br />9. fin<br />

×