Estructura general de  un programa (II)            Departamento de ingeniería
Enunciados o Instrucciones               Departamento de ingeniería
Instrucciones y tipos de instrucciones Es importante en un programa definir las instrucciones que   resolverán el problema...
Instrucciones y tipos de instrucciones                     Inicio / fin                      Inicio, fin                  ...
Enunciado de Lectura. El enunciado de lectura se utiliza para  introducir datos que se van a utilizar en la  solución de ...
Enunciado de Escritura.   El enunciado de escritura se utiliza para    presentar los resultados que se esperaban    obten...
Enunciado de Asignación (I).•   Es una acción o proceso por el cual se le asigna un    valor (constante o variable) o el r...
Enunciado de Asignación (II).Asignación aritmética. Las expresiones en las operaciones  son aritméticasEjm.         Instru...
Enunciado de Asignación (III).Asignación lógica. La expresión que se evalúa en la operación  de asignación es lógicaEjm.  ...
Enunciado de Asignación (III).Asignación de cadena de caracteres. La expresión que se  evalua es de tipo cadena.Ejm.  x  ...
Reglas para la construcción deenunciados de asignación (I).Toda variable que aparezca al lado derecho de un enunciado  de ...
Reglas para la construcción deenunciados de asignación (II). En un enunciado de asignación, la variable de la izquierda es...
Reglas para la construcción deenunciados de asignación (III).Las variables que aparecen en la partederecha de un enunciado...
Reglas para la construcción deenunciados de asignación (IV).Si la variable de la parte izquierda delenunciado se encuentra...
Enunciado de Decisión.Los enunciados de decisión se utilizan paratomar una acción o conocer el estado dealguna situación e...
Enunciado de Decisión – Si.. SinoDiagrama de Flujo   SI                         NO                         <comparación>  ...
Enunciado de Decisión – SI .. SinoDiagrama de Flujo                      SI                                  NO           ...
Enunciado de Repetición. Son los enunciados que permiten repetir  varias veces un conjunto de enunciados  según se necesi...
Enunciado de Repetición - MientrasDiagrama de Flujo                    SI                         NO                      ...
Enunciado de Repetición - MientrasDiagrama de Flujo               SI                contador < numero                     ...
Enunciado de Repetición – Haga .. MientrasDiagrama de Flujo                         SI                                    ...
Enunciado de Repetición – Haga .. MientrasDiagrama de Flujo                Leer               SI               (Edad)     ...
Ejemplo algoritmo para “sumar dos              números”Entrada:Dos números (num1, num2)Salida:Resultado de la suma de los ...
Ejemplos de diagramas de flujo                   Inicio            Num_suma        0              Leer num1             Le...
ActividadEn un diagrama de flujo, representar unalgoritmo para dividir dos números. Si elsegundo número que se recibe es “...
Pseudocódigo
Pseudocódigo (I)Es muy importante la indentación (sangría en el margenizquierdo) de las diferentes líneas del algoritmo.El...
Pseudocódigo (II)Escribir (y): Se utiliza para solicitar escribir un dato y.Escribir(‘mensaje’): Se utiliza para escribir ...
Pseudocódigo (III)Si sentencia1 entonces   instrucciones1sino si sentencia2 entonces         instrucciones 2      sino si ...
Ejemplo de pseudocódigoEscribir en pseudocódigo un algoritmo que pida el nombre deuna persona e imprima en pantalla el nom...
Actividad en Clase (I)1. Escribir en pseudocódigo un algoritmo para   multiplicar dos números.2. Escribir en pseudocódigo ...
Actividad en ClaseEscribir un algoritmo que: «Dados tres números determina si lasuma de dos de ellos es igual al otro núme...
Algoritmo comparar_iguales                                    Solución IVar       entero: num1,num2,num3Inicio       Escri...
Solución IIAlgoritmo comparar_igualesVar     entero: num1,num2,num3Inicio     Escribir(‘Ingrese primer número’)     leer(n...
Actividad en ClaseEscriba un algoritmo que pida a un profesor una nota.Dependiendo de la nota se debe realizar lo siguient...
SoluciónAlgoritmo validar_notaVar       real: notaInicio       Escribir(‘Ingrese la nota del estudiante’)       leer(nota)...
Gracias!!!       Departamento de ingeniería
Upcoming SlideShare
Loading in...5
×

Presentacion ip pseudocodigo_2012_segunda_parte

2,346
-1

Published on

0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
2,346
On Slideshare
0
From Embeds
0
Number of Embeds
1
Actions
Shares
0
Downloads
58
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Presentacion ip pseudocodigo_2012_segunda_parte

  1. 1. Estructura general de un programa (II) Departamento de ingeniería
  2. 2. Enunciados o Instrucciones Departamento de ingeniería
  3. 3. Instrucciones y tipos de instrucciones Es importante en un programa definir las instrucciones que resolverán el problema. Lineal Instrucciones se ejecutan linealmente.Programa No lineal La secuencia se interrumpe con “instrucciones de bifurcación ó de decisión”. El tipo de instrucciones dependen del tipo de lenguaje, sin embargo se tienen instrucciones básicas (Independientes del lenguaje). Departamento de ingeniería
  4. 4. Instrucciones y tipos de instrucciones Inicio / fin Inicio, fin LecturaInstrucciones Asignación Escritura Bifurcación o decisión Departamento de ingeniería
  5. 5. Enunciado de Lectura. El enunciado de lectura se utiliza para introducir datos que se van a utilizar en la solución de un algoritmo. Se almacena en la variable el valor ingresado por el usuario. Ejemplo: ◦ Leer(edad) ◦ Si el usuario digita 5, la variable edad almacena este valor. Departamento de ingeniería
  6. 6. Enunciado de Escritura. El enunciado de escritura se utiliza para presentar los resultados que se esperaban obtener al ejecutarse el algoritmo. Ejemplo: ◦ Escribir(edad) ◦ Presenta el valor correspondiente con edad. Departamento de ingeniería
  7. 7. Enunciado de Asignación (I).• Es una acción o proceso por el cual se le asigna un valor (constante o variable) o el resultado de una operación (expresión) a una variable. Los enunciados de asignación se utilizan generalmente para cambiar el valor a una variable o definirla.• Definir una variable consiste en asignarle o darle por primera vez un valor; y puede hacerse de dos maneras: – Por medio de una lectura de datos, o – Utilizando un enunciado de asignación.• Ejemplo: leer(edad) edad  25 Departamento de ingeniería
  8. 8. Enunciado de Asignación (II).Asignación aritmética. Las expresiones en las operaciones son aritméticasEjm. Instrucciones Traza 1) N 3 1) La variable N toma el valor de 3 2) N N+1 2) La variable N toma el valor de 4 3) S 2 3) La variable S toma el valor de 2 4) S N+5 4) La variable S toma el valor de 9 Departamento de ingeniería
  9. 9. Enunciado de Asignación (III).Asignación lógica. La expresión que se evalúa en la operación de asignación es lógicaEjm. Instrucciones Traza 1) M 31 < 2 1) La variable M toma el valor de falso 2) P P o (2 <= 12) 2) La variable P toma el valor de verdadero 3) Q MyP 3) La variable S toma el valor de falso Departamento de ingeniería
  10. 10. Enunciado de Asignación (III).Asignación de cadena de caracteres. La expresión que se evalua es de tipo cadena.Ejm. x  ‘Pedro Perez’La acción de asignación asigna a la variable tipo cadena x, la cadena de caracteres ‘Linterna verde’.Asignación múltiple. La sintaxis que se utiliza es<variable> <variable> <operador> <expresión> Departamento de ingeniería
  11. 11. Reglas para la construcción deenunciados de asignación (I).Toda variable que aparezca al lado derecho de un enunciado de asignación debe estar definida.• Ejemplo 1: edad  25 contador  0 contador  contador + edad • Las variables edad y contador se definieron correctamente• Ejemplo 2: contador  0 contador  contador + edad • La variable edad nunca fue definida. Departamento de ingeniería
  12. 12. Reglas para la construcción deenunciados de asignación (II). En un enunciado de asignación, la variable de la izquierda es la única que cambia de valor cuando con anterioridad tiene un valor asignado. Ejemplo : edad  25 contador  0 contador  contador + edad Departamento de ingeniería
  13. 13. Reglas para la construcción deenunciados de asignación (III).Las variables que aparecen en la partederecha de un enunciado de asignaciónconservan su valor después de ejecutarsela asignación.Ejemplo: salario  1000 bono  120 salario_neto  salario + bono Departamento de ingeniería
  14. 14. Reglas para la construcción deenunciados de asignación (IV).Si la variable de la parte izquierda delenunciado se encuentra también en el ladoderecho, esta variable cambia de valor poraparecer en la izquierda.Ejemplo: acumulador  0 edad  25 acumulador  acumulador + edad Departamento de ingeniería
  15. 15. Enunciado de Decisión.Los enunciados de decisión se utilizan paratomar una acción o conocer el estado dealguna situación especial, quegeneralmente toman un valor Verdadero oFalso. Departamento de ingeniería
  16. 16. Enunciado de Decisión – Si.. SinoDiagrama de Flujo SI NO <comparación> SI <comparación> ENTONCES Pseudo Código VERDADERO Enunciado(s) SINO FALSO Enunciado(s) FIN SI Departamento de ingeniería
  17. 17. Enunciado de Decisión – SI .. SinoDiagrama de Flujo SI NO contador > 0 promedio  acumulador/contador promedio  0 SI contador >0 ENTONCES Pseudo Código promedio  acumulador/contador SINO promedio  0 FIN SI Departamento de ingeniería
  18. 18. Enunciado de Repetición. Son los enunciados que permiten repetir varias veces un conjunto de enunciados según se necesite de acuerdo a una condición. Se les conoce también como ciclos. Departamento de ingeniería
  19. 19. Enunciado de Repetición - MientrasDiagrama de Flujo SI NO <comparación> MIENTRAS <comparación> HACER Pseudo Código VERDADERO Enunciado(s) a repetir FIN MIENTRAS FALSO Enunciado(s) Departamento de ingeniería
  20. 20. Enunciado de Repetición - MientrasDiagrama de Flujo SI contador < numero NO contador  contador + 1 promedio  acumulador/contador Leer(edad) Escribir (promedio)acumulador  acumulador + edad Fin MIENTRAS contador < numero HACER Pseudo Código contador  contador +1 leer(edad) acumulador  acumulador + edad FIN MIENTRAS promedio  acumulador/contador Departamento de ingeniería escribir(promedio)
  21. 21. Enunciado de Repetición – Haga .. MientrasDiagrama de Flujo SI NO <comparación> HAGA Pseudo Código VERDADERO Enunciado(s) a repetir MIENTRAS <comparación> FALSO Enunciado(s) Departamento de ingeniería
  22. 22. Enunciado de Repetición – Haga .. MientrasDiagrama de Flujo Leer SI (Edad) NO Promedio  Edad > 0 acumulador/contador contador  contador + 1 Acumulador  acumulador + edad Escriba(promedio) HAGA Pseudo Código leer (edad) contador  contador + 1 Acumulador  acumulador + edad MIENTRAS edad > 0 promedio  acumulador/contador Escriba (promedio) Departamento de ingeniería
  23. 23. Ejemplo algoritmo para “sumar dos números”Entrada:Dos números (num1, num2)Salida:Resultado de la suma de los dos números.Proceso:Se reciben los dos números, luego en una variablenum_suma se el asigna el resultado de la suma delos números. Se imprime el resultado.
  24. 24. Ejemplos de diagramas de flujo Inicio Num_suma 0 Leer num1 Leer num2 Num_suma num1+ num2 Escribir num_suma Fin Departamento de ingeniería
  25. 25. ActividadEn un diagrama de flujo, representar unalgoritmo para dividir dos números. Si elsegundo número que se recibe es “0”, sedebe presentar un mensaje.
  26. 26. Pseudocódigo
  27. 27. Pseudocódigo (I)Es muy importante la indentación (sangría en el margenizquierdo) de las diferentes líneas del algoritmo.Elementos básicos◦Inicio. Se coloca al empezar el pseudocódigo◦Fin. Se coloca al finalizar el pseudocócigo◦//. Se utiliza para colocar comentarios. Se utiliza para realizar una asignación. Ejemplo: num_suma num1 + num2 Leer (y): Se utiliza para solicitar información y
  28. 28. Pseudocódigo (II)Escribir (y): Se utiliza para solicitar escribir un dato y.Escribir(‘mensaje’): Se utiliza para escribir la palabra mensaje. Si sentencia entonces Si sentencia instrucciones 1 entonces Si_no instrucciones instrucciones 2 fin si fin si
  29. 29. Pseudocódigo (III)Si sentencia1 entonces instrucciones1sino si sentencia2 entonces instrucciones 2 sino si sentencia3 entonces instrucciones3 sino instrucciones4 fin si fin sifin simientras sentencia haga instruccionesfin mientras
  30. 30. Ejemplo de pseudocódigoEscribir en pseudocódigo un algoritmo que pida el nombre deuna persona e imprima en pantalla el nombre ingresado.Var cadena: nombre;inicio Escribir (‘Ingrese su nombre’) Leer (nombre) //En nombre se guardará la información que se ingrese Escribir (‘El nombre ingresado es:’, nombre)fin
  31. 31. Actividad en Clase (I)1. Escribir en pseudocódigo un algoritmo para multiplicar dos números.2. Escribir en pseudocódigo un algoritmo para dividir dos números.3. Escribir un algoritmo que determine si un número es o no par. En caso de ser par debe presentar un mensaje “El número X es par” ó “El número X es impar”.
  32. 32. Actividad en ClaseEscribir un algoritmo que: «Dados tres números determina si lasuma de dos de ellos es igual al otro número. En caso de quesean iguales escribir «iguales», en caso de ser desigualesescribir «desiguales».Entradas: tres números num1,num2,num3Salidas: mensaje “iguales” ó “desiguales”.Proceso: Se solicitan los números al usuario Se comparan las tres posibles comparaciones de números Se muestra el resultado respectivo.
  33. 33. Algoritmo comparar_iguales Solución IVar entero: num1,num2,num3Inicio Escribir(‘Ingrese primer número’) leer(num1) Escribir(‘Ingrese segundo número’) leer(num2) Escribir(‘Ingrese tercer número’) leer(num3) si(num1+num2=num3)entonces escribir(‘iguales’) sino si(num1+num3=num2)entonces escribir(‘iguales’) sino si(num2+num3=num2)entonces escribir(‘iguales’) sino escribir(‘desiguales’) fin_si fin_si fin_siFin
  34. 34. Solución IIAlgoritmo comparar_igualesVar entero: num1,num2,num3Inicio Escribir(‘Ingrese primer número’) leer(num1) Escribir(‘Ingrese segundo número’) leer(num2) Escribir(‘Ingrese tercer número’) leer(num3) si((num1+num2=num3) ó (num1+num3=num2) ó (num2+num3=num1 ó ) )entonces escribir(‘iguales’) sino escribir(‘desiguales’) fin_siFin
  35. 35. Actividad en ClaseEscriba un algoritmo que pida a un profesor una nota.Dependiendo de la nota se debe realizar lo siguiente:  Si la nota está entre 0y 2.9 presente un mensaje: “perdió la materia”.  Si la nota está entre 3 y 5 presente un mensaje: “ganó la materia”. Si la nota está entre 4.5 y 5 presentar también un mensaje: “excelente nota”.Entradas: nota del estudianteSalida: mensaje respectivoProceso: Se solicita la nota del estudiante. Se valida el rango en la cual se encuentra la nota. Se presenta el mensaje respectivo.
  36. 36. SoluciónAlgoritmo validar_notaVar real: notaInicio Escribir(‘Ingrese la nota del estudiante’) leer(nota) si ((nota>=0) y (nota<2.9)) entonces escribir(‘perdió la materia’) sino si((nota>=3) y (nota<=5)) entonces escribir(‘ganó la materia’) si ((nota>=4.5) y (nota<=5)) entonces escribir(‘excelente nota’) fin_si sino escribir(‘La nota no está en el rango de 0 a 5’) fin_si fin_siFin
  37. 37. Gracias!!! Departamento de ingeniería
  1. A particular slide catching your eye?

    Clipping is a handy way to collect important slides you want to go back to later.

×