REPUBLICA BOLIVARIANA DE VENEZUELAMINISTERIO DEL PODER POPULAR PARA LA EDUCACIÓN UNIVERSITARIA                   MERIDA ES...
Ejercicios Resueltos.1. Diseñar un algoritmo que lea dos valores numéricos X e Y, determina si son iguales y   en caso de ...
2. Diseño de un algoritmo correspondiente a un programa que lee un número entero   positivo y determina el número de dígit...
3. Diseño de un algoritmo correspondiente a un programa que suma todos aquellos   números leídos mientras no sean negativo...
4. Diseño de un algoritmo que lee un conjunto de valores, si cada valor se encuentra   entre cero y diez ([0,10]) debe esc...
De lo contrario                                     Escribir “Valor fuera de rango”                             FinSi     ...
5. Diseño de un algoritmo que permite leer treinta valores y escribir la suma de ellos y   cuantas veces se repite el nume...
6. Diseño del algoritmo correspondiente a un programa que calcula la potencia de un numero   dada la base y el exponente.P...
7. Algoritmo que lee cincos valores numéricos y calcula su producto.Programa: ProductoMódulo: principalInicio         Dato...
Upcoming SlideShare
Loading in...5
×

Algoritmos

3,920

Published on

Ejercicios de algoritmos

Published in: Education
0 Comments
2 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
3,920
On Slideshare
0
From Embeds
0
Number of Embeds
1
Actions
Shares
0
Downloads
60
Comments
0
Likes
2
Embeds 0
No embeds

No notes for slide

Algoritmos

  1. 1. REPUBLICA BOLIVARIANA DE VENEZUELAMINISTERIO DEL PODER POPULAR PARA LA EDUCACIÓN UNIVERSITARIA MERIDA ESTADO MERIDA TSU Araque A.Yelixa
  2. 2. Ejercicios Resueltos.1. Diseñar un algoritmo que lea dos valores numéricos X e Y, determina si son iguales y en caso de no serlo, indica cuál de ellos es el mayor.Programa: Condicion_anidadaMódulo: principalInicio Datos: Variables X Numérico Real Y Numérico Real Algoritmo Leer X, Y Si X>Y Escribir “El mayor es: ”, X Sino Si X=Y Escribir “son iguales” Sino Escribir “El mayor es:”, Y FinSi FinSiFin.
  3. 3. 2. Diseño de un algoritmo correspondiente a un programa que lee un número entero positivo y determina el número de dígitos decimales necesarios para la representación de dicho valor.Programa: Cuenta_digitosMódulo: principalInicio Datos: Variables Ndígitos Numérico Entero Pot Numérico Entero N Numérico Entero Algoritmo Ndígitos= 1 Pot= 10 Leer N Mientras Pot <= N Ndigitos = Ndigitos+1 Pot = Pot * 10 FinMientras Escribir “Se necesitan”, NdigitosFin.
  4. 4. 3. Diseño de un algoritmo correspondiente a un programa que suma todos aquellos números leídos mientras no sean negativos.Programa: SumaMódulo: principalInicio Datos: Variables Suma Numérico Entero Num Numérico Entero Algoritmo Suma= 0 Leer Num Mientras Num >= 0 Suma = Suma+Num Leer Num FinMientras Escribir “La suma es:”, SumaFin.
  5. 5. 4. Diseño de un algoritmo que lee un conjunto de valores, si cada valor se encuentra entre cero y diez ([0,10]) debe escribirse el nombre de (‘Gisela’) tantas veces hasta llegar a cero. Si el valor leído se encuentra entre once y veinte ([11,20]) debe escribirse el nombre (‘Pedro’) tantas veces hasta llegar a veinte. En caso contrario envía un mensaje indicando que el número esta fuera de rango.Programa: Conjunto_valoresMódulo: principalInicio Datos: Variables X Numérico Real Resp Numérico Real Algoritmo Resp = S Mientras (Resp = S) Leer X Si (X >=0) y (X<=10 ) entonces Mientras (X>=0) Escribir (‘Gisela’) X=X-1 FinMientras Sino Si (X>=11) y (X<=20) Mientras (X<=20) Escribir (‘Pedro’) X=X+1 FinMientras
  6. 6. De lo contrario Escribir “Valor fuera de rango” FinSi FinSi Escribir “Desea continuar S/ N” Leer Resp FinMientrasFin.
  7. 7. 5. Diseño de un algoritmo que permite leer treinta valores y escribir la suma de ellos y cuantas veces se repite el numero 3.Programa: numeroMódulo: principalInicio Datos: Variables Suma Numérico Entero Num Numérico Entero Cont Numérico Entero I Numérico Entero Algoritmo Suma= 0 Cont = 0 I=1 Mientras I<= 30 Leer Num Suma = Suma+Num Si (Num = 3) Cont = Cont+1 Finsi I= I+1 FinMientras Escribir “La suma es:”, Suma Escribir “El numero se repite:”, ContFin.
  8. 8. 6. Diseño del algoritmo correspondiente a un programa que calcula la potencia de un numero dada la base y el exponente.Programa: PotenciaMódulo: principalInicio Datos: Variables Pot Numérico Entero C Numérico Entero Base Numérico Entero Exp Numérico Entero Algoritmo Pot= 1 C=1 Leer Base Leer Exp Mientras C <= Exp Pot = Pot*Base C= C+1 FinMientras Escribir “La potencia es:”, PotFin.
  9. 9. 7. Algoritmo que lee cincos valores numéricos y calcula su producto.Programa: ProductoMódulo: principalInicio Datos: Variables P Numérico Entero C Numérico Entero N Numérico Entero Algoritmo P= 1 Para C de 1 a 5 con Inc= 1 Leer N P= P * N FinPara Escribir “El producto es:”, PFin.

×