Fundamento da Administração da Informação

688 views

Published on

Apresentação do Trabalho em Grupo do 1.º Semestre de ADS.

Published in: Education
1 Comment
0 Likes
Statistics
Notes
  • Be the first to like this

No Downloads
Views
Total views
688
On SlideShare
0
From Embeds
0
Number of Embeds
2
Actions
Shares
0
Downloads
18
Comments
1
Likes
0
Embeds 0
No embeds

No notes for slide

Fundamento da Administração da Informação

  1. 1. 4.2
  2. 2. Aqui começa o código: algoritmo "Cadastro_Nossa_Locadora" var Variável, em Matemática, é um ente, em geral representado por uma letra, que pode assumir diferentes valores numéricos em uma expressão algébrica, numa fórmula ou num algoritmo; // aqui embaixo esta as declarações das variáveis cliente,livro: caractere cpf: inteiro mes, dia, ano: inteiro inicio // Seção de Comandos // mostra na tela um menu de consulta a ser realizada para a locação do livro // no item gênero colocamos ao invés de numero como no exemplo, foi desenvolvida a forma de chamar pelo nome do gênero // dando mais transparência ao sistema e para chamar o livro pelo gênero que seria a categoria, usamos o (" Estrutura de Múltipla Escolha") escreval // aqui embaixo está o cabeçalho escreval(" NOSSA LOCADORA DE LIVROS ")escrevalescreval("")escreval ("Qual livro desejas consultar")escreval(".")
  3. 3. • // aqui está código da lista de gênero para o usuário escolher esta lista será impressa na tela•• escreval("Lista de genero da Biblioteca Nossa Locadora.")• escreval(".")• escreval(".")• escreval("1 - Aviação")• escreval("2 - Bebidas")• escreval("3 - Culinaria")• escreval("4 - Esportes")• escreval(".")•• // aqui começa a coleta de dados com o comando leia ( Ler o gênero do livro ) aqui o usuário digita o gênero do livro• // Aviação, Bebidas, Culinária, Esportes
  4. 4. • caso "Aviação"•• escreval• escreval(" NOSSA LOCADORA DE LIVROS ")• escreval• escreval("")• escreva ("Você escolheu o Livro de aviação")• escreval()• escreval()• escreva("Nome do cliente: ")• leia(cliente)• escreva("CPF: ")• leia(cpf)• escreval()• escreval ("Digite o dia da aquisição: ")• leia (dia)• escreval ("Digite o mês da aquisição: ")• escreval• escreval("")• leia (mes)• escreval ("Digite o ano da aquisição: ")• leia (ano)• limpatela
  5. 5. • escreval()• escreval()• escreval ("Codigo: 001 ")• escreval (" Genero: Aviação Valor R$ 20,00")• escreval (" Nome do Livro: Quem Inventou o 14 Bis")• escreval("")• escreval (" Assunto: A Conquista dos Céus ")• escreval (" Autor: Santos Dumont")• escreval("")• escreval (" Editora: Abril")• escreval (" Edição: 01 de Ouro")• escreval("")• escreval (" Ano de Públicação: 1920")• escreval (" Idioma: Brasileiro")• escreval
  6. 6. • //inicio da validação da data• escreval("Digite o dia, mês e ano da locação")• leia(dia, mes, ano)•• // Logo abaixo está um exemplo de data inválida 31 / 13 / 2012, não existe os mês treze, então o sistema vai dar um feed back dizendo para digitar novamente a data usando a estrutura subalgoritmimica
  7. 7. • A condição "se-então(-senão)" é uma estrutura de seleção comum em diversas linguagens de programação.• se (mes < 1) ou (mes > 12) ou (dia < 1) ou (dia > 31) ou (ano < 0) entao• escreva("Data inválida!")• escreval• escreval("Digite novamente")• escreval• escreval("Digite o dia, mês e ano da locação")• // se der erro ele vai ler o comando novamente• leia(dia, mes, ano)• se (mes < 1) ou (mes > 12) ou (dia < 1) ou (dia > 31) ou (ano < 0) entao• escreva("Data inválida o sistema travou!")• escreval• escreval("Reinicie o sistema, aperte ESC depois F-9")• fimse
  8. 8. • senao• se ((mes = 4) ou (mes = 6) ou (mes = 9) ou (mes = 11)) e (dia > 30) entao• escreva("Data inválida!")• escreval• escreval("Digite novamente")• escreval• escreval("Digite o dia, mês e ano da locação")• leia(dia, mes, ano)• se ((mes = 4) ou (mes = 6) ou (mes = 9) ou (mes = 11)) e (dia > 30) entao• escreva("Data inválida o sistema travou!")• escreval• escreval("Reinicie o sistema, aperte ESC depois F-9")• fimse
  9. 9. • // aqui ocódigo verifica se é ano bissexto• // o Ano tem quer diferente de zer (0) e ano divisão modular por 4 igual a zero•• se (ano <>0)e(ano mod 4 = 0)entao• escreva (" ano bissexto")
  10. 10. • // aqui começa a validação do mes de Fevereiro, se é mês de ano bissexto ou não se o dia for menor que• // 29 e o mes for igual data válida•• se (dia < 29) e (mes = 2) entao•• // se o mes = 2 e o dia for menor que 29 então esta tudo normal e o código passar direto•• escreval(" ... data válida")• escreval("...passando para a proxima etapa do sistema")• fimse••
  11. 11. • se (ano <> 0)e(ano mod 4 = 0) entao• escreval(“Ano Bissexto")
  12. 12. • senao• escreva("ano não é bissexto")• fimse• fimse
  13. 13. • // aqui começa a contar de 1 até 1000 ou seja ele vai repetir a pergunta para locação //de livros de 1 até 1000 que já seria um numero alto e que podemos classificar como // ilimitado•• para contador de 1 ate 1000 passo 1 faca
  14. 14. • escreval()• escreval ("Codigo: 001 ")• escreval (" Genero: Aviação, Valor: R$ 20,00 ")• escreval (" Nome do Livro: Quem Inventou o 14 Bis")• escreval("")• escreval (" Assunto: A Conquista dos Céus ")• escreval (" Autor: Santos Dumont")• escreval("")• escreval (" Editora: Abril")• escreval (" Edição: 01 de Ouro")• escreval("")• escreval (" Ano de Públicação: 1920")• escreval (" Idioma: Brasileiro")• escreval•• escreval("Quantos livros desejas Locar: ")• leia(biss14)••• escreva ("Voce locou: ", biss14, " no valor da locação por unidade R$ ", valbiss14)
  15. 15. • escreval(" NOSSA LOCADORA DE LIVROS ")• escreval• escreval("Nome do Cliente ",cliente)• escreval("CPF de N.º ",cpf)• escreval("Endereço: ", endereco)• escreval("Telefone: ", telefone)• escreval()• escreval(" RESUMO DA LOCAÇÃO ")• escreval•• escreval ("Quantidade de livros de Aviação ", biss14, " no valor de R$ ", Valbiss14)• escreval ("Quantidade de livros de Bebidas ", bebi, " no valor de R$ ", valbebi)• escreval ("Quantidade de livros de Culinaria ", culi, " no valor de R$ ", valculi)• escreval ("Quantidade de livros de Esportes ", esport, " no valor de R$ ", valesport)• valbiss14<- valbiss14 * biss14• valbebi<- valbebi * bebi• valculi<- valculi * culi• valesport<- valesport * esport• valfinal<- (valbiss14) + (valbebi) + (valculi) + (valesport)• valquant<- biss14 + bebi + culi + esport• escreval• escreval• escreval("numero de unidades locadas ",valquant)• escreval("Valor total da locação de livros à pagar R$ ",valfinal)•• Fimalgoritmo
  16. 16. • – CONCLUSÃO••• Foi altamente didático o aprendizado contido neste trabalho, a expansão de horizontes proporcionada, colocou em xeque nossas dúvidas, nos capacitou e nos qualificou de forma eficaz quanto a elaboração de sistemas de alarmes de incêndio com detectores, no desenvolvimento de algoritmos e na compreensão da lógica aristotélica e Booleana que são a base para a lógica algorítmica que executada a através dos conectivos lógicos e usada nos pseudocódigos.

×