• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Sort
 

Sort

on

  • 233 views

 

Statistics

Views

Total Views
233
Views on SlideShare
233
Embed Views
0

Actions

Likes
0
Downloads
7
Comments
0

0 Embeds 0

No embeds

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Sort Sort Presentation Transcript

    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. _
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. i _ 1
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 i 8_ 1
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 i 8_ 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 i 8 6_ 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 i 8 6_ 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 i 8 6 5_ 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 i 8 6 5_ 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 i 8 6 5 3_ 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 i 8 6 5 3_ 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 i 8 6 5 3_ 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 J i 8 6 5 3_ 2 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 J i 8 6 5 3_ 2 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 J T 5 i 8 6 5 3_ 2 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 3 J T 5 i 8 6 5 3_ 2 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 5 i 8 6 5 3_ 2 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 5 i 8 6 5 3_ 2 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 5 i 8 6 5 3_ 2 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 5 i 8 6 5 3_ 2 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 6 i 8 6 5 3_ 2 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 3 P4 5 J T 6 i 8 6 5 3_ 2 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 6 P4 5 J T 6 i 8 6 5 3_ 2 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 6 P4 5 J T 6 i 8 6 5 3_ 2 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 6 P4 5 J T 6 i 8 6 5 3_ 2 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 3 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 3 2
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 3 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 3 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 6 i 8 6 5 3_ 3 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 5 J T 6 i 8 6 5 3_ 3 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 6 i 8 6 5 3_ 3 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 6 i 8 6 5 3_ 3 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 6 i 8 6 5 3_ 3 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 6 i 8 6 5 3_ 3 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 8 i 8 6 5 3_ 3 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 5 P4 6 J T 8 i 8 6 5 3_ 3 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 3 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 3 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 3 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 4 3
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 4 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 4 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 4 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 6 J T 8 i 8 6 5 3_ 4 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4
    • Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4