Your SlideShare is downloading. ×

Sort

140

Published on

0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
140
On Slideshare
0
From Embeds
0
Number of Embeds
1
Actions
Shares
0
Downloads
8
Comments
0
Likes
0
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. _
  • 2. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. i _ 1
  • 3. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 i 8_ 1
  • 4. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 i 8_ 2
  • 5. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 i 8 6_ 2
  • 6. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 i 8 6_ 3
  • 7. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 i 8 6 5_ 3
  • 8. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 i 8 6 5_ 4
  • 9. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 i 8 6 5 3_ 4
  • 10. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 i 8 6 5 3_ 4
  • 11. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 i 8 6 5 3_ 2
  • 12. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 J i 8 6 5 3_ 2 4
  • 13. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 J i 8 6 5 3_ 2 4
  • 14. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 5 P4 3 J T 5 i 8 6 5 3_ 2 4
  • 15. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 3 J T 5 i 8 6 5 3_ 2 4
  • 16. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 5 i 8 6 5 3_ 2 4
  • 17. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 5 i 8 6 5 3_ 2 4
  • 18. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 5 i 8 6 5 3_ 2 3
  • 19. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 5 i 8 6 5 3_ 2 3
  • 20. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 6 P3 3 P4 5 J T 6 i 8 6 5 3_ 2 3
  • 21. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 3 P4 5 J T 6 i 8 6 5 3_ 2 3
  • 22. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 6 P4 5 J T 6 i 8 6 5 3_ 2 3
  • 23. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 6 P4 5 J T 6 i 8 6 5 3_ 2 2
  • 24. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 6 P4 5 J T 6 i 8 6 5 3_ 2 2
  • 25. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 8 P2 3 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
  • 26. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 3 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
  • 27. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
  • 28. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
  • 29. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 2 2
  • 30. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 3 2
  • 31. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 3 4
  • 32. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 8 i 8 6 5 3_ 3 4
  • 33. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 6 P4 5 J T 6 i 8 6 5 3_ 3 4
  • 34. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 5 J T 6 i 8 6 5 3_ 3 4
  • 35. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 6 i 8 6 5 3_ 3 4
  • 36. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 6 i 8 6 5 3_ 3 4
  • 37. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 6 i 8 6 5 3_ 3 3
  • 38. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 6 i 8 6 5 3_ 3 3
  • 39. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 8 P3 5 P4 6 J T 8 i 8 6 5 3_ 3 3
  • 40. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 5 P4 6 J T 8 i 8 6 5 3_ 3 3
  • 41. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 3 3
  • 42. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 3 3
  • 43. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 3 3
  • 44. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 4 3
  • 45. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 4 4
  • 46. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 4 4
  • 47. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 8 P4 6 J T 8 i 8 6 5 3_ 4 4
  • 48. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 6 J T 8 i 8 6 5 3_ 4 4
  • 49. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4
  • 50. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4
  • 51. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4
  • 52. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4
  • 53. Αρχή Για i από 1 μέχρι 4 Διάβασε P[i] Τέλος_επανάληψης Για i από 2 μέχρι 4 Για J από 4 μέχρι i με_βήμα -1 Αν P[J-1] > P[J] Τότε T  P[J-1] P[J-1]  P[J] P[J]  T Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος. P1 3 P2 5 P3 6 P4 8 J T 8 i 8 6 5 3_ 4 4

×