Your SlideShare is downloading. ×
0
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Presentacion x logo
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×
Saving this for later? Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime – even offline.
Text the download link to your phone
Standard text messaging rates apply

Presentacion x logo

2,487

Published on

Published in: Technology
0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
2,487
On Slideshare
0
From Embeds
0
Number of Embeds
1
Actions
Shares
0
Downloads
80
Comments
0
Likes
1
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. xLogo
  • 2. ¿Qué es L OGO ? … <ul><li>L OGO fue creado por Seymour Papert a finales de los años 60 </li></ul><ul><li>Desarrolló el aprendizaje Construccionista: </li></ul><ul><li>“ el aprendizaje mejora si se aplica activamente </li></ul><ul><li> a la vida cotidiana” -> “ learning-by-doing” </li></ul><ul><li>L OGO es una potente herramienta para desarrollar </li></ul><ul><li>los procesos de pensamiento lógico-matemáticos. </li></ul><ul><li>El usuario mueve un objeto llamado &quot;tortuga&quot; dentro de la </li></ul><ul><li>pantalla usando órdenes simples como &quot;avanza&quot;, &quot;retrocede&quot;, </li></ul><ul><li>&quot;giraderecha&quot; y similares. </li></ul><ul><li>Con cada movimiento la tortuga dibuja una línea tras de sí, </li></ul><ul><ul><li> y de esta manera se crean gráficos. </li></ul></ul>
  • 3. … y, ¿XL OGO ? <ul><li>XL OGO es una versión de L OGO escrita en J AVA y distribuida bajo licencia GPL (General Public License) </li></ul><ul><li>GPL implica que XL OGO es gratis. </li></ul><ul><li>Actualmente admite 7 idiomas </li></ul><ul><li>Poder usar órdenes en el idioma natural favorece su aprendizaje y asimilación </li></ul><ul><li>J AVA es multiplataforma, lo que permite ejecutar XL OGO en todos aquellos sistemas operativos que la soporten (Linux, Windows, MacOS, Solaris, …) </li></ul>
  • 4. Presentando XL OGO Menús Línea de Comando Área de Dibujo Histórico de Comandos Botones de menú Botones Edición y Alto
  • 5. ¿Algo fácil para empezar? ¿Cómo consigo que XL OGO muestre esto?
  • 6. El programa Descargar http://xlogo.tuxfamily.org/sp/curso/presentacion.lgo Abrir el fichero presentacion.lgo “ Click” en el botón del pingüino Escribir presentacion en la barra inferior “ Click” en el botón
  • 7. Debería mostrarse una pantalla como esta: PRUEBA CÓMO SE MUEVE LA TORTUGA Y COMPRENDE “SU” PUNTO DE VISTA
  • 8. Y con esa pantalla, ¿qué? Figuras complejas Proponer figuras simples Plantear juegos (Infantil)
  • 9. El Lenguaje de la Tortuga avanza 100 giraderecha 90 avanza 150 giraderecha 90 avanza 80
  • 10. Las primitivas <ul><li>Las órdenes que recibe la tortuga se llaman “ primitivas ” </li></ul><ul><li>Las primitivas asociadas a los movimientos requieren más información: los “ argumentos ” </li></ul><ul><ul><li>avanza y retrocede esperan un número: cuántos pasos debe desplazarse </li></ul></ul><ul><ul><li>giraderecha y giraizquierda necesitan el número de grados que queremos que gire </li></ul></ul><ul><li>Para borrar lo dibujado: borrapantalla </li></ul>
  • 11. La primitiva repite <ul><li>La primitiva repite sirve para acortar las órdenes cuando una secuencia de ellas se repite </li></ul><ul><li>Ejemplo: </li></ul><ul><ul><li>repite 2 [avanza 30 giraderecha 90] </li></ul></ul><ul><ul><li>es equivalente a escribir </li></ul></ul><ul><ul><li>avanza 30 giraderecha 90 </li></ul></ul><ul><ul><li>avanza 30 giraderecha 90 </li></ul></ul>
  • 12. Polígonos <ul><li>Debemos pensar en: </li></ul><ul><ul><li>Número de vértices </li></ul></ul><ul><ul><li>Ángulo de giro </li></ul></ul><ul><ul><li>Longitud del lado </li></ul></ul><ul><li>Programa: </li></ul><ul><li>repite 6 </li></ul><ul><ul><li>[ avanza 100 </li></ul></ul><ul><ul><li>giraderecha 60 ] </li></ul></ul>
  • 13. repite 8 [...] repite 9 [...] repite 3 [...] repite 5 [...]
  • 14. Para conseguir polígonos estrellados debemos tener un número de vértices impar y mayor que 3 repite 3 [av 100 giraderecha 120] repite 3 [av 100 giraizquierda 120] repite 3 [ avanza 150 giraderecha 120]
  • 15. Más primitivas <ul><li>La tortuga dibuja con un lápiz al moverse </li></ul><ul><li>El lápiz puede estar abajo , arriba , invertido o ser una goma . </li></ul><ul><li>Para hacer que dibuje o no, disponemos de: </li></ul><ul><ul><li>bajalapiz -> la tortuga dibuja al moverse </li></ul></ul><ul><ul><li>subelapiz -> la tortuga no dibuja al moverse </li></ul></ul><ul><ul><li>inviertelapiz -> si hay dibujo, invierte los colores </li></ul></ul><ul><ul><li>goma -> la tortuga borra en vez de dibujar </li></ul></ul><ul><li>Para ver o no a la tortuga </li></ul><ul><ul><ul><ul><li>muestratortuga -> la tortuga es visible </li></ul></ul></ul></ul><ul><ul><ul><ul><li>ocultatortuga -> no se ve a la tortuga </li></ul></ul></ul></ul>
  • 16. Gracias por su atención

×