Taller  de algoritmos
Upcoming SlideShare
Loading in...5
×
 

Like this? Share it with your network

Share

Taller de algoritmos

on

  • 8,819 views

 

Statistics

Views

Total Views
8,819
Views on SlideShare
8,779
Embed Views
40

Actions

Likes
2
Downloads
115
Comments
0

1 Embed 40

http://tecnicoensistemasietagpc5.blogspot.com 40

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

Taller de algoritmos Presentation Transcript

  • 1. Taller de Algoritmos
    Fabián Andrés Gallego Barrios
    1002
  • 2. 1.Dadas las horas trabajadas de una persona y el valor por hora calcula su salario e imprimirlo
    ENTEROS horas, valor, salario
    INICIO
    LEER hora, valor
    Salario <-hora*valor
    ESCRIBIR salario
    FIN
  • 3. 2.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que lea el valor correspondiente a una distancia en millas marinas y escríbalas expresadas en metros. Sabiendo que 1 milla marina equivale a 1852 metros
  • 4. INICIO
    DATOS:
    CONSTANTES
    MILL_METR Numero entero=1852
    VARIABLES
    Dmillas Numero Entero
    Dmetros Numero Entero
    ALGORITMO:
    Escribir “distancias en millas:”
    Leer Dmillas
    Dmetros=Dmillas*MILL_METR
    Escribir “distancia en metros;” Dmetros
    FIN
  • 5. 3.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que pida por teclado dos números enteros y muestre su suma, resta , multiplicación y división y el resto el (modulo) de la división. Si la operación no es conmutativa, también se mostrara el resultado invirtiendo los operadores .
  • 6. INICIO
    DATOS:
    VARIABLES
    Num1 Numero entero
    Num2 Numero entero
    ALGORITMO:
    Leer num1,num2
    Escribir “n1+n2=“,num1+num2
    Escribir “n1-n2=“,num1-num2
    Escribir “n2-n1=“,num2-num1
    Escribir “n1*n2=“,num1*num2
    Escribir “n1/n2=“,num1/num2
    Escribir “n2/n1=“,num2/num1
    Escribir “n1 mod n2=“,num1 mod mun2
    Escribir “n2 modn1=“,num2 modmun1
    FIN
  • 7. 4.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que obtiene la ultima cifra de un numero introducido
    NINICIO
    DATOS:
    VARIABLES
    Núm numérico Entero
    ALGORITMO:
    Escribir ”introduzca numero:”
    Leer num
    Escribir “Ultima Cifra:”, munmod 10
    FIN
  • 8. 5.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que calcule el área y el perímetro de un triangulo rectángulo dada la base y la altura.
  • 9. INICIO
    DATOS:
    VARIABLES
    Base numérico entero
    Altura numérico entero
    Área numérico real
    Hipotenusa numero real
    Perímetro numero real
    ALGORITMO:
    Leer base, altura
    Área=base*altura/2
    Hipotenusa= raíz (base^ 2+altura^2)
    Perímetro=base + altura + hipotenusa
    escribir “área=“,área
    Escribir ”perímetro=“, perímetro
    FIN
  • 10. 5.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que tras introducir una medida expresada en centímetros la convierta en pulgadas ( 1 pulgada es =2,54 centímetros)
  • 11. INICIO
    DATOS:
    CONSTANTES
    ACM_PUL G numero real=2,54
    VARIABLES
    Cm numero real
    Pulgadas numero real
    ALGORITMO:
    Escribir valor en centímetros :”
    Leer cm
    Pulgadas=cm / ACM_PUL G
    Escribir “pulgadas:”, pulgadas
    FIN
  • 12. 6.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que exprese en horas, minutos y segundos un tiempo expresado en segundos.
  • 13. INICIO
    DATOS:
    VARIABLES
    Segundo numérico enteros
    Minutos numérico entero
    Horas numérico entero
    ALGORITMOS:
    Leer segundos / 3600
    Segundos=segundo mod 3600
    Minutos=segundos mod /60
    Segundos=segundos mod 60
    Escribir horas ,”h,” minutos “M”; Segundo's ,”S”
    FIN
  • 14. 7.Calculo un algoritmo que nos permita calcular promedio de notas ;finaliza cuando N=0
    INICIO
    Declaración de variables
    N=0, promedio=0, acumula=0
    Leer N
    Mientras N<> o hacer
    Cuenta=cuenta +1
    Acumula =acumula +N
    FIN MIENTRAS
    Promedio =acumula/cuenta
    Imprimir “promedio:”;promedio
    FIN
  • 15. 8.Desarrolla una algoritmo que realice la sumatoria de los números enteros comprendidos Entre le 1 y 10. Es decir 1+2+3…+10
    INICIO
    Declaración de variables
    N=0, suma=0
    Asignación contador:
    N=N+1
    Asignación acumulador
    Suma= suma + N
    SI N =10ENTONCES
    Escribir suma
    DE LO CONTRARIO REPETIR DESDE EL PASO 3
    FIN_SI
    FIN
  • 16. 9. Determinar la hipotenusa de triangulo rectángulo conocidas las longitudes de sus dos catetos. Desarrolle el algoritmo correspondiente
    INICIO
    DECLARACION DE VARIBLES :CatA=0, CatB=0
    Leer el valor de cada cateto
    Almacenarlo en la variable CatA, CatB
    Calcular el valor de hip con la
    Formula indicada
    Escribir el valor d la hipotenusa
    Fin
  • 17. 10.Dasarrlle un algoritmo que permita determinar el area y el volumen de un circulo dado su (r) y altura (h)
    INICIO
    DECLARACION DE BARIABLES:R=0,H=0
    LEER EL VALOR DE RADIO (R) ALTURA(H)
    CALCULAR EL VOLOMEN APLICANDO EN LA FORMULOA
    CALCULAR EL VALOR DEL AREA APLICANDO LA
    FORMULA RESPECTIVA
    ESCRIBIR EL VALOR DE AREA Y DEL VOLUMEN
    FIN
  • 18. 11.Desarrolle un algoritmo que permita leer un valor cualquier N y escriba si dicho numero es par o impar
    INICIO
    DECLARACION DE VARIABLES:N
    LEER UN NUMERO
    ASIGNARLO A LA VARIBLE N
    SI EL RESIDUO DE DIVIDIR A N 2 ES
    IGUAL A CERO
    SI ES SI:ENTONCES”ES PAR”
    SI NO:ESCRIBIR” ES IMPAR”
    FIN_SI
    FIN
  • 19. 12.desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor, si es el caso
    INICIO
    DECLARACION DE VARIABLES :
    A=0,B=0,TEMPORAL=0
    LEER A y B
    SI A <B ENTONCES
    ASIGNAR a TEMPORAL=B
    ASIGNAR a B=A
    ASIGNAR a A=TEMPORAL
    SI NO (DE LO CRONTRARIO)
    FIN_SI
    ESCRIBIR”ORDEN =“,A,B
    FIN
  • 20. 13.Dasarrolla un algoritmo que permite leer u valor entero positivo N y determinar síes primo o no
    Inicio declaración de variables :
    J=2, S=0
    Leer N
    Mientras J <=N/2hacer
    Si N / J=0
    S=S+1
    J=J+1
    Fin _si
    Fin del ciclo mientras
    Si S =o entonces
    Escribir N “es primo”
    Si no (de lo contrario)
    Escribir N” no es primo”
    Fin _si
    Fin
  • 21. 14.Dado un tiempo en segundos, calcular los segundos restantes que le correspondan para convertirse exactamente en minutos
    Variable : tiempo_ seg, minutos ,segundos
    Inicio
    Leer: tiempo_ seg
    Si minutos < -- tiempo_seg div 60 entonces
    Segundos < -- tiempo_segmod 60
    Fin_si
    Imprimir: minutos, segundos.
    fin
  • 22. 15.Dado el tiempo en minutos, calcular los días, horas y minutos que le corresponde.
    Variables: tiempo, días, horas y minutos
    Inicio
    Leer: tiempo
    Si: días < -- tiempo div 1440
    X < -- tiempo mod 1440
    Horas < -- x div 60
    Imprimir: días, minutos, horas
    Fin_si
    fin
  • 23. 16.Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C respectivamente. El algoritmo debe imprimir cual es el mayor y cual es el menor. Recuerde constatar que los tres valores introducidos por el teclado sean distintos. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.
  • 24. Inicio
    Inicializar las variables A, B y C
    Leer los tres valores
    Almacenar en las variables A, B y C
    Si A > B y A > C entonces
    Escribir A “es el mayor”
    Si no
    Si B > A y B > C entonces
    Escribir B “es el mayor”
    Si no
    Escribir C “es el mayor”
    Fin_si
    fin
  • 25. 17.Desarrolle un algoritmo que funcione como una caja registradora
  • 26. inicio
    Declaración de variables:
    Sub_total=0, total=0
    Ingrese “código de producto y
    Precio :”
    Almacenar codigo_producto, precio
    Imprimir líneas de títulos del recibo
    de pago
    Mientras codigo_producto <> “ ”
    Subtotal=subtotal +precio
    Imprimir código _ producto, precio
    Ingrese “ código del producto y
    Precio
    Fin mientras
    IVA =subtotal * 0,15
    Total = subtotal + IVA
    Imprimir “ sub total :”, subtotal
    Imprimir “IVA :”, IVA
    Imprimir “total :”, total
    fin