Taller de algoritmos

11,376 views
11,051 views

Published on

0 Comments
4 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
11,376
On SlideShare
0
From Embeds
0
Number of Embeds
42
Actions
Shares
0
Downloads
143
Comments
0
Likes
4
Embeds 0
No embeds

No notes for slide

Taller de algoritmos

  1. 1. Taller de Algoritmos<br />Fabián Andrés Gallego Barrios<br />1002<br />
  2. 2. 1.Dadas las horas trabajadas de una persona y el valor por hora calcula su salario e imprimirlo <br />ENTEROS horas, valor, salario <br />INICIO<br />LEER hora, valor <br />Salario <-hora*valor<br />ESCRIBIR salario<br />FIN<br />
  3. 3. 2.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que lea el valor correspondiente a una distancia en millas marinas y escríbalas expresadas en metros. Sabiendo que 1 milla marina equivale a 1852 metros <br />
  4. 4. INICIO <br />DATOS:<br />CONSTANTES<br />MILL_METR Numero entero=1852<br />VARIABLES <br />Dmillas Numero Entero <br />Dmetros Numero Entero <br />ALGORITMO:<br />Escribir “distancias en millas:”<br />Leer Dmillas<br />Dmetros=Dmillas*MILL_METR<br />Escribir “distancia en metros;” Dmetros<br />FIN<br />
  5. 5. 3.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que pida por teclado dos números enteros y muestre su suma, resta , multiplicación y división y el resto el (modulo) de la división. Si la operación no es conmutativa, también se mostrara el resultado invirtiendo los operadores . <br />
  6. 6. INICIO <br />DATOS:<br />VARIABLES<br />Num1 Numero entero<br />Num2 Numero entero <br />ALGORITMO:<br />Leer num1,num2<br />Escribir “n1+n2=“,num1+num2 <br />Escribir “n1-n2=“,num1-num2 <br />Escribir “n2-n1=“,num2-num1<br />Escribir “n1*n2=“,num1*num2 <br />Escribir “n1/n2=“,num1/num2 <br />Escribir “n2/n1=“,num2/num1<br />Escribir “n1 mod n2=“,num1 mod mun2<br />Escribir “n2 modn1=“,num2 modmun1<br />FIN<br />
  7. 7. 4.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que obtiene la ultima cifra de un numero introducido <br />NINICIO<br />DATOS:<br />VARIABLES <br />Núm numérico Entero <br />ALGORITMO:<br />Escribir ”introduzca numero:”<br />Leer num<br />Escribir “Ultima Cifra:”, munmod 10 <br />FIN<br />
  8. 8. 5.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que calcule el área y el perímetro de un triangulo rectángulo dada la base y la altura.<br />
  9. 9. INICIO<br />DATOS:<br />VARIABLES <br />Base numérico entero <br />Altura numérico entero <br />Área numérico real<br />Hipotenusa numero real<br />Perímetro numero real <br />ALGORITMO:<br />Leer base, altura<br />Área=base*altura/2<br />Hipotenusa= raíz (base^ 2+altura^2)<br />Perímetro=base + altura + hipotenusa<br />escribir “área=“,área <br />Escribir ”perímetro=“, perímetro<br />FIN<br />
  10. 10. 5.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que tras introducir una medida expresada en centímetros la convierta en pulgadas ( 1 pulgada es =2,54 centímetros)<br />
  11. 11. INICIO<br />DATOS:<br />CONSTANTES<br />ACM_PUL G numero real=2,54<br />VARIABLES<br />Cm numero real<br />Pulgadas numero real <br />ALGORITMO:<br />Escribir valor en centímetros :”<br />Leer cm<br />Pulgadas=cm / ACM_PUL G<br />Escribir “pulgadas:”, pulgadas<br />FIN<br />
  12. 12. 6.Diseñar el algoritmo (ordinograma pseudocódigo) correspondiente a un programa que exprese en horas, minutos y segundos un tiempo expresado en segundos.<br />
  13. 13. INICIO<br />DATOS:<br />VARIABLES <br />Segundo numérico enteros <br />Minutos numérico entero <br />Horas numérico entero <br />ALGORITMOS:<br />Leer segundos / 3600<br />Segundos=segundo mod 3600<br />Minutos=segundos mod /60<br />Segundos=segundos mod 60<br />Escribir horas ,”h,” minutos “M”; Segundo's ,”S”<br />FIN<br />
  14. 14. 7.Calculo un algoritmo que nos permita calcular promedio de notas ;finaliza cuando N=0<br />INICIO<br />Declaración de variables <br />N=0, promedio=0, acumula=0<br />Leer N<br />Mientras N<> o hacer <br />Cuenta=cuenta +1<br />Acumula =acumula +N<br />FIN MIENTRAS<br />Promedio =acumula/cuenta <br />Imprimir “promedio:”;promedio <br />FIN<br />
  15. 15. 8.Desarrolla una algoritmo que realice la sumatoria de los números enteros comprendidos Entre le 1 y 10. Es decir 1+2+3…+10<br />INICIO <br />Declaración de variables <br />N=0, suma=0<br />Asignación contador:<br />N=N+1<br />Asignación acumulador <br />Suma= suma + N<br />SI N =10ENTONCES<br />Escribir suma <br />DE LO CONTRARIO REPETIR DESDE EL PASO 3 <br />FIN_SI<br />FIN<br />
  16. 16. 9. Determinar la hipotenusa de triangulo rectángulo conocidas las longitudes de sus dos catetos. Desarrolle el algoritmo correspondiente <br />INICIO <br />DECLARACION DE VARIBLES :CatA=0, CatB=0<br />Leer el valor de cada cateto <br />Almacenarlo en la variable CatA, CatB<br />Calcular el valor de hip con la <br />Formula indicada <br />Escribir el valor d la hipotenusa <br />Fin <br />
  17. 17. 10.Dasarrlle un algoritmo que permita determinar el area y el volumen de un circulo dado su (r) y altura (h)<br />INICIO<br />DECLARACION DE BARIABLES:R=0,H=0<br />LEER EL VALOR DE RADIO (R) ALTURA(H)<br />CALCULAR EL VOLOMEN APLICANDO EN LA FORMULOA<br />CALCULAR EL VALOR DEL AREA APLICANDO LA<br />FORMULA RESPECTIVA<br />ESCRIBIR EL VALOR DE AREA Y DEL VOLUMEN <br />FIN <br />
  18. 18. 11.Desarrolle un algoritmo que permita leer un valor cualquier N y escriba si dicho numero es par o impar <br />INICIO<br />DECLARACION DE VARIABLES:N<br />LEER UN NUMERO <br />ASIGNARLO A LA VARIBLE N<br />SI EL RESIDUO DE DIVIDIR A N 2 ES<br />IGUAL A CERO<br />SI ES SI:ENTONCES”ES PAR”<br />SI NO:ESCRIBIR” ES IMPAR”<br />FIN_SI<br />FIN<br />
  19. 19. 12.desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor, si es el caso<br />INICIO <br />DECLARACION DE VARIABLES :<br />A=0,B=0,TEMPORAL=0<br />LEER A y B<br />SI A <B ENTONCES <br />ASIGNAR a TEMPORAL=B<br />ASIGNAR a B=A<br />ASIGNAR a A=TEMPORAL<br />SI NO (DE LO CRONTRARIO)<br />FIN_SI<br />ESCRIBIR”ORDEN =“,A,B<br />FIN<br />
  20. 20. 13.Dasarrolla un algoritmo que permite leer u valor entero positivo N y determinar síes primo o no <br />Inicio declaración de variables :<br />J=2, S=0<br />Leer N<br />Mientras J <=N/2hacer<br />Si N / J=0<br />S=S+1<br />J=J+1<br />Fin _si<br />Fin del ciclo mientras<br />Si S =o entonces <br />Escribir N “es primo”<br />Si no (de lo contrario)<br />Escribir N” no es primo”<br />Fin _si <br />Fin <br />
  21. 21. 14.Dado un tiempo en segundos, calcular los segundos restantes que le correspondan para convertirse exactamente en minutos <br />Variable : tiempo_ seg, minutos ,segundos<br />Inicio <br />Leer: tiempo_ seg<br />Si minutos < -- tiempo_seg div 60 entonces <br />Segundos < -- tiempo_segmod 60<br />Fin_si<br />Imprimir: minutos, segundos.<br />fin<br />
  22. 22. 15.Dado el tiempo en minutos, calcular los días, horas y minutos que le corresponde.<br />Variables: tiempo, días, horas y minutos<br />Inicio <br />Leer: tiempo<br />Si: días < -- tiempo div 1440<br />X < -- tiempo mod 1440 <br />Horas < -- x div 60 <br />Imprimir: días, minutos, horas <br />Fin_si<br />fin<br />
  23. 23. 16.Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C respectivamente. El algoritmo debe imprimir cual es el mayor y cual es el menor. Recuerde constatar que los tres valores introducidos por el teclado sean distintos. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales. <br />
  24. 24. Inicio <br />Inicializar las variables A, B y C<br />Leer los tres valores <br />Almacenar en las variables A, B y C <br />Si A > B y A > C entonces <br />Escribir A “es el mayor”<br />Si no <br />Si B > A y B > C entonces <br />Escribir B “es el mayor”<br />Si no <br />Escribir C “es el mayor”<br />Fin_si<br />fin<br />
  25. 25. 17.Desarrolle un algoritmo que funcione como una caja registradora <br />
  26. 26. inicio <br />Declaración de variables:<br />Sub_total=0, total=0<br />Ingrese “código de producto y <br />Precio :” <br />Almacenar codigo_producto, precio <br />Imprimir líneas de títulos del recibo <br />de pago<br />Mientras codigo_producto <> “ ” <br />Subtotal=subtotal +precio <br />Imprimir código _ producto, precio <br />Ingrese “ código del producto y <br />Precio<br />Fin mientras<br />IVA =subtotal * 0,15<br />Total = subtotal + IVA<br />Imprimir “ sub total :”, subtotal <br />Imprimir “IVA :”, IVA <br />Imprimir “total :”, total<br />fin <br />

×