Ejercicios propuestos 4
1. Muestre los números del 1 al 100 utilizando la instrucción while.
PSEINT
Proceso sin_titulo
Esc...
2. Muestre los números del 1 al 100 utilizando la instrucción
do..while.
PSEINT
Proceso sin_titulo
n<-0;
Escribir "numeros...
3. Muestre los números del 1 al 100 utilizando la instrucción for.
PSEINT
Proceso sin_titulo
n<-1;
Escribir "numeros del 1...
4. Muestre los números del 100 al 1 utilizando la instrucción while.
PSEINT
Proceso sin_titulo
Escribir "numeros del 100 a...
5. Muestre los números del 100 al 1 utilizando la instrucción
do..while
PSEINT
Proceso sin_titulo
n<-100;
Escribir "numero...
6. MUESTRE LOS NÚMEROS DEL 100 AL 1 UTILIZANDO LA
INSTRUCCIÓN FOR.
PSEINT
Proceso sin_titulo
n<-100;
Escribir "numeros del...
7. Leer un número y mostrar su cuadrado, repetir el proceso hasta
que se introduzca un número
negativo.
PSEINT
Proceso sin...
8. Escribir todos los números del 100 al 0 de 7 en 7.
PSEINT
Proceso sin_titulo
n<-100;
Escribir "numeros del 1 al 100";
M...
9.- En una fabrica de computadoras se planea ofrecer a los clientes un
descuento que dependerá del numero de computadoras ...
JAVA
package tarea;
public class ejercicio9 {
public static void main(String[] args) {
int precio,n,precio_t;
double desc,...
10.-Calcular el promedio de un alumno que tiene 7 calificaciones
en la materia de Programación Concurrente.
PSEINT
Proceso...
Upcoming SlideShare
Loading in...5
×

Ejercicios propuestos 4

757

Published on

0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
757
On Slideshare
0
From Embeds
0
Number of Embeds
2
Actions
Shares
0
Downloads
41
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Ejercicios propuestos 4

  1. 1. Ejercicios propuestos 4 1. Muestre los números del 1 al 100 utilizando la instrucción while. PSEINT Proceso sin_titulo Escribir "numeros del 1 al 100"; n<-0; Mientras n<100 Hacer n<-n+1; Escribir "===> ",n; FinMientras FinProceso JAVA package tarea; public class ejercicio1 { public static void main(String[] args) { int n=0; System.out.print("numeros del 1 al 100"); while(n<100){ n=n+1; System.out.println("====>"+n); } } }
  2. 2. 2. Muestre los números del 1 al 100 utilizando la instrucción do..while. PSEINT Proceso sin_titulo n<-0; Escribir "numeros del 1 al 100"; Repetir n<-n+1; Escribir "===>",n; Hasta Que n>=100 FinProceso JAVA package tarea; public class ejercicio2 { public static void main(String[] args) { int n=0; System.out.println("numeros del 1 al 100"); do{ n=n+1; System.out.println("====>"+n); } while (n<100); } }
  3. 3. 3. Muestre los números del 1 al 100 utilizando la instrucción for. PSEINT Proceso sin_titulo n<-1; Escribir "numeros del 1 al 100"; Para i<-1 Hasta 100 Con Paso 1 Hacer Escribir "===>",n; n<-n+1; FinPara FinProceso JAVA package tarea; public class ejercicio3 { public static void main(String[] args) { int i=0; for (int n=0;n<=100;n++){ System.out.println("====> "+n); } } }
  4. 4. 4. Muestre los números del 100 al 1 utilizando la instrucción while. PSEINT Proceso sin_titulo Escribir "numeros del 100 al 1"; n<-100; Mientras n>=1 Hacer Escribir "===> ",n; n<-n-1; FinMientras FinProceso JAVA package tarea; public class ejercicio4 { public static void main(String[] args) { int n=100; System.out.println("numeros del 100 al 1"); while(n>=1){ System.out.println("====>"+n); n=n+-1; } } }
  5. 5. 5. Muestre los números del 100 al 1 utilizando la instrucción do..while PSEINT Proceso sin_titulo n<-100; Escribir "numeros del 100 al 1"; Repetir Escribir "===>",n; n<-n-1; Hasta Que n<1 FinProceso JAVA package tarea; public class ejercicio5 { public static void main(String[] args) { int n=100; System.out.println("numeros del 100 al 1"); do{ System.out.println("====>"+n); n=n-1; } while (n>=1); } }
  6. 6. 6. MUESTRE LOS NÚMEROS DEL 100 AL 1 UTILIZANDO LA INSTRUCCIÓN FOR. PSEINT Proceso sin_titulo n<-100; Escribir "numeros del 100 al 1"; Para i<-1 Hasta 100 Con Paso 1 Hacer Escribir "===>",n; n<-n-1; FinPara FinProceso JAVA package tarea; public class ejercicio6 { public static void main(String[] args) { int i=100; for (int n=100;n>=1;n=n-1){ System.out.println("====> "+n); } } }
  7. 7. 7. Leer un número y mostrar su cuadrado, repetir el proceso hasta que se introduzca un número negativo. PSEINT Proceso sin_titulo Escribir "--------Calculando el cuadrado--------- " Repetir Escribir "Ingrese un numero:" leer n cuadrado<-n*n Escribir "El cuadrado es",cuadrado; Hasta Que n<0 FinProceso JAVA package tarea; public class ejercicio7 { public static void main(String[] args) { int n,cuadrado; do{ System.out.println("ingrese un numero"); n=entrada.entero(); cuadrado=n*n; System.out.println("====>"+cuadrado); } while (n>0); } }
  8. 8. 8. Escribir todos los números del 100 al 0 de 7 en 7. PSEINT Proceso sin_titulo n<-100; Escribir "numeros del 1 al 100"; Mientras n>=0 Hacer Escribir "====>",n; n<-n-7 FinMientras FinProceso JAVA package tarea; public class ejercicio8 { public static void main(String[] args) { int n=100; System.out.println("números del 100 al 0 de 7 en 7"); while(n>0){ System.out.println("====>"+n); n=n-7; } } }
  9. 9. 9.- En una fabrica de computadoras se planea ofrecer a los clientes un descuento que dependerá del numero de computadoras que compre. Si las computadoras son menos de cinco se les dará un 10% de descuento sobre el total de la compra; si el numero de computadoras es mayor o igual a cinco pero menos de diez se le otorga un 20% de descuento; y si son 10 o mas se les da un 40% de descuento. El precio de cada computadora es de $1000 Proceso sin_titulo precio<-1000 Escribir "ingrese numero de computadoras "; leer n precio_t<-precio*n Si n<5 Entonces desc<-precio_t*0.10; FinSi Si (n>=5) y (n<10) Entonces desc<-precio_t*0.20; FinSi Si n>=10 Entonces desc<-precio_t*0.40; FinSi precio_f<-precio_t-desc; Escribir "su descuento es de: ",desc; Escribir "el precio final es : ",precio_f; FinProceso
  10. 10. JAVA package tarea; public class ejercicio9 { public static void main(String[] args) { int precio,n,precio_t; double desc,precio_f; precio=1000; desc=0; System.out.println("ingrese el numero de computadoras"); n=entrada.entero(); precio_t=precio*n; if (n<5){ desc=precio_t*0.1; } else if (n>=5&n<10){ desc=precio_t*0.2; } else if (n>=10){ desc=precio_t*0.4; } precio_f=precio_t - desc; System.out.println("su descuento es de: "+desc); System.out.println("el total a pagar es de: "+precio_f); } }
  11. 11. 10.-Calcular el promedio de un alumno que tiene 7 calificaciones en la materia de Programación Concurrente. PSEINT Proceso sin_titulo Escribir "Calculando promedio " n<-0 suma<-0 Mientras n<7 Hacer n<-n+1 Escribir "Ingrese nota: " , n leer nota suma<-suma+nota FinMientras prom<-suma/n Escribir "El promedio es:",prom FinProceso JAVA package tarea; public class ejercicio10 { public static void main(String[] args) { int n,suma,nota,promedio; n=0; suma=0; System.out.println("promedio de notas"); while(n<7){ n=n+1; System.out.print("ingrese nota"+n+": "); nota=entrada.entero(); suma=suma+nota; } promedio=suma/n; System.out.println("su promdio es de : "+promedio); } }

×