Your SlideShare is downloading. ×
Problemas de mep
Problemas de mep
Problemas de mep
Problemas de mep
Problemas de mep
Problemas de mep
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×
Saving this for later? Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime – even offline.
Text the download link to your phone
Standard text messaging rates apply

Problemas de mep

437

Published on

Published in: Education
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
437
On Slideshare
0
From Embeds
0
Number of Embeds
3
Actions
Shares
0
Downloads
9
Comments
0
Likes
0
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. 1) Las tablas de multiplicar ascendente o descendente Proceso tabla_de_multiplicar op<-"si"; Repetir Escribir "da 1 para tabla de multiplicar ascendente del 1 al 10:"; Escribir "da 2 para tabla de multiplicar descendente del 1 al 10:"; leer num; Segun num Hacer 1: Escribir "Ingrese un numero para la tabla del multiplicar: "; Leer num; Si (num>10) Entonces Escribir "dato erroneo"; Sino Escribir "Tabla del ",num; Para j<-1 Hasta 10 Con Paso 1 Hacer Escribir j,"*",num,"=",j*num; FinPara FinSi 2: Escribir "Ingrese un numero para la tabla del multiplicar: "; Leer num; Si (num>10) Entonces Escribir "dato erroneo"; Sino Escribir "Tabla del ",num; Para j<-10 Hasta 1 Con Paso -1 Hacer Escribir j,"*",num,"=",j*num; FinPara FinSi De Otro Modo: Escribir "dato erroneo"; FinSegun Escribir "deseas repetir este proceso"; Leer op; Hasta Que op="no" Escribir "fin de programa"; FinProceso
  • 2. 2) Factorial Proceso factorizar fac<-1; num<-1; Mientras num=1 Hacer Escribir "escribir un numero para factorizar"; Leer z; Para x<-1 Hasta z Con Paso 1 Hacer fac<-fac*x; Escribir "factorizacion:",fac; FinPara Escribir ""; Escribir "factorizacion:",fac; Escribir "quieres sacar otra factorizacion"; Escribir ""; Escribir "si es SI presiones 1"; Escribir ""; Escribir "si es NO presionas cualquier tecla"; Escribir ""; Leer num; FinMientras Escribir ""; Escribir "gracias por usar este programa hasta la proxima"; FinProceso
  • 3. 3) Un vendedor desea calcular su comisión total sobre la venta de varios artículos. Al vendedor le corresponde el 5% de su comisión sobre artículos cuyo precio es menor a $ 100 y el 7.5 % de comisión sobre aquellos artículos valor su precio es de 100 o más, suponga el vendedor realiza n artículos. Proceso comision Escribir "dime el precio de 3 articulos vendidos"; Escribir "el precio de el articulo"; Leer art1; Escribir "el precio de el articulo"; Leer art2; Escribir "el precio de el articulo"; Leer art3; si art1 < 100 Entonces suma1<- art1*0.05 Sino suma1<- art1*0.075 FinSi si art2 < 100 Entonces suma2<- art2*0.05 Sino suma2<- art2*0.075 FinSi si art3 < 100 Entonces suma3<- art3*0.05 Sino suma3<- art3*0.075 FinSi pagar_total<-suma1+suma2+suma3; Escribir "su comision es: ",pagar_total; FinProceso
  • 4. 4) Imprimir una tabla de conversión de temperatura de grados centígrados a Fahrenheit o de Fahrenheit a centígrados según lo indique el usuario además se le indicara el inicio y fin de la tabla Proceso centigrados_a_fahrenheit op<-"si"; Repetir Escribir "selecciona una accion:"; Escribir "Dame 1 para convertir de °C a °F"; Escribir "Dame 2 para convertir de °F a °C"; Leer num; Segun num Hacer 1: Escribir "Convertir de °C a °F"; Escribir "Dame la cantidad de grados"; leer centigrados; si ((centigrados >-15) y (centigrados <15)) Entonces Para centigrados<--15 Hasta 15 Con Paso 1 Hacer resultado<-(centigrados*1.8)+32; Escribir "El resultado de la convercion",centigrados," es: ",resultado,"°F"; FinPara Sino Escribir "dato Erroneo"; FinSi 2: Escribir "Convertir de °F a °C"; Escribir "Dame la cantidad de grados"; leer fahrenheit; si ((fahrenheit >-15) y (fahrenheit <15)) Entonces Para fahrenheit<--15 Hasta 15 Con Paso 1 Hacer resultado<-(fahrenheit-32)/1.8; Escribir "El resultado de la converción es: ",resultado,"°C"; FinPara Sino Escribir "dato Erroneo"; FinSi De Otro Modo: Escribir "Dato erroneo"; FinSegun Escribir "Deceas repetir este proceso" Leer op; Hasta Que (op="no") Escribir "Fin del programa"; FinProceso
  • 5. 5) Pedir un numero y decir si es positivo, negativo y si es igual a cero Proceso numero_positivo_negativo_ne respuesta<-1; Mientras (respuesta=1) Hacer Escribir "dame un numero"; Escribir "te dire si es positivo o negativo o es cero"; Leer num; Si (num>0) Entonces Escribir "tu numero es positivo"; Sino Si (num=0) Entonces Escribir "tu numero es cero"; Sino Si (num<0) Entonces Escribir "tu numero es negativo"; Sino Escribir "pon un numero no un caracter"; FinSi FinSi FinSi Escribir "quieres intentarlo de nuevo"; Escribir "si es SI presiones 1"; Escribir " si es NO presiones otro numero o tecla "; Leer respuesta; FinMientras Escribir "gracias por usar este programa hasta la proxima"; FinProceso
  • 6. 6) Calcular la raíz cuadrada de un numero introduce un numero si es negativo mostrar un mensaje de error y volver a pedirlo Proceso raiz_de_un_numero respuesta<-1; Mientras (respuesta=1) Hacer Escribir "dame un numero"; Escribir "sacaremos raiz de ese numero"; Leer num; si num > 0 Entonces total<-rc(num); Escribir "tu raiz es:",total; Escribir "quieres intentarlo de nuevo"; Escribir "si es SI presiones 1"; Escribir "si es NO presiones presiona otro numero"; Leer respuesta; Sino Escribir "Dato Erroneo"; FinSi FinMientras Escribir "gracias por usar este programa hasta la proxima"; FinProceso

×