Conceitos e técnicas de programação exercícios i respostas

985 views
879 views

Published on

1 Comment
0 Likes
Statistics
Notes
  • preciso desse programa resolvido


    Uma Loja de eletrodomésticos possui 1500 clientes fidelidade que podem realizar compras com descontos diferenciados conforme a tabela a seguir:
    TEMPO DE FIDELIDADE DESCRIÇÃO DESCONTO
    5 – 7 ANOS Cliente silver 15%
    8 – 10 ANOS Cliente gold 20%
    MAIS DE 10 ANOS Cliente Plus 30%

    Faça um programa que leia o código do cliente, o tempo de fidelidade e o valor da compra, e que calcule e mostre o tipo de cliente de acordo com o tempo de fidelidade, alem do valor da compra já com o desconto.
       Reply 
    Are you sure you want to  Yes  No
    Your message goes here
  • Be the first to like this

No Downloads
Views
Total views
985
On SlideShare
0
From Embeds
0
Number of Embeds
200
Actions
Shares
0
Downloads
27
Comments
1
Likes
0
Embeds 0
No embeds

No notes for slide

Conceitos e técnicas de programação exercícios i respostas

  1. 1. Conceitos e técnicas de programação exercícios I respostas Parte 1 1. É uma forma de escrever um programa de computador com uma linguagem de fácil entendimento para nós humanos. 2. É um sistema de numeração posicional onde todas as quantidades se representam com base em dois números, ou seja 0 e 1. 3. É uma sequência finita de instruções bem definidas e não ambíguas. 4. É uma coleção de instruções que descrevem uma tarefa a ser realizada por um computador. 5. É como se fosse uma receita de culinária, o passo a passo da realização de algo de forma que nós ser humanos podemos entender. 6. Serve como modelo para programas, também conhecido como linguagem estruturada ou portunhol. 7. Ver a necessidade, interpretar a questão, transformar em uma linguagem de sua escolha, compilar e por fim testar o programa. 8. É a representação gráfica de um processo e podemos representá-los por figuras geométricas. 9. 00101000 10. 75 Parte 2 1 2 3algoritmo "questão 1" algoritmo "questão 2" algoritmo "questão 3"// Função : // Função : // Função :// Autor : // Autor : // Autor :// Data : 24/11/2012 // Data : 24/11/2012 // Data : 24/11/2012// Seção de Declarações // Seção de Declarações // Seção de Declaraçõesvar var var n: inteiro a: inteiro anos: inteiroinicio b: inteiro meses: inteiro// Seção de Comandos aux: inteiro dias: inteiroescreval ("Informe o inicio idade: inteironúmero") // Seção de Comandos inicioleia (n) a<-10 // Seção de Comandosse n>=0 entao b<-20 escreval ("informe quantosescreval ("positivo") aux<-a anos você tem:")senao a<-20 leia (anos)escreval ("negativo") b<-aux escreval ("informe mesesfimse escreval ("antes o valor de a anos você tem:")fimalgoritmo era: ",b, " agora o valor de a é leia (meses) ",a) escreval ("informe dias anos escreval ("antes o valor de b você tem:") era: ",a, " agora o valor de b é leia (dias) ",b) fimalgoritmo anos<-anos*365 meses<-meses*30 idade<-anos+meses+dias
  2. 2. escreval ("você tem ", idade, " dias de vida") fimalgoritmo 4 5 6algoritmo "questão 4" algoritmo "questão 5" algoritmo "questão 6"// Função : // Função : // Função :// Autor : // Autor : // Autor :// Data : 24/11/2012 // Data : 24/11/2012 // Data : 24/11/2012// Seção de Declarações // Seção de Declarações // Seção de Declaraçõesvar var vareleitores:inteiro pera:real num: inteirobrancos:inteiro peraduzia:real inicionulos:inteiro qtd:inteiro // Seção de Comandosvalidos:real valorpago:real escreval ("informe umpercbrancos:real inicio número inteiro:")percnulos:real // Seção de Comandos leia (num)percvalidos:real pera<-1.50 peraduzia<-1.10 se num < 10 entaoinicio escreval ("informe quantas escreval ("este número é// Seção de Comandos pera você comprou:") menor que 10") leia (qtd) senaoeleitores<- 100 se num > 10 entaobrancos<-30 se qtd >=12 entao escreval ("este número énulos<-30 valorpago<-qtd*peraduzia maior que 10")validos<-40 escreval ("você pagou senaopercbrancos<- R$",valorpago, " pelas se num = 10 entao(brancos*100)/eleitores pêras.") escreval ("este número épercnulos<- senao igual à 10")(nulos*100)/eleitores se qtd <=11 entao fimsepercvalidos<- valorpago<-qtd*pera fimse(validos*100)/eleitores escreval ("você pagou fimseescreval ("o percentual de R$",valorpago, " pelas fimalgoritmovotos brancos é: pêras.")",percbrancos, " %") fimseescreval ("o percentual de fimsevotos nulos é: ",percnulos, "%") fimalgoritmoescreval ("o percentual devotos válidos é: ",percvalidos," %")fimalgoritmo 7 8 9algoritmo "questao 7" algoritmo "questão 8" algoritmo "questão 9"// Função : // Função : // Função :// Autor : // Autor : // Autor :// Data : 24/11/2012 // Data : 24/11/2012 // Data : 24/11/2012// Seção de Declarações // Seção de Declarações // Seção de Declaraçõesvar var varvalor1:inteiro valor1: inteiro peso1: inteiro
  3. 3. valor2:inteiro valor2: inteiro peso2: inteiro inicio peso3: inteiroinicio // Seção de Comandos// Seção de Comandos escreval ("Informe o primeiroescreval ("informe o 1º número:") inicionúmero:") leia (valor1) // Seção de Comandosleia(valor1) escreval ("Informe o segundo escreval ("Informe o 1ºescreval ("informe o 2º número:") peso:")número:") leia (valor1) leia (peso1)leia (valor2) se valor1 > valor2 entao escreval ("Informe o 2º escreval ("O primeiro número peso:")se valor1 = valor2 entao é maior que o segundo.") leia (peso2)escreval ("os números são senao escreval ("Informe o 3ºiguais") escreval ("O segundo número peso:")senao é maior que o primeiro.") leia (peso3)se valor1 > valor2 entao fimseescreval ("o 1º número é fimalgoritmo se (peso1 > peso2) e (peso1 >maior") peso3) entaosenao escreval ("O primeiro peso ése valor1 < valor2 entao maior")escreval ("o 2º número é senaomaior") se (peso2 > peso3) e (peso2 >fimse peso1) entaofimse escreval ("O segundo peso éfimse maior")fimalgoritmo senao se (peso3 > peso2) e (peso3 > peso1) entao escreval ("O terceiro peso é maior") fimse fimse fimse fimalgoritmo 10 11 12algoritmo "questão 10" algoritmo "questao 11" algoritmo "questão 12"// Função : // Função : // Função :// Autor : // Autor : // Autor :// Data : 24/11/2012 // Data : 25/11/2012 // Data : 25/11/2012// Seção de Declarações // Seção de Declarações // Seção de Declaraçõesvar var var valor1: inteiro f : real nota1:real valor2: inteiro c: real nota2:real valor3: inteiro opcao:caractere nota3:realinicio temp: real media:real// Seção de Comandos inicio nome: caractereescreval ("Informe o 1º // Seção de Comandos iniciovalor:") escreval ("Para converter de // Seção de Comandosleia (valor1) fahrenheit para celsius digite escreval ("Informe o nome doescreval ("Informe o 2º F") aluno:")valor:") escreval ("Para converter de leia (nome)
  4. 4. leia (valor2) celsius para fahrenheit digite escreval ("Informe a 1ª notaescreval ("Informe o 3º C") do aluno: ",nome)valor:") leia (opcao) leia (nota1)leia (valor3) escreval ("Informe a escreval ("Informe a 2ª nota temperatura:") do aluno: ",nome)se (valor1 < valor2) e (valor2 leia (temp) leia (nota2)< valor3) entao se opcao = "c" entao escreval ("Informe a 3ª notaescreval ("sequência ", f <- temp*1.8+32 do aluno: ",nome)valor1, valor2, valor3) escreval ("A temperatura é: leia (nota3)senao ",f,"º Fahrenheit") media <-se (valor1 < valor3) e (valor3 senao (nota1+nota2+nota3)/3< valor2) entao c <- (5/9)*(temp-32) entaoescreval ("sequência ", escreval ("A temperatura é: se media >=7 entaovalor1, valor3, valor2) ",c,"º celsius") escreval ("O aluno ", nome, "senao fimse foi aprovado com média:",se (valor2 < valor1) e (valor1 fimalgoritmo media)< valor3) entao senaoescreval ("sequência ", se media <5 entaovalor2, valor1, valor3) escreval ("O aluno ", nome, "senao foi reprovado com média:",se (valor2 < valor3) e (valor3 media)< valor1) entao senaoescreval ("sequência ", escreval ("O aluno ", nome, "valor2, valor3, valor1) está em recuperação comsenao média:", media)se (valor3 < valor2) e (valor2 fimse< valor1) entao fimseescreval ("sequência ", fimalgoritmovalor3, valor2, valor1)senaose (valor3 < valor1) e (valor1< valor2) entaoescreval ("sequência ",valor3, valor1, valor2)fimsefimsefimsefimsefimsefimsefimalgoritmo 13 14 15algoritmo "questão 13" algoritmo "questão 14" algoritmo "Questão 15"// Função : // Função : // Função :// Autor : // Autor : // Autor :// Data : 25/11/2012 // Data : 25/11/2012 // Data : 25/11/2012// Seção de Declarações // Seção de Declarações // Seção de Declaraçõesvar var varnome: caractere nome:caractere idade:inteiroqtd: inteiro idade:inteiro iniciopreco: real inicio // Seção de Comandos
  5. 5. total: real // Seção de Comandos escreval ("Informe a idade doprecopago:real escreval ("Informe o nome do nadador:")desc1:real atleta:") leia (idade) leia (nome) se (idade>=5) e (idade<=7)inicio escreval ("Informe a idade do entao// Seção de Comandos atleta:") escreval ("O nadador é daescreval ("Informe a leia (idade) categoria INFANTIL A")descreção do produto:") se (idade>=5) e (idade<=10) senaoleia (nome) entao se (idade>=8) e (idade<=10)escreval ("Informe a escreval ("Este atleta ", entaoquantidade:") nome, " é da categoria escreval ("O nadador é daleia (qtd) INFANTIL") categoria INFANTIL B")escreval ("Informe o preço do senao senaoproduto") se (idade>=11) e (idade<=15) se (idade>=11) e (idade<=13)leia (preco) entao entao escreval ("Este atleta ", escreval ("O nadador é datotal <- qtd*preco entao nome, " é da categoria categoria JUVENIL A")se qtd<=5 entao JUVENIL") senaodesc1<- total*2/100 entao senao se (idade>=14) e (idade<=17)precopago<-total-desc1 se (idade>=16) e (idade<=20) entaoentao entao escreval ("O nadador é daescreval ("O valor total é escreval ("Este atleta ", categoria JUVENIL B")",total, " com desconde de nome, " é da categoria senao2% ", desc1, " o valor à pagar JÚNIOR") se (idade>=18) e (idade<=25)é ", precopago) senao entaosenao se (idade>=21) e (idade<=30) escreval ("O nadador é dase (qtd>=5) e (qtd<10) entao entao categoria SÊNIOR")desc1<- total*3/100 entao escreval ("Este atleta ", senaoprecopago<-total-desc1 nome, " é da categoria escreval ("IDADE FORA DAentao PROFISSIONAL") FAIXA ETÁRIA")escreval ("O valor total é senao fimse",total, " com desconde de escreval ("Sem categoria fimse3% ", desc1, " o valor à pagar informada") fimseé ", precopago) fimse fimsesenao fimse fimsese qtd>10 entao fimse fimalgoritmodesc1<- total*5/100 entao fimseprecopago<-total-desc1 fimalgoritmoentaoescreval ("O valor total é",total, " com desconde de5% ", desc1, " o valor à pagaré ", precopago)fimsefimsefimsefimalgoritmo

×