taller practico

8,156 views

Published on

taller oractico

Published in: Travel
1 Comment
2 Likes
Statistics
Notes
No Downloads
Views
Total views
8,156
On SlideShare
0
From Embeds
0
Number of Embeds
9
Actions
Shares
0
Downloads
179
Comments
1
Likes
2
Embeds 0
No embeds

No notes for slide

taller practico

  1. 1. GUÍA DE COMPUTACIÓN PARA DECIMO<br />CONCEPTOS:<br />Algunas funciones no calculan los valores, pero en lugar de eso, hacen comparaciones lógicas como:  =, < ,y > o  las combinaciones <=, >=, <>. Tal prueba le permitirá hacer una cosa cuando la comparación es VERDAD y algo diferente cuando es FALSA.<br />La función SI es la prueba lógica más utilizada.  Tiene tres argumentos entre paréntesis y separados por comas:<br />la declaración de comparación lógica  <br />el valor de la celda a usar cuando la comparación es VERDAD <br />el valor de la celda a usar cuando la comparación es FALSA <br />La forma general de una función SI es  <br />=SI(comparación lógica, valor si es VERDAD, valor si es FALSA)<br />Un valor puede ser un número, texto entre comillas, una celda de referencia, una fórmula u otra prueba lógica.<br />Operador LógicoSignificadoEjemplo=Igual a=SI(E8=C8," Igual," No igual" )Cuando las dos celdas son iguales, se muestra la palabra  " Igual" . Cuando las dos celdas no son iguales, se muestra la frase " No igual" .<Menor que=SI(F4<E4,E4-F4, F4-E4)Si F4 es menor que E4, restar F4 de E4. De lo contrario, hacer la resta de la otra forma. Esto asegura que obtenga un número positivo de la resta de los dos números.>Mayor que=SI(C6>100,C6,100)Si C6 es mayor que 100, mostrar C6. De los contrario mostrar 100.<=Menor que o igual a=SI((B5<=10,B5," Máximo" )Si B5 es mayor que, o igual a 10, mostrar B5. De lo contrario mostrar la palabra " Máximo" .>=Mayor que o igual a=SI((MAX(B4:E8)>=SUMA(B4:E8)/2,MáX(B4:E8), SUMA(B4:E8)/2)Si el valor más grande en el rango, es mayor que o igual a la mitad de la suma del rango, entonces mostrar el valor más grande. De lo contrario mostrar la mitad de la suma del rango. (Estas declaraciones pueden ofrecer un aspecto realmente desordenado!)<>No igual a=SI((B8<>D6,SI((B8<10,10,B8),D6)Si B8 no es igual a D6, verificar para ver si B8 es menor que 10. Mostrar 10 si lo es y B8 si no lo es. De lo contrario, mostrar D6, el que en este caso será igual a B8.<br />FUNCION SI ANIDADAS<br />Puede anidar hasta 7 declaraciones Y SI... para crear pruebas complejas. <br />Por ejemplo, para mostrar una letra de calificación en la celda vecina a Calificación Promedio, podría usar 4 declaraciones anidadas en una sola fórmula:<br />=SI(PROMEDIO=20," SOBRESALIENTE" , SI(PROMEDIO >17," MUY BUENO" ,SI(PROMEDIO >15," BUENO" ,SI(PROMEDIO >10," REGULAR" ," INSUFICIENTE" ))))<br />En lugar de escribir complicadas expresiones dentro de una declaración de SI , se puede hacer cada cálculo en una celda por separado y usar solo las celdas de referencias en la declaración SI. Desde luego que si hace eso, mirando la fórmula SI no le dirá nada sobre lo que realmente está pasando. Nombrar las celdas sería mucho más útil en este tipo de situación.<br />EJERCICIOS FUNCIONES LOGICA:<br />Ejercicio#1<br />Si el número que tenemos en la columna A es mayor que 5 la columna B debe decir “MAYOR”, de lo contrario en B debe decir “NO ES MAYOR”<br />La función quedaría de la siguiente forma:<br />=SI(A1>5," MAYOR" ," NO ES MAYOR" )<br />Como se aprecia en la imagen.<br />Posteriormente la función se debe repetir para cada valor que tengamos en “A” como se muestra en la imagen.<br />Finalmente tenemos el resultado.<br />Ejercicio#2<br />AlumnoNota 1Nota 2Nota 3a   b   c   d   e   f   g   1. Inventar tres notas a cada alumno y:1- Hallar los promedios, el promedio más alto y el más bajo.2- Colocar el texto:" Aprobado" a quienes tienen promedio mayor o igual a 7" Recupera" , al resto.<br />Ejercicio#3<br />Nº de socioNombreEdadDeuda/CuotasAntigüedad1255Pedro Pou11012148Luis Sanguineti18052365Martín Gallo23163255José Piperno43533654Marcelo Tinelli22014578Luisa Vehil563205967Martín Redrado11126685Rolando Rivas291121. Agregar una columna a la tabla de socios de modo que:Si la cantidad de cuotas adeudas es mayor a 2 y el socio tiene más de 20 años mostrar el nº de socio si no nada. <br />EJERCICIOS DE FUNCIONES SI ANIDADAS<br />Ejercicio#1<br />En la tienda de ropa SISTEMAS II, se tiene la política de ofrecer descuentos a partir de un monto de compra de $ 2000. Los descuentos varían en función del monto y del tipo de departamento, los cuales para identificarlos se les asigna un número, es decir, el número 1 a niños, el 2 a damas y el 3 a caballeros. Se tiene a continuación la tabla de descuentos ofrecida por la tienda:<br />20005000100001500012%3%5%7%23%4%6%8%35%5%6%7%<br />Suponiendo que los siguientes clientes realizaron sus compras por el monto y en el departamento especificado. Calcular el descuento total a efectuar por los clientes antes mencionados<br />CLIENTE DEPARTAMENTOCOMPRA2531500452900235230012315600095 11780156 12390<br />Ejercicio#2<br />En un depósito se encuentran almacenados distintos productos. En la tabla quese encuentra debajo se detallan los códigos de identificación y otras características mas.CódigoCantidadPrecio Unit.Inflamable (Categ.)a1125680,23Aa223560,25Ba345880,36Ab195220,14Cb2125440,18Ab310200,6Cc1154020,27Ac265980,78Bc387871,02B1. Determinar cuántos tipos de productos pertenecen a la categoría A de inflamabilidad.2. Hallar la suma de la cantidad de productos con un precio unitario menor a 0,53. Agregar una columna en donde figuren los textos: " Máxima precaución" para categ. A" Precaución moderada" para el resto.<br />Ejercicio#3<br />AlumnoCondición 1Condición 2Condición 3axx b  cxx d  xe  xfx  gx x1. Agregar una columna en donde figure:10, si posee dos o mas condiciones cualquiera.9, si posee al menos una condición.8 si no posee ninguna.<br />Ejercicio#4<br />En un depósito se encuentran almacenados distintos productos. En la tabla quese encuentra debajo se detallan los códigos de identificación y otras características mas.CódigoCantidadPrecio Unit.Inflamable (Categ.)a1125680,23Aa223560,25Ba345880,36Ab195220,14Cb2125440,18Ab310200,6Cc1154020,27Ac265980,78Bc387871,02B1. Determinar cuántos tipos de productos tienen un precio unitario mayor al promedio gral.2. Hallar la suma de la cantidad de productos que pertenecen a la categoría A (inflamables)3. Agregar una columna en donde figuren los textos: " Máxima precaución" para categ. A" Precaución moderada" para categ. B" Precaución de rutina" para categ. C<br />

×