Apresentacao 05 algoritmos estruturas de seleção

9,069 views
8,765 views

Published on

Apresentacao_05 Algoritmos - Estruturas de Seleção

Published in: Education
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
9,069
On SlideShare
0
From Embeds
0
Number of Embeds
5
Actions
Shares
0
Downloads
107
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Apresentacao 05 algoritmos estruturas de seleção

  1. 1. Algoritmos Estruturas de Seleção Professora: Maely Moraes Código: DCC 105 Carga-horária: 60 horas-aula
  2. 2. Roteiro Estrutura de Seleção Conceito Simples Composta Aninhada Múltipla escolha
  3. 3. Estrutura de Seleção São aquelas que permitem alterar o Fluxo de Execução, de forma a selecionar qual parte deve ser executada Essa “decisão” de execução é tomada a partir de uma condição, que pode resultar apenas em Verdade ou Falsidade Uma condição é representada por expressões relacionais ou lógicas
  4. 4. Estrutura de Seleção Considere as seguintes afirmativas: 1. Distribuição gratuita de cestas básicas. 2. Distribuição gratuita de cestas básicas para famílias com 4 ou mais componentes. 3. Distribuição gratuita de ingressos para o cinema, sendo dois para pessoas do sexo feminino e um para pessoas do sexo masculino. Conceito: é uma estrutura de controle de fluxo, executando um ou vários comandos se a condição testada for verdadeira e, em alguns casos, executando um ou vários comandos se for falsa.
  5. 5. Estrutura de Seleção Simples Utilizada quando precisamos testar uma certa condição antes de executar um ou mais comandos. Sintaxe: se <expressão-lógica> entao <seqüência-de-comandos> fimse A <expressão-lógica> é a condição a ser testada pela ULA, que devolve como resposta: VERDADEIRO ou FALSO. A condição pode ser uma simples expressão relacional ou expressão lógica.
  6. 6. Estrutura de Seleção Exemplo: algoritmo "media_simples" // UNIVERSIDADE FEDERAL DE RORAIMA // Função : Calcula média aritmética e retorna situação do aluno // Autor : Maely Moraes // Data : 25/08/2011 // Seção de Declarações var N1, N2, NF, media: real inicio // Seção de Comandos escreval ("Entre com a Primeira Nota: ") leia (N1) escreval ("Entre com a Segunda Nota: ") leia (N2) escreval ("Entre com a Nota Final: ") leia (NF) media <-(N1 + N2 + NF) / 3 se (media >= 7.0) entao escreva("Nota: ",media,", Aluno aprovado!") fimse fimalgoritmo
  7. 7. Estrutura de Seleção Composta Utilizada em situações em que duas alternativas dependem da mesma condição, uma da condição verdadeira (entao) e a outra da condição falsa (senao). Sintaxe: se <expressão-lógica> entao <seqüência-de-comandos-1> senao <seqüência-de-comandos-2> fimse
  8. 8. Estrutura de Seleção Exemplo: algoritmo "media_simples2" // UNIVERSIDADE FEDERAL DE RORAIMA // Função : Calcula média aritmética e retorna situação do aluno // Autor : Maely Moraes // Data : 25/08/2011 // Seção de Declarações var N1, N2, NF, media: real inicio // Seção de Comandos escreval ("Entre com a Primeira Nota: ") leia (N1) escreval ("Entre com a Segunda Nota: ") leia (N2) escreval ("Entre com a Nota Final: ") leia (NF) media <-(N1 + N2 + NF) / 3 se (media >= 7.0) entao escreva("Nota: ",media,", Aluno Aprovado!") senao escreva("Nota: ",media,", Aluno Reprovado!") fimse fimalgoritmo
  9. 9. Estrutura de Seleção Aninhada Utilizada em situações em que é necessário tomar outras decisões dentro de uma das alternativas da estrutura de seleção se. Sintaxe: se <expressão-lógica> entao <seqüência-de-comandos-1> senao se <expressão-lógica> entao <seqüência-de-comandos-1> senao <seqüência-de-comandos-2> ... fimse fimse
  10. 10. Estrutura de Seleção Exemplo: algoritmo “maiorde3" // UNIVERSIDADE FEDERAL DE RORAIMA // Função : Retorna o maior de 3 inteiros // Autor : Maely Moraes // Data : 25/08/2011 // Seção de Declarações var A, B, C, max: inteiro inicio // Seção de Comandos escreval ("Entre com o Primeiro número: ") leia (A) escreval ("Entre com o Segundo número: ") leia (B) escreval ("Entre com o Terceiro número: ") leia (C) se (A > B) entao senao se (A > C) entao se (B > C) entao max <- A max <- B senao senao max <- C max <- C fimse fimse fimse escreval ("O maior número é: ",max) fimalgoritmo
  11. 11. Estrutura de Seleção Múltipla Escolha Utilizada quando um conjunto de valores discretos e ações diferentes são associadas a cada um desses valores. Sintaxe: escolha <variavel> caso <valor11>, <valor12>, ..., <valor1n> <seqüência-de-comandos-1> caso <valor21>, <valor22>, ..., <valor2n> <seqüência-de-comandos-2> ... outrocaso <seqüência-de-comandos-extra> fimescolha
  12. 12. Estrutura de Seleção Exemplo: algoritmo "times" // UNIVERSIDADE FEDERAL DE RORAIMA // Função : Retorna a naturalidade do time // Autor : Maely Moraes // Data : 25/08/2011 // Seção de Declarações var time: caractere inicio escreva ("Entre com o nome de um time de futebol: ") leia (time) escolha time caso "Flamengo", "Fluminense", "Vasco", "Botafogo" escreval ("É um time carioca.") caso "São Paulo", "Palmeiras", "Santos", "Corínthians" escreval ("É um time paulista.") outrocaso escreval ("É de outro estado.") fimescolha fimalgoritmo
  13. 13. Exercícios Fazer um algoritmo para ler um valor x e determinar se ele é par ou impar. Para atingir-se o índice olímpico, são realizados vários torneios de corridas de 100 metros. Faça um algoritmo que leia o nome e o tempo de um atleta e apresente sua pontuação, conforme listado abaixo: T < 10 seg 100 pontos T >= 10 e T <=13 seg 70 pontos T > 13 Seg 40 pontos Fazer um algoritmo que leia três valores inteiros, determine e imprima o menor deles. Fazer um algoritmo que dados três valores distintos, retorne- os em ordem crescente.
  14. 14. Exercícios Fazer um algoritmo para dados três valores X, Y, Z, verificar se eles podem ser os comprimentos dos lados de um triângulo e, se forem, verificar se é um triângulo eqüilátero, isósceles ou escaleno. Se eles não formarem um triângulo, escrever uma mensagem. Antes de começar a elaboração do algoritmo, torna-se necessária a revisão de algumas propriedades e definições. Propriedade – O comprimento de cada lado de um triângulo é menor do que a soma dos comprimentos dos outros dois lados. Definição 1 – Chama-se triângulo eqüilátero ao triângulo que tem os comprimentos dos três lados iguais. Definição 2 – Chama-se triângulo isósceles ao triangulo que tem os comprimentos de dois lados iguais. Portanto, todo triângulo eqüilátero é também isósceles. Definição 3 – Chama-se triângulo escaleno ao triângulo que tem os comprimentos de seus três lados diferentes.
  15. 15. Exercícios Ler um peso na Terra e o número de um planeta e imprimir o valor desse peso neste planeta. A relação de planetas é dada a seguir juntamente com o valor das gravidades relativas á Terra: # Gravidade Planeta Relativa 1 0,37 Mercúrio 2 0,88 Vênus 3 0,38 Marte 4 2,64 Júpiter 5 1,15 Saturno 6 1,17 Urano Para calcular o peso no planeta use a fórmula: Pplaneta=Pterra.gravidade 10
  16. 16. Exercícios Calcular a área total de uma residência (sala, cozinha, banheiro, quartos, área de serviço, quintal, etc). O programa deve solicitar a entrada do nome, a largura e o comprimento de um determinado cômodo. Em seguida, deve apresentar a área do cômodo lido e também uma mensagem solicitando do usuário a confirmação de continuar calculando novos cômodos. Caso o usuário responda “NÃO”, o programa deve apresentar o valor total acumulado da área residencial.
  17. 17. Referências Bibliográficas LOPES, A.: Introdução à Programação: 500 algoritmos resolvidos, Campus, 2002. Manual do VisuAlg

×