CURSO DE PROGRAMACION BASICA - Cap 3

21,151 views
20,927 views

Published on

Universidad Técnica Particular de Loja Tema: Estudio de Algoritmos Capitulo 3 Expositor: Ing. Daniel Irene R. Periodo: Abril-Agosto 2009

Published in: Education, Technology
7 Comments
4 Likes
Statistics
Notes
No Downloads
Views
Total views
21,151
On SlideShare
0
From Embeds
0
Number of Embeds
5
Actions
Shares
0
Downloads
1,077
Comments
7
Likes
4
Embeds 0
No embeds

No notes for slide

CURSO DE PROGRAMACION BASICA - Cap 3

  1. 1. Programa inicio //Pseudocódigo en PSeInt Proceso sin_titulo edad <-0; anoNac <-0; anoAct <-0; lectura Leer anoNac ; FinProceso asignación Dim edad, anoNac, anoAct As Integer anoNac = Console.ReadLine() escritura Const anoAct As Integer = 2009 fin Const PI As Double = 3.1416
  2. 2. Programa inicio Aritméticos lectura ^, *, /, div, , mod, +, -, & asignación Relacionales =, <>, <, >, <=, >= escritura Lógicos no (not), y (and), o (or) fin
  3. 3. Programa inicio lectura Expresiones (5 > 10) o (‘A’ < ‘B’) (10 > 5) y (5 < 10+Num) asignación escritura Otras funciones abs(x), arctan(x), sqr(x) fin
  4. 4. Programación Estructurada Flujos de control • Controlar el orden en el que se ejecutan las sentencias de un programa.
  5. 5. Estructuras SECUENCIALES Son aquellas en las que una acción (instrucción) sigue a otra en secuencia. comienzo Cabecera del Inicio del programa programa. Sección de declaración lectura Entrada de datos asignación Proceso de datos Cuerpo del programa escritura Salida de datos Fin del programa Finalización fin
  6. 6. Estructuras de SELECCIÓN Cuando existen multiples alternativas, se utilizan para tomar decisiones lógicas. comienzo Cabecera del Inicio del programa programa. Sección de declaración lectura Entrada de datos NO SI condición Condición Cuerpo del programa asignación Proceso de datos escritura Salida de datos Fin del programa Finalización fin
  7. 7. Estructuras REPETITIVAS Estructuras que repiten una secuencia de instrucciones (iteraciones) un número determinado de veces (bucle) • Mientras, hacer-mientras, repetir-hasta que, desde o para. NO acciones condición SI SI condición acciones NO i=1 NO acciones i <= 50 SI NO proceso condición i = i +1 SI
  8. 8. Programación Estructurada Flujos de control SECUENCIALES • Controlar el orden en el que se ejecutan las sentencias de un programa.
  9. 9. Estructuras SECUENCIALES Son aquellas donde una acción (instrucción) siguen a otra en secuencia. • Donde la salida de una, es la entrada de otra y de la siguiente y asi sucesivamente. //Pseudocódigo en PSeInt comienzo Proceso SumarDosNumeros intNum1 <- 0; lectura intNum2 <- 0; asignación intSumatoria <- 0; Escribir quot;Deme dos numerosquot;; escritura Leer intNum1, intNum2; intSumatoria <- intNum1 + intNum2; fin Escribir quot;La suma es = quot;, intSumatoria; FinProceso
  10. 10. Estructuras SECUENCIALES Son aquellas donde una acción (instrucción) siguen a otra en secuencia. • Donde la salida de una, es la entrada de otra y de la siguiente y asi sucesivamente. 'Codificado en Visual Basic Module SumarDosNumeros comienzo Public Sub Main() Dim intNum1, intNum2, intSumatoria As Integer Console.WriteLine(quot;Deme dos numerosquot;) lectura intNum1 = Console.ReadLine() intNum2 = Console.ReadLine() asignación intSumatoria = intNum1 + intNum2 Console.WriteLine(quot;La suma es = quot; & intSumatoria) Console.ReadLine() escritura End Sub End Module fin
  11. 11. Programación Estructurada Flujos de control • Controlar el orden en el que se ejecutan las sentencias de un programa.
  12. 12. Programación Estructurada Flujos de control SELECTIVOS • Controlar el orden en el que se ejecutan las sentencias de un programa.
  13. 13. Estructuras de SELECCIÓN Estructura de decisión simple. Pseudocódigo en español Si {expresion_logica} Entoces SI condición {acciones_por_verdadero} FinSi NO Sentencia(s) Pseudocódigo en ingles If {expresion_logica} Then {acciones_por_verdadero} End If
  14. 14. Estructuras de SELECCIÓN Estructura de decisión doble. Pseudocódigo en español Si {expresion_logica} Entoces {acciones_por_verdadero} SI NO Sino condición {acciones_por_falso FinSi Sentencia(s) Sentencia(s) POR EL SI POR EL NO Pseudocódigo en Ingles If {expresion_logica} Then {acciones_por_verdadero} Else {acciones_por_falso} End If
  15. 15. Estructuras de SELECCIÓN O de decisión: • Permiten la decisión entre acciones alternativas, además el de llevar acabo una acción si una condición (lógica) tiene un valor (verdadero, true, V, 1) o (falsa, false, F, 0). • operadores lógicos <, >, <>, =, >=, <=, comienzo lectura CONDICIONES NO SI condición x Mod y (5 > 10) o (‘A’ < ‘B’) (10 > 5) y (5 < 10) asignación cos (a) >= 0 escritura no (40 > 2) fin
  16. 16. Estructuras de SELECCIÓN O de decisión: • Permiten la decisión entre acciones alternativas, además el de llevar acabo una acción si una condición (lógica) tiene un valor (verdadero, true, V, 1) o (falsa, false, F, 0). • operadores lógicos <, >, <>, =, >=, <=, comienzo lectura CONDICIONES NO SI x Mod y x Mod y (5 > 10) o (‘A’ < ‘B’) asignación (10 > 5) y (5 < 10) escritura cos (a) >= 0 no (40 > 2) fin
  17. 17. Estructuras de SELECCIÓN O de decisión: • Permiten la decisión entre acciones alternativas, además el de llevar acabo una acción si una condición (lógica) tiene un valor (verdadero, true, V, 1) o (falsa, false, F, 0). • operadores lógicos <, >, <>, =, >=, <=, comienzo lectura CONDICIONES NO SI (5 > 10) o (‘A’ < ‘B’) x Mod y (5 > 10) o (‘A’ < ‘B’) asignación (10 > 5) y (5 < 10) escritura cos (a) >= 0 no (40 > 2) fin
  18. 18. Estructuras de SELECCIÓN O de decisión: • Permiten la decisión entre acciones alternativas, además el de llevar acabo una acción si una condición (lógica) tiene un valor (verdadero, true, V, 1) o (falsa, false, F, 0). • operadores lógicos <, >, <>, =, >=, <=, comienzo lectura CONDICIONES NO SI x Mod y (10 > 5) y (5 < 10) (5 > 10) o (‘A’ < ‘B’) asignación (10 > 5) y (5 < 10) escritura cos (a) >= 0 no (40 > 2) fin
  19. 19. Estructuras de SELECCIÓN O de decisión: • Permiten la decisión entre acciones alternativas, además el de llevar acabo una acción si una condición (lógica) tiene un valor (verdadero, true, V, 1) o (falsa, false, F, 0). • operadores lógicos <, >, <>, =, >=, <=, comienzo lectura CONDICIONES NO SI cos (a) > 0 x Mod y (5 > 10) o (‘A’ < ‘B’) (10 > 5) y (5 < 10) asignación cos (a) >= 0 escritura no (40 > 2) fin
  20. 20. Estructuras de SELECCIÓN O de decisión: • Permiten la decisión entre acciones alternativas, además el de llevar acabo una acción si una condición (lógica) tiene un valor (verdadero, true, V, 1) o (falsa, false, F, 0). • operadores lógicos <, >, <>, =, >=, <=, comienzo lectura CONDICIONES NO SI no (40 > 2) x Mod y (5 > 10) o (‘A’ < ‘B’) (10 > 5) y (5 < 10) asignación cos (a) >= 90 escritura no (40 > 2) fin
  21. 21. Estructuras de SELECCIÓN Estructura de decisión doble: EJEMPLO modulo //Pseudocódigo en PSeInt Proceso Modulo_MOD x<-0; z<-0; Escribir quot;Ingrese valores para X y Zquot;; Leer x,z; Si (x Mod z) = 0 Entonces Escribir x, quot; ES exactamente divisible para quot;, z; Sino Escribir x, quot; NO es exactamente divisible para quot;, z; FinSi FinProceso
  22. 22. Estructuras de SELECCIÓN Estructura de decisión doble: EJEMPLO modulo 'Codificado en Visual Basic Module Modulo_MOD Public Sub Main() Dim x, z As Integer x=0 z=0 Console.WriteLine(quot;Ingrese valores para X y Zquot;) x = Console.ReadLine z = Console.ReadLine If (x Mod z) = 0 Then Console.WriteLine(x & quot; ES exactamente divisible para quot; & z) Else Console.WriteLine(x & quot; NO es exactamente divisible para quot; & z) End If Console.ReadLine() End Sub End Module
  23. 23. Estructuras de decisión anidadas Son estructuras en las que si la evaluación de la expresión lógica resulta ser verdadera se ejecuta la sentencia 1. Mientras que si el resultado de su evaluación es falsa se evalúa otra expresión lógica, si el resultado de esta ultima es verdadera, se ejecuta la sentencia 2, si es falso se evalúa otra expresión y así sucesivamente. Pseudocódigo en ingles V Sentencia(s) 1 condición 1 if {expresion_logica} then <acción(es) SI 1> F else V Sentencia(s) 2 condición 2 if {expresion_logica} then <acción(es) SI 2> F else V Sentencia(s) N + 1 if {expresion_logica} then condición n <acción(es) SI n+1> F else …. Sentencia(s) N+1 endif . … endif
  24. 24. Estructuras de decisión anidadas Estructura de decisión anidadas: EJEMPLO Mayor_TresNum //Pseudocódigo en PSeInt Proceso Mayor_TresNum a<-0; b<-0; c<-0; mayor<-0; Escribir quot;Ingrese tres numeroquot;; Leer a,b,c; Si a>b Entonces Si a>c Entonces mayor<-a; Sino Si c>b Entonces mayor<-c; FinSi FinSi FinSi Escribir quot;El mayor es A = “,mayor; FinProceso
  25. 25. Estructuras de decisión anidadas Estructura de decisión anidadas: EJEMPLO Mayor_TresNum 'Codificado en Visual Basic Module Mayor_TresNum Public Sub Main() Dim a, b, c, mayor As Integer a=0 b=0 c=0 mayor = 0 Console.WriteLine(quot;Ingrese tres numeroquot;) a = Console.ReadLine() b = Console.ReadLine() c = Console.ReadLine() If a > b Then If a > c Then mayor = a Else If c > b Then mayor = c End If End If End If Console.WriteLine(quot;El mayor es = quot; & mayor) Console.ReadLine() End Sub End Module
  26. 26. Estructuras de decisión múltiple A veces es necesario que existan mas de dos elecciones posibles. La estructura de decisión múltiple evalúa una expresión que podrá tomar n valores distintos. Según se elija uno de estos valores en la condición, se realizara una de las n acciones. Pseudocódigo en español Según_sea {variable_numerica} hacer condición {opcion_1}: {secuencia_de_acciones_1} {opcion_2}: 1 2 n {secuencia_de_acciones_2} {opcion_3}: {secuencia_de_acciones_3} Sentencia(s) Sentencia(s) Sentencia(s) … S1 S2 Sn De Otro Modo: {secuencia_de_acciones_dom} FinSegun
  27. 27. Estructuras de decisión múltiple A veces es necesario que existan mas de dos elecciones posibles. La estructura de decisión múltiple evalúa una expresión que podrá tomar n valores distintos. Según se elija uno de estos valores en la condición, se realizara una de las n acciones. Pseudocódigo en Ingles Select [ Case ] testexpression Case expresión constante: condición <acción(es)> Case expresión constante: 1 2 n <acción(es)> Case expresión constante: Sentencia(s) Sentencia(s) Sentencia(s) <acción(es)> … S1 S2 Sn [Case Else] [<acción(es)>] ] End Select
  28. 28. Estructuras de decisión múltiple Ejemplo de estructuras de decisión múltiple: Presentar si un número entre el 1 y el 10 ingresado por el teclado es par o impar • ANÁLISIS: • 2, 4, 6, 8, 10 SON PARES • 1, 3, 5, 7, 9 SON IMPARES • DISEÑO: Como se muestra a continuación //Pseudocódigo en PSeInt Proceso Segun_ParesImpares Escribir quot;deme un número del 1 al 10quot;; Leer num; Segun num hacer 2, 4, 6, 8, 10: Escribir quot;El número es PARquot;; 1, 3, 5, 7, 9: Escribir quot;El número es IMPARquot;; De Otro Modo: Escribir quot;Número fuera de rango de entre el 1 al 10quot;; FinSegun FinProceso
  29. 29. Estructuras de decisión múltiple Ejemplo de estructuras de decisión múltiple: Presentar si un número entre el 1 y el 10 ingresado por el teclado es par o impar 'Codificado en Visual Basic Module Segun_ParesImpares Public Sub Main() Dim num As Integer Console.WriteLine(quot;deme un número del 1 al 10quot;) num = Console.ReadLine Select Case num Case 2, 4, 6, 8, 10 : Console.WriteLine(quot;El número es PARquot;) Case 1, 3, 5, 7, 9 : Console.WriteLine(quot;El número es IMPARquot;) Case Else Console.WriteLine(quot;Fuera de rango de 1 al 10quot;) End Select Console.ReadLine() End Sub End Module
  30. 30. Programación Estructurada Flujos de control SELECTIVOS • Controlar el orden en el que se ejecutan las sentencias de un programa.
  31. 31. Programación Estructurada Flujos de control • Controlar el orden en el que se ejecutan las sentencias de un programa.
  32. 32. Programación Estructurada Flujos de control REPETITIVOS • Controlar el orden en el que se ejecutan las sentencias de un programa.
  33. 33. Estructuras REPETITIVAS Estructuras que repiten una secuencia de instrucciones (iteraciones) un número determinado de veces (bucle) • Mientras, hacer-mientras, repetir-hasta que, desde o para. NO acciones condición SI SI condición acciones NO i=1 NO acciones i <= 50 SI NO proceso condición i = i +1 SI
  34. 34. Estructuras REPETITIVAS Mientras, While: • Donde el cuerpo del bucle se repite mientras se cumple la CONDICIÓN. • Aquí lo primero que se ejecuta es la CONDICIÓN. • Para que se ejecute el bucle la evaluación de la condición debe ser TRUE. Pseudocódigo en español comienzo Mientras {expresion_logica} Hacer lectura {secuencia_de_acciones} FinMientras NO condición Pseudocódigo en inglés SI acciones While condition [ statements ] [ Exit While ] fin [ statements ] End While
  35. 35. Estructuras REPETITIVAS Mientras, While EJEMPLO: Presentar por pantalla la sumatoria de los 10 primeros números pares. • ANÁLISIS: • SumaPares = 2 + 4 + 6 + 8 + 10 +12 + 14 + 16 + 18 + 20 = 110 • DISEÑO: Como se muestra a continuación //Pseudocódigo en PSeInt Proceso Mientras_SumaPares intSumaPares <- 0; intContador <- 0; intPar <- 0; Mientras (intContador < 10) Hacer intPar <- intPar + 2; intContador <- intContador + 1; Escribir intContador, quot; Par = [quot;,intPar, quot;]quot;; intSumaPares <- intSumaPares + intPar; FinMientras Escribir quot;Suma 10 primeros pares es quot;, intSumaPares; FinProceso
  36. 36. Estructuras REPETITIVAS Mientras, While EJEMPLO: Presentar por pantalla la sumatoria de los 10 primeros números pares. 'Codificado en Visual Basic Module Segun_ParesImpares Public Sub Main() Console.WriteLine(quot;ESTRUCTURA REPETITIVA WHILEquot;) Dim intSumaPares, intContador, intPar As Integer intSumaPares = 0 intContador = 0 intPar = 0 While (intContador < 10) intPar = intPar + 2 intContador = intContador + 1 Console.WriteLine(intContador & quot; Par = [quot; & intPar & quot;]quot;) intSumaPares = intSumaPares + intPar End While Console.WriteLine(quot;Suma 10 primeros pares es quot; & _ intSumaPares) Console.ReadLine() End Sub End Module
  37. 37. Estructuras REPETITIVAS Estructuras que repiten una secuencia de instrucciones (iteraciones) un número determinado de veces (bucle) • Mientras, hacer-mientras, repetir-hasta que, desde o para. NO acciones condición SI SI condición acciones NO i=1 NO acciones i <= 50 SI NO proceso condición i = i +1 SI
  38. 38. Estructuras REPETITIVAS Hacer-Mientras, Do Loop-While: • Donde el cuerpo del bucle se repite al menos una vez. • Aquí la CONDICIÓN se evalua al final del bucle. • Para que se ejecute el bucle la evaluación de la condición debe ser TRUE. Pseudocódigo en español comienzo Hacer <acción S1> lectura … <acción Sn> acciones Mientras <condición> SI Pseudocódigo en inglés condición Do NO [ statements ] fin [ Exit Do ] [ statements ] Loop { While } condition
  39. 39. Estructuras REPETITIVAS Hacer-Mientras, Do Loop-While EJEMPLO: Presentar por pantalla la sumatoria de los 10 primeros números pares. • ANÁLISIS: • SumaPares = 2 + 4 + 6 + 8 + 10 +12 + 14 + 16 + 18 + 20 = 110 • DISEÑO: Como se muestra a continuación „Codificado en Visual Basic Module HacerMientras_SumaPares Public Sub Main() Console.WriteLine(quot;ESTRUCTURA REPETITIVA “ & _ “HACER-MIENTRASquot;) Dim intPar, intContador, intSumaPares As Integer intPar = 0 intContador = 0 intSumaPares = 0 Do intPar = intPar + 2 intContador = intContador + 1 Console.WriteLine(intContador & quot; Par = [quot; & intPar & quot;]quot;) intSumaPares = intSumaPares + intPar Loop While (intContador < 10) Console.WriteLine(quot;Suma 10 primeros pares es quot; & intSumaPares) End Sub End Module
  40. 40. Estructuras REPETITIVAS Estructuras que repiten una secuencia de instrucciones (iteraciones) un número determinado de veces (bucle) • Mientras, hacer-mientras, repetir-hasta que, desde o para. NO acciones condición SI SI condición acciones NO i=1 NO acciones i <= 50 SI NO proceso condición i = i +1 SI
  41. 41. Estructuras REPETITIVAS Repetir Hasta-Que, Do Loop-Until: • Donde el cuerpo del bucle se repite al menos una vez. • Aquí la CONDICIÓN se evalua al final del bucle. • Para que se ejecute el bucle la evaluación de la condición debe ser FALSE. Pseudocódigo en español comienzo Repetir lectura {secuencia_de_acciones} Hasta Que {expresion_logica} acciones Pseudocódigo en inglés NO condición Do SI [ statements ] [ Exit Do ] fin [ statements ] Loop { Until } condition
  42. 42. Estructuras REPETITIVAS Repetir Hasta-Que, Do Loop-Until EJEMPLO: Presentar por pantalla la sumatoria de los 10 primeros números pares. • ANÁLISIS: • SumaPares = 2 + 4 + 6 + 8 + 10 +12 + 14 + 16 + 18 + 20 = 110 • DISEÑO: Como se muestra a continuación //Pseudocódigo en PSeInt Proceso Repetir_SumaPares intSumaPares <- 0; intContador <- 0; intPar <- 0; Repetir intPar <- intPar + 2; intContador <- intContador + 1; Escribir intContador, quot; Par = [quot;,intPar, quot;]quot;; intSumaPares <- intSumaPares + intPar; Hasta Que (intContador >= 10) Escribir quot;Suma 10 primeros pares es quot;, intSumaPares; FinProceso
  43. 43. Estructuras REPETITIVAS Repetir Hasta-Que, Do Loop-Until EJEMPLO: Presentar por pantalla la sumatoria de los 10 primeros números pares. 'Codificado en Visual Basic Module Repetir_SumaPares Public Sub Main() Console.WriteLine(quot;ESTRUCTURA REPETITIVA quot; & _ quot;REPETIR HASTA-QUEquot;) Dim intSumaPares, intContador, intPar As Integer intSumaPares = 0 intContador = 0 intPar = 0 Do intPar = intPar + 2 intContador = intContador + 1 Console.WriteLine(intContador & quot; Par = [quot; & intPar & quot;]quot;) intSumaPares = intSumaPares + intPar Loop Until (intContador >= 10) Console.WriteLine(quot;Suma 10 primeros pares es quot; & intSumaPares) Console.ReadLine() End Sub End Module
  44. 44. Estructuras REPETITIVAS Estructuras que repiten una secuencia de instrucciones (iteraciones) un número determinado de veces (bucle) • Mientras, hacer-mientras, repetir-hasta que, desde o para. NO acciones condición SI SI condición acciones NO i=1 NO acciones i <= 50 SI NO proceso condición i = i +1 SI
  45. 45. Estructuras REPETITIVAS Desde-Para, For-To-Next: • Cuando se conoce de antemano el número de veces que se ejecutaran las acciones en un bucle. • Cuando el número de iteraciones sea FIJO o CONSTANTE. • Este es un bucle AUTOMATIZA el ingremento del contador y la evaluación de la condición. comienzo Pseudocódigo en español lectura Para {variable_numerica}<-{valor_inicial} Hasta {valor_final} Con Paso {paso} Hacer {secuencia_de_acciones} FinPara i=1 F i <= 50 V Pseudocódigo en inglés proceso For counter [ As datatype ] = start To end [ Step step ] [ statements ] i = i +1 [ Exit For ] [ statements ] Next [ counter ] fin
  46. 46. Estructuras REPETITIVAS Desde-Para, For-To-Next: • Cuando se conoce de antemano el número de veces que se ejecutaran las acciones en un bucle. • Cuando el número de iteraciones sea FIJO o CONSTANTE. • Este es un bucle AUTOMATIZA el ingremento del contador y la evaluación de la condición. DESDE contador = 0 HASTA limite [incremento decremento] HACER <acciones> FIN_DESDE For counter [ As datatype ] = 0 To end [ Step step ] [ statements ] [ Exit For ] [ statements ] Next [ counter ]
  47. 47. Estructuras REPETITIVAS Desde-Para, For-To-Next EJEMPLO: Presentar por pantalla la sumatoria de los 10 primeros números pares. • ANÁLISIS: • SumaPares = 2 + 4 + 6 + 8 + 10 +12 + 14 + 16 + 18 + 20 = 110 • DISEÑO: Como se muestra a continuación //Pseudocódigo en PSeInt Proceso Para_SumaPares intSumaPares <- 0; intContador <- 0; intPar <- 0; Para intContador<-1 Hasta 10 Con Paso 1 Hacer intPar <- intPar + 2; intSumaPares <- intSumaPares + intPar; Escribir intContador, quot; Par = [quot;,intPar, quot;]quot;; FinPara Escribir quot;Suma 10 primeros pares es quot;, intSumaPares; FinProceso
  48. 48. Estructuras REPETITIVAS Desde-Para, For-To-Next EJEMPLO: Presentar por pantalla la sumatoria de los 10 primeros números pares. 'Codificado en Visual Basic Module Para_SumaPares Public Sub Main() Console.WriteLine(quot;ESTRUCTURA REPETITIVA FORquot;) Dim intSumaPares, intPar As Integer intSumaPares = 0 intPar = 0 For intContador As Integer = 1 To 10 intPar = intPar + 2 Console.WriteLine(intContador & quot; Par = [quot; & intPar & quot;]quot;) intSumaPares = intSumaPares + intPar Next Console.WriteLine(quot;Suma 10 primeros pares es quot; & intSumaPares) Console.ReadLine() End Sub End Module
  49. 49. Estructuras REPETITIVAS Otros ejemplos: Presentar la suma de N números ANÁLISIS Leer <número1> y sumarlo en <sumatoria>, leer <número2> y sumarlo en <sumatoria>, leer <númeron>y sumarlo en <sumatoria>…. DISEÑO Proceso SumarN_Numeros numero <- 0; sumatoria <- 0; contador <- 1; Escribir quot;deme el limite de num a sumarquot;; Leer limite; Mientras (limite >= contador) Hacer Escribir quot;deme num quot;, contador ; Leer numero; sumatoria <- sumatoria + numero; contador <- contador + 1; FinMientras Escribir quot;La sumatoria es: quot; ,sumatoria; FinProceso
  50. 50. Programación Estructurada Flujos de control • Controlar el orden en el que se ejecutan las sentencias de un programa.
  51. 51. Programación Estructurada Flujos de control • Controlar el orden en el que se ejecutan las sentencias de un programa. Una sentenci a sigue de otra
  52. 52. Programación Estructurada Flujos de control • Controlar el orden en el que se ejecutan las sentencias de un programa. • If-Then-End If Simples • If-Then-Else-End Dobles If • Select Case- Multiple Case-Case Else- s End Select
  53. 53. Programación Estructurada Flujos de control • Controlar el orden en el que se ejecutan las sentencias de un programa. • While-End Mientr as While Hacer • Do-Loop Mientr While as Pepeti • Do-Loop r Until Hasta • For-To-Next PARA
  54. 54. Programación Estructurada Flujos de control REPETITIVOS • Controlar el orden en el que se ejecutan las sentencias de un programa.
  55. 55. Estructuras REPETITIVAS Presentar la serie del Fibinacci = 0, 1, 1, 2, 3, 5, 8, 13, 21, … ANÁLISIS Los primeros números inicializados deberían ser. CERO 0 y UNO 1 El siguiente número es la suma de un par de números anteriores, es decir 1 = 0+1, 2 = 1 + 1 Presento 0 (cero) Fibo = 0 + 1 = 1 Fibo = 1 + 0 = 1 Fibo = 1 + 1 = 2 Fibo = 2 + 1 = 3 Fibo = 3 + 2 = 5 Fibo = 5 + 3 = 8 Fibo = 8 + 5 = 13
  56. 56. Estructuras REPETITIVAS Valor Valor inicial = 0 inicial = 1 FIBO = FIBO + NUMERO Presento 0 (cero) AUX = FIBO Fibo = 0 + 1 = 1 FIBO = FIBO + NUMERO Fibo = 1 + 0 = 1 AUX = FIBO FIBO = FIBO + NUMERO Fibo = 1 + 1 = 2 Fibo = 2 + 1 = 3 Fibo = 3 + 2 = 5 Fibo = 5 + 3 = 8 Fibo = 8 + 5 = 13
  57. 57. Conceptos Claves: Bucles infinitos: Aquellos en los que por la condición especificada por el programador, la condición no se termina. Estructuras repetitivas anidadas: Todos aquellos bucles contenidos dentro de otro bucle. • Cuando se anidan bucles se debe tener cuidado que el bucle inferior este contenido completamente dentro del bucle exterior.
  58. 58. Conceptos Claves: Un programa sin ninguna sentencia de bifurcación o iteración (selectiva o repetitiva), se ejecuta secuencialmente (en el orden en el que están escritas las sentencias). Una sección de código repetitivo se conoce como bucle controlado por una sentencia de repetición que comprueba una condición para determinar si el código se ejecutará. Cada pasada a través del bucle se conoce como una iteración o repetición controladas por una sentencia o condición.
  59. 59. Tipos básicos de bucles
  60. 60. Tipos básicos de bucles <hacer mientras> se repite mientras la condición es verdadera <repetir hasta> se repite mientras la condición es falsa.
  61. 61. Referencias: Bibliográficas  LUÍS, JOYANES AGUILAR. (2003): “Fundamentos de Programación, Algoritmos, Estructuras de Datos y Objetos.” Mc-Graw Hill. Madrid. Páginas 131 y siguientes (Cap# 4 y Cap#5). Direcciones electrónicas  Instalador del [pseint]: http://pseint.sourceforge.net/  Video, manejo del [pseint]: http://monje.oneble.com/tag/pseint/  “El algoritmo, una iniciación a la programación” http://www.scribd.com/doc/6686520/Manual-Algoritmo Otros medios  Microsoft Corporation (2008): Microsoft Document Explore Version 8.0.50727.42, actualizado 06 de diciembre de 2007 (citado 25 de Marzo del 2009). Disponible a través de: MSDN Library para Visual Studio 2005 (US).
  62. 62. MATRICULATE AL CURSO

×