Estructura Repetitiva MIENTRAS (While) con PSeInt

43,462 views
42,996 views

Published on

Ejemplos de la estructura repetitiva MIENTRAS (While) con PSeInt.

Published in: Education
0 Comments
9 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
43,462
On SlideShare
0
From Embeds
0
Number of Embeds
4
Actions
Shares
0
Downloads
713
Comments
0
Likes
9
Embeds 0
No embeds

No notes for slide

Estructura Repetitiva MIENTRAS (While) con PSeInt

  1. 1. UNIVERSIDAD GERARDO BARRIOS – FACULTAD DE CIENCIA Y TECNOLOGÍA – FUNDAMENTOS DE PROGRAMACIÓN – GRUPO B Docente: Pedro Antonio Villalta https://plus.google.com/u/0/105223072803758915793/about facebook.com/pavillaltaugb || twitter.com/pavillalta || pavillalta@gmail.com || pavillalta@ugb.edu.sv 1 Ejemplos y Ejercicios de la Estructura Repetitiva Mientras (While) con PSeInt Docente: Pedro Antonio Villalta Google+ https://plus.google.com/u/0/105223072803758915793/about facebook.com/pavillaltaugb || twitter.com/pavillalta || pavillalta@gmail.com || pavillalta@ugb.edu.sv EJEMPLOS DE ESTRUCTURA REPETITIVA MIENTRAS (WHILE) EJEMPLO # 1 Descripción: Calcular el salario de un grupo de n trabajadores dada la cantidad de horas trabajadas y la tarifa por hora para cada uno. Seudocódigo: Código PSeInt: Proceso salarios Definir n,contador,salario,horas,tarifa,suma como Enteros; Leer n; contador <- 1; suma <- 0; Mientras contador <= n Hacer Leer horas,tarifa; salario <- horas * tarifa; Escribir salario; suma <- suma + salario; contador <- contador + 1; FinMientras Escribir "La suma de ",n," Trabajadores es : ", suma; FinProceso 1
  2. 2. UNIVERSIDAD GERARDO BARRIOS – FACULTAD DE CIENCIA Y TECNOLOGÍA – FUNDAMENTOS DE PROGRAMACIÓN – GRUPO B Docente: Pedro Antonio Villalta https://plus.google.com/u/0/105223072803758915793/about facebook.com/pavillaltaugb || twitter.com/pavillalta || pavillalta@gmail.com || pavillalta@ugb.edu.sv 2 Ejecución del Programa. Modifique el programa para usando etiquetado para que oriente mejor a los usuarios en las acciones que debe realizar, la salida en pantalla debe ser la siguiente: Código PSeInt: Proceso salarios Definir n,contador,salario,horas,tarifa,suma como Enteros; Escribir "Ingrese la cantidad de trabajadores: " Leer n; contador <- 1; suma <- 0; Mientras contador <= n Hacer Escribir "Ingrese los datos del empleado: ",contador; Escribir "Horas Trabajadas: "; Leer horas; Escribir "Tarifa por hora: $"; Leer tarifa; salario <- horas * tarifa;
  3. 3. UNIVERSIDAD GERARDO BARRIOS – FACULTAD DE CIENCIA Y TECNOLOGÍA – FUNDAMENTOS DE PROGRAMACIÓN – GRUPO B Docente: Pedro Antonio Villalta https://plus.google.com/u/0/105223072803758915793/about facebook.com/pavillaltaugb || twitter.com/pavillalta || pavillalta@gmail.com || pavillalta@ugb.edu.sv 3 Escribir "Salario del empleado ",contador," = $",salario; suma <- suma + salario; contador <- contador + 1; FinMientras Escribir "La suma de ",n," Trabajadores es : $", suma; FinProceso EJEMPLO # 2 Descripción: El programa solamente muestra los números primos desde el 1 hasta el 100. Por definición, un numero primo es aquel que solamente puede ser dividido enteramente por el 1 o por sí mismo esto implica que los primos solamente tienen dos divisores. La única restricción sería el uno el cual presenta solo un divisor. Seudocódigo: Programa primos {i,primo,j,prime,h,k son variables de tipo entero} Inicio Hacer prime<- 0 Hacer i<- 1 Mientras i <= 100 Hacer Hacer primo<-0 Repetir j desde 1 Hasta i Si i%j=0 Entonces Hacer primo<-primo+1 {fin condicional si} Hacer j <- j+1 {fin ciclo repetir} Si primo=2 Entonces Hacer prime <- prime + 1 Escribir i {fin condicional si} Hacer i<- i+1 {fin ciclo repetir} Escribir "Se encontraron ", prime, " numeros primos entre 1 y 100" Fin Código PSeInt: Proceso numprimos Definir n,primo,j,cuenta,h,k Como Entero; cuenta <- 0; n <- 1; Mientras n <= 100 Hacer primo <- 0; Para j <-1 Hasta n Hacer Si n%j=0 Entonces primo <- primo + 1; FinSi FinPara Si primo = 2 Entonces cuenta <- cuenta + 1; Escribir n; FinSi i<- n+1; FinMientras Escribir "Se encontraron ", cuenta, " números primos entre 1 y 100"; FinProceso
  4. 4. UNIVERSIDAD GERARDO BARRIOS – FACULTAD DE CIENCIA Y TECNOLOGÍA – FUNDAMENTOS DE PROGRAMACIÓN – GRUPO B Docente: Pedro Antonio Villalta https://plus.google.com/u/0/105223072803758915793/about facebook.com/pavillaltaugb || twitter.com/pavillalta || pavillalta@gmail.com || pavillalta@ugb.edu.sv 4 La estructura del programa se basa en dos ciclos, un mientras y un repetir (llamado Para en PseInt) y una estructura condicional Sí. El ciclo externo (Mientras) está encargado de contar desde el uno al 100 indiscriminadamente, la estructura repetir recorre hasta el número en donde va i realizando un conteo interno de los divisores y la cantidad de primos. Para finalmente usar un condicional Si para dar el mensaje al usuario. EJEMPLO # 3 Calcular la suma de los números entre 0 y una cantidad n que es ingresada por el usuario. Proceso Suma_Numeros Leer n; suma<-0; indice<-1; Mientras indice<= n Hacer suma<-suma+indice; indice<-indice+1; FinMientras Escribir "Suma: ",suma; FinProceso EJERCICIOS DE ESTRUCTURA REPETITIVA MIENTRAS (WHILE) 1. Calcular la sumatoria de los primeros 100 enteros. 2. Calcular la sumatoria de los enteros entre 100 y 200. 3. Imprimir los hasta n los numeros enteros, pero solo los pares. 4. Imprimir su nombre 10 veces. 5. Leer un número e imprimir su tabla de multiplicar. 6. Calcular el factorial de un número. 7. Leer N números y sumar los pares en una variable y los impares en otra. Docente: Pedro Antonio Villalta (Pavillalta) Google+ https://plus.google.com/u/0/105223072803758915793/about Sitio web http://ingenieria-en-sistemas-informaticos.blogspot.com/ Blogs Educativos Comercio E (e-commerce) Compiladores e Interpretes Desarrollo de Aplicaciones para Dispositivos Móviles (developmentmobileapplications) Ingenieria en Sistemas Informáticos (systemsengineering) Ingenieria Web (web engineering) Noticias de Tecnología | informática | ciencia (technologynews) Programacion Visual C# .net (Visual C # programming) Programación Visual Basic .net (programming visual basic) Redes de Computadoras (computernetwork) Investigación Científica Artes Marciales, Tae Kwon Do

×