Estructuras Repetitivas con PSeInt (Parte 2)

15,685 views
15,063 views

Published on

Definición de cada una de las estructuras repetitivas.
Hacer Mientras
Hacer Hasta - Que
Hacer Desde - Hasta – Incremento

Published in: Education
0 Comments
6 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
15,685
On SlideShare
0
From Embeds
0
Number of Embeds
118
Actions
Shares
0
Downloads
449
Comments
0
Likes
6
Embeds 0
No embeds

No notes for slide

Estructuras Repetitivas con PSeInt (Parte 2)

  1. 1. 1 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT Facultad de Ciencia y Tecnología Universidad Gerardo Barrios Clase 17,18 Estructuras Repetitivas, Programas en PSeInt Fundamentos de Programación
  2. 2. 2 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT Docente: Pedro Antonio Villalta pavillalta@gmail.com pavillalta@ugb.edu.sv facebook.com/pavillaltaugb twitter.com/pavillalta https://plus.google.com/u/0/105223072803758915793/about Google+
  3. 3. 3 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT CONTENIDO  Hacer mientras  Hacer - desde - hasta – incremento  Hacer hasta - que
  4. 4. MIESTRAS (WHILE). DEFINICION 4 permite que un fragmento de un programa se repita mientras una cierta condición se siga cumpliendo. 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  5. 5. MIESTRAS (WHILE). FLUJOGRAMA 5 Diagrama de flujo para representar este tipo de condiciones repetitivas, en las que si se cumple la condición, se realiza una serie de acciones y se vuelve a comprobar la condición, y así sucesivamente hasta que la condición no se cumpla 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  6. 6. MIESTRAS (WHILE). ESTRUCTURA EN PSE INT 6 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  7. 7. MIESTRAS (WHILE). EJEMPLO 4 7 programa capaz de sumar muchos números, todos los que el usuario quisiera, y en el que hubiera que escribir "0" para indicar que queremos terminar. 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  8. 8. HACER HASTA – QUE (DO WHILE). DEFINICION 8 Usaremos HACER HASTA Cuando la estructura MIENTRAS no pueda utilizarse porque un bloque de programa que quizás se repita, deba ejecutarse al menos una vez. 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  9. 9. HACER HASTA – QUE (DO WHILE). FLUJOGRAMA 9 Por ejemplo, si queremos pedir un dato al usuario, quizá exista algún error y haya que insistir, pero al menos deberemos pedírselo una primera vez. 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  10. 10. HACER HASTA – QUE (DO WHILE). EN PSE INT 10 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  11. 11. HACER HASTA – QUE (DO WHILE). EJEMPLO 1 11 programa que pida al usuario una clave de acceso, y que no le permita seguir hasta que la introduzca correctamente. 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  12. 12. HACER HASTA – QUE (DO WHILE). EJEMPLO 2 12 Programa capaz de sumar muchos números, todos los que el usuario quisiera, y en el que hubiera que escribir "0" para indicar que queremos terminar. proceso sumar Repetir a<-0 Tot<-0 Tot<-Tot+a; Escribir "Ingrese un número (0 para salir)"; Leer a; Hasta Que a = 0 Escribir "Total:",Tot; Fin Proceso 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  13. 13. HACER - DESDE - HASTA – INCREMENTO (FOR). DEFINICIÓN 13 En muchas ocasiones, no querremos que algo se repita mientras se cumpla una condición, sino un cierto número de veces. En este caso usaremos la orden "para", que hace que una variable tome una serie de valores que se van incrementando. 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  14. 14. HACER - DESDE - HASTA – INCREMENTO (FOR). FLUJOGRAMA 14 Su representación en un diagrama de flujo sería: Vi: Valor de variable inicial (Inicio) Vf: Valor de variable final (Fin) P: Incremento 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  15. 15. HACER - DESDE - HASTA – INCREMENTO (FOR). EN PSE INT 15 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  16. 16. HACER - DESDE - HASTA – INCREMENTO (FOR). EJEMPLO 16 Programa que mostrara los números del 1 al 10. 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  17. 17. HACER - DESDE - HASTA – INCREMENTO (FOR). EJEMPLO CON ESPECIFICACIÓN “PASO” 17 Si no queremos avanzar de uno en uno, podemos indicar otro tamaño de "paso": 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  18. 18. HACER - DESDE - HASTA – INCREMENTO (FOR). EJEMPLO 2 18 Código para repetir diez veces el nombre. Proceso escribir_nombre Escribir "dame tu nombre"; leer a; Para i<-1 Hasta 10 Con Paso 1 Hacer escribir a; Fin Para Fin Proceso 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  19. 19. HACER - DESDE - HASTA – INCREMENTO (FOR). EJEMPLO 3 19 Qué hace el siguiente programa: Proceso incremento escribir "digita un numero: "; leer a; Para a<-a+1 Hasta 10 Con Paso 1 Hacer escribir a Fin Para Fin Proceso 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  20. 20. HACER - DESDE - HASTA – INCREMENTO (FOR). DESARROLLE LOS SIGUIENTES EJERCICIOS 20 1.Ejercicio de repaso propuesto 8.1: Crea un programa que escriba los múltiplos del 3, desde el 3 hasta el 30. 2.Ejercicio de repaso propuesto 8.2: Crea un programa que escriba los números del 20 al 10, descendiendo. 3.Ejercicio de repaso propuesto 8.3: Crea un programa que escriba la tabla de multiplicar del 5: desde "5 x 0 = 0" hasta "5 x 10 = 50" 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT
  21. 21. 21 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT BLOG EDUCATIVOS PAVILLALTA 1. Comercio electronico (e-commerce) 2. Compiladores e interpretes 3. Desarrollo de aplicaciones para dispositivos móviles (development mobile applications) 4. Ingenieria en sistemas informáticos (systems engineering) 5. Ingenieria web (web engineering) 6. Noticias de tecnología | informática | ciencia (technology news) 7. Programacion visual c++ .net (programming visual c + +. net) 8. Programacion web php, ajax, css, javascrip...(web programming) 9. Programación visual basic .net (programming visual basic) 10. Programacion visual c# (visual c # programming) 11. Redes de computadoras (computer network) 12. Investigación Científica 13. Artes Marciales, Tae Kwon Do
  22. 22. 22 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT FUENTES CONSULTADAS http://www.aprendeaprogramar.com Cursos gratuitos de programación de ordenadores
  23. 23. 23 24 y 25 de Marzo de 2014 ESTRUCTURAS REPETITIVAS CON PSEINT

×