19ο ΓΥΜΝΑΣΙΟ ΘΕΣ/ΝΙΚΗΣ ΤΑΞΗ : Γ’
ΣΧΟΛΙΚΟ ΕΤΟΣ : 2013-2014 ΜΑΘΗΜΑ : ΠΛΗΡΟΦΟΡΙΚΗ
ΕΞΕΤΑΣΤΙΚΗ ΠΕΡΙΟΔΟΣ : ΕΙΣΗΓΗΤHΣ :
ΜΑΪΟΥ-ΙΟΥ...
6. Αντιστοιχίστε τις διαδικασίες στα αριστερά με τα ανάλογα σχήματα στα δεξιά.
(π.χ 1  Α, 2  Β, 3  Γ, κ.λ.π)
1.
για δια...
7. Γράψτε δίπλα από τις εντολές εξόδου τι θα εμφανιστεί στην οθόνη μετά την
εκτέλεση των εντολών:
ΕΝΤΟΛΕΣ ΟΘΟΝΗ
Α. Κάνε “ζ...
ΑΠΑΝΤΗΣΕΙΣ ΣΤΑ ΘΕΜΑΤΑ ΤΩΝ ΓΡΑΠΤΩΝ ΑΠΟΛΥΤΗΡΙΩΝ
ΕΞΕΤΑΣΕΩΝ ΠΛΗΡΟΦΟΡΙΚΗΣ
1. Βιβλίο Πληροφορικής, σελ. 178, 179, 180.
2. Βιβλίο...
Upcoming SlideShare
Loading in...5
×

Exam&ans 2014

1,496

Published on

Published in: Education
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
1,496
On Slideshare
0
From Embeds
0
Number of Embeds
3
Actions
Shares
0
Downloads
3
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Transcript of "Exam&ans 2014"

  1. 1. 19ο ΓΥΜΝΑΣΙΟ ΘΕΣ/ΝΙΚΗΣ ΤΑΞΗ : Γ’ ΣΧΟΛΙΚΟ ΕΤΟΣ : 2013-2014 ΜΑΘΗΜΑ : ΠΛΗΡΟΦΟΡΙΚΗ ΕΞΕΤΑΣΤΙΚΗ ΠΕΡΙΟΔΟΣ : ΕΙΣΗΓΗΤHΣ : ΜΑΪΟΥ-ΙΟΥΝΙΟΥ 2014 Ν.ΤΣΟΡΜΠΑΤΖΟΓΛΟΥ ΗΜΕΡΟΜΗΝΙΑ : 11 - 6 - 2014 ΘΕΜΑΤΑ ΓΡΑΠΤΩΝ ΑΠΟΛΥΤΗΡΙΩΝ ΕΞΕΤΑΣΕΩΝ 1. α. Τι είναι ο αλγόριθμος; β. Ποιες είναι οι βασικές ιδιότητες ενός αλγορίθμου; 2.Τι είναι γλώσσες προγραμματισμού και ποια τα χαρακτηριστικά τους; Αναφέρετε τρείς γλώσσες προγραμματισμού. 3. Ποια είναι τα στάδια για την εκτέλεση ενός αλγορίθμου από την Κεντρική Μονάδα Επεξεργασίας (Κ.Μ.Ε); 4. Συμπληρώστε τα κενά στις προτάσεις που ακολουθούν με την κατάλληλη λέξη από τις παρακάτω: ΔΕΙΞΕ, Περιοχή καρτελών, ΣΤΑ, χελώνα, Επιφάνεια εργασίας, ΜΠΡΟΣΤΑ, ΚΑΝΕ, ΑΝΑΚΟΙΝΩΣΗ, Κέντρο εντολών, ΕΡΩΤΗΣΗ, Basic, ΣΒΓ, ΑΠΑΝΤΗΣΗ, Logo, ΣΤΚ, ΦΡΑΣΗ, μεταβλητή, ΠΙΣΩ, διαδικασία . Α. Στο …………………………………….μπορούμε να πληκτρολογούμε εντολές στη γλώσσα προγραμματισμού …………………………. Β. Η εντολή …………………………[ ] ορίζει ότι περικλείεται μέσα στις αγκύλες [ ] ως κείμενο. Γ. Η εντολή …………………………………[ ] προβάλλει ένα παράθυρο που περιέχει το κείμενο που περιέχεται μέσα στις αγκύλες [ ]. Δ. Η εντολή ………..…….… δίνει εντολή στην χελώνα να αφήνει ίχνος από κάθε σημείο της οθόνης. Ε. Η εντολή ……………. σβήνει γραφικά στην ………………………………………... Ζ. Η ομαδοποίηση των εντολών ονομάζεται ………………………….. 5. α. Γράψτε κατάλληλη εντολή που να ανακοινώνει τα εξής: Το παγκόσμιο κύπελλο 2014 θα διεξαχθεί στην Βραζιλία. β. Γράψτε κατάλληλες εντολές που να σχεδιάζουν ένα κύκλο.
  2. 2. 6. Αντιστοιχίστε τις διαδικασίες στα αριστερά με τα ανάλογα σχήματα στα δεξιά. (π.χ 1  Α, 2  Β, 3  Γ, κ.λ.π) 1. για διαδικασία1 στκ επανάλαβε 3[μπ 100 δε 120] τέλος Α. σκάλα 4. για διαδικασία4 στκ δε 45 επανάλαβε 2[μπ 50 δε 90 μπ 50 αρ 90] τέλος Δ. τρίγωνο 2. για διαδικασία2 στκ επανάλαβε 3[μπ 50 δε 90 μπ 50 αρ 90] τέλος Β. γράμμα Μ 5. για διαδικασία5 στκ επανάλαβε 5[μπ 100 δε 144] τέλος Ε. πεντάγωνο 3. για διαδικασία3 στκ δε 45 επανάλαβε 3[μπ 100 δε 90] μπ 100 τέλος Γ. αστέρι 6. για διαδικασία6 στκ επανάλαβε 5[μπ 100 δε 72] τέλος Ζ. ρόμβος
  3. 3. 7. Γράψτε δίπλα από τις εντολές εξόδου τι θα εμφανιστεί στην οθόνη μετά την εκτέλεση των εντολών: ΕΝΤΟΛΕΣ ΟΘΟΝΗ Α. Κάνε “ζώο “λιοντάρι Δείξε :ζώο Β. Κάνε “άνθρωπο “φίλο Δείξε (φρ[έχω ένα] :άνθρωπο) Γ. Κάνε “Φιλόσοφοι [Σωκράτης Πλάτωνας Αριστοτέλης] Δείξε :Φιλόσοφοι Δ. Κάνε “χ 2 Κάνε “ψ :χ Δείξε (2 + :χ - 10) / (3 * :ψ) Ε . Κάνε “ψ 2 Κάνε “χ 3 Δείξε δύναμη :ψ :χ Ζ. Κάνε “ζ 81 Δείξε (ΤετραγωνικήΡίζα :ζ) + 3 8. Να γραφούν δύο διαδικασίες που να υπολογίζουν και να εμφανίζουν στο κέντρο εντολών αντίστοιχα τους: α) 10 πρώτους ακέραιους αριθμούς και β) 10 πρώτους άρτιους αριθμούς. 9. Να δημιουργήσετε μια παραμετρική διαδικασία με το όνομα πολύγωνο που να σχεδιάζει ένα πολύγωνο. Η διαδικασία θα δέχεται δυο παραμέτρους. Η μια παράμετρος θα καθορίζει πόσες πλευρές θα έχει το πολύγωνο, και η άλλη το μήκος τους σε εικονοστοιχεία. Ποιες εντολές θα γράφατε στο κέντρο εντολών ώστε η χελώνα να σχεδιάσει : α) ένα οκτάγωνο με μήκος πλευράς 50 εικονοστοιχεία. β) ένα δωδεκάγωνο με μήκος πλευράς 60 εικονοστοιχεία. (Να απαντήσετε σε 6 θέματα από τα 9 και να μεταφέρετε τις απαντήσεις των θεμάτων στην κόλλα αναφοράς. Όλα τα θέματα είναι ισοδύναμα.) ΚΑΛΗ ΕΠΙΤΥΧΙΑ!!! O Δ/ΝΤΗΣ Ο ΕΙΣΗΓΗΤΗΣ ΠΑΜΠΟΥΚΙΔΗΣ ΧΑΡΑΛΑΜΠΟΣ Ν.ΤΣΟΡΜΠΑΤΖΟΓΛΟΥ
  4. 4. ΑΠΑΝΤΗΣΕΙΣ ΣΤΑ ΘΕΜΑΤΑ ΤΩΝ ΓΡΑΠΤΩΝ ΑΠΟΛΥΤΗΡΙΩΝ ΕΞΕΤΑΣΕΩΝ ΠΛΗΡΟΦΟΡΙΚΗΣ 1. Βιβλίο Πληροφορικής, σελ. 178, 179, 180. 2. Βιβλίο Πληροφορικής, σελ. 182, 183. 3. Βιβλίο Πληροφορικής, σελ. 184. 1. Α. Κέντρο εντολών – Logo. Β. ΦΡΑΣΗ. Γ. ΑΝΑΚΟΙΝΩΣΗ Δ. ΣΤΚ Ε. ΣΒΓ – Επιφάνεια εργασίας. Ζ. διαδικασία. 5. α) Ανακοίνωση [Το παγκόσμιο κύπελλο 2014 θα διεξαχθεί στην Βραζιλία] β) στκ επανάλαβε 360 [μπ 1 δε 1] 6. 1  Δ, 2  Α, 3  Ζ, 4  Β, 5  Γ, 6  Ε. 7. Α  λιοντάρι, Β  έχω ένα φίλο, Γ  Σωκράτης Πλάτωνας Αριστοτέλης Δ  -1 Ε  8 Ζ  12 8. α) για ακέραιοι_10 β) για άρτιοι_10 κάνε “α 1 κάνε “α 2 δείξε :α δείξε :α επανάλαβε 9[κανε “α :α + 1 δείξε :α] επανάλαβε 9[κανε “α :α + 2 δείξε :α] τέλος τέλος 9. για πολύγωνο :πλευρά :μήκος στκ επανάλαβε :πλευρά [μπ :μήκος δε 360 / :πλευρά] τέλος α) πολύγωνο 8 50 β) πολύγωνο 12 60

×