• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Network
 

Network

on

  • 784 views

 

Statistics

Views

Total Views
784
Views on SlideShare
784
Embed Views
0

Actions

Likes
3
Downloads
82
Comments
0

0 Embeds 0

No embeds

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Network Network Presentation Transcript

    • NETWORKING
      • BY:-SUBAHSH DUDI
      • 08EBTCS054
      • CSE
    • CONTENTS
      • Introduction
      • Types Of Network
      • IP Addressing
      • Cables
      • Networking Devices
      • Router Configuration
      • Routing Protocol
      • Conclusion
    • DEFINATION
      • A network is a system that transmits any combination of voice, video and/or data between users.
      • It consists of:-
      • Network operating system
      • Cables connecting all network devices
      • Network components
    • TYPES OF NETWORK
      • LAN(Local Area Network)
      • WAN(Wide Area Network)
    • LAN These are privately owned networks within a single building or campus of up to a few a kilometers in size.
      • Contd….
      • LAN’s are distinguished from other networks by three
      • characteristics:
      • 1) Their size.
      • 2) Their transmission technology.
      • 3) Their topology.
      • LANs run at speeds of 10 to 100 Mbps.
    • WAN
      • It is a Computer network that spans a relatively large
      • geographical area, often a country or continent. Typically
      • a WAN consists of two or more Local Area Network.
      • .WANs run at speed of maximum 2 to 10 Mbps.
      • . The largest WAN in existence is Internet.
    • Contd….
    • IP ADDRESSING
      • Every machine on the internet has a unique identifying
      • number, called an IP Address.
      • A typical; IP address looks like this:
      • 216.27.61.45
      • IP ADDRESS is a 32-bit number, usually written in dotted decimal form
      • Each IP address is split into 2 sections:
      • Network address
      • Host address
      • Contd….
      • There are five IP classes:-
      • 1. Class A:-
      • Range – 1.0.0.0 t0 126.255.255.254
      • Private IP - 10.0.0.1 to 10.255.255.244
      • 2. Class B:-
      • Range - 128.0.0.0 to 191.255.255.254
      • Private IP – 172.16.0.1 to 172.34.255.254
      • 3.Class C:-
      • Range - 192.0.0.0 to 223.255.255.254
      • Private IP - 192.168.0.0
      • Contd….
      • 4. Class D:-
      • Range – 224.0.0.0 to 239.255.255.254
      • 5.Class E:-
      • Range – 240.0.0.0 to 254.255.255.254
      • It is used for experimental purpose only.
      • -127.0.0.0 to 127.255.255.254 is also considered as Private IP.
    • CABLES
      • There are different Cabling options depending on the
      • access method:
      • 1. Twisted Pair :-
      • The wires are twisted around each other to minimize interference from other twisted pairs in the cable.
      • Typical lengths are up to 100m.
      • Twisted pair network uses a star topology.
      • 2. Coaxial :-
      • Coaxial cable uses BNC connectors.
      • The maximum cable lengths are around 500m.
      • Coaxial networks use a single bus topology
      • Contd….
      • 3. Fiber Optic:-
      • By using the Fiber cables it is possible to send the data about 10 kilometers.
      • In fiber cables the data is converted to light signals.
    • NETWORKING DEVICES
      • Networking devices do various kind of jobs like transferring the data to signals, providing connectivity to different network devices, transferring the data in form of packets or frames form one device to other.
      • 1. NETWORK INTERFACE CARD:-
      • A Network Interface Card (NIC) is a circuit board that plugs into both clients and servers and controls the exchange of data between them.
      • 2. HUB:-
      • Hub is a layer one device. i.e. it operates on the physical layer of the OSI model. It is designed to do broadcasting.
      • 3. SWITCH:-
      • Switches are intelligent devices which work on the Layer2 of the OSI model. Basically a switch keeps a record of MAC addresses of all the devices connected to it. Using this information, it builds a MAC address table. So when a frame is received, it knows exactly which port to send it to.
      • 4. ROUTER:-
      • For interconnecting two LAN or two or more different networks anther device known as router is used. Its main job is to route ( sends ) packets to other networks and to do the routing it uses the IP address. A router is typically connected to at least two networks, commonly two LAN’s or WAN’s or a LAN and its ISP’s network.
    • ROUTER CONFIGURATION
      • The console port is used for configuring a router locally with the help of a PC or a Laptop. The console port of the router is connected to the serial port of the router.
      • show running-config
      • show startup-config
      • Router> (user mode)
      • Router> enable
      • Router# (privilaged exec mode)
      • Router#configure terminal
      • Configuring a Router name:
      • Router(config)#hostname xyz
      • xyz(config)#
      • Set Passwords:-
      • Router(config)#enable password 123
      • Router(config)#enable secret abc123
      • Router(config)#line con 0
      • Router(config-line)#password xyz123
      • Router(config)#line aux 0
      • Router(config-line)#password xyz123
      • Router(config)#line vty 0 4
      • Router(config-line)#password xyz123
      • For configuring ethernet interface:
      • Router (config)# interface FA0/0
      • Router(config-if)# ip address 192.168.1.1 255.255.255.0
      • Contd….
      • Router (config-if)# no shutdown
      • Router (config-if)# exit
      • For configuring serial interface:
      • Router (config)# interface serial 0
      • Router (config-if)# ip address 192.168.3.1 255.255.255.0
      • Router (config-if)# no shutdown
      • Router (config-if)# exit
      • Router (config)# interface serial 1
      • Router (config-if)# ip address 192.168.3.2 255.255.255.0
      • Router (config-if)# no shutdown
      • Router(config-if)# exit
    •  
    • ROUTING PROTOCOL
      • ROUTING INFORMATION PROTOCOL (RIP):-
      • RIP is a dynamic, distance vector routing protocol. RIP calculates the best route based on hop count. This makes RIP very fast to converge.RIP sends full table updates at regular intervals specified by the route-update timer .
      • router> enable
      • router# conf t
      • router(config)#interface ethernet 0
      • Contd….
      • router(config-if)# ip address 192.168.1.1 255.255.255.0
      • router(config-if)# exit
      • router(config)# router rip
      • router(config-router)# network 192.168.2.1
      • router(config-router)# network 192.168.2.2
      • router(config-router)# exit
      • router#wr
    • CONCLUSION
      • Computer networks provide communication possibilities faster then other facilities because of these optimal information and communication possibilities , computer networks may increase organizational learning rate.
    • THANK YOU