Your SlideShare is downloading. ×
Chapter 6 Enhanced IGRP(EIGRP) and Open Shortest Path
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×
Saving this for later? Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime – even offline.
Text the download link to your phone
Standard text messaging rates apply

Chapter 6 Enhanced IGRP(EIGRP) and Open Shortest Path

2,152
views

Published on


0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
2,152
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
114
Comments
0
Likes
0
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. 网络分析与设计 计算机系:李志远
  • 2. Chapter 6
    • Enhanced IGRP(EIGRP) and Open hortest Path First(OSPF)
  • 3. two most popular routing protocols
    • Enhanced Interior Gateway Routing Protocol (EIGRP) is a proprietary Cisco protocol that runs on Cisco routers
    • Open Shortest Path First (OSPF) routing protocol,which is the other most popular routing protocol in use today
  • 4. EIGRP Features and Operation
    • Enhanced IGRP (EIGRP) is a classless, enhanced distance-vector protocol
    • EIGRP includes the subnet mask in its route updates.
  • 5.
    • EIGRP is sometimes referred to as a hybrid routing protocol because it has characteristics of both distance-vector and link-state protocols
  • 6. Protocol-Dependent Modules
    • provides routing support for multiple Network layer protocols:
      • IP, IPX, and AppleTalk.
    • EIGRP supports different Network layer protocols through the use of protocol-dependent modules (PDMs)
  • 7. Neighbor Discovery
    • Before EIGRP routers are willing to exchange routes with each other, they must become neighbors.There are three conditions that must be met for neighborship establishment:
      • Hello or ACK received
      • AS numbers match
      • Identical metrics (K values)
  • 8.
    • use Hello messages to establish neighborship
    • EIGRP routers that belong to different autonomous systems (ASes) don’t automatically share routing information and they don’t become neighbors.
  • 9.
    • The only time EIGRP advertises its entire routing table is when it discovers a new neighbor and forms an adjacency with it through the exchange of Hello packets. When this happens, both neighbors advertise their entire routing tables to one another. After each has learned its neighbor’s routes, only changes to the routing table are propagated from then on.
  • 10. Some terms
    • Feasible distance
    • Reported distance
    • Neighbor table
    • Topology table
    • Feasible successor
    • Successor
  • 11. Reliable Transport Protocol (RTP)
    • EIGRP uses a proprietary protocol, called Reliable Transport Protocol (RTP) , to manage the communication of messages between EIGRP-speaking routers.
  • 12. Diffusing Update Algorithm (DUAL)
    • This algorithm allows for the following:
      • Backup route determination if one is available
      • Support of Variable-Length Subnet Masks (VLSMs)
      • Dynamic route recoveries
      • Queries for an alternate route if no route can be found
  • 13. The key to EIGRP’s speedy convergence is twofold
    • First , EIGRP routers maintain a copy of all of their neighbors’ routes, which they use to calculate their own cost to each remote network.If the best path goes down, it may be as simple as examining the contents of the topology table to select the best replacement route.
  • 14.
    • Secondly, if there isn’t a good alternative in the local topology table, EIGRP routers very quickly ask their neighbors for help finding one
  • 15. Using EIGRP to Support Large Networks
    • EIGRP includes a bunch of cool features that make it suitable for use in large networks:
      • Support for multiple ASes on a single router
      • Support for VLSM and summarization
      • Route discovery and maintenance
  • 16. What’s a discontiguous network?
    • It’s one that has two or more subnetworks of a classful network connected together by different classful networks.
  • 17.  
  • 18.
    • EIGRP automatically summarizes networks at their classful boundaries
  • 19.  
  • 20. Route Discovery and Maintenance
    • Given the huge amount of information that EIGRP routers have to collect
    • EIGRP uses a series of tables to store important information about its environment:
      • Neighborship table
      • Topology table
      • Route table
  • 21. neighborship table
    • The neighborship table (usually referred to as the neighbor table) records information about routers with whom neighborship relationships have been formed.
  • 22. topology table
    • The topology table stores the route advertisements about every route in the internetwork received from each neighbor.
  • 23. route table
    • The route table stores the routes that are currently used to make routing decisions. There would be separate copies of each of these tables for each protocol that is actively being supported by EIGRP, whether it’s IP, IPX, or AppleTalk.
  • 24. EIGRP Metrics
    • Bandwidth
    • Delay
    • Load
    • Reliability
  • 25. Maximum Paths and Hop Count
    • By default, EIGRP (and IGRP) can provide unequal cost load balancing of up to four links.However, you can have EIGRP actually load balance across up to six links by using the following command:
    • Pod1R1(config)# router eigrp 10
    • Pod1R1(config-router)# maximum-paths ?
    • <1-6> Number of paths
  • 26.
    • EIGRP (and again IGRP) has a maximum hop count of 100, but can be set up to 255
    • Pod1R1(config)# router eigrp 10
    • Pod1R1(config-router)# metric maximum-hops ?
    • <1-255> Hop count
  • 27. Configuring EIGRP
    • Let’s look at an example of enabling EIGRP for autonomous system 20 on a router connected to two networks, with the network numbers being 10.3.1.0/24 and 172.16.10.0/24:
    • Router# config t
    • Router(config)# router eigrp 20
    • Router(config-router)# network 172.16.0.0
    • Router(config-router)# network 10.0.0.0
  • 28.
    • EIGRP has an AD of 90, IGRP is 100 and RIP is 120, so only EIGRP routes will populate the routing tables even if all three routing protocols are enabled.
  • 29.  
  • 30.  
  • 31. Lab_A
    • Lab_A# config t
    • Enter configuration commands, one per line. End with CNTL/Z.
    • Lab_A(config)# router eigrp ?
    • <1-65535> Autonomous system number
    • Lab_A(config)# router eigrp 10
    • Lab_A(config-router)# netw 192.168.10.0
    • Lab_A(config-router)# netw 192.168.20.0
    • Lab_A(config-router)# ^Z
    • Lab_A#
  • 32. Lab_B
    • Lab_B# config t
    • Enter configuration commands, one per line. End with CNTL/Z.
    • Lab_B(config)# router eigrp 10
    • Lab_B(config-router)# netw 192.168.20.0
    • Lab_B(config-router)# netw 192.168.30.0
    • Lab_B(config-router)# netw 192.168.40.0
    • Lab_B(config-router)# ^Z
    • Lab_B#
  • 33. Lab_C
    • Lab_C# config t
    • Enter configuration commands, one per line. End with CNTL/Z.
    • Lab_C(config)# router eigrp 10
    • Lab_C(config-router)# netw 192.168.40.0
    • Lab_C(config-router)# netw 192.168.50.0
    • Lab_C(config-router)# ^Z
    • Lab_C#
  • 34. Configuring Discontiguous Networks
  • 35.
    • Lab_A# config t
    • Lab_A(config)# router eigrp 100
    • Lab_A(config-router)# network 172.16.0.0
    • Lab_A(config-router)# network 10.0.0.0
    • Lab_A(config-router)# no auto-summary
  • 36.
    • Lab_B# config t
    • Lab_B(config)# router eigrp 100
    • Lab_B(config-router)# network 172.16.0.0
    • Lab_B(config-router)# network 10.0.0.0
    • Lab_B(config-router)# no auto-summary
  • 37. Verifying EIGRP
  • 38. Open Shortest Path First (OSPF) Basics
    • Open Shortest Path First (OSPF) is an open standards routing protocol that’s been implemented by a wide variety of network vendors, including Cisco.
  • 39.
    • This works by using the Dijkstra algorithm. First, a shortest path tree is constructed, and then the routing table is populated with the resulting best paths.
    • it only supports IP routing
  • 40. OSPF provides the following features:
    • Consists of areas and autonomous systems
    • Minimizes routing update traffic
    • Allows scalability
    • Supports VLSM/CIDR
    • Has unlimited hop count
    • Allows multi-vendor deployment (open standard)
  • 41. OSPF and RIP comparison
  • 42.  
  • 43. The reasons for creating OSPF in a hierarchical design include:
    • To decrease routing overhead
    • To speed up convergence
    • To confine network instability to single areas of the network
  • 44. OSPF design example
  • 45. OSPF Terminology
    • Link A link is a network or router interface assigned to any given network.
    • Router ID The Router ID (RID) is an IP address used to identify the router.
    • Neighbors Neighbors are two or more routers that have an interface on a common network,such as two routers connected on a point-to-point serial link.
  • 46.
    • Neighbors Neighbors are two or more routers that have an interface on a common network,such as two routers connected on a point-to-point serial link.
    • Adjacency An adjacency is a relationship between two OSPF routers that permits the direct exchange of route updates.
  • 47.
    • Hello protocol The OSPF Hello protocol provides dynamic neighbor discovery and maintains neighbor relationships
    • Neighborship database The neighborship database is a list of all OSPF routers for which Hello packets have been seen.
    • Topology database The topology database contains information from all of the Link State Advertisement packets that have been received for an area.
  • 48.
    • Link State Advertisement A Link State Advertisement (LSA) is an OSPF data packet containing link-state and routing information that’s shared among OSPF routers
  • 49.
    • Designated router A designated router (DR) is elected whenever OSPF routers are connected to the same multi-access network.
    • Backup designated router A backup designated router (BDR) is a hot standby for the DR on multi-access links
  • 50.
    • OSPF areas An OSPF area is a grouping of contiguous networks and routers. All routers in the same area share a common Area ID
    • Broadcast (multi-access)
    • Non-broadcast multi-access
    • Point-to-point Point-to-point refers to a type of network topology consisting of a direct connection between two routers that provides a single communication path.
  • 51.
    • Point-to-multipoint Point-to-multipoint refers to a type of network topology consisting of a series of connections between a single interface on one router and multiple destination routers.
  • 52. SPF Tree Calculation
    • Within an area, each router calculates the best/shortest path to every network in that same area.This calculation is based upon the information collected in the topology database and an algorithm called shortest path first (SPF)
  • 53. Configuring OSPF
    • the basic single area OSPF configuration.
    • These two elements are the basic elements of OSPF configuration:
      • Enabling OSPF
      • Configuring OSPF areas
  • 54. Enabling OSPF
    • Lab_A(config)# router ospf ?
    • <1-65535>
    • A value in the range 1–65,535 identifies the OSPF Process ID.
  • 55. Configuring OSPF Areas
    • After identifying the OSPF process, you need to identify the interfaces that you want to activate OSPF communications on, as well as the area in which each resides. This will also configure the networks you’re going to advertise to others.
  • 56.
    • Lab_A# config t
    • Lab_A(config)# router ospf 1
    • Lab_A(config-router)# network 10.0.0.0 0.255.255.255 area ?
    • <0-4294967295> OSPF area ID as a decimal value
    • A.B.C.D OSPF area ID in IP address format
    • Lab_A(config-router)# network 10.0.0.0 0.255.255.255 area 0
  • 57. A quick review of wildcards:
    • A 0 octet in the wildcard mask indicates that the corresponding octet in the network must match exactly. On the other hand, a 255 indicates that you don’t care what the corresponding octet is in the network number.
  • 58.
    • See here
  • 59. Verifying OSPF Configuration
    • sh ip route
    • sho ip ospf
    • sh ip ospf database
    • show ip ospf interface
    • sh ip ospf neighbor
    • sh ip protocols
  • 60. OSPF and Loopback Interfaces
    • Loopback interfaces are logical interfaces, which are virtual, software-only interfaces; they are not real router interfaces. Using loopback interfaces with your OSPF configuration ensures that an interface is always active for OSPF processes.
  • 61.
    • They can be used for diagnostic purposes as well as OSPF configuration. The reason you want to configure a loopback interface on a router is because if you don’t, the highest IP address on a router will become that router’s RID. The RID is used to advertise the routes as well as elect the DR and BDR.
  • 62. Configuring Loopback Interfaces
  • 63.
    • Lab_A# config t
    • Enter configuration commands, one per line. End with CNTL/Z.
    • Lab_A(config)# int loopback 0
    • Lab_A(config-if)# ip address 172.16.10.1 255.255.255.255
    • Lab_A(config-if)# no shut
    • Lab_A(config-if)# ^Z
    • Lab_A#