• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Plantillafer
 

Plantillafer

on

  • 403 views

fer

fer

Statistics

Views

Total Views
403
Views on SlideShare
403
Embed Views
0

Actions

Likes
0
Downloads
3
Comments
0

0 Embeds 0

No embeds

Accessibility

Categories

Upload Details

Uploaded via as Adobe PDF

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Plantillafer Plantillafer Document Transcript

    • PrácticasColegio de Estudios Científicos y Tecnológicos del Estado de México Profesora: Domínguez Escalona René Alumna: Pérez Luna Ma. Fernanda Materia: Principios de programación en la solución de Sistemas. “Manual de Practicas” Grupo: 403 CECYTEM Tecámac 2
    • Prácticas Introducción:En este manual aprenderemos como diferenciar un código de unPseudocódigo, esto es importante. También aprenderemos como existe unasecuencia para poder llevar a cabo un programa, estos programas debentener funcionamiento para toda aquella persona que los quiera utilizar.Este programa es interesante.En este manual te enseñaremos desde como iniciarlo hasta como finalizarlo.Al igual es muy práctico para tomarle un buen uso. CECYTEM Tecámac 3
    • Prácticas Practica 1:“Operaciones Básicas” CECYTEM Tecámac 4
    • Prácticas° Pseudocódigo:Proceso OperacionesEscribir "Operaciones con 2 numeros";Escribir "Introduce numero1:";Leer num1;Escribir "Introduce numero:2";Leer num2;S<- num1+num2;R<- num1-num2;M<- num1*num2;D<- num1/num2;Escribir "Suma:",S;Escribir "Resta:",R;Escribir "Multiplicacion:",M;Escribir "Divicion:",D;Escribir "Hasta Luego";FinProceso Código C++ #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; int main(){ float d; float m; float num1; CECYTEM Tecámac 5
    • Prácticasfloat num2;float r;float s;cout<<"Operaciones con 2 numeros"<<endl;cout<<"Introduce numero1:"<<endl;cin>>num1;cout<<"Introduce numero:2"<<endl;cin>>num2;s=num1+num2;r=num1-num2;m=num1*num2;d=num1/num2;cout<<"Suma:"<<s<<endl;cout<<"Resta:"<<r<<endl;cout<<"Multiplicacion:"<<m<<endl;cout<<"Divicion:"<<d<<endl;cout<<"Hasta Luego"<<endlgetch (); CECYTEM Tecámac 6
    • Prácticas PROGRAMA: Conclusión:En esta práctica comencé a utilizar el programa con facilidad y así mismo ocurrió con elobjetivo que deseaba realizar. CECYTEM Tecámac 7
    • Prácticas Practica 2:“Eres mayor o Menor” ° CECYTEM Tecámac 8
    • PrácticasPseudocódigo:Proceso Eres MayorEscribir "Introduce Edad";leer Edad;Si Edad >=18 EntoncesEscribir "Adulto";SinoEscribir "No Eres Adulto";FinSiCódigo C++#include<iostream>#include<stdio.h>#include<conio.h>using namespace std;int main() {float edad;cout<<"Introduce Edad"<<endl;cin>>edad;if (edad>=18) {cout<<"Adulto"<<endl;} else {cout<<"No Eres Adulto"<<endl;}getch (); CECYTEM Tecámac 9
    • Prácticas } PROGRAMA: Conclusión:En esta práctica, fue sencillo manejar el código, puesto que solo tenias queidentificar si eras o no adulto dependiendo de el ingreso de tu edad. CECYTEM Tecámac 10
    • Prácticas Practica 3“Área del triangulo” CECYTEM Tecámac 11
    • Prácticas ° Pseudocódigo:Proceso AreadelTriangulo Escribir "Introduce Base del triangulo:"; Leer num1; Escribir "Introduce Altura"; Leer num2; A <- num1*num2/2; Escribir "Area:",A; Escribir "Gracias";FinProceso ° Código C++ #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; int main() { float a; float num float num2; cout<<"Introduce Base del triangulo:"<<endl; cin>>num1; cout<<"Introduce Altura"<<endl; cin>>num2; a=num1*num2/2; cout<<"Area:"<<a<<endl; cout<<"Gracias"<<endl; getch (); CECYTEM Tecámac 12
    • Prácticas PROGRAMA: Conclusión:Esta práctica fue algo interesante, puesto que no fue muy común identificar el área de unafigura, insertando valores diferentes. CECYTEM Tecámac 13
    • Prácticas Practica 4“Tablas de Multiplicar” CECYTEM Tecámac 14
    • Prácticas° PseudocódigoProceso TabladeMultiplicarEscribir "Operaciones con 2 numeros";Escribir "Introduce numero1:";Leer num1;A<-num1*1;B<-num1*2;C<-num1*3;D<-num1*4;E<-num1*5;F<-num1*6;G<-num1*7;H<-num1*8;I<-num1*9;J<-num1*10;Escribir "",num1,"X 1:",A;Escribir "",num1,"X 2:",B;Escribir "",num1,"X 3:",C;Escribir "",num1,"X 4:",D;Escribir "",num1,"X 5:",E;Escribir "",num1,"X 6:",F;Escribir "",num1,"X 7:",G;Escribir "",num1,"X 8:",H;Escribir "",num1,"X 9:",I;Escribir "",num1,"X 10:",J;FinProceso CECYTEM Tecámac 15
    • Prácticas Código C++#include<iostream>#include<stdio.h>#include<conio.h>using namespace std;int main()float b;float c;float d;float e;float f;float g;float h;float i;float j;float num1;cout<<"Operaciones con 2 numeros"<<endl; cout<<"Introduce numero1:"<<endl; cin>>num1; a=num1*1; b=num1*2; c=num1*3; d=num1*4; e=num1*5; f=num1*6; g=num1*7; CECYTEM Tecámac 16
    • Prácticash=num1*8;i=num1*9;j=num1*10;cout<<""<<num1<<"X 1:"<<a<<endl;cout<<""<<num1<<"X 2:"<<b<<endl;cout<<""<<num1<<"X 3:"<<c<<endl;cout<<""<<num1<<"X 4:"<<d<<endl;cout<<""<<num1<<"X 5:"<<e<<endl;cout<<""<<num1<<"X 6:"<<f<<endl;cout<<""<<num1<<"X 7:"<<g<<endl;cout<<""<<num1<<"X 8:"<<h<<endl;cout<<""<<num1<<"X 9:"<<i<<endl;cout<<""<<num1<<"X 10:"<<j<<endl;getch (); PROGRAMA: CECYTEM Tecámac 17
    • Prácticas Conclusión:En esta práctica se me complico un poco, ya que el código va creciendosegún lo que tengas que definir en tu práctica. Y pues aquí depende elnúmero que insertaras me tenía que dar toda su tabla numérica. CECYTEM Tecámac 18
    • Prácticas Practica 5 “Promedio”° CECYTEM Tecámac 19
    • PrácticasPseudocódigoProceso Promedio Escribir "Calificacion Calculo"; Leer Calificacion1; Escribir "Calificacion Historia"; Leer Calificacion2; Escribir "Calificacion Sistemas"; Leer Calificacion3; Escribir "Calificacion Geografia"; Leer Calificacion4; Escribir "Calificacion Ingles"; Leer Calificacion5; A <- Calificacion1+Calificacion2+Calificacion3+Calificacion4+Calificacion5 B <- A/5 Escribir "Promedio:",B; Si B>=9.0 EntoncesEscribir "Excelente Alumno" FinSi Si B>=7.0 y B<9.0 Entonces Escribir "Alumno Bueno"; FinSi Si B>=6.0 y B<7.0 Entonces Escribir "Alumno Regular"; CECYTEM Tecámac 20
    • Prácticas FinSi Si B>=5.0 y B<6.0 Entonces Escribir "Alumno Malo"; FinSiFinProceso Código C++#include<iostream>#include<stdio.h>#include<conio.h>using namespace std;// para las variables que no se pudo determinar el tipo se utiliza la constante SIN_TIPO// el usuario debe reemplazar sus ocurrencias por el tipo adecuado (usualmente int,float,stringo bool)#define SIN_TIPO stringint main() { float a; float b; SIN_TIPO calificacion1; SIN_TIPO calificacion2; SIN_TIPO calificacion3; SIN_TIPO calificacion4; SIN_TIPO calificacion5; cout<<"Calificacion Calculo"<<endl; cin>>calificacion1; cout<<"Calificacion Historia"<<endl; cin>>calificacion2; cout<<"Calificacion Sistemas"<<endl; CECYTEM Tecámac 21
    • Prácticas cin>>calificacion3; cout<<"Calificacion Geografia"<<endl; cin>>calificacion4; cout<<"Calificacion Ingles"<<endl; cin>>calificacion5; a=calificacion1+calificacion2+calificacion3+calificacion4+calificacion5; b=a/5;cout<<"Promedio:"<<b<<endl; f (b>=9.0) { cout<<"Excelente Alumno"<<endl; } if (=7.0&&b<9.0) { cout<<"Alumno Bueno"<<endl; } if (b>=6.0&&b<7.0) { cout<<"Alumno Regular"<<endl; }if (b>=5.0&&b<6.0) { cout<<"Alumno Malo"<<endl; } getch (); PROGRAMA: CECYTEM Tecámac 22
    • PrácticasConclusión:Esta práctica fue interesante porque a mi parecer siento que se facilita aunmás la manera del poder saber tu promedio. Fue rápida y correcta. CECYTEM Tecámac 23
    • Prácticas Practica 6“Ordena los números” CECYTEM Tecámac 24
    • Prácticas° PseudocódigoProceso Escribir Introduce primer numero: ; Leer num1; Escribir Introduce segundo numero: ; Leer num2; Escribir Introduce tercer numero: ; Leer num3; Si num1>num2 Y num1>num3 Y num2>num3 Entonces Escribir num1, ,num2, ,num3; FinSi Si num1<num2 Y num1<num3 Y num2<num3 Entonces Escribir num3, ,num2, ,num1; FinSi Si num3<num2 Y num1<num2 Y num1<num3 Entonces Escribir num2, ,num3, ,num1; FinSi Si num1<num3 Y num2<num3 Y num2<num1 Entonces Escribir num3, ,num1, ,num2; FinSi Si num2<num1 Y num3<num1 Y num2<num3 Entonces Escribir num1, ,num3, ,num2; FinSi Si num3<num2 Y num1<num2 Y num3<num1 Entonces Escribir num2, ,num1, ,num3; FinSi CECYTEM Tecámac 25
    • Prácticas FinProceso Código C++ #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; // para las variables que no se pudo determinar el tipo se utiliza la constante SIN_TIPO // el usuario debe reemplazar sus ocurrencias por el tipo adecuado (usualmente int,float,string o bool) #define SIN_TIPO string int main() { SIN_TIPO num1; SIN_TIPO num2; SIN_TIPO num3cout<<"Introduce primer numero: "<<endl; cin>>num1; cout<<"Introduce segundo numero: "<<endl; cin>>num2; cout<<"Introduce tercer numero: "<<endl; cin>>num3; if (num1>num2&&num1>num3&&num2>num3) { cout<<num1<<" "<<num2<<" "<<num3<<endl; if (num1<num2&&num1<num3&&num2<num3) { cout<<num3<<" "<<num2<<" "<<num1<<endl; if (num3<num2&&num1<num2&&num1<num3) { cout<<num2<<" "<<num3<<" "<<num1<<endl; if (num1<num3&&num2<num3&&num2<num1) { cout<<num3<<" "<<num1<<" "<<num2<<endl; CECYTEM Tecámac 26
    • Prácticas if (num2<num1&&num3<num1&&num2<num3) { cout<<num1<<" "<<num3<<" "<<num2<<endl; if (num3<num2&&num1<num2&&num3<num1) { cout<<num2<<" "<<num1<<" "<<num3<<endl getchPROGRAMA: Programa Conclusion:Esta practica fue un poco dificil de compilar, puesto que los valores se marcabancomo incorrectos, esto es un problemas que tu debes de checar si no en ningunaocacion te compilara. CECYTEM Tecámac 27
    • Prácticas Practica 7“Desglose Monetario” CECYTEM Tecámac 28
    • Prácticas° PseudocódigoProceso desglose definir bmil,bqui,bdos,bcien,bcin,bveinte,mdiez,mcin,mdos,mpeso Como Entero cant<-1; Repetir Si cant<1 | cant>10000 Entonces Escribir "No seas malito introduce un valor correcto numérico:"; FinSi Escribir "Ingresa una cantidad entre $1 y $10000 "; Leer cant; Hasta Que cant>=1 & cant<=10000 Si cant>=1000 Entonces bmil=cant/1000; cant<-cant-(bmil*1000) FinSi Si cant>=500 Entonces bqui=cant/500; cant<-cant-(bqui*500) FinSi Si canti<=200 Entonces bdos=cant/200; cant<-cant-(bdos*200) FinSi Si canti<=100 Entonces bcien=cant/100; CECYTEM Tecámac 29
    • Prácticas cant<-cant-(bcien*100) FinSiSi canti<=50 Entoncesbcin=cant/50; cant<-cant-(bcin*50)FinSiSi canti<=20 Entoncesbveinte=cant/20;cant<-cant-(bveinte*20)FinSiSi canti<=10 Entoncesmdiez=cant/10;cant<-cant-(mdiez*10) FinSi Si canti<=5 Entonces mcin=cant/5; cant<-cant-(mcin*5) FinSi Si canti<=2 Entonces mdos=cant/2; cant<-cant-(mdos*2) FinSi Si canti<=1 Entonces mpeso=cant/1; cant<-cant-(mpeso*1) FinSi Escribir "Billetes de mil: ", bmil; CECYTEM Tecámac 30
    • Prácticas Escribir "Billetes de quinientos: ", bqui; Escribir "Billetes de doscientos: ", bdos; Escribir "Billetes de cien: ", bcien; Escribir "Billetes de cincuenta: ", bcin; Escribir "Billetes de veinte: ", bveinte; Escribir "Monedas de diez ", mdiez; Escribir "Monedas de cinco: ", mcin; Escribir "Monedas de dos: ", mdos; Escribir "Monedas de peso: ", mpeso; Escribir "Me sobra: ",cant; FinProceso Código C++#include<iostream>#include<stdio.h>#include<conio.h>using namespace std;int main() int bcien; int bcin; int bdos; int bmil; int bqui; int bveinte; float cant; float canti; int mcin; CECYTEM Tecámac 31
    • Prácticas int mdiez; int mdos; int mpeso cant=1;do { if (cant<1||cant>10000) { cout<<"No seas malito introduce un valor correcto numérico:"<<endl cout<<"Ingresa una cantidad entre $1 y $10000 "<<endl; cin>>cant; } while (!(cant>=1&&cant<=10000)); if (cant>=1000) { bmil=cant/1000; cant=cant-(bmil*1000); } if (cant>=500) { bqui=cant/500; cant=cant-(bqui*500); } if (canti<=200) { bdos=cant/200; cant=cant-(bdos*200); } if (canti<=100) { bcien=cant/100; cant=cant-(bcien*100); } if (canti<=50) { bcin=cant/50; cant=cant-(bcin*50); } if (canti<=20) { bveinte=cant/20; cant=cant-(bveinte*20); CECYTEM Tecámac 32
    • Prácticasif (canti<=10) { mdiez=cant/10; cant=cant-(mdiez*10); }if (canti<=5) { mcin=cant/5; cant=cant-(mcin*5); }if (canti<=2) { mdos=cant/2; cant=cant-(mdos*2); }if (canti<=1) { mpeso=cant/1; cant=cant-(mpeso*1); }cout<<"Billetes de mil: "<<bmil<<endl;cout<<"Billetes de quinientos: "<<bqui<<endl;cout<<"Billetes de doscientos: "<<bdos<<endl;cout<<"Billetes de cien: "<<bcien<<endl;cout<<"Billetes de cincuenta: "<<bcin<<endl;cout<<"Billetes de veinte: "<<bveinte<<endl;cout<<"Monedas de diez "<<mdiez<<endl;cout<<"Monedas de cinco: "<<mcin<<endl;cout<<"Monedas de dos: "<<mdos<<endl;cout<<"Monedas de peso: "<<mpeso<<endl;cout<<"Me sobra: "<<cant<<endl;getch (); CECYTEM Tecámac 33
    • Prácticas } PROGRAMA: Conclusión:En esta práctica se desarrollo un código demasiado largo, y fue algo costoso,puesto que no es fácil desglosar toda una cantidad en monedas o ya seadependiendo el extremo de esa cantidad. Fue interesante, porque aprendimosfunciones que no sabíamos que podía realizar todo eso. CECYTEM Tecámac 34
    • Prácticas Practica 8 “Edad” CECYTEM Tecámac 35
    • Prácticas° Pseudocódigo Proceso CalcularEdad DEFINIR NOMBRE,AÑO,DIA Como Entero Definir a,m,d Como Entero DEFINIR MES Como Caracter Definir aa, mm, dd Como Entero D<-1 Escribir " CALCULAR EDAD"; Escribir ""; Escribir "INTRODUCE TU NOMBRE "; Leer IntroduceTuNombre; Escribir "Fecha actual (dd mm aaaa)"; Leer da, ma, aa A<-1970; Repetir Si A<1970 | A>2010 Entonces Escribir "Error al introducir tu Año de Nacimiento"; FinSi Escribir "Introducir tu Año de Nacimiento (dddd)"; Leer A; Hasta Que A>=1970 & A<=2010 Escribir ""; M<-1; Repetir Si M<1 | M>12 Entonces Escribir "Error al introducir tu Mes de Nacimiento"; FinSi CECYTEM Tecámac 36
    • PrácticasEscribir "Introducir tu Mes de Nacimiento (mm)";Escribir "";Leer M;Hasta Que M>=1 & M<=12Escribir "";Segun M Hacer1:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=3MES<-"Enero";2:RepetirSi D<1 | D>28 EntoncesEscribir "Error al introducir tu dia";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=28MES<-"Febrero";3:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introducir tu DIA"; CECYTEM Tecámac 37
    • PrácticasFinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31MES<-"Marzo";4:RepetirSi D<1 | D>30 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)"; Leer D; Hasta Que D>=1 & D<=30 MES<-"Abril"; 5: Repetir Si D<1 | D>31 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introducir tu DIA de Nacimiento (DD)"; Leer D; Hasta Que D>=1 & D<=31 MES<-"Mayo"; 6: Repetir Si D<1 | D>30 Entonces Escribir "Error al introducir tu DIA"; FinSi CECYTEM Tecámac 38
    • PrácticasEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=30MES<-"Junio";7:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31MES<-"Julio";8:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31MES<-"Agosto";9:RepetirSi D<1 | D>30 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)"; CECYTEM Tecámac 39
    • Prácticas Leer D; Hasta Que D>=1 & D<=30 MES<-"Septiembre"; 10: Repetir Si D<1 | D>31 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introducir tu DIA de Nacimiento (DD)"; Leer D; Hasta Que D>=1 & D<=31 MES<-"Octubre"; 11: Repetir Si D<1 | D>30 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introducir tu DIA de Nacimiento (DD)"; Leer D; Hasta Que D>=1 & D<=30 MES<-"Noviembre"; 12: Repetir Si D<1 | D>31 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introducir tu DIA de Nacimiento (DD)";Leer D; CECYTEM Tecámac 40
    • Prácticas Hasta Que D>=1 & D<=31 MES<-"Diciembre"; FinSegun Escribir "Hola ", IntroduceTuNombreCompleto," Naciste el ", D," de ",MES," de ",A; Repetir si da<1 | da>31 escribir "Dia incorrecto"; FinSi Escribir "Dia Actual"; leer da; hasta que da>=1 & da<=31 Repetir Si ma <1 | ma>12 escribir "mes incorrecto"; FinSi Escribir " "; Escribir "Mes Actual"; Leer ma; hasta que ma>=1 & ma<=12 Escribir " ";Escribir "Año Actual";Leer aaEscribir " "Si ma Es Igual A M Entoncessi da Es Igual A D Entoncesa= aa - A;m= 0; CECYTEM Tecámac 41
    • Prácticasd= 0;Escribir "Caso 1";FinSisi da Es Mayor Que D Entoncesa= aa - A;m= 0;d= da - D;Escribir "Caso 2";FinSiSi da Es Menor Que D Entoncesa= aa - A-1;m= 11;d= D - da;d= 30 - dEscribir "Caso 3"; FinSi Sino si ma>M Entonces si da=D Entonces a= aa - A; m= ma - M; d= 0; Escribir "Caso 4"; FinSi si da>D Entonces a= aa - A; m= ma - M; d= da - D; CECYTEM Tecámac 42
    • Prácticas Escribir "Caso 5"; FinSi si da<D Entonces a= aa - A; m= ma - M - 1; d= D - da; d= 30 - d; Escribir "Caso 6"; FinSi Sino si da = D Entoncesa= aa - A - 1;m= M - ma ;m= 12 - m;d= 0;Escribir "Caso 7"FinSisi da > D Entoncesa= aa - A - 1;m= M - ma ;m= 12 - m;d= da - D;Escribir "Caso 8"si da < D Entoncesa= aa - A - 1;m= M - ma + 1;m= 12 - m;d= D - da; CECYTEM Tecámac 43
    • Prácticas d= 30 - d; Escribir "Caso 9" FinSi FinSi FinSi FinSi Escribir "Tu edad es: " ,a, "años" ,m, "meses" ,d, "dias"FinProcesoCódigo C++#include<iostream>#include<stdio.h>#include<cono.h>using namespace std;// para leer variables de texto se utiliza el operador << del objeto cin, que lee solo una palabra// para leer una linea completa se debe utilzar getline (ej, reemplazar cin>>x por getline(cin,x),// pero obliga a agregar un cin.ignore() si antes del getline se leyó otra variable con >>.// para las variables que no se pudo determinar el tipo se utiliza la constante SIN_TIPO// el usuario debe reemplazar sus ocurrencias por el tipo adecuado (usualmente int,float,string obool)#define SIN_TIPO stringint main() { int a; int aa; int ano; int d; CECYTEM Tecámac 44
    • Prácticasfloat da;int dd;int dia;SIN_TIPO introducetunombre;SIN_TIPO introducetunombrecompleto;int m;float ma;string mes;int mm;int nombre;d=1;cout<<" CALCULAR EDAD"<<endl;cout<<""<<endl;cout<<"INTRODUCE TU NOMBRE "<<endl;cin>>introducetunombre;cout<<"Fecha actual (dd mm aaaa)"<<endl;cin>>da>>ma>>aa;a=1970; do { if (a<1970||a>2010) { cout<<"Error al introducir tu Año de Nacimiento"<<endl; } cout<<"Introducir tu Año de Nacimiento (dddd)"<<endl; cin>>a; } while (!(a>=1970&&a<=2010)); cout<<""<<endl; m=1; CECYTEM Tecámac 45
    • Prácticas do { if (m<1||m>12) { cout<<"Error al introducir tu Mes de Nacimiento"<<endl; } cout<<"Introducir tu Mes de Nacimiento (mm)"<<endl; cout<<""<<endl; cin>>m; } while (!(m>=1&&m<=12)); cout<<""<<endl; switch (int(m)) { case 1: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; }cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl;cin>>d;} while (!(d>=1&&d<=31));mes="Enero";break;case 2:do {if (d<1||d>28) {cout<<"Error al introducir tu dia"<<endl;}cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl;cin>>d;} while (!(d>=1&&d<=28)); CECYTEM Tecámac 46
    • Prácticasmes="Febrero";break;case 3:do {if (d<1||d>31) {cout<<"Error al introducir tu DIA"<<endl;}cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl;cin>>d;} while (!(d>=1&&d<=31));mes="Marzo"; break; case 4: do { if (d<1||d>30) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=30)); mes="Abril"; break; case 5: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; CECYTEM Tecámac 47
    • Prácticascin>>d;} while (!(d>=1&&d<=31));mes="Mayo";break;case 6:do {if (d<1||d>30) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=30)); mes="Junio"; break; case 7: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=31)); mes="Julio"; break; case 8: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; CECYTEM Tecámac 48
    • Prácticas}cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl;cin>>d; } while (!(d>=1&&d<=31)); mes="Agosto"; break; case 9: do { if (d<1||d>30) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=30)); mes="Septiembre"; break; case 10: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=31)); mes="Octubre"; break; case 11:do {if (d<1||d>30) { CECYTEM Tecámac 49
    • Prácticas cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=30)); mes="Noviembre"; break; case 12: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=31)); mes="Diciembre"; break; cout<<"Hola "<<introducetunombrecompleto<<" Naciste el "<<d<<" de "<<mes<<" de"<<a<<endl; do { if (da<1||da>31) { cout<<"Dia incorrecto"<<endl; cout<<"Dia Actual"<<endl; cin>>da; } while (!(da>=1&&da<=31)); do { if (ma<1||ma>12) { cout<<"mes incorrecto"<<endl; CECYTEM Tecámac 50
    • Prácticas cout<<" "<<endl; cout<<"Mes Actual"<<endl; cin>>ma; } while (!(ma>=1&&ma<=12)); cout<<" "<<endl; cout<<"Año Actual"<<endl; cin>>aa; cout<<" "<<endl; if ((ma==m)) { if ((da==d)) { a=aa-a; m=0; d=0; cout<<"Caso 1"<<endl; } if ((da>d)) {a=aa-a;m=0;d=da-d;cout<<"Caso 2"<<endl;if ((da<d)) {a=aa-a-1;m=11;d=d-da;d=30-d;cout<<"Caso 3"<<endl;} else {if (ma>m) { CECYTEM Tecámac 51
    • Prácticasif (da==d) {a=aa-a;m=ma-m;d=0;cout<<"Caso 4"<<endl;if (da>d) {a=aa-a;m=ma-m;d=da-d;cout<<"Caso 5"<<endl;if (da<d) {a=aa-a;m=ma-m-1;d=d-da;d=30-d;cout<<"Caso 6"<<endl;} else {if (da==d) {a=aa-a-1;m=m-ma;m=12-m;d=0;cout<<"Caso 7"<<endl;if (da>d) {a=aa-a-1;m=m-ma;m=12-m;d=da-d; CECYTEM Tecámac 52
    • Prácticas cout<<"Caso 8"<<endl; if (da<d) { a=aa-a-1; m=m-ma+1; m=12-m; d=d-da; d=30-d; cout<<"Caso 9"<<endl; cout<<"Tu edad es: "<<a<<"años"<<m<<"meses"<<d<<"dias"<<endl; getch (); PROGRAMA: Conclusión:Esta práctica si se me hizo difícil, porque aun estando bien en micódigo, mi compilación era un error y marcaba algunos casos comoincorrectos, lo cheque y aprendí a captar cuales fueron esos errores.La verdad estuvo difícil pero está muy interesante. CECYTEM Tecámac 53
    • Prácticas Practica 9“Teorema de Pitágoras” CECYTEM Tecámac 54
    • Prácticas° Pseudocódigo Proceso teoremadepitagoras Definir Opcion Como Entero ca=1; co=1; hip=1; Repetir Escribir ""; Escribir "Menu"; Escribir ""; Escribir " Opcion1=Hipotenusa" ; Escribir " Opcion2=Cateto Adyacente" ; Escribir " Opcion3=Cateto Opuesto" ; Escribir ""; Escribir "Opcion4= Salir"; Escribir ""; Escribir "Elije una opcion"; Escribir ""; Leer Opcion; Segun Opcion Hacer 1: Escribir "********************* (:"; Escribir "--Calcular Hipotenusa--"; Repetir si ca<1 Entonces Escribir "El valor debe de ser mayor a 1"; FinSi CECYTEM Tecámac 55
    • PrácticasEscribir "Escribe el valor de la cateto adyacente" ;Leer ca;Hasta Que ca>=1Repetirsi co<1 EntoncesEscribir "El valor debe de ser mayor a 1";FinSiEscribir "Escribe el valor de la cateto opuesto" ;Leer co;Hasta Que co>=1Escribir "********************** (:";hip=rc((ca*ca)+(co*co));Escribir "El valor de la hipotenusa Es Igual A:" ,hip ;Escribir "";Escribir "Calcular cateto adyacente";Repetirsi hip<1 EntoncesEscribir "El valor debe de ser mayor a 1";FinSiEscribir "Escribe el valor de la hipotenusa" ;Leer hip;Hasta Que hip>=1Repetirsi co>hip EntoncesEscribir "Valor invalido";FinSiEscribir "Escribe el valor de la cateto opuesto" ; CECYTEM Tecámac 56
    • Prácticas Leer co; Hasta Que co<hip Escribir "********************** (:"; ca=rc((hip*hip)-(co*co)); Escribir "El valor de la cateto adyacente Es Igual A:" ,ca ; 3: Escribir ""; Escribir "Calcular cateto opuesto"; Repetir si hip<1 Entonces Escribir "El valor debe de ser mayor a 1"; FinSi Escribir "Escribe el valor de la hipotenusa" ; Leer hip; Hasta Que hip>=1 Repetir si ca>hip Entonces Escribir "Valor invalido"; FinSi Escribir "Escribe el valor de la cateto adyacente" ; Leer ca; Hasta Que ca<hip Escribir "*************************************** (:"; co=rc((hip*hip)-(ca*ca)); Escribir "El valor de la cateto opuesto Es Igual A:" ,hip ; De Otro Modo: Escribir "BYE";FinSegun CECYTEM Tecámac 57
    • Prácticas Hasta Que opcion=4FinProcesoCódigo C++#include<iostream>#include<cmath>#include<stdio.h>#include<conio.h>using namespace std;int main() float ca; float co; float hip; int opcion; ca=1; co=1; hip=1; do { cout<<""<<endl; cout<<"Menu"<<endl; cout<<""<<endl; cout<<" Opcion1=Hipotenusa"<<endl; cout<<" Opcion2=Cateto Adyacente"<<endl; cout<<" Opcion3=Cateto Opuesto"<<endl; cout<<""<<endl; cout<<"Opcion4= Salir"<<endl; cout<<""<<endl; CECYTEM Tecámac 58
    • Prácticas cout<<"Elije una opcion"<<endl; cout<<""<<endl; cin>>opcion; switch (int(opcion)) { case 1: cout<<"********************* (:"<<endl; cout<<"--Calcular Hipotenusa--"<<endl; do { if (ca<1) { cout<<"El valor debe de ser mayor a 1"<<endl;cout<<"Escribe el valor de la cateto adyacente"<<endl; cin>>ca; } while (ca<1); do { if (co<1) { cout<<"El valor debe de ser mayor a 1"<<endl cout<<"Escribe el valor de la cateto opuesto"<<endl; cin>>co; } while (co<1); cout<<"********************** (:"<<endl; hip=sqrtf((ca*ca)+(co*co)); cout<<"El valor de la hipotenusa Es Igual A:"<<hip<<endl; break; case 2: cout<<""<<endl; cout<<"Calcular cateto adyacente"<<endl; do { if (hip<1) { CECYTEM Tecámac 59
    • Prácticas cout<<"El valor debe de ser mayor a 1"<<endl; cout<<"Escribe el valor de la hipotenusa"<<endl; cin>>hip; } while (hip<1); do { if (co>hip) { cout<<"Valor invalido"<<endl; cout<<"Escribe el valor de la cateto opuesto"<<endl; cin>>co; } while (co>=hip); cout<<"********************** (:"<<endl; ca=sqrtf((hip*hip)-(co*co)); cout<<"El valor de la cateto adyacente Es Igual A:"<<ca<<endl; break; case 3: cout<<""<<endl;cout<<"Calcular cateto opuesto"<<endl;do {if (hip<1) {cout<<"El valor debe de ser mayor a 1"<<endl;cout<<"Escribe el valor de la hipotenusa"<<endl;cin>>hip;} while (hip<1);do {if (ca>hip) {cout<<"Valor invalido"<<endl;cout<<"Escribe el valor de la cateto adyacente"<<endl;cin>>ca; CECYTEM Tecámac 60
    • Prácticas} while (ca>=hip);cout<<"*************************************** (:"<<endl;co=sqrtf((hip*hip)-(ca*ca));cout<<"El valor de la cateto opuesto Es Igual A:"<<hip<<endl;break;default: cout<<"BYE"<<endl; break; } while (opcion!=4); PROGRAMA: Conclusión: Aquí observamos y realizamos un código para poder acceder al resultado de un teorema de Pitágoras. No fue difícil pero existen errores que nunca debes olvidar, porque en PseInt en la mayoría de las prácticas no te aceptan valores menores. CECYTEM Tecámac 61
    • Prácticas Practica 10“Índice de masa Corporal” CECYTEM Tecámac 62
    • Prácticas° Pseudocódigo Proceso IMC peso<-1; Altura<-1; escribir "Nombre" Leer nombre; repetir si Altura<0.80 | Altura>2.20 escribir "Altura incorrecta"; FinSi escribir "Ingresa tu Altura m" leer Altura; hasta que Altura>=0.80 & Altura<=2.20 Repetir si Peso<20 | Peso>200 escribir "Peso incorrecto"; Finsi escribir "Ingresa tu Peso" leer Peso; hasta que Peso>=20 & Peso<=20 Talla = Altura * Altura IMC = Peso / Talla Si IMC <=16 Entonces escribir "tienes D e s n u t r i c i o n"; escribir "Ve al hospital" CECYTEM Tecámac 63
    • Prácticas FinSi Si IMC >16 & IMC <=16.99 Entonces escribir "Tienes Principios de desnutricion"; escribir "Come mas "; FinS Si IMC >=17 & IMC <=18.49 Entonces escribir "Estas delgado"; escribir "Alimentate bien"; FinSi Si IMC >=18.50 & IMC <=24.99 Entonces escribir "PERFECTO"; FinSiSi IMC >=25 & IMC <=29.99 Entoncesescribir "Ya tienes longitasss";FinSiSi IMC >=30 & IMC <=34.99 Entoncesescribir "has ejersicio Gordibuena";FinSiSi IMC >=35 & IMC <=40 Entoncesescribir "Ya estass Pesado";FinSisi IMC >=40 Entoncesescribir "Tienes Obesidad";FinSiEscribir "OYE" ,Nombre "Tu masa corporal es" , IMCFinProcesoCódigo C++ CECYTEM Tecámac 64
    • Prácticas #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; // para las variables que no se pudo determinar el tipo se utiliza la constanteSIN_TIPO // el usuario debe reemplazar sus ocurrencias por el tipo adecuado(usualmente int,float,string o bool) #define SIN_TIPO string int main() { float altura; float imc; SIN_TIPO nombre; float peso; float talla; peso=1; altura=1; cout<<"Nombre"<<endl; cin>>nombre; do { if (altura<0.80||altura>2.20) { cout<<"Altura incorrecta"<<endl; } cout<<"Ingresa tu Altura m"<<endl; cin>>altura; } while (!(altura>=0.80&&altura<=2.20)); do { if (peso<20||peso>200) { CECYTEM Tecámac 65
    • Prácticas cout<<"Peso incorrecto"<<endl; cout<<"Ingresa tu Peso"<<endl; cin>>peso; } while (!(peso>=20&&peso<=200)); talla=altura*altura; imc=peso/talla; if (imc<=16) { cout<<"tienes D e s n u t r i c i o n"<<endl; cout<<"Ve al hospital"<<endl; if (imc>16&&imc<=16.99) { cout<<"Tienes Principios de desnutricion"<<endl; cout<<"Come mas "<<endl; if (imc>=17&&imc<=18.49) { cout<<"Estas delgado"<<endl; cout<<"Alimentate bien"<<endl; if (imc>=18.50&&imc<=24.99) { cout<<"PERFECTO"<<endl; if (imc>=25&&imc<=29.99) { cout<<"Ya tienes longitasss"<<endl; if (imc>=30&&imc<=34.99) { cout<<"has ejersicio Gordibuena"<<endl;if (imc>=35&&imc<=40) {cout<<"Ya estass Pesado"<<endl;if (imc>=40) {cout<<"Tienes Obesidad"<<endl;cout<<"OYE"<<nombre<<"Tu masa corporal es"<<imc<<endl;getch (); CECYTEM Tecámac 66
    • Prácticas PROGRAMA: Conclusión:Esta práctica fue una de las prácticas que más se me facilito,puesto que no es tan difícil declarar valores de acuerdo a lo quetu tomas en cuenta. CECYTEM Tecámac 67
    • Prácticas Examen CECYTEM Tecámac 68
    • Prácticas°PseudocódigoProceso NOMINAEscribir "Escribe tu Nombre";sal= 0sub = 0premio = 0despensa = 0estimulo = 0seguro=0impuesto = 0infonavit = 0puesto= "";leer nombre;Repetirsi option>3 | option<0 EntoncesEscribir "ERROR";FinSiEscribir "MENU";Escribir "";Escribir " 1 - Gerente";Escribir " 2 - Vendedor";Escribir " 3 - Cajero";Escribir "";Escribir " Elige una opcion: ";leer option;Hasta Que option<=3 &option>0 CECYTEM Tecámac 69
    • PrácticasSegun option Hacer1:sal = 1000;puesto="Gerente";Escribir "Tu puesto es: ",puesto;Escribir "Tu salario es: ",sal;2:sal = 750;puesto="Vendedor";Escribir "Tu puesto es: ",puesto;Escribir "Tu salario es: ",sal;3:sal = 500;puesto="Cajero";Escribir "Tu puesto es: ",puesto;Escribir "Tu salario es: ",sal;FinSegunRepetirsi dias>15 | dias<1 EntoncesEscribir "dias incorrectos";FinSiEscribir "";Escribir "¿Cuantos dias trabajaste?";Leer dias;Hasta Que dias<=15 & dias>0sub<-dias*sal;Escribir "El subtotal es: $",sub;Escribir ""; CECYTEM Tecámac 70
    • Prácticas Escribir "Percepciones"; premio<-sub * 0.1; Escribir "Tu premio es: $",premio; despensa<-sub * 0.2; Escribir "Tu despensa es: $",despensa; estimulo<-sub * 0.3; Escribir "Tu estimulo es: $",estimulo; Escribir ""; Escribir "Deduciones"; seguro<-sub * 0.5; Escribir "Tus gastos de seguro es: $",seguro; impuesto<-sub * 0.15; Escribir "Tus gastos de impuesto es: $",impuesto; infonavit<-sub * 0.25; Escribir "Tus gastos de infonavit es: $",infonavit; total = sub+premio+despensa+estimulo-seguro-impuesto-infonavit Escribir "Tu nombre es: ",nombre; Escribir "Tu puesto es: ",puesto; Escribir "El total es de: $",total; FinProceso Código C++ #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; // para leer variables de texto se utiliza el operador << del objeto cin, que leesolo una palabra CECYTEM Tecámac 71
    • Prácticas // para leer una linea completa se debe utilzar getline (ej, reemplazar cin>>xpor getline(cin,x), // pero obliga a agregar un cin.ignore() si antes del getline se leyó otravariable con >>. // para las variables que no se pudo determinar el tipo se utiliza la constanteSIN_TIPO // el usuario debe reemplazar sus ocurrencias por el tipo adecuado(usualmente int,float,string o bool) #define SIN_TIPO string int main() { float despensa; float dias; float estimulo; float impuesto; float infonavit; SIN_TIPO nombre; float option; float premio; string puesto; float sal; float seguro; float sub; float total; cout<<"Escribe tu Nombre"<<endl; sal=0; sub=0; premio=0; despensa=0; estimulo=0; seguro=0; CECYTEM Tecámac 72
    • Prácticasimpuesto=0;infonavit=0;puesto="";cin>>nombre;do {if (option>3||option<0) {cout<<"ERROR"<<endl;cout<<"MENU"<<endl;cout<<""<<endl;cout<<" 1 - Gerente"<<endl;cout<<" 2 - Vendedor"<<endl;cout<<" 3 - Cajero"<<endl;cout<<""<<endl;cout<<" Elige una opcion: "<<endl;cin>>option;} while (!(option<=3&&option>0));switch (int(option)) {case 1:sal=1000;puesto="Gerente";cout<<"Tu puesto es: "<<puesto<<endl;cout<<"Tu salario es: "<<sal<<endl;break;case 2:sal=750;puesto="Vendedor";cout<<"Tu puesto es: "<<puesto<<endl;cout<<"Tu salario es: "<<sal<<endl; CECYTEM Tecámac 73
    • Prácticasbreak;case 3:sal=500;puesto="Cajero";cout<<"Tu puesto es: "<<puesto<<endl;cout<<"Tu salario es: "<<sal<<endl;break;do {if (dias>15||dias<1) {cout<<"dias incorrectos"<<endl;cout<<""<<endl;cout<<"¿Cuantos dias trabajaste?"<<endl;cin>>dias;} while (!(dias<=15&&dias>0));sub=dias*sal;cout<<"El subtotal es: $"<<sub<<endl;cout<<""<<endl;cout<<"Percepciones"<<endl;premio=sub*0.1;cout<<"Tu premio es: $"<<premio<<endl;despensa=sub*0.2;cout<<"Tu despensa es: $"<<despensa<<endl;estimulo=sub*0.3;cout<<"Tu estimulo es: $"<<estimulo<<endl;cout<<""<<endl;cout<<"Deduciones"<<endl;seguro=sub*0.5;cout<<"Tus gastos de seguro es: $"<<seguro<<endl; CECYTEM Tecámac 74
    • Prácticasimpuesto=sub*0.15;cout<<"Tus gastos de impuesto es: $"<<impuesto<<endl;infonavit=sub*0.25;cout<<"Tus gastos de infonavit es: $"<<infonavit<<endl;total=sub+premio+despensa+estimulo-seguro-impuesto-infonavit;cout<<"Tu nombre es: "<<nombre<<endl;cout<<"Tu puesto es: "<<puesto<<endl;cout<<"El total es de: $"<<total<<endl;getch (); PROGRAMA CECYTEM Tecámac 75
    • Prácticas Conclusión:Esta Práctica por llamarlo así, porque más bien fue mi examen, estuvointeresante porque en el desarrollamos algo que al verlo en el pizarrón seveía demasiado complicado, pero al darnos cuenta que todo eso ya losabíamos, al comenzar a hacerlo fue recordar todo lo que habíamoshecho antes, entonces se puedo manejar muy bien el problema y diomuy buen resultado CECYTEM Tecámac 76