Your SlideShare is downloading. ×
Prácticas                   PrácticasCECY                    CECYTEM Tecámac   1
PrácticasLo que haremos será un manual de prácticas echas en PSint las cualesse pasaran al programa de c++ para verificar ...
Prácticas            CECYTEM Tecámac   3
PrácticasProceso OperacionesEscribir "Operaciones con 2 numeros";Escribir "Introduce numero1:";Leer num1;Escribir "Introdu...
Prácticas#include<iostream>#include<stdio.h>#include<conio.h>using namespace std;int main(){      float d;    float m;    ...
PrácticasEn esta práctica empecé a ver como se utilizaba el programa y lasetiquetas que utilizaríamos comenzamos con una p...
Prácticas°                CECYTEM Tecámac   7
PrácticasProceso Eres MayorEscribir "Introduce Edad";leer Edad;Si Edad >=18 EntoncesEscribir "Adulto";SinoEscribir "No Ere...
PrácticasEn esta práctica fue fácil ya que lo único que tenías que hacer era quesi ponías una edad menor a 18 tenía que de...
Prácticas            CECYTEM Tecámac   10
PrácticasProceso AreadelTriangulo    Escribir "Introduce Base del triangulo:";    Leer num1;    Escribir "Introduce Altura...
PrácticasEsta práctica tenía algo parecido a la primera solo que en esta era sacar el área deun triángulo.                ...
Prácticas            CECYTEM Tecámac   13
PrácticasProceso TabladeMultiplicarEscribir "Operaciones con 2 numeros";Escribir "Introduce numero1:";Leer num1;A<-num1*1;...
Prácticas#include<iostream>                           d=num1*4;#include<stdio.h>                            e=num1*5;#incl...
PrácticasEn esta práctica se me dificulto mas ya que al principio no savia comorealizarla primero estaba haciendo un códig...
Prácticas            CECYTEM Tecámac   17
Prácticas  Proceso Promedio       Escribir "Calificacion Calculo";       Leer Calificacion1;    Escribir "Calificacion His...
Prácticas#include<iostream>                                              cout<<"Calificacion                              ...
PrácticasEsta práctica fue fácil ya que solo era sacar el promedio de todas lascalificaciones.                            ...
Prácticas            CECYTEM Tecámac   21
PrácticasProceso Escribir Introduce primer numero: ; Leer num1; Escribir Introduce segundo numero: ; Leer num2; Escribir I...
Prácticas   #include<iostream>   #include<stdio.h>   #include<conio.h>   using namespace std;   // para las variables que ...
PrácticasEsta practica fue un poco dificil ya que primero no me salia el orden perorebice el error y me Sali.             ...
Prácticas            CECYTEM Tecámac   25
PrácticasProceso desglose  definir bmil,bqui,bdos,bcien,bcin,bveinte,mdiez,mcin,mdos,mpeso Como Entero  cant<-1;  Repetir ...
Prácticas cant<-cant-(bcin*50)FinSiSi canti<=20 Entoncesbveinte=cant/20;cant<-cant-(bveinte*20)FinSiSi canti<=10 Entoncesm...
Prácticas  Escribir "Monedas de peso: ", mpeso;  Escribir "Me sobra: ",cant;  FinProceso#include<iostream>#include<stdio.h...
Prácticas} while (!(cant>=1&&cant<=10000));if (cant>=1000) { bmil=cant/1000; cant=cant-(bmil*1000);        }if (cant>=500)...
Prácticas      mpeso=cant/1;      cant=cant-(mpeso*1);         }cout<<"Billetes de mil: "<<bmil<<endl;cout<<"Billetes de q...
PrácticasEn esta práctica se me hiso tedioso ya que el código era demasiado.                                              ...
Prácticas            CECYTEM Tecámac   32
PrácticasProceso CalcularEdadDEFINIR NOMBRE,AÑO,DIA Como EnteroDefinir a,m,d Como EnteroDEFINIR MES Como CaracterDefinir a...
PrácticasLeer M;Hasta Que M>=1 & M<=12Escribir "";Segun M Hacer1:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introduci...
Prácticas4:RepetirSi D<1 | D>30 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimien...
PrácticasFinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31MES<-"Julio";8:RepetirSi D<1 | ...
Prácticas MES<-"Octubre"; 11: Repetir Si D<1 | D>30 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introd...
Prácticas  escribir "mes incorrecto";  FinSi  Escribir " ";  Escribir "Mes Actual";  Leer ma;  hasta que ma>=1 & ma<=12  E...
Prácticas si ma>M Entonces si da=D Entonces a= aa - A; m= ma - M; d= 0; Escribir "Caso 4"; FinSi si da>D Entonces a= aa - ...
Prácticas     m= 12 - m;     d= da - D;     Escribir "Caso 8"     si da < D Entonces     a= aa - A - 1;     m= M - ma + 1;...
Prácticas#define SIN_TIPO stringint main() { int a; int aa; int ano; int d; float da; int dd; int dia; SIN_TIPO introducet...
Prácticas    } while (!(a>=1970&&a<=2010));    cout<<""<<endl;    m=1;    do {    if (m<1||m>12) {    cout<<"Error al intr...
Prácticasmes="Febrero";break;case 3:do {if (d<1||d>31) {cout<<"Error al introducir tu DIA"<<endl;}cout<<"Introducir tu DIA...
Prácticasbreak;case 6:do {if (d<1||d>30) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimie...
Prácticas    case 9:    do {    if (d<1||d>30) {    cout<<"Error al introducir tu DIA"<<endl;    }    cout<<"Introducir tu...
Prácticas      if (d<1||d>31) {      cout<<"Error al introducir tu DIA"<<endl;      }      cout<<"Introducir tu DIA de Nac...
Prácticas  d=0;  cout<<"Caso 1"<<endl;  }  if ((da>d)) {a=aa-a;m=0;d=da-d;cout<<"Caso 2"<<endl;if ((da<d)) {a=aa-a-1;m=11;...
Prácticascout<<"Caso 6"<<endl;} else {if (da==d) {a=aa-a-1;m=m-ma;m=12-m;d=0;cout<<"Caso 7"<<endl;if (da>d) {a=aa-a-1;m=m-...
PrácticasEsta práctica se me hiso solo laboriosa por que era muchacodificación y a veces no salían los casos.             ...
Prácticas            CECYTEM Tecámac   50
PrácticasProceso teoremadepitagoras Definir Opcion Como Entero ca=1; co=1; hip=1; Repetir Escribir ""; Escribir "Menu"; Es...
PrácticasRepetirsi co<1 EntoncesEscribir "El valor debe de ser mayor a 1";FinSiEscribir "Escribe el valor de la cateto opu...
Prácticas    Escribir "";    Escribir "Calcular cateto opuesto";    Repetir    si hip<1 Entonces    Escribir "El valor deb...
Prácticas#include<iostream>#include<cmath>#include<stdio.h>#include<conio.h>using namespace std;int main() float ca; float...
Prácticas do { if (ca<1) { cout<<"El valor debe de ser mayor a 1"<<endl;cout<<"Escribe el valor de la cateto adyacente"<<e...
Prácticas       cout<<"********************** (:"<<endl;       ca=sqrtf((hip*hip)-(co*co));       cout<<"El valor de la ca...
PrácticasEn esta práctica lo que realizamos fue que en un menú podíamos elegir cualquier opción y dependiendo de los datos...
Prácticas            CECYTEM Tecámac   58
PrácticasProceso IMCpeso<-1;Altura<-1;escribir "Nombre"Leer nombre;repetirsi Altura<0.80 | Altura>2.20escribir "Altura inc...
Prácticas   escribir "Estas delgado";   escribir "Alimentate bien";   FinSi   Si IMC >=18.50 & IMC <=24.99 Entonces   escr...
Prácticas    #include<iostream>    #include<stdio.h>    #include<conio.h>    using namespace std;    // para las variables...
Prácticas   cout<<"Ingresa tu Peso"<<endl;   cin>>peso;      } while (!(peso>=20&&peso<=200));      talla=altura*altura;  ...
PrácticasEsta práctica fue fácil ya que casi era igual que lapráctica anterior solo era de cambiar datos y poner otrasetiq...
Prácticas°                CECYTEM Tecámac   64
PrácticasProceso NOMINAEscribir "Escribe tu Nombre";sal= 0sub = 0premio = 0despensa = 0estimulo = 0seguro=0impuesto = 0inf...
PrácticasEscribir "Tu salario es: ",sal;2:sal = 750;puesto="Vendedor";Escribir "Tu puesto es: ",puesto;Escribir "Tu salari...
Prácticas    Escribir "Deduciones";    seguro<-sub * 0.5;    Escribir "Tus gastos de seguro es: $",seguro;    impuesto<-su...
Prácticasfloat impuesto;float infonavit;SIN_TIPO nombre;float option;float premio;string puesto;float sal;float seguro;flo...
Prácticascin>>option;} while (!(option<=3&&option>0));switch (int(option)) {case 1:sal=1000;puesto="Gerente";cout<<"Tu pue...
Prácticascout<<"Percepciones"<<endl;premio=sub*0.1;cout<<"Tu premio es: $"<<premio<<endl;despensa=sub*0.2;cout<<"Tu despen...
PrácticasEste fue el examen más que nada fue tedioso y aquí utiliceetiquetas que ya conocía al principio se me hizo un poc...
Upcoming SlideShare
Loading in...5
×

Manual naye

121

Published on

Manual de practicas del profesor renne

Published in: Education
0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
121
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
5
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Transcript of "Manual naye"

  1. 1. Prácticas PrácticasCECY CECYTEM Tecámac 1
  2. 2. PrácticasLo que haremos será un manual de prácticas echas en PSint las cualesse pasaran al programa de c++ para verificar si igual sale .La diferencia es que en PSint es un seudocódigo y en c++ es un códigotambién debemos de diferenciar eso.En nuestro programa de PSint hay una función la cual nosotros podemoschecar nuestro diagrama de flujo de como quedo.Este manual nos sirve de mucha ya que así nosotros podemos ver pasoa paso como es que fuimos realizando cada práctica.Al principio los códigos eran cortos ya que las primeras practicas erafáciles y cortas con pocas funciones pero después el código se hiso másy más ya que cada practica cada vez tenían más funciones. CECYTEM Tecámac 2
  3. 3. Prácticas CECYTEM Tecámac 3
  4. 4. PrácticasProceso OperacionesEscribir "Operaciones con 2 numeros";Escribir "Introduce numero1:";Leer num1;Escribir "Introduce numero:2";Leer num2;S<- num1+num2;R<- num1-num2;M<- num1*num2;D<- num1/num2;Escribir "Suma:",S;Escribir "Resta:",R;Escribir "Multiplicacion:",M;Escribir "Divicion:",D;Escribir "Hasta Luego";FinProceso CECYTEM Tecámac 4
  5. 5. Prácticas#include<iostream>#include<stdio.h>#include<conio.h>using namespace std;int main(){ float d; float m; float num1; float num2; float r; float s; cout<<"Operaciones con 2 numeros"<<endl; cout<<"Introduce numero1:"<<endl; cin>>num1; cout<<"Introduce numero:2"<<endl; cin>>num2; s=num1+num2; r=num1-num2; m=num1*num2; d=num1/num2; cout<<"Suma:"<<s<<endl; cout<<"Resta:"<<r<<endl; cout<<"Multiplicacion:"<<m<<endl; cout<<"Divicion:"<<d<<endl; cout<<"Hasta Luego"<<endl getch (); CECYTEM Tecámac 5
  6. 6. PrácticasEn esta práctica empecé a ver como se utilizaba el programa y lasetiquetas que utilizaríamos comenzamos con una practica fácil. CECYTEM Tecámac 6
  7. 7. Prácticas° CECYTEM Tecámac 7
  8. 8. PrácticasProceso Eres MayorEscribir "Introduce Edad";leer Edad;Si Edad >=18 EntoncesEscribir "Adulto";SinoEscribir "No Eres Adulto";FinSi#include<iostream>#include<stdio.h>#include<conio.h>using namespace std;int main() {float edad;cout<<"Introduce Edad"<<endl;cin>>edad;if (edad>=18) {cout<<"Adulto"<<endl;} else {cout<<"No Eres Adulto"<<endl;}getch ();} CECYTEM Tecámac 8
  9. 9. PrácticasEn esta práctica fue fácil ya que lo único que tenías que hacer era quesi ponías una edad menor a 18 tenía que decir que aún no eras adultoen el caso contrario te diría que eras adulto. CECYTEM Tecámac 9
  10. 10. Prácticas CECYTEM Tecámac 10
  11. 11. PrácticasProceso AreadelTriangulo Escribir "Introduce Base del triangulo:"; Leer num1; Escribir "Introduce Altura"; Leer num2; A <- num1*num2/2; Escribir "Area:",A; Escribir "Gracias";FinProceso #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; int main() { float a; float num float num2; cout<<"Introduce Base del triangulo:"<<endl; cin>>num1; cout<<"Introduce Altura"<<endl; cin>>num2; a=num1*num2/2; cout<<"Area:"<<a<<endl; cout<<"Gracias"<<endl; getch (); CECYTEM Tecámac 11
  12. 12. PrácticasEsta práctica tenía algo parecido a la primera solo que en esta era sacar el área deun triángulo. CECYTEM Tecámac 12
  13. 13. Prácticas CECYTEM Tecámac 13
  14. 14. PrácticasProceso TabladeMultiplicarEscribir "Operaciones con 2 numeros";Escribir "Introduce numero1:";Leer num1;A<-num1*1;B<-num1*2;C<-num1*3;D<-num1*4;E<-num1*5;F<-num1*6;G<-num1*7;H<-num1*8;I<-num1*9;J<-num1*10;Escribir "",num1,"X 1:",A;Escribir "",num1,"X 2:",B;Escribir "",num1,"X 3:",C;Escribir "",num1,"X 4:",D;Escribir "",num1,"X 5:",E;Escribir "",num1,"X 6:",F;Escribir "",num1,"X 7:",G;Escribir "",num1,"X 8:",H;Escribir "",num1,"X 9:",I;Escribir "",num1,"X 10:",J;FinProceso CECYTEM Tecámac 14
  15. 15. Prácticas#include<iostream> d=num1*4;#include<stdio.h> e=num1*5;#include<conio.h> f=num1*6;using namespace std; g=num1*7; h=num1*8;int main() i=num1*9;float b; j=num1*10;float c; cout<<""<<num1<<"X 1:"<<a<<endl;float d; cout<<""<<num1<<"Xfloat e; 2:"<<b<<endl;float f; cout<<""<<num1<<"X 3:"<<c<<endl;float g; cout<<""<<num1<<"Xfloat h; 4:"<<d<<endl;float i; cout<<""<<num1<<"X 5:"<<e<<endl;float j; cout<<""<<num1<<"Xfloat num1; 6:"<<f<<endl;cout<<"Operaciones con 2 cout<<""<<num1<<"Xnumeros"<<endl; 7:"<<g<<endl; cout<<"Introduce cout<<""<<num1<<"Xnumero1:"<<endl; 8:"<<h<<endl; cin>>num1; cout<<""<<num1<<"X a=num1*1; 9:"<<i<<endl; b=num1*2; cout<<""<<num1<<"X 10:"<<j<<endl; c=num1*3; getch (); CECYTEM Tecámac 15
  16. 16. PrácticasEn esta práctica se me dificulto mas ya que al principio no savia comorealizarla primero estaba haciendo un código demasiado grande perono me salía en todos los caso y después con unas etiquetas que puseme di cuenta de que así si salía bien. CECYTEM Tecámac 16
  17. 17. Prácticas CECYTEM Tecámac 17
  18. 18. Prácticas Proceso Promedio Escribir "Calificacion Calculo"; Leer Calificacion1; Escribir "Calificacion Historia"; Leer Calificacion2; Escribir "Calificacion Sistemas"; Leer Calificacion3; Escribir "Calificacion Geografia"; Leer Calificacion4; Escribir "Calificacion Ingles"; Leer Calificacion5; A <- Calificacion1+Calificacion2+Calificacion3+Calificacion4+Calificacion5 B <- A/5 Escribir "Promedio:",B; Si B>=9.0 Entonces Escribir "Excelente Alumno" FinSi Si B>=7.0 y B<9.0 Entonces Escribir "Alumno Bueno"; FinSi Si B>=6.0 y B<7.0 Entonces Escribir "Alumno Regular"; FinSi Si B>=5.0 y B<6.0 Entonces Escribir "Alumno Malo"; FinSiFinProceso CECYTEM Tecámac 18
  19. 19. Prácticas#include<iostream> cout<<"Calificacion Sistemas"<<endl;#include<stdio.h> cin>>calificacion3;#include<conio.h> cout<<"Calificacionusing namespace std; Geografia"<<endl;// para las variables que no se pudo cin>>calificacion4;determinar el tipo se utiliza la constanteSIN_TIPO cout<<"Calificacion Ingles"<<endl;// el usuario debe reemplazar susocurrencias por el tipo adecuado cin>>calificacion5;(usualmente int,float,string o bool) a=calificacion1+calificacion2+c#define SIN_TIPO string alificacion3+calificacion4+calificacion5 ;int main() { b=a/5; float a; cout<<"Promedio:"<<b<<endl; float b; f (b>=9.0) { SIN_TIPO calificacion1; cout<<"Excelente SIN_TIPO calificacion2; Alumno"<<endl; SIN_TIPO calificacion3; } if (=7.0&&b<9.0) { SIN_TIPO calificacion4; cout<<"Alumno Bueno"<<endl; SIN_TIPO calificacion5; } if (b>=6.0&&b<7.0) { cout<<"Calificacion cout<<"Alumno Regular"<<endl;Calculo"<<endl; }if (b>=5.0&&b<6.0) { cin>>calificacion1; cout<<"Alumno Malo"<<endl; cout<<"CalificacionHistoria"<<endl; } getch (); cin>>calificacion2; CECYTEM Tecámac 19
  20. 20. PrácticasEsta práctica fue fácil ya que solo era sacar el promedio de todas lascalificaciones. CECYTEM Tecámac 20
  21. 21. Prácticas CECYTEM Tecámac 21
  22. 22. PrácticasProceso Escribir Introduce primer numero: ; Leer num1; Escribir Introduce segundo numero: ; Leer num2; Escribir Introduce tercer numero: ; Leer num3; Si num1>num2 Y num1>num3 Y num2>num3 Entonces Escribir num1, ,num2, ,num3; FinSi Si num1<num2 Y num1<num3 Y num2<num3 Entonces Escribir num3, ,num2, ,num1; FinSi Si num3<num2 Y num1<num2 Y num1<num3 Entonces Escribir num2, ,num3, ,num1; FinSi Si num1<num3 Y num2<num3 Y num2<num1 Entonces Escribir num3, ,num1, ,num2; FinSi Si num2<num1 Y num3<num1 Y num2<num3 Entonces Escribir num1, ,num3, ,num2; FinSi Si num3<num2 Y num1<num2 Y num3<num1 Entonces Escribir num2, ,num1, ,num3; FinSi FinProceso CECYTEM Tecámac 22
  23. 23. Prácticas #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; // para las variables que no se pudo determinar el tipo se utiliza la constante SIN_TIPO // el usuario debe reemplazar sus ocurrencias por el tipo adecuado (usualmente int,float,string o bool) #define SIN_TIPO string int main() { SIN_TIPO num1; SIN_TIPO num2; SIN_TIPO num3cout<<"Introduce primer numero: "<<endl; cin>>num1; cout<<"Introduce segundo numero: "<<endl; cin>>num2; cout<<"Introduce tercer numero: "<<endl; cin>>num3; if (num1>num2&&num1>num3&&num2>num3) { cout<<num1<<" "<<num2<<" "<<num3<<endl; if (num1<num2&&num1<num3&&num2<num3) { cout<<num3<<" "<<num2<<" "<<num1<<endl; if (num3<num2&&num1<num2&&num1<num3) { cout<<num2<<" "<<num3<<" "<<num1<<endl; if (num1<num3&&num2<num3&&num2<num1) { cout<<num3<<" "<<num1<<" "<<num2<<endl; if (num2<num1&&num3<num1&&num2<num3) { cout<<num1<<" "<<num3<<" "<<num2<<endl; if (num3<num2&&num1<num2&&num3<num1) { cout<<num2<<" "<<num1<<" "<<num3<<endl getch CECYTEM Tecámac 23
  24. 24. PrácticasEsta practica fue un poco dificil ya que primero no me salia el orden perorebice el error y me Sali. CECYTEM Tecámac 24
  25. 25. Prácticas CECYTEM Tecámac 25
  26. 26. PrácticasProceso desglose definir bmil,bqui,bdos,bcien,bcin,bveinte,mdiez,mcin,mdos,mpeso Como Entero cant<-1; Repetir Si cant<1 | cant>10000 Entonces Escribir "No seas malito introduce un valor correcto numérico:"; FinSi Escribir "Ingresa una cantidad entre $1 y $10000 "; Leer cant; Hasta Que cant>=1 & cant<=10000 Si cant>=1000 Entonces bmil=cant/1000; cant<-cant-(bmil*1000) FinSi Si cant>=500 Entonces bqui=cant/500; cant<-cant-(bqui*500) FinSi Si canti<=200 Entonces bdos=cant/200; cant<-cant-(bdos*200) FinSi Si canti<=100 Entonces bcien=cant/100; cant<-cant-(bcien*100) FinSiSi canti<=50 Entoncesbcin=cant/50; CECYTEM Tecámac 26
  27. 27. Prácticas cant<-cant-(bcin*50)FinSiSi canti<=20 Entoncesbveinte=cant/20;cant<-cant-(bveinte*20)FinSiSi canti<=10 Entoncesmdiez=cant/10;cant<-cant-(mdiez*10) FinSi Si canti<=5 Entonces mcin=cant/5; cant<-cant-(mcin*5) FinSi Si canti<=2 Entonces mdos=cant/2; cant<-cant-(mdos*2) FinSi Si canti<=1 Entonces mpeso=cant/1; cant<-cant-(mpeso*1) FinSi Escribir "Billetes de mil: ", bmil; Escribir "Billetes de quinientos: ", bqui; Escribir "Billetes de doscientos: ", bdos; Escribir "Billetes de cien: ", bcien; Escribir "Billetes de cincuenta: ", bcin; Escribir "Billetes de veinte: ", bveinte; Escribir "Monedas de diez ", mdiez; Escribir "Monedas de cinco: ", mcin; Escribir "Monedas de dos: ", mdos; CECYTEM Tecámac 27
  28. 28. Prácticas Escribir "Monedas de peso: ", mpeso; Escribir "Me sobra: ",cant; FinProceso#include<iostream>#include<stdio.h>#include<conio.h>using namespace std;int main() int bcien; int bcin; int bdos; int bmil; int bqui; int bveinte; float cant; float canti; int mcin; int mdiez; int mdos; int mpeso cant=1;do { if (cant<1||cant>10000) { cout<<"No seas malito introduce un valor correcto numérico:"<<endl cout<<"Ingresa una cantidad entre $1 y $10000 "<<endl; cin>>cant; CECYTEM Tecámac 28
  29. 29. Prácticas} while (!(cant>=1&&cant<=10000));if (cant>=1000) { bmil=cant/1000; cant=cant-(bmil*1000); }if (cant>=500) { bqui=cant/500; cant=cant-(bqui*500); }if (canti<=200) { bdos=cant/200; cant=cant-(bdos*200); }if (canti<=100) { bcien=cant/100; cant=cant-(bcien*100); }if (canti<=50) { bcin=cant/50; cant=cant-(bcin*50); }if (canti<=20) { bveinte=cant/20; cant=cant-(bveinte*20); if (canti<=10) { mdiez=cant/10; cant=cant-(mdiez*10); } if (canti<=5) { mcin=cant/5; cant=cant-(mcin*5); } if (canti<=2) { mdos=cant/2; cant=cant-(mdos*2); } if (canti<=1) { CECYTEM Tecámac 29
  30. 30. Prácticas mpeso=cant/1; cant=cant-(mpeso*1); }cout<<"Billetes de mil: "<<bmil<<endl;cout<<"Billetes de quinientos: "<<bqui<<endl;cout<<"Billetes de doscientos: "<<bdos<<endl;cout<<"Billetes de cien: "<<bcien<<endl;cout<<"Billetes de cincuenta: "<<bcin<<endl;cout<<"Billetes de veinte: "<<bveinte<<endl;cout<<"Monedas de diez "<<mdiez<<endl;cout<<"Monedas de cinco: "<<mcin<<endl;cout<<"Monedas de dos: "<<mdos<<endl;cout<<"Monedas de peso: "<<mpeso<<endl;cout<<"Me sobra: "<<cant<<endl;getch (); CECYTEM Tecámac 30
  31. 31. PrácticasEn esta práctica se me hiso tedioso ya que el código era demasiado. CECYTEM Tecámac 31
  32. 32. Prácticas CECYTEM Tecámac 32
  33. 33. PrácticasProceso CalcularEdadDEFINIR NOMBRE,AÑO,DIA Como EnteroDefinir a,m,d Como EnteroDEFINIR MES Como CaracterDefinir aa, mm, dd Como EnteroD<-1Escribir " CALCULAR EDAD";Escribir "";Escribir "INTRODUCE TU NOMBRE ";Leer IntroduceTuNombre;Escribir "Fecha actual (dd mm aaaa)";Leer da, ma, aaA<-1970;RepetirSi A<1970 | A>2010 EntoncesEscribir "Error al introducir tu Año de Nacimiento";FinSiEscribir "Introducir tu Año de Nacimiento (dddd)";Leer A; Hasta Que A>=1970 & A<=2010 Escribir ""; M<-1; Repetir Si M<1 | M>12 Entonces Escribir "Error al introducir tu Mes de Nacimiento"; FinSi Escribir "Introducir tu Mes de Nacimiento (mm)"; Escribir ""; CECYTEM Tecámac 33
  34. 34. PrácticasLeer M;Hasta Que M>=1 & M<=12Escribir "";Segun M Hacer1:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=3MES<-"Enero";2:RepetirSi D<1 | D>28 EntoncesEscribir "Error al introducir tu dia";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=28MES<-"Febrero";3:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31MES<-"Marzo"; CECYTEM Tecámac 34
  35. 35. Prácticas4:RepetirSi D<1 | D>30 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)"; Leer D; Hasta Que D>=1 & D<=30 MES<-"Abril"; 5: Repetir Si D<1 | D>31 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introducir tu DIA de Nacimiento (DD)"; Leer D; Hasta Que D>=1 & D<=31 MES<-"Mayo"; 6: Repetir Si D<1 | D>30 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introducir tu DIA de Nacimiento (DD)"; Leer D; Hasta Que D>=1 & D<=30 MES<-"Junio"; 7: Repetir Si D<1 | D>31 Entonces Escribir "Error al introducir tu DIA"; CECYTEM Tecámac 35
  36. 36. PrácticasFinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31MES<-"Julio";8:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31MES<-"Agosto";9:RepetirSi D<1 | D>30 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=30MES<-"Septiembre";10:RepetirSi D<1 | D>31 EntoncesEscribir "Error al introducir tu DIA";FinSiEscribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31 CECYTEM Tecámac 36
  37. 37. Prácticas MES<-"Octubre"; 11: Repetir Si D<1 | D>30 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introducir tu DIA de Nacimiento (DD)"; Leer D; Hasta Que D>=1 & D<=30 MES<-"Noviembre"; 12: Repetir Si D<1 | D>31 Entonces Escribir "Error al introducir tu DIA"; FinSi Escribir "Introducir tu DIA de Nacimiento (DD)";Leer D;Hasta Que D>=1 & D<=31MES<-"Diciembre";FinSegunEscribir "Hola ", IntroduceTuNombreCompleto," Naciste el ", D," de ",MES," de ",A;Repetirsi da<1 | da>31escribir "Dia incorrecto";FinSiEscribir "Dia Actual";leer da;hasta que da>=1 & da<=31RepetirSi ma <1 | ma>12 CECYTEM Tecámac 37
  38. 38. Prácticas escribir "mes incorrecto"; FinSi Escribir " "; Escribir "Mes Actual"; Leer ma; hasta que ma>=1 & ma<=12 Escribir " ";Escribir "Año Actual";Leer aaEscribir " "Si ma Es Igual A M Entoncessi da Es Igual A D Entoncesa= aa - A;m= 0;d= 0;Escribir "Caso 1";FinSisi da Es Mayor Que D Entoncesa= aa - A;m= 0;d= da - D;Escribir "Caso 2";FinSiSi da Es Menor Que D Entoncesa= aa - A-1;m= 11;d= D - da;d= 30 - dEscribir "Caso 3"; FinSi Sino CECYTEM Tecámac 38
  39. 39. Prácticas si ma>M Entonces si da=D Entonces a= aa - A; m= ma - M; d= 0; Escribir "Caso 4"; FinSi si da>D Entonces a= aa - A; m= ma - M; d= da - D; Escribir "Caso 5"; FinSi si da<D Entonces a= aa - A; m= ma - M - 1; d= D - da; d= 30 - d; Escribir "Caso 6"; FinSi Sino si da = D Entoncesa= aa - A - 1;m= M - ma ;m= 12 - m;d= 0;Escribir "Caso 7"FinSisi da > D Entoncesa= aa - A - 1;m= M - ma ; CECYTEM Tecámac 39
  40. 40. Prácticas m= 12 - m; d= da - D; Escribir "Caso 8" si da < D Entonces a= aa - A - 1; m= M - ma + 1; m= 12 - m; d= D - da; d= 30 - d; Escribir "Caso 9" FinSi FinSi FinSi FinSi Escribir "Tu edad es: " ,a, "años" ,m, "meses" ,d, "dias"FinProceso#include<iostream>#include<stdio.h>#include<cono.h>using namespace std;// para leer variables de texto se utiliza el operador << del objeto cin, que lee solo unapalabra// para leer una linea completa se debe utilzar getline (ej, reemplazar cin>>x porgetline(cin,x),// pero obliga a agregar un cin.ignore() si antes del getline se leyó otra variable con >>.// para las variables que no se pudo determinar el tipo se utiliza la constante SIN_TIPO// el usuario debe reemplazar sus ocurrencias por el tipo adecuado (usualmenteint,float,string o bool) CECYTEM Tecámac 40
  41. 41. Prácticas#define SIN_TIPO stringint main() { int a; int aa; int ano; int d; float da; int dd; int dia; SIN_TIPO introducetunombre; SIN_TIPO introducetunombrecompleto; int m; float ma; string mes; int mm; int nombre; d=1; cout<<" CALCULAR EDAD"<<endl; cout<<""<<endl; cout<<"INTRODUCE TU NOMBRE "<<endl; cin>>introducetunombre; cout<<"Fecha actual (dd mm aaaa)"<<endl; cin>>da>>ma>>aa; a=1970; do { if (a<1970||a>2010) { cout<<"Error al introducir tu Año de Nacimiento"<<endl; } cout<<"Introducir tu Año de Nacimiento (dddd)"<<endl; cin>>a; CECYTEM Tecámac 41
  42. 42. Prácticas } while (!(a>=1970&&a<=2010)); cout<<""<<endl; m=1; do { if (m<1||m>12) { cout<<"Error al introducir tu Mes de Nacimiento"<<endl; } cout<<"Introducir tu Mes de Nacimiento (mm)"<<endl; cout<<""<<endl; cin>>m; } while (!(m>=1&&m<=12)); cout<<""<<endl; switch (int(m)) { case 1: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; }cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl;cin>>d;} while (!(d>=1&&d<=31));mes="Enero";break;case 2:do {if (d<1||d>28) {cout<<"Error al introducir tu dia"<<endl;}cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl;cin>>d;} while (!(d>=1&&d<=28)); CECYTEM Tecámac 42
  43. 43. Prácticasmes="Febrero";break;case 3:do {if (d<1||d>31) {cout<<"Error al introducir tu DIA"<<endl;}cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl;cin>>d;} while (!(d>=1&&d<=31));mes="Marzo"; break; case 4: do { if (d<1||d>30) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=30)); mes="Abril"; break; case 5: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=31)); mes="Mayo"; CECYTEM Tecámac 43
  44. 44. Prácticasbreak;case 6:do {if (d<1||d>30) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=30)); mes="Junio"; break; case 7: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=31)); mes="Julio"; break; case 8: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=31)); mes="Agosto"; break; CECYTEM Tecámac 44
  45. 45. Prácticas case 9: do { if (d<1||d>30) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=30)); mes="Septiembre"; break; case 10: do { if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=31)); mes="Octubre"; break; case 11:do {if (d<1||d>30) {cout<<"Error al introducir tu DIA"<<endl;}cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl;cin>>d;} while (!(d>=1&&d<=30));mes="Noviembre";break;case 12:do { CECYTEM Tecámac 45
  46. 46. Prácticas if (d<1||d>31) { cout<<"Error al introducir tu DIA"<<endl; } cout<<"Introducir tu DIA de Nacimiento (DD)"<<endl; cin>>d; } while (!(d>=1&&d<=31)); mes="Diciembre"; break; cout<<"Hola "<<introducetunombrecompleto<<" Naciste el "<<d<<" de"<<mes<<" de "<<a<<endl; do { if (da<1||da>31) { cout<<"Dia incorrecto"<<endl; cout<<"Dia Actual"<<endl; cin>>da; } while (!(da>=1&&da<=31)); do { if (ma<1||ma>12) { cout<<"mes incorrecto"<<endl; cout<<" "<<endl; cout<<"Mes Actual"<<endl; cin>>ma; } while (!(ma>=1&&ma<=12)); cout<<" "<<endl; cout<<"Año Actual"<<endl; cin>>aa; cout<<" "<<endl; if ((ma==m)) { if ((da==d)) { a=aa-a; m=0; CECYTEM Tecámac 46
  47. 47. Prácticas d=0; cout<<"Caso 1"<<endl; } if ((da>d)) {a=aa-a;m=0;d=da-d;cout<<"Caso 2"<<endl;if ((da<d)) {a=aa-a-1;m=11;d=d-da;d=30-d;cout<<"Caso 3"<<endl;} else {if (ma>m) {if (da==d) {a=aa-a;m=ma-m;d=0;cout<<"Caso 4"<<endl;if (da>d) {a=aa-a;m=ma-m;d=da-d;cout<<"Caso 5"<<endl;if (da<d) {a=aa-a;m=ma-m-1;d=d-da;d=30-d; CECYTEM Tecámac 47
  48. 48. Prácticascout<<"Caso 6"<<endl;} else {if (da==d) {a=aa-a-1;m=m-ma;m=12-m;d=0;cout<<"Caso 7"<<endl;if (da>d) {a=aa-a-1;m=m-ma;m=12-m;d=da-d;cout<<"Caso 8"<<endl;if (da<d) { a=aa-a-1; m=m-ma+1; m=12-m; d=d-da; d=30-d; cout<<"Caso 9"<<endl; cout<<"Tu edad es: "<<a<<"años"<<m<<"meses"<<d<<"dias"<<endl; getch (); CECYTEM Tecámac 48
  49. 49. PrácticasEsta práctica se me hiso solo laboriosa por que era muchacodificación y a veces no salían los casos. CECYTEM Tecámac 49
  50. 50. Prácticas CECYTEM Tecámac 50
  51. 51. PrácticasProceso teoremadepitagoras Definir Opcion Como Entero ca=1; co=1; hip=1; Repetir Escribir ""; Escribir "Menu"; Escribir ""; Escribir " Opcion1=Hipotenusa" ; Escribir " Opcion2=Cateto Adyacente" ; Escribir " Opcion3=Cateto Opuesto" ; Escribir ""; Escribir "Opcion4= Salir"; Escribir ""; Escribir "Elije una opcion"; Escribir ""; Leer Opcion; Segun Opcion Hacer 1: Escribir "********************* (:"; Escribir "--Calcular Hipotenusa--"; Repetir si ca<1 Entonces Escribir "El valor debe de ser mayor a 1"; FinSi Escribir "Escribe el valor de la cateto adyacente" ; Leer ca; Hasta Que ca>=1 CECYTEM Tecámac 51
  52. 52. PrácticasRepetirsi co<1 EntoncesEscribir "El valor debe de ser mayor a 1";FinSiEscribir "Escribe el valor de la cateto opuesto" ;Leer co;Hasta Que co>=1Escribir "********************** (:";hip=rc((ca*ca)+(co*co));Escribir "El valor de la hipotenusa Es Igual A:" ,hip ;Escribir "";Escribir "Calcular cateto adyacente";Repetirsi hip<1 EntoncesEscribir "El valor debe de ser mayor a 1";FinSiEscribir "Escribe el valor de la hipotenusa" ;Leer hip;Hasta Que hip>=1Repetirsi co>hip EntoncesEscribir "Valor invalido";FinSiEscribir "Escribe el valor de la cateto opuesto" ;Leer co;Hasta Que co<hipEscribir "********************** (:";ca=rc((hip*hip)-(co*co));Escribir "El valor de la cateto adyacente Es Igual A:" ,ca ;3: CECYTEM Tecámac 52
  53. 53. Prácticas Escribir ""; Escribir "Calcular cateto opuesto"; Repetir si hip<1 Entonces Escribir "El valor debe de ser mayor a 1"; FinSi Escribir "Escribe el valor de la hipotenusa" ; Leer hip; Hasta Que hip>=1 Repetir si ca>hip Entonces Escribir "Valor invalido"; FinSi Escribir "Escribe el valor de la cateto adyacente" ; Leer ca; Hasta Que ca<hip Escribir "*************************************** (:"; co=rc((hip*hip)-(ca*ca)); Escribir "El valor de la cateto opuesto Es Igual A:" ,hip ; De Otro Modo: Escribir "BYE";FinSegun Hasta Que opcion=4FinProceso CECYTEM Tecámac 53
  54. 54. Prácticas#include<iostream>#include<cmath>#include<stdio.h>#include<conio.h>using namespace std;int main() float ca; float co; float hip; int opcion; ca=1; co=1; hip=1; do { cout<<""<<endl; cout<<"Menu"<<endl; cout<<""<<endl; cout<<" Opcion1=Hipotenusa"<<endl; cout<<" Opcion2=Cateto Adyacente"<<endl; cout<<" Opcion3=Cateto Opuesto"<<endl; cout<<""<<endl; cout<<"Opcion4= Salir"<<endl; cout<<""<<endl; cout<<"Elije una opcion"<<endl; cout<<""<<endl; cin>>opcion; switch (int(opcion)) { case 1: cout<<"********************* (:"<<endl; cout<<"--Calcular Hipotenusa--"<<endl; CECYTEM Tecámac 54
  55. 55. Prácticas do { if (ca<1) { cout<<"El valor debe de ser mayor a 1"<<endl;cout<<"Escribe el valor de la cateto adyacente"<<endl; cin>>ca; } while (ca<1); do { if (co<1) { cout<<"El valor debe de ser mayor a 1"<<endl cout<<"Escribe el valor de la cateto opuesto"<<endl; cin>>co; } while (co<1); cout<<"********************** (:"<<endl; hip=sqrtf((ca*ca)+(co*co)); cout<<"El valor de la hipotenusa Es Igual A:"<<hip<<endl; break; case 2: cout<<""<<endl; cout<<"Calcular cateto adyacente"<<endl; do { if (hip<1) { cout<<"El valor debe de ser mayor a 1"<<endl; cout<<"Escribe el valor de la hipotenusa"<<endl; cin>>hip; } while (hip<1); do { if (co>hip) { cout<<"Valor invalido"<<endl; cout<<"Escribe el valor de la cateto opuesto"<<endl; cin>>co; } while (co>=hip); CECYTEM Tecámac 55
  56. 56. Prácticas cout<<"********************** (:"<<endl; ca=sqrtf((hip*hip)-(co*co)); cout<<"El valor de la cateto adyacente Es Igual A:"<<ca<<endl; break; case 3: cout<<""<<endl;cout<<"Calcular cateto opuesto"<<endl;do {if (hip<1) {cout<<"El valor debe de ser mayor a 1"<<endl;cout<<"Escribe el valor de la hipotenusa"<<endl;cin>>hip;} while (hip<1);do {if (ca>hip) {cout<<"Valor invalido"<<endl;cout<<"Escribe el valor de la cateto adyacente"<<endl;cin>>ca;} while (ca>=hip);cout<<"*************************************** (:"<<endl;co=sqrtf((hip*hip)-(ca*ca));cout<<"El valor de la cateto opuesto Es Igual A:"<<hip<<endl;break;default: cout<<"BYE"<<endl; break; } while (opcion!=4); CECYTEM Tecámac 56
  57. 57. PrácticasEn esta práctica lo que realizamos fue que en un menú podíamos elegir cualquier opción y dependiendo de los datos que pusiéramos nos daría el resultado pero no se podrían meter datos negativos. CECYTEM Tecámac 57
  58. 58. Prácticas CECYTEM Tecámac 58
  59. 59. PrácticasProceso IMCpeso<-1;Altura<-1;escribir "Nombre"Leer nombre;repetirsi Altura<0.80 | Altura>2.20escribir "Altura incorrecta";FinSiescribir "Ingresa tu Altura m"leer Altura;hasta que Altura>=0.80 & Altura<=2.20Repetirsi Peso<20 | Peso>200escribir "Peso incorrecto";Finsiescribir "Ingresa tu Peso"leer Peso;hasta que Peso>=20 & Peso<=20 Talla = Altura * Altura IMC = Peso / Talla Si IMC <=16 Entonces escribir "tienes D e s n u t r i c i o n"; escribir "Ve al hospital" FinSi Si IMC >16 & IMC <=16.99 Entonces escribir "Tienes Principios de desnutricion"; escribir "Come mas "; FinS Si IMC >=17 & IMC <=18.49 Entonces CECYTEM Tecámac 59
  60. 60. Prácticas escribir "Estas delgado"; escribir "Alimentate bien"; FinSi Si IMC >=18.50 & IMC <=24.99 Entonces escribir "PERFECTO"; FinSiSi IMC >=25 & IMC <=29.99 Entoncesescribir "Ya tienes longitasss";FinSiSi IMC >=30 & IMC <=34.99 Entoncesescribir "has ejersicio Gordibuena";FinSiSi IMC >=35 & IMC <=40 Entoncesescribir "Ya estass Pesado";FinSisi IMC >=40 Entoncesescribir "Tienes Obesidad";FinSiEscribir "OYE" ,Nombre "Tu masa corporal es" , IMCFinProceso CECYTEM Tecámac 60
  61. 61. Prácticas #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; // para las variables que no se pudo determinar el tipo se utiliza laconstante SIN_TIPO // el usuario debe reemplazar sus ocurrencias por el tipo adecuado(usualmente int,float,string o bool) #define SIN_TIPO string int main() { float altura; float imc; SIN_TIPO nombre; float peso; float talla; peso=1; altura=1; cout<<"Nombre"<<endl; cin>>nombre; do { if (altura<0.80||altura>2.20) { cout<<"Altura incorrecta"<<endl; } cout<<"Ingresa tu Altura m"<<endl; cin>>altura; } while (!(altura>=0.80&&altura<=2.20)); do { if (peso<20||peso>200) { cout<<"Peso incorrecto"<<endl; CECYTEM Tecámac 61
  62. 62. Prácticas cout<<"Ingresa tu Peso"<<endl; cin>>peso; } while (!(peso>=20&&peso<=200)); talla=altura*altura; imc=peso/talla; if (imc<=16) { cout<<"tienes D e s n u t r i c i o n"<<endl; cout<<"Ve al hospital"<<endl; if (imc>16&&imc<=16.99) { cout<<"Tienes Principios de desnutricion"<<endl; cout<<"Come mas "<<endl; if (imc>=17&&imc<=18.49) { cout<<"Estas delgado"<<endl; cout<<"Alimentate bien"<<endl; if (imc>=18.50&&imc<=24.99) { cout<<"PERFECTO"<<endl; if (imc>=25&&imc<=29.99) { cout<<"Ya tienes longitasss"<<endl; if (imc>=30&&imc<=34.99) { cout<<"has ejersicio Gordibuena"<<endl;if (imc>=35&&imc<=40) {cout<<"Ya estass Pesado"<<endl;if (imc>=40) {cout<<"Tienes Obesidad"<<endl;cout<<"OYE"<<nombre<<"Tu masa corporal es"<<imc<<endl;getch (); CECYTEM Tecámac 62
  63. 63. PrácticasEsta práctica fue fácil ya que casi era igual que lapráctica anterior solo era de cambiar datos y poner otrasetiquetas. CECYTEM Tecámac 63
  64. 64. Prácticas° CECYTEM Tecámac 64
  65. 65. PrácticasProceso NOMINAEscribir "Escribe tu Nombre";sal= 0sub = 0premio = 0despensa = 0estimulo = 0seguro=0impuesto = 0infonavit = 0puesto= "";leer nombre;Repetirsi option>3 | option<0 EntoncesEscribir "ERROR";FinSiEscribir "MENU";Escribir "";Escribir " 1 - Gerente";Escribir " 2 - Vendedor";Escribir " 3 - Cajero";Escribir "";Escribir " Elige una opcion: ";leer option;Hasta Que option<=3 &option>0Segun option Hacer1:sal = 1000;puesto="Gerente";Escribir "Tu puesto es: ",puesto; CECYTEM Tecámac 65
  66. 66. PrácticasEscribir "Tu salario es: ",sal;2:sal = 750;puesto="Vendedor";Escribir "Tu puesto es: ",puesto;Escribir "Tu salario es: ",sal;3:sal = 500;puesto="Cajero";Escribir "Tu puesto es: ",puesto;Escribir "Tu salario es: ",sal;FinSegunRepetirsi dias>15 | dias<1 EntoncesEscribir "dias incorrectos";FinSiEscribir "";Escribir "¿Cuantos dias trabajaste?";Leer dias;Hasta Que dias<=15 & dias>0sub<-dias*sal;Escribir "El subtotal es: $",sub;Escribir "";Escribir "Percepciones";premio<-sub * 0.1;Escribir "Tu premio es: $",premio;despensa<-sub * 0.2;Escribir "Tu despensa es: $",despensa;estimulo<-sub * 0.3;Escribir "Tu estimulo es: $",estimulo;Escribir ""; CECYTEM Tecámac 66
  67. 67. Prácticas Escribir "Deduciones"; seguro<-sub * 0.5; Escribir "Tus gastos de seguro es: $",seguro; impuesto<-sub * 0.15; Escribir "Tus gastos de impuesto es: $",impuesto; infonavit<-sub * 0.25; Escribir "Tus gastos de infonavit es: $",infonavit; total = sub+premio+despensa+estimulo-seguro-impuesto-infonavit Escribir "Tu nombre es: ",nombre; Escribir "Tu puesto es: ",puesto; Escribir "El total es de: $",total; FinProceso #include<iostream> #include<stdio.h> #include<conio.h> using namespace std; // para leer variables de texto se utiliza el operador << del objeto cin,que lee solo una palabra // para leer una linea completa se debe utilzar getline (ej, reemplazarcin>>x por getline(cin,x), // pero obliga a agregar un cin.ignore() si antes del getline se leyóotra variable con >>. // para las variables que no se pudo determinar el tipo se utiliza laconstante SIN_TIPO // el usuario debe reemplazar sus ocurrencias por el tipo adecuado(usualmente int,float,string o bool) #define SIN_TIPO string int main() { float despensa; float dias; float estimulo; CECYTEM Tecámac 67
  68. 68. Prácticasfloat impuesto;float infonavit;SIN_TIPO nombre;float option;float premio;string puesto;float sal;float seguro;float sub;float total;cout<<"Escribe tu Nombre"<<endl;sal=0;sub=0;premio=0;despensa=0;estimulo=0;seguro=0;impuesto=0;infonavit=0;puesto="";cin>>nombre;do {if (option>3||option<0) {cout<<"ERROR"<<endl;cout<<"MENU"<<endl;cout<<""<<endl;cout<<" 1 - Gerente"<<endl;cout<<" 2 - Vendedor"<<endl;cout<<" 3 - Cajero"<<endl;cout<<""<<endl;cout<<" Elige una opcion: "<<endl; CECYTEM Tecámac 68
  69. 69. Prácticascin>>option;} while (!(option<=3&&option>0));switch (int(option)) {case 1:sal=1000;puesto="Gerente";cout<<"Tu puesto es: "<<puesto<<endl;cout<<"Tu salario es: "<<sal<<endl;break;case 2:sal=750;puesto="Vendedor";cout<<"Tu puesto es: "<<puesto<<endl;cout<<"Tu salario es: "<<sal<<endl;break;case 3:sal=500;puesto="Cajero";cout<<"Tu puesto es: "<<puesto<<endl;cout<<"Tu salario es: "<<sal<<endl;break;do {if (dias>15||dias<1) {cout<<"dias incorrectos"<<endl;cout<<""<<endl;cout<<"¿Cuantos dias trabajaste?"<<endl;cin>>dias;} while (!(dias<=15&&dias>0));sub=dias*sal;cout<<"El subtotal es: $"<<sub<<endl;cout<<""<<endl; CECYTEM Tecámac 69
  70. 70. Prácticascout<<"Percepciones"<<endl;premio=sub*0.1;cout<<"Tu premio es: $"<<premio<<endl;despensa=sub*0.2;cout<<"Tu despensa es: $"<<despensa<<endl;estimulo=sub*0.3;cout<<"Tu estimulo es: $"<<estimulo<<endl;cout<<""<<endl;cout<<"Deduciones"<<endl;seguro=sub*0.5;cout<<"Tus gastos de seguro es: $"<<seguro<<endl;impuesto=sub*0.15;cout<<"Tus gastos de impuesto es: $"<<impuesto<<endl;infonavit=sub*0.25;cout<<"Tus gastos de infonavit es: $"<<infonavit<<endl;total=sub+premio+despensa+estimulo-seguro-impuesto-infonavit;cout<<"Tu nombre es: "<<nombre<<endl;cout<<"Tu puesto es: "<<puesto<<endl;cout<<"El total es de: $"<<total<<endl;getch (); CECYTEM Tecámac 70
  71. 71. PrácticasEste fue el examen más que nada fue tedioso y aquí utiliceetiquetas que ya conocía al principio se me hizo un poco difícilpero ya después lo fuimos haciendo hasta que nos salió. Elexamen fue en parejas asi que pues era mas fácil porque cadaquien aportaba sus opiniones de cómo se haría. CECYTEM Tecámac 71

×