Funciones excel

13,945 views
13,537 views

Published on

Funciones Excel

0 Comments
2 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
13,945
On SlideShare
0
From Embeds
0
Number of Embeds
919
Actions
Shares
0
Downloads
362
Comments
0
Likes
2
Embeds 0
No embeds

No notes for slide

Funciones excel

  1. 1. Microsoft Excel Fórmulas y Funciones
  2. 2. Fórmulas <ul><ul><li>Efectúan cálculos con los valores de la hoja de cálculo. </li></ul></ul><ul><ul><li>Ejemplo: = PI() * A2 ^ 2 </li></ul></ul><ul><li>Comienzan por un signo igual (=) </li></ul><ul><li>Pueden contener: </li></ul><ul><ul><li>Funciones : Matemáticas, trigonométricas, estadísticas, financieras, … </li></ul></ul><ul><ul><li>Referencias: Devuelven el valor de la celda (A2, …) </li></ul></ul><ul><ul><li>Operadores: Aritméticos (^,…), comparaciones (<,<=,…), de referencia (A2 : B8) … </li></ul></ul><ul><ul><li>Constantes: Valores escritos directamente en la formula (33, “Aprobado”, …) </li></ul></ul>
  3. 3. Funciones <ul><li>Son formulas predefinidas que operan sobre valores denominados argumentos </li></ul><ul><ul><li>Comienzan con el signo igual ( = ) seguido del nombre de la función </li></ul></ul><ul><ul><li>A continuación, los argumentos encerrados entre paréntesis y separados por punto y coma ( ; ) </li></ul></ul><ul><ul><li>Pueden anidarse: una función puede ser un argumento de otra </li></ul></ul>
  4. 4. Argumentos <ul><li>Valores que recibe la función. Por ejemplo, la función SUMA() recibe como argumentos el conjunto de valores que queremos sumar (separados por ; ) </li></ul><ul><ul><ul><li>Constantes: =SUMA(3;5) </li></ul></ul></ul><ul><ul><ul><li>Celdas: =SUMA(A2;A4) </li></ul></ul></ul><ul><ul><ul><li>Rangos contiguos: =SUMA(A2:A4) </li></ul></ul></ul><ul><ul><ul><li>Intersecciones: =SUMA(A1:A4 A3:A7) </li></ul></ul></ul><ul><ul><ul><li>Combinaciones de los anteriores: =SUMA(A2:A4;$A$7;3) </li></ul></ul></ul>
  5. 5. Funciones Numéricas <ul><li>Operan sobre valores numéricos </li></ul><ul><li>Matemáticas y trigonométricas: </li></ul><ul><ul><li>SUMA(), POTENCIA(), COS(), … </li></ul></ul><ul><li>Estadísticas </li></ul><ul><ul><li>PROMEDIO(), MAX(), MIN(), CONTAR(), CONTAR.SI(), … </li></ul></ul>
  6. 6. Funciones CONTAR y CONTAR.SI <ul><li>CONTAR() : Cuenta el número de celdas que contienen números en un rango ó conjunto de valores. Por ejemplo: </li></ul><ul><li>=CONTAR(A2:A10) </li></ul><ul><li>CONTAR.SI( rango,criterio ) : Cuenta el número de celdas del rango que coinciden con el criterio. Por ejemplo: </li></ul><ul><ul><li>=CONTAR.SI(A2:A10,”Aprobado”) </li></ul></ul>
  7. 7. Funciones Lógicas <ul><li>Operan con argumentos de tipo lógico ( VERDADERO y FALSO ) </li></ul><ul><ul><li>Función SI() </li></ul></ul><ul><ul><li>Función Y() </li></ul></ul><ul><ul><li>Función O() </li></ul></ul>
  8. 8. Función SI <ul><li>SI( condición; valor_si_verdadero; valor_si_falso ) </li></ul><ul><li>Recibe tres argumentos: </li></ul><ul><li>Condición : Prueba lógica que se quiere comprobar </li></ul><ul><li>Valor_si_verdadero : Valor que devuelve la función si la condición se evalúa a VERDADERO </li></ul><ul><li>Valor_si_falso : Valor que devuelve la función si la condición se evalúa a FALSO </li></ul>
  9. 9. Función SI . Ejemplo: <ul><li>=SI(A2>=5; ”Aprobado”; ”Suspenso”) </li></ul><ul><li>Condición: A2>=5 </li></ul><ul><li>Valor_si_verdadero: “Aprobado” </li></ul><ul><li>Valor_si_falso: “Suspenso” </li></ul>
  10. 10. Función Y <ul><li>Y( valor_lógico1; valor_lógico2; valor_lógico3; … ) </li></ul><ul><li>Recibe como argumentos un conjunto de valores lógicos </li></ul><ul><li>Devuelve VERDADERO si todos los valores que recibe son verdaderos </li></ul><ul><li>En otro caso devuelve FALSO </li></ul>
  11. 11. Función Y . Ejemplo: <ul><li>=Y(A2>=7; A2<9) </li></ul><ul><li>Valor_logico1: A2>=7 </li></ul><ul><li>Valor_lógico2: A2<9 </li></ul><ul><li>¿ Resultado ? </li></ul>
  12. 12. Función O <ul><li>O( valor_lógico1; valor_lógico2; valor_lógico3; … ) </li></ul><ul><li>Recibe como argumento un conjunto de valores lógicos </li></ul><ul><li>Devuelve VERDADERO si al menos uno de los valores que recibe es verdadero </li></ul><ul><li>En otro caso devuelve FALSO </li></ul>
  13. 13. Funciones Lógicas Anidadas <ul><li>Una función se pasa como argumento a otra función </li></ul><ul><li>El valor devuelto por la función debe ser del tipo esperado para el argumento </li></ul><ul><li>¡ Cuidado con los paréntesis ! </li></ul>
  14. 14. Ejemplo de funciones anidadas <ul><li>=SI( Y(A2>=0; A2<=10) ;””;”ERROR”) </li></ul><ul><li>Condición: Y(A2>=0; A2<=10) </li></ul><ul><li>Valor_si_verdadero: “” </li></ul><ul><li>Valor_si_falso: “ERROR” </li></ul>
  15. 15. Ejercicio <ul><li>Escribir una función lógica que convierta las notas en calificaciones conforme a la siguiente tabla: </li></ul>NOTA CALIFICACIÓN nota<5 Suspenso 5<=nota<7 Aprobado 7<=nota<9 Notable 9<=nota<10 Sobresaliente Nota=10 Matrícula de Honor
  16. 16. Solución <ul><li>=SI ( A2=10;&quot;Matrícula&quot;; </li></ul><ul><li> SI ( A2>=9;&quot;Sobresaliente&quot;; </li></ul><ul><li> SI ( A2>=7;&quot;Notable&quot;; </li></ul><ul><li> SI ( A2>=5;&quot;Aprobado&quot;;&quot;Suspenso&quot; ) ) ) ) </li></ul>
  17. 17. Funciones de Búsqueda <ul><li>Buscan un valor en una matriz (tabla). </li></ul><ul><li>BUSCARH ( H orizontal) : Busca el valor en la primera fila de la tabla y devuelve el valor de la misma columna en una fila determinada. </li></ul><ul><li>BUSCARV ( V ertical ): Busca el valor en la primera columna de la tabla, y devuelve el valor de la misma fila en una columna determinada. </li></ul>
  18. 18. Función BUSCARH <ul><li>BUSCARH( valor_buscado; tabla; fila_resultado; [ ordenado ]) </li></ul><ul><li>Valor_buscado : el valor ó referencia a buscar en la tabla </li></ul><ul><li>Tabla : coordenadas superior-izda. e inferior-dcha. de la tabla </li></ul><ul><li>Fila_resultado : Posición de la fila que contiene los valores a devolver </li></ul><ul><li>Ordenado : Valor lógico (VERDADERO ó FALSO) que indica si los valores de la primera fila de la tabla están ordenados. </li></ul>
  19. 19. Función BUSCARH . Ejemplo <ul><li>BUSCARH(A2 ; $D$2:$G$3; 2; VERDADERO) </li></ul><ul><li>Valor_buscado : el valor de la celda A2 </li></ul><ul><li>Tabla : Comprendida entre D2 y G3 (referencias absolutas) </li></ul><ul><li>Fila_resultado : Si el valor de A2 se encuentra en la primera fila, devuelve el valor de la fila 2 </li></ul><ul><li>Ordenado : VERDADERO. Los valores de la primera fila tienen orden. </li></ul>
  20. 20. Ejercicio <ul><li>Construir una formula con la función BUSCARH que determine qué profesor corresponde a un grupo de prácticas, basándose en la tabla siguiente: </li></ul>La tabla ocupa las celdas D1:G3 y el grupo de prácticas se indica en la celda A2 A B C D Lunes Martes Jueves Viernes Almudena Almudena Javier Almudena
  21. 21. Solución <ul><li>=BUSCARH(A2;D1:G3;2;VERDADERO) </li></ul><ul><li>Ejercicio : Resover el ejercicio anterior mediante la función BUSCARV , suponiendo que la tabla está ahora situada entre D1 y F4, con los valores de búsqueda en la primera columna. </li></ul>
  22. 22. Funciones de Fecha y Hora <ul><li>Operan sobre valores de fecha y hora. </li></ul><ul><li>Ejemplos: </li></ul><ul><ul><li>AHORA(): Devuelven la fecha y hora actuales </li></ul></ul><ul><ul><li>HOY() : Devuelve la fecha actual </li></ul></ul><ul><ul><li>MES( fecha ) : Devuelve el mes de una fecha. Por ejemplo: =MES(HOY()) </li></ul></ul><ul><ul><li>DIA(), DIASEM(), HORA(), … </li></ul></ul>
  23. 23. FIN

×