Tutorial algoritmo estructuras ciclicas

30,525 views
29,874 views

Published on

Published in: Technology
1 Comment
9 Likes
Statistics
Notes
  • muy bueno
       Reply 
    Are you sure you want to  Yes  No
    Your message goes here
No Downloads
Views
Total views
30,525
On SlideShare
0
From Embeds
0
Number of Embeds
676
Actions
Shares
0
Downloads
577
Comments
1
Likes
9
Embeds 0
No embeds

No notes for slide

Tutorial algoritmo estructuras ciclicas

  1. 1. Tutorial Estructuras Algorítmicas Instrucciones Cíclicas Elaborado por: Michele André Universidad Simón Bolívar Marzo 2013
  2. 2. Lámina  2 Objetivo del Tutorial Al finalizar el estudiante será capaz de:  Definir las estructuras algorítmicas que corresponden a las instrucciones cíclicas o repetitivas.  Utilizar las instrucciones cíclicas Mientras, Repetir y Para.  Crear algoritmos sencillos utilizando las instrucciones cíclicas.
  3. 3. Lámina  3 Introducción Instrucciones Cíclicas o Repetitivas  En las estructuras secuenciales y de decisión las instrucciones que conforman el algoritmo se ejecutan una, y sólo una vez, en el mismo orden en que aparecen.  Existen problemas que requieren que un grupo de instrucciones no se aplique sólo a un caso específico, sino que estas mismas instrucciones se apliquen a muchos otros casos.
  4. 4. Lámina  4 Introducción Instrucciones Cíclicas o Repetitivas Calcular el promedio de calificaciones de los estudiantes de una universidad. Ejemplo de uso Se establece un modelo para obtener el promedio de calificaciones para un estudiante y, este se aplica a todos los estudiantes El grupo de instrucciones que conforman el modelo de solución de un determinado proceso dentro del algoritmo se repita tantas veces como sea necesario.
  5. 5. Lámina  5 Las instrucciones repetitivas o cíclicas permiten realizar una secuencia de instrucciones cero o más veces de acuerdo al resultado de la evaluación de una expresión lógica. Introducción Instrucciones Cíclicas o Repetitivas
  6. 6. Lámina  6 1. Las estructuras cíclicas o repetitivas es la estructura de algorítmica que contiene o representa un bucle o conjunto de instrucciones que se repiten un número finito de veces. 2. Cada repetición del bucle se llama una iteración. 3. Todo bucle tiene asociada una condición, que es la que va a determinar si se ejecuta el bucle y hasta cuando. Estructuras Cíclicas Instrucciones Cíclicas o Repetitivas Definición
  7. 7. Lámina  7 Existen tres tipos básicos de estructuras repetitivas:  Mientras hacer (While do)  Repetir hasta (Repeat until)  Para (For) Estructuras Cíclicas Instrucciones Cíclicas o Repetitivas
  8. 8. Lámina  8 Estructura Cíclica Mientras - Hacer Acciones A condición verdadero falso Acciones B Estructuras Cíclica Mientras - Hacer
  9. 9. Lámina  9 1. La expresión de tipo lógico que se evalúa cada vez que se repite el ciclo 2. El grupo de instrucciones que se ejecutan para cada iteración Estructura Cíclica Mientras-hacer Acciones A condición verdadero falso Acciones B 1 2 La estructura Mientras-hacer está formada por dos partes:
  10. 10. Lámina  10 Estructura Cíclica Mientras-hacer Acciones A condición verdadero falso Acciones B Funcionamiento:  La condición del Mientras-hacer se evalúa al principio, antes de entrar en las acciones. (1)  Si la condición es verdadera, se comienza a ejecutar las acciones del Mientras hacer. (2)  Después de la ejecutar la última acción, se repite el proceso de evaluación de la condición(1); si la condición es verdadera de nuevo, se repite el ciclo. (2)  Este proceso se conoce como un bucle y continúa hasta que la condición sea falsa. En ese momento, la ejecución prosigue con la sentencia siguiente del programa. (3) 1 2 3
  11. 11. Lámina  11 Estructura Cíclica Mientras-hacer Acciones A condición verdadero falso Acciones B 2 Dentro del grupo de las instrucciones del ciclo debe haber por lo menos una instrucción que modifique el resultado de la expresión lógica de lo contrario, nunca se terminará la repetición de la ejecución de las instrucciones y será un proceso infinito. Observación
  12. 12. Lámina  12 Se representa en: Pseudocódigo Mientras (condición) hacer accion1 accion2 : accionN Fin Mientras Diagrama de Flujo Representación Estructuras Mientras-hacer Acciones A condición verdadero falso Acciones B Mientras la condición sea verdadera se repite el bucle hasta que la condición sea falsa
  13. 13. Lámina  13 Datos de entrada: Los datos de entrada son aquellos valores que se desconocen en el momento de hacer el algoritmo. En este problema los valores a imprimir son conocidos, los números del 1 al 5 que se pueden generar en el proceso. Datos de salida: Los cinco primeros números. Proceso: Se tendrá una variable que sirva para generar los números entre 1 y 5. (NUM) La variable también sirve para controlar la condición del ciclo. Estructura Mientras-hacer – Ejemplo 1 Enunciado Problema Imprimir los primeros cinco números naturales (1,2,3, 4 y 5). Algoritmo
  14. 14. Lámina  14 Inicio Entero NUM NUM  0 Mientras (NUM < 5) hacer NUM  NUM + 1 Escribir NUM Fin mientras Fin algoritmo Problema: Imprimir los primeros cinco números naturales (1,2,3, 4 y 5). Declaración e inicialización de variable NUM Instrucciones del bucle Modificación de la expresión Pseudocódigo Algoritmo Estructura Mientras-hacer – Ejemplo 1
  15. 15. Lámina  15 Diagrama de FlujoInicio verdadero falso NUM < 5 Entero: NUM NUM  0 Fin Escribir “NUM” NUM  NUM + 1 Problema: Imprimir los primeros cinco números naturales (1,2,3, 4 y 5). Algoritmo Declaración e inicialización de variable NUM Modificación de la expresión Instrucciones del bucle Estructura Mientras-hacer – Ejemplo 1
  16. 16. Lámina  16 Traza de la ejecución del algoritmo Algoritmo : Imprimir los primeros cinco números naturales (1,2,3, 4 y 5). Pseudocódigo PASO NUM Comentario 1 0 2 0 < 5 entra al lazo 3 1 Incrementa NUM 4 Escribe NUM va a paso (2) 2 1 < 5 entra al lazo 3 2 Incrementa NUM 4 Escribe NUM va a paso (2) 2 2 < 5 entra al lazo 3 3 Incrementa NUM 4 Escribe NUM va a paso (2) 2 3 < 5 entra al lazo 3 4 Incrementa NUM 4 Escribe NUM va a paso (2) 2 4 < 5 entra al lazo 3 5 Incrementa NUM 4 Escribe NUM va a paso (2) 2 5 < 5 falso, sale del lazo y termina Inicio Entero NUM (1) NUM  0 (2) Mientras (NUM < 5) hacer (3) NUM  NUM + 1 (4) Escribir NUM Fin mientras Fin algoritmo Estructura Mientras-hacer – Ejemplo 1
  17. 17. Lámina  17 Estructura Mientras-hacer - Ejemplo 2 Ejercicio; Modifique el algoritmo anterior para calcular e imprimir la suma de los cinco primeros números naturales. Problema : Calcular la suma de los primeros cinco números naturales (1,2,3, 4 y 5).
  18. 18. Lámina  18 Datos de entrada: Los datos de entrada se pueden generar en el proceso. Datos de salida: Los suma de los cinco números naturales. (1,2,3, 4 y 5). Proceso: Se tendrá: 1) Una variable que sirva para generar los números entre 1 y 5 y controlar también la condición del ciclo. (variable NUM) 2) Una variable donde se va acumulando la suma de los números. (Variable SUMA) Ejemplo Estructura Mientras-hacer – Ejemplo 2 Calcular la suma de los primeros cinco números naturales (1,2,3,4 y 5). Enunciado Problema Algoritmo
  19. 19. Lámina  19 Pseudocódigo Inicio Entero NUM, SUM NUM  0 SUMA  0 Mientras (NUM < 5) hacer NUM  NUM + 1 SUMA  SUMA + NUM Fin mientras Escribir “La suma es: , “ SUMA” Fin algoritmo Instrucciones del bucle Declaración e inicialización de variable NUM y SUM Instrucciones que se ejecutan al salir del bucle Verifique el algoritmo haga su traza o prueba Calcular la suma de los primeros cinco números naturales (1,2,3,4 y 5). Enunciado Problema Algoritmo Estructura Mientras-hacer - Ejemplo 2
  20. 20. Lámina  20  La estructura Repetir-hasta es una estructura de ciclo en la que la condición se evalúa después de realizar la primera iteración del bucle  Se repite el bucle mientras la condición del ciclo al final se mantenga en falsa.  Cuando se cumple la condición se sale del bucle Estructura Cíclica Repetir-hasta Bucle Condición del Ciclo Acciones A condición verdadera falsa Acciones B Estructura Cíclica Repetir- Hasta
  21. 21. Lámina  21 Estructura Cíclica Repetir-hasta Funcionamiento:  Se repite el bucle hasta que la condición sea verdadera, es decir, el bucle se repite y ejecuta mientras la condición sea falsa.  La condición se evalúa siempre al final del bucle. Si es falsa volvemos a ejecutar las acciones. Si es verdadera se sale del bucle.  Dado que la condición se evalúa al final se habrá pasado al menos una vez por el bucle.  Se puede usar esta estructura cuando el bucle se tenga que ejecutar como mínimo una vez Bucle Condición del Ciclo Acciones A condición verdadera falsa Acciones B Estructura Cíclica Repetir- Hasta
  22. 22. Lámina  22 Se representa en: Pseudocódigo Repetir Accion1 Accion2 : Accion Hasta (condición) Diagrama de Flujo Representación Estructuras Repetir-hasta Repetir el bucle hasta que la condición sea verdadera Acciones A condición verdadera falsa Acciones B Estructura Cíclica Repetir- Hasta
  23. 23. Lámina  23 Estructura Repetir-hasta – Ejemplo Utilice la estructura Repetir-hasta Datos de entrada: Los datos de entrada se pueden generar en el proceso. Datos de salida: Los suma de los cinco números naturales. (1,2,3, 4 y 5). Proceso: Se tendrá: 1) Una variable que sirva para generar los números entre 1 y 5 y controlar también la condición del ciclo. (variable NUM) 2) Una variable donde se va acumulando la suma de los números. (Variable SUMA) Enunciado Problema Imprimir los primeros cinco números naturales (1,2,3, 4 y 5). Algoritmo Observación: El algoritmo es el mismo lo que cambia es la estructura cíclica que se va a usar
  24. 24. Lámina  24 Ejemplo Estructura Repetir-hasta Pseudocódigo Inicio Entero NUM, SUM NUM  0 SUMA  0 Repetir NUM  NUM + 1 SUMA  SUMA + NUM Hasta (NUM == 5) Escribir “La suma es: , “ SUMA” Fin algoritmo Instrucciones del bucle Declaración e inicialización de variable NUM y SUM Instrucciones que se ejecutan al salir del bucle Enunciado Problema Calcular la suma de los primeros cinco números naturales (1,2,3,4 y 5). Algoritmo
  25. 25. Lámina  25 Mientras hacer Repetir hasta Inicio Entero NUM, SUMA NUM  0 SUMA  0 Mientras (NUM < 5) Hacer NUM  NUM + 1 SUMA  SUMA + NUM Fin mientras Escribir “La suma es: , “ SUMA” Fin algoritmo Inicio Entero NUM, SUMA NUM  0 SUMA  0 Repetir NUM  NUM + 1 SUMA  SUMA + NUM Hasta (NUM = = 5) Escribir “La suma es: , “ SUMA” Fin algoritmo Comparación de las Estructuras Cíclicas
  26. 26. Lámina  26 Estructura Cíclica “Para”  Es una estructura de ciclo que se usa cuando se sabe el número exacto de veces que se va a ejecutar el bucle.  El bucle lleva asociada una variable denominada índice o contador, se le asigna un valor inicial y se establece cual va a ser su valor final.  La variable índice se incrementa o decrementa en cada iteración del bucle en un valor constante de manera automática.  El programador no se debe de ocupar de actualizar el valor de esta variable en cada iteración del bucle, es una operación implícita. Estructura Cíclica “Para” Para <v  vi> hasta <vf> hacer accion1 accion2 : accionN Fin Para
  27. 27. Lámina  27 Se representa en: Pseudocódigo Para <v  vi> hasta <vf> hacer accion1 accion2 : accionN Fin Para Diagrama de Flujo Representación Estructura Cíclica “Para” v: variable índice vi, vf: Valores inicial y final de la variable índice v. Después de cada iteración se Incrementa en 1 y si el valor no es mayor que vf se entra nuevamente al bucle Acciones A verdadero falso Acciones B v  vi v > vf v  v +1 Estructura Cíclica “Para”
  28. 28. Lámina  28 Utilice la estructura “Para” Datos de entrada: Los datos de entrada se pueden generar en el proceso. Datos de salida: Los suma de los cinco números naturales. (1,2,3, 4 y 5). Proceso: Se tendrá: 1) Una variable que sirva para generar los números entre 1 y 5 y controlar también la condición del ciclo. (variable NUM) 2) Una variable donde se va acumulando la suma de los números. (Variable SUMA) Enunciado Problema Imprimir los primeros cinco números naturales (1,2,3, 4 y 5). Algoritmo Observación: El algoritmo es el mismo lo que cambia es la estructura cíclica que se va a usar Estructura Cíclica “Para” - Ejemplo 1
  29. 29. Lámina  29 Pseudocódigo Inicio Entero NUM, SUM SUMA  0 Para (NUM  1) hasta 5 hacer SUMA  SUMA + NUM Fin desde Escribir “La suma es: , “ SUMA” Fin algoritmo Instrucciones del bucle Declaración e inicialización de variable NUM y SUM Instrucciones que se ejecutan al salir del bucle Enunciado Problema Imprimir los primeros cinco números naturales (1,2,3, 4 y 5). Algoritmo Estructura Cíclica “Para” - Ejemplo 1
  30. 30. Lámina  30 Enunciado Problema Imprimir los primeros cinco números naturales (1,2,3, 4 y 5). Algoritmo NUM  1 NUM > 5 NUM NUM +1 verdadero falso Inicio Fin Escribir “SUMA” Entero: NUM, SUMA SUMA  0 SUMA  SUMA + NUM Diagrama de Flujo Estructura Cíclica “Para” - Ejemplo 1
  31. 31. Lámina  31 Datos de entrada: El número que se debe calcular la tabla de multiplicar. Datos de salida: La tabla de multiplicar del número dado Proceso:  Se lee en una variable el valor del números del que se va a generar la tabla de multiplicar llámese NUM.  Se define una variable de control “I” que sirva para generar los números entre 1 y 10 de la tabla y controlar la condición del ciclo. Esta variable se inicializa en 1.  Se establece un ciclo donde en cada iteración se multiplica NUM * I, y se almacena en la variable MULT, esta se imprime y, se incrementa el valor de I en 1 hasta que I sea mayor a 10. Enunciado Problema Calcular e imprimir la tabla de multiplicar de un número dado Algoritmo Estructura Cíclica “Para” – Ejemplo 2
  32. 32. Lámina  32 Inicio Entero NUM, I, MULT Leer NUM Desde (I  1) hasta 10 hacer MULT  I * NUM Imprimir NUM, “ * “, X, “ = “, MULT Fin desde Fin Algoritmo Estructura Cíclica “Para” – Ejemplo 2 Actividad: Realice la prueba del algoritmo Enunciado Problema Calcular e imprimir la tabla de multiplicar de un número dado Algoritmo
  33. 33. Lámina  33 Estructuras Cíclicas Mientras-Hacer Repetir- Hasta Desde Mientras (condición) hacer accion1 accion2 : accionN Fin Mientras Repetir Accion1 Accion2 : AccionN Hasta (condición) Desde <v  vi> hasta <vf> hacer accion1 accion2 : accionN Fin Desde Resumen
  34. 34. Lámina  34 Fin del Tutorial Finalizado el tutorial usted debe ser capaz de:  Definir las estructuras algorítmicas que corresponden a las instrucciones cíclicas o repetitivas.  Utilizar las instrucciones cíclicas Mientras, Repetir y Para.  Crear algoritmos sencillos utilizando las instrucciones cíclicas.

×