Your SlideShare is downloading. ×
Algoritmica i clase00 introduccion
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×

Introducing the official SlideShare app

Stunning, full-screen experience for iPhone and Android

Text the download link to your phone

Standard text messaging rates apply

Algoritmica i clase00 introduccion

87
views

Published on


0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
87
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
4
Comments
0
Likes
0
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. UNMSM – FISI Introducción a Algorítmica I Algorítmica I - Problemas de Aplicación Problema 1: Obtenga la edad de una persona en días, si se ingresa su edad en años, meses y días. Pseudocódigo VARIABLES ENTERO: anio, mes, dia, R ACCION Convertir_anio_dias LEER(anio) LEER(mes) LEER(día) Ranio*12*30+mes*30+dia ESCRIBIR( R ) FIN_ACCION Programación en Turbo C++ #include <iostream.h> #include <conio.h> void main() {int anio, mes, dia, R; cout<<"Ingrese la cantidad de anios : ";cin>>anio; cout<<"Ingrese la cantidad de meses : ";cin>>mes; cout<<"Ingrese la cantidad de dias : ";cin>>dia; R=anio*12*30+mes*30+dia; cout<<"La edad en dias es : "<<R; getch(); clrscr(); } Problema 2: Se tiene como datos la altura y la base de un triángulo, determine y muestre el área del  Pseudocódigo VARIABLES ENTERO: L1, L2, L3 REAL : sp, R ACCION Hallar_area_triangulo LEER(L1) LEER(L2) LEER(L3) UNMSM-FISI 1
  • 2. UNMSM – FISI Introducción a Algorítmica I sp(L1+L2+L3)/2 Rraiz2(p*(p-L1)*(p-L2)*(p-L3)) ESCRIBIR( R ) FIN_ACCION Programación en Turbo C++ #include <iostream.h> #include <conio.h> #include <math.h> void main() {int L1, L2, L3; float sp, R; cout<<"Ingrese el primer lado : ";cin>>L1; cout<<"Ingrese el segundo lado : ";cin>>L2; cout<<"Ingrese el tercer lado : ";cin>>L3; sp=(L1+L2+L3)/2; R=sqrt(sp*(sp-L1)*(sp-L2)*(sp-L3)); cout<<"El area del triangulo es : "<<R; getch(); clrscr(); } Problema 3: Calcular el cociente de dos números reales, dar un mensaje apropiado en el caso de la división por cero. Pseudocódigo VARIABLES REAL: num, den, R ACCION Conciente_dos_números LEER(num) LEER(den) Si ( den <> 0 ) Entonces R num / den Sino ESCRIBIR(“La división no existe”) Fin_si FIN_ACCION Programación en Turbo C++ #include <iostream.h> UNMSM-FISI 2
  • 3. UNMSM – FISI Introducción a Algorítmica I #include <iostream.h> #include <conio.h> void main() {float num, den, R; cout<<"Ingrese el numerador : ";cin>>num; cout<<"Ingrese el denominador : ";cin>>den; if(den!=0) {R=num/den; cout<<"El resultado de la division es : "<<R; } else {cout<<"La division no existe";} getch(); clrscr(); } Problema 4: Se lee tres números enteros, se desea ordenarlos en forma ascendente. Pseudocódigo VARIABLES ENTERO: A, B, C ACCION Ordenar_numeros LEER(A) LEER(B) LEER(C) Si(A>B) Entonces Si(A>C) Entonces Si(B>C) Entonces Escribir("Numeros ordenados : ",C,B,A) Sino Escribir("Numeros ordenados : ",B,C,A) Fin_si Sino Escribir("Numeros ordenados : ",B,A,C) Fin_si Sino Si(B>C) Entonces Si(A>C) Entonces Escribir("Numeros ordenados : ",C,A,B) Sino Escribir("Numeros ordenados : ",A,C,B) UNMSM-FISI 3
  • 4. UNMSM – FISI Introducción a Algorítmica I Fin_si Sino Escribir("Numeros ordenados : ",A,B,C) Fin_si FIN_ACCION Programación en Turbo C++ #include <iostream.h> #include <conio.h> void main() {int A,B,C; cout<<"Ingrese el numero : ";cin>>A; cout<<"Ingrese el numero : ";cin>>B; cout<<"Ingrese el numero : ";cin>>C; if(A>B) {if(A>C) {if(B>C) {cout<<"Numeros ordenados : "<<C<<" "<<B<<" "<<A;} else {cout<<"Numeros ordenados : "<<B<<" "<<C<<" "<<A;} } else {cout<<"Numeros ordenados : "<<B<<" "<<A<<" "<<C;} } else {if(B>C) {if(A>C) {cout<<"Numeros ordenados : "<<C<<" "<<A<<" "<<B;} else {cout<<"Numeros ordenados : "<<A<<" "<<C<<" "<<B;} } else {cout<<"Numeros ordenados : "<<A<<" "<<B<<" "<<C;} } getch(); clrscr(); } UNMSM-FISI 4
  • 5. UNMSM – FISI Introducción a Algorítmica I Problema 5: Calcular la suma de los 50 primeros números. Pseudocódigo VARIABLE ENTERO : i, suma ACCION Hallar_suma i1 suma  0 Mientras( i <= 50) Hacer suma  suma + i ii+1 Fin_mientras ESCRIBIR(“La suma de los 50 primeros numeros es : ”, suma ) FIN_ACCION Programación en Turbo C++ #include <iostream.h> #include <conio.h> void main() {int i=1, suma=0; while(i<=50) {suma=suma+i; i++; } cout<<"La suma de los 50 primeros numeros es : "<<suma; getch(); clrscr(); } UNMSM-FISI 5