Your SlideShare is downloading. ×
Problemas 1 al 7, diagrama de flujo problema 7, y pseudocódigo y diagrama de flujo para el problema de leer tres notas del alumno
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×
Saving this for later? Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime – even offline.
Text the download link to your phone
Standard text messaging rates apply

Problemas 1 al 7, diagrama de flujo problema 7, y pseudocódigo y diagrama de flujo para el problema de leer tres notas del alumno

18,352
views

Published on

Logica y programacion

Logica y programacion

Published in: Education, Spiritual, Travel

0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
18,352
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
241
Comments
0
Likes
1
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. Instituto Tecnológico de Hermosillo Dpto. de Mecánica Ing. Mecánica Lógica y Programación Ing. Moisés Jonathan Saldaña Salazar “Pseudocódigo problemas 1 al 7, diagrama de flujo problema 7, y pseudocódigo y diagrama de flujo para el problema de leer tres notas del alumno” Santa cruz Galaz Juan Guillermo 07330176 Hermosillo, Sonora, Noviembre de 2010
  • 2. 1. Hacer el pseudocódigo para sumar dos números leídos por teclado y escribir el resultado. Inicio Num1, num2, suma=entero Leer num1, num2 Suma= num1 + num2 Escribir “ la suma es:”, suma Fin 2. Modificar el anterior pero para sumar 100 números leídos por teclado. Inicio Cont,=0 Num1, num2,…,num100, suma=entero Leer num1, num2 Suma=num1+num2 Cont=1 hasta 99 incrementar de uno en uno Fin para Fin para Fin
  • 3. 3. Modificar el anterior para que permita sumar N números. El valor de N se debe leer previamente por teclado. Inicio Acum.=N Num1, num2,…,num100, suma=entero Leer num1, num2 Suma=num1+num2 Mientras N mayor a cero hacer Fin para Fin para Fin 4. Hacer un pseudocódigo que permita escribir los 100 primeros pares. Inicio Acum.=0 Num1, num2,…, num100, suma=entero Para Cont.=1 hasta 100 decremento de 1 Acum.=acum.+2 Escribir acum. Fin para Fin
  • 4. 5. Hacer un pseudocódigo que permita calcular el perímetro y la superficie de un círculo. Inicio Pi=3.1416 Pi, D=real D entre dos=radio Perímetro es igual a la multiplicación de pi por radio Superficie es igual al perímetro por radio Escribir perímetro y superficie Fin para Fin 6. Hacer el pseudocódigo para sumar los N primeros impares. Realizar después uno que haga lo mismo con los pares y, otro, con los múltiplos de 3. Inicio Cont.,=N Num1, num3, num5…, numN, suma=entero Leer num1, num3 Suma=num1+num3 Si Cont. Menor a N hacer Fin para Fin para Fin
  • 5. Inicio Cont.,=N Num1, num2, num4…, numN, suma=entero Leer num1, num2 Suma=num1+num2 Si Cont. Menor a N hacer Fin para Fin para Fin Inicio Cont.,=N Acum.=1 Num1, num2, num3…, numN, suma=entero Leer num1, num2 Suma=num1+num Acum.=1+3 Si Cont. Menor a N hacer Fin para Fin para Fin
  • 6. 7. La sucesión de Fibonacci se define de la siguiente forma: a1=1, a2=1 y an=an-1+an-2 paran>2, es decir los dos primeros son 1 y el resto cada uno es la suma de los dos anteriores, los primeros son: 1, 1, 2, 3, 5, 8, 13, 21,... Hacer un diagrama de flujo y pseudocódigo para calcular el N-ésimo término de la sucesión. Inicio N B=1 No Si S < N Fin S=A+B A=1 Escribir S Escribir A Y B A=B Y B=S
  • 7. Inicio NumN= entero Cont., acum., suma =entero NumA, NumB iguales a 1 La suma de NumA + NumB es igual a NumC NumA= NumB NumB=NumC Si NumC igual a N fin para si No sigue Fin para Fin para Fin
  • 8. 8. Se pide leer tres notas del alumno, calcular su promedio y enviar un mensaje donde se diga si el alumno aprobó el curso y lo mínimo para pasar es 7, usando pseudocódigo y diagrama de flujo Pseudocódigo: INICIO Cal1, Cal2, Cal 3: REAL Res: REAL LEA Nota1, Nota2, Nota3 Res (Cal1 + Cal2 + Cal3) /3 Si Res < 7 entonces Escriba “Reprobó el curso” Sino Escriba “Aprobó el curso” Fin-Si FIN Cal1, Cal2, Cal3 Res = (Cal1+Cal2+Cal3)/3 Res< 7 Si No Fin Inicio Réprobo el curso Aprobó el curso

×