ΑΕΠΠ - Δομή Ακολουθίας
Upcoming SlideShare
Loading in...5
×
 

ΑΕΠΠ - Δομή Ακολουθίας

on

  • 7,182 views

Μία παρουσίαση που καλύπτει τις ενότητες 7.10 και 2.4.1 του βιβλίου "Ανάπτυξη Εφαρμογών σε Προγραμματιστικό ...

Μία παρουσίαση που καλύπτει τις ενότητες 7.10 και 2.4.1 του βιβλίου "Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον".

Statistics

Views

Total Views
7,182
Views on SlideShare
3,159
Embed Views
4,023

Actions

Likes
0
Downloads
181
Comments
0

19 Embeds 4,023

http://pliroforikiatschool.blogspot.com 1530
http://pliroforikiatschool.blogspot.gr 1098
http://alexmind26.blogspot.gr 446
http://alexmind26.blogspot.com 425
http://www.sxoleio.org 395
http://blogs.sch.gr 63
http://users3.sch.gr 26
https://alexmind26.blogspot.com 10
http://www.pliroforikiatschool.blogspot.gr 9
http://msth-aepp.wikispaces.com 4
http://users.sch.gr 4
http://alexmind26.blogspot.de 3
http://webcache.googleusercontent.com 3
http://alexmind26.blogspot.it 2
http://alexmind26.blogspot.fr 1
http://pliroforikiatschool.blogspot.be 1
http://alexmind26.blogspot.in 1
http://static.slidesharecdn.com 1
http://pliroforikiatschool.blogspot.de 1
More...

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

ΑΕΠΠ - Δομή Ακολουθίας ΑΕΠΠ - Δομή Ακολουθίας Presentation Transcript

  • Δομή ακολουθίας
    Σαρημπαλίδης Ιωάννης
    Φωτό από Kaddy
  • Είναι μία από τις τρεις
    βασικές δομές του δομημένου προγραμματισμού
  • Εντολή 1
    Στην ακολουθιακή δομή εντολών εκτελούμε τις εντολές με τη σειρά με την οποία εμφανίζονται στο πρόγραμμα.
    Εντολή 2
    Εντολή 3
  • ΠΡΟΣΟΧΗ !!!
    Κάθε φορά που εκτελούμε μία εντολή η οποία αλλάζει την τιμή μίας μεταβλητής αυτό έχει ως αποτέλεσμα η προηγούμενη τιμή αυτής της μεταβλητής να χάνεται.
    Χ  4
    Χ  5
    Μετά την εκτέλεση των 2 εντολών η τελική τιμή της μεταβλητής Χ είναι 5. Η τιμή 4 χάθηκε.
  • Ας δούμε τη δομή
    ενός απλού προγράμματος
  • Πρόγραμμα υπολογισμού του αθροίσματος δύο ακεραίων αριθμών
    ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
    ΑΡΧΗ
    ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "
    ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "
    ΔΙΑΒΑΣΕ Υ  
    ΑΘΡ  Χ + Υ
    ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών
  • ΕΠΙΚΕΦΑΛΙΔΑ
    ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
    ΑΡΧΗ
    ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "
    ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "
    ΔΙΑΒΑΣΕ Υ  
    ΑΘΡ  Χ + Υ
    ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών
  • ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
    ΑΡΧΗ
    ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "
    ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "
    ΔΙΑΒΑΣΕ Υ  
    ΑΘΡ  Χ + Υ
    ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών
    ΔΗΛΩΣΗ ΜΕΤΑΒΛΗΤΩΝ
  • ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
    ΑΡΧΗ
    ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "
    ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "
    ΔΙΑΒΑΣΕ Υ  
    ΑΘΡ  Χ + Υ
    ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών
    ΑΡΧΗ
  • ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
    ΑΡΧΗ
    ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "
    ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "
    ΔΙΑΒΑΣΕ Υ  
    ΑΘΡ  Χ + Υ
    ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών
    ΕΙΣΑΓΩΓΗ ΔΕΔΟΜΕΝΩΝ
  • ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
    ΑΡΧΗ
    ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "
    ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "
    ΔΙΑΒΑΣΕ Υ  
    ΑΘΡ  Χ + Υ
    ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών
    ΠΡΑΞΕΙΣ
  • ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
    ΑΡΧΗ
    ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "
    ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "
    ΔΙΑΒΑΣΕ Υ  
    ΑΘΡ  Χ + Υ
    ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών
    ΕΜΦΑΝΙΣΗ ΑΠΟΤΕΛΕΣΜΑΤΩΝ
  • ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
    ΑΡΧΗ
    ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "
    ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "
    ΔΙΑΒΑΣΕ Υ  
    ΑΘΡ  Χ + Υ
    ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών
    ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ
  • Λίγα ακόμα πράγματα που πρέπει να ξέρουμε …
  • Σταθερές
    Αν υπάρχουν σταθερές τότε το τμήμα δηλώσεων των σταθερών τοποθετείται πριν το τμήμα δηλώσεων των μεταβλητών
    ΣΤΑΘΕΡΕΣ
    Π = 3.14
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ
  • Σχόλια
    Τα σχόλια δεν είναι εκτελέσιμες εντολές.
    Απλά μας βοηθάνε να καταλάβουμε
    τι κάνει το πρόγραμμα.
    Ξεκινάνε πάντα με τον χαρακτήρα !
    ! Αυτό είναι ένα σχόλιο
  • Εντολές
    Αν μία εντολή πρέπει να συνεχιστεί και στην επόμενη γραμμή τότε ο πρώτος χαρακτήρας της επόμενης γραμμής θα είναι ο χαρακτήρας &
    ΓΡΑΨΕ "Αυτή η εντολή δεν χωράει
    & σε μία γραμμή."
  • ΣΑΣ ΕΥΧΑΡΙΣΤΩ
    Περισσότερα μπορείτε να βρείτε στο
    http://pliroforikiatschool.blogspot.com