PROBLEMAS PROPUESTOS- CLASE 0-1
1) Dada una cantidad en nuevos soles, obtener la equivalencia en
dólares, asumiendo que la...
2) Leer un número y escribir el valor absoluto del mismo.
PSEINT:
Proceso Algoritmo
Escribir "INGRSAR VALOR ABSLOUTO DE: "...
3)La presión, el volumen y la temperatura de una masa de aire se
relacionan por la fórmula:
masa = (presión * volumen)/ (0...
4) Calcular el número de pulsaciones que una persona debe tener por
cada 10 segundos de ejercicio, si la fórmula es:
num. ...
5)Calcular el nuevo salario de un obrero si obtuvo un incremento del
25% sobre su salario anterior.
PSEINT:
Proceso nuevos...
6) En un hospital existen tres áreas: Ginecología, Pediatría,
Traumatología. El presupuesto anual del hospital se reparte ...
7) El dueño de una tienda compra un artículo a un precio determinado.
Obtener el precio en que lo debe vender para obtener...
8) Todos los lunes, miércoles y viernes, una persona corre la misma ruta y
cronometra los tiempos obtenidos. Determinar el...
JAVA:
//AUTOR: JESUS FRANCO RAMOS
public class PromediodeCorrer {
public static void main(String[] args) {
// promedio de ...
9) Tres personas deciden invertir su dinero para fundar una empresa.
Cada una de ellas invierte una cantidad distinta. Obt...
JAVA:
publicclassinvertirdinero {
//AUTOR: JESUS FRANCO RAMOS
public static void main(String[] args) {
// invertir dinero ...
10) Un alumno desea saber cuál será su promedio general en las tres
materias más difíciles que cursa y cuál será el promed...
JAVA:
//AUTOR: JESUS FRANCO RAMOS
publicclasspromediodelAlumno {
publicstaticvoidmain(String[] args) {
// promedio del alu...
Upcoming SlideShare
Loading in …5
×

Problemas propuestos

804 views

Published on

Published in: Entertainment & Humor
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
804
On SlideShare
0
From Embeds
0
Number of Embeds
49
Actions
Shares
0
Downloads
22
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Problemas propuestos

  1. 1. PROBLEMAS PROPUESTOS- CLASE 0-1 1) Dada una cantidad en nuevos soles, obtener la equivalencia en dólares, asumiendo que la unidad cambiaría es un dato desconocido. PSEINT Proceso CAMBIO Escribir "INGRESAR CANTIDAD EN SOLES : " LEER SOLES; ESCRIBIR '--------------------------------' ESCRIBIR 'INGRESAR DOLAR: ' LEER DOLAR; CAMBIO<-SOLES/DOLAR Escribir "EL CAMBIO EN DOLARES ES : $",CAMBIO ESCRIBIR '--------------------------------' FinProceso JAVA: //AUTOR: JESUS FRANCO RAMOS public class Dolares { public static void main(String[] args) { //Cambiar soles a dolares doublesoles,dolares,cambio; System.out.print("Ingresar la cantidad en soles: "); soles=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingrese el cambio: "); cambio=Entrada.real(); System.out.println("-----------------------------------"); dolares=soles/cambio; System.out.println("En Dolares es : $"+dolares); } }
  2. 2. 2) Leer un número y escribir el valor absoluto del mismo. PSEINT: Proceso Algoritmo Escribir "INGRSAR VALOR ABSLOUTO DE: "; LEER NUMERO; ESCRIBIR '--------------------------------' Si NUMERO<0.0 Entonces VALORABSOLUTO <- -NUMERO; Sino VALORABSOLUTO<- NUMERO; FinSi Escribir "EL VALOR ABSOLUTO ES: ", VALORABSOLUTO; ESCRIBIR '--------------------------------' FinProceso JAVA: //AUTOR: JESUS FRANCO RAMOS public class VALORABSOLUTO { public static void main(String[] args) { // LEER EL NUMERO ABSOLUTO intnumero,absoluto; System.out.print("Ingresar el numero: "); numero=Entrada.entero(); System.out.println("-----------------------------------"); if (numero<0.0) absoluto=numero*-1; else absoluto=numero; System.out.println("El valor absoluto es : "+absoluto); } }
  3. 3. 3)La presión, el volumen y la temperatura de una masa de aire se relacionan por la fórmula: masa = (presión * volumen)/ (0.37 * (temperatura + 460)) PSEINT: Proceso MASADEAIRE ESCRIBIR 'INGRESAR PRESION: ' LEER PRESION; escribir '--------------------------' ESCRIBIR 'INGRESAR VOLUMEN: ' LEER VOLUMEN; escribir '--------------------------' ESCRIBIR 'INGRESAR TEMPERATURA: ' LEER TEMPERATURA; escribir '--------------------------' MASA<-(PRESION*VOLUMEN)/(0.37*(TEMPERATURA+460)) ESCRIBIR 'EL RESULTADO DE LA MASA DE AIRE ES : ', MASA; escribir '--------------------------' FinProceso JAVA: publicclassMasadeAire { //AUTOR: JESUS FRANCO RAMOS public static void main(String[] args) { // hallar masa de aire doublepresion,volumen,temperatura,masa; System.out.print("Ingresar Presion: "); presion=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar Volumen: "); volumen=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar Temperatura: "); temperatura=Entrada.real(); System.out.println("-----------------------------------"); masa=(presion*volumen)/(0.37*(temperatura+460)); System.out.println("La Masa de Aire es : "+masa); } }
  4. 4. 4) Calcular el número de pulsaciones que una persona debe tener por cada 10 segundos de ejercicio, si la fórmula es: num. Pulsaciones = (220 – edad)/10 PSEINT: Proceso PULSACIONES escribir 'Ingresar Nombre: ' leer nombre; escribir '--------------------------' escribir 'Ingresar Edad: ' leer edad; escribir '--------------------------' pulsaciones<- (220 - edad)/10 escribir 'CANTIDAD DE PULSACIONES ES : ', pulsaciones; escribir '--------------------------' FinProceso JAVA: //AUTOR: JESUS FRANCO RAMOS public class Pulsaciones { public static void main(String[] args) { // Cantidad de pulsaciones doubleedad,pulsaciones,nombre; System.out.print("Ingresar nombre: "); nombre=Entrada.caracter(); System.out.println("-----------------------------------"); System.out.print("Ingresar edad: "); edad=Entrada.entero(); System.out.println("-----------------------------------"); pulsaciones=(220-edad)/10; System.out.println("La Cantidad de Pulsaciones es : "+pulsaciones); } }
  5. 5. 5)Calcular el nuevo salario de un obrero si obtuvo un incremento del 25% sobre su salario anterior. PSEINT: Proceso nuevosalario ESCRIBIR 'INGRESAR NOMBRE DEL OBRERO: ' LEER NOMBRE; ESCRIBIR '********************************' ESCRIBIR 'INGRESAR SALARIO DEL OBRERO: ' LEER SALARIO; ESCRIBIR '********************************' NUEVOSALARIO<-(SALARIO*0.25)+SALARIO ESCRIBIR 'EL NUEVO SALARIO DEL OBRERO ES: ', NUEVOSALARIO; ESCRIBIR '********************************' FinProceso JAVA: //AUTOR: JESUS FRANCO RAMOS public class OBREROSALARIO { public static void main(String[] args) { // salario del obrero doublesalario,nuevosalario,nombre; System.out.print("Ingresar nombre del obreo :"); nombre=Entrada.caracter(); System.out.println("-----------------------------------"); System.out.print("Ingresar salario: "); salario=Entrada.real(); System.out.println("-----------------------------------"); nuevosalario=(salario*0.25)+salario; System.out.println("El nuevo salario es : "+nuevosalario); } }
  6. 6. 6) En un hospital existen tres áreas: Ginecología, Pediatría, Traumatología. El presupuesto anual del hospital se reparte conforme a la sig. Tabla:Área Porcentaje del presupuesto Ginecología 40% Traumatología 30% Pediatría 30% Obtener la cantidad de dinero que recibirá cada área, para cualquier monto presupuestal. PSEINT: Proceso HOSPITAL ESCRIBIR 'INGRESAR CANTIDAD: ' LEER N; ESCRIBIR '******************' PG<-N*0.40 PP<-N*0.30 PT<-N*0.30 ESCRIBIR "GINECOLOGIA RECIBE: ", PG; ESCRIBIR '*****************************' ESCRIBIR "PEDIATRIA RECIBE:", PP; ESCRIBIR '*****************************' ESCRIBIR 'TRAUMATOLOGIA RECIBE: ', PT; ESCRIBIR '***************************' FinProceso JAVA: public class hospital { //AUTOR: JESUS FRANCO RAMOS public static void main(String[] args) { // cantidad de dinero de cada area doublen,ginecologia,pediatria,traumatologia; System.out.print("Ingresar cantidad: "); n=Entrada.real(); System.out.println("-----------------------------------"); ginecologia=n*0.40; pediatria=n*0.30; traumatologia=n*0.30; System.out.println("Ginecologiarecibe: " + ginecologia); System.out.println("Ginecologiarecibe: " + pediatria); System.out.println("Ginecologiarecibe: " + traumatologia); } }
  7. 7. 7) El dueño de una tienda compra un artículo a un precio determinado. Obtener el precio en que lo debe vender para obtener una ganancia del 30%. PSEINT: Proceso COMPRAARTICULO ESCRIBIR 'INGRESAR NOMBRE DEL ARTICULO: ' LEER ARTICULO; ESCRIBIR '********************************' ESCRIBIR 'INGRESAR PRECIO DEL ARTICULO: ' LEER PRECIO; ESCRIBIR '********************************' GANANCIA<-(PRECIO*0.30)+PRECIO ESCRIBIR 'EL ARTICULO LO DEBE DE VENDER A : ', GANANCIA; ESCRIBIR '********************************' FinProceso JAVA: publicclass articulo { //AUTOR: JESUS FRANCO RAMOS public static void main(String[] args) { // ganancia del articulo doublenombre,precio,ganancia; System.out.print("Ingresar nombre del articulo: "); nombre=Entrada.caracter(); System.out.println("-----------------------------------"); System.out.print("Ingresar Precio del articulo: "); precio=Entrada.real(); System.out.println("-----------------------------------"); ganancia=(precio*0.25)+precio; System.out.println("El nuevo salario es : "+ganancia); } }
  8. 8. 8) Todos los lunes, miércoles y viernes, una persona corre la misma ruta y cronometra los tiempos obtenidos. Determinar el tiempo promedio que la persona tarda en recorrer la ruta en una semana cualquiera. PSEINT: Proceso DIASEMANA ESCRIBIR 'INGRESAR DIA : ' LEER DIA; ESCRIBIR '********************************' ESCRIBIR 'INGRESAR CATEGORIA DE LOS DIAS: ' LEER CATEGORIA; ESCRIBIR '********************************' ESCRIBIR 'CATEGORIAS 1(30)' ESCRIBIR 'CATEGORIAS 2(40)' ESCRIBIR 'CATEGORIAS 3(50)' Segun CATEGORIA Hacer 1: TIEMPO<-30; 2: TIEMPO<-40; 3: TIEMPO<-50; De Otro Modo: Escribir 'INGRESE DIAS DE 1-3'; FinSegun ESCRIBIR 'INGRESAR CANTIDAD DE SEMANA: ' LEER SEMANA; ESCRIBIR '********************************' TIEMPORECORRIDO<-SEMANA*TIEMPO ESCRIBIR 'EL TIEMPO RECORRIDO DE LA SEMANA ES: ', TIEMPORECORRIDO; ESCRIBIR '********************************' FinProceso
  9. 9. JAVA: //AUTOR: JESUS FRANCO RAMOS public class PromediodeCorrer { public static void main(String[] args) { // promedio de correr una semana cualquiera double dia,dia_1,dia_2,semana,t_recorrido; System.out.print("Ingresar recorrido del dia lunes: "); dia=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar recorrido del dia martes: "); dia_1=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar recorrido del diamiercoles: "); dia_2=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar semana: "); semana=Entrada.real(); System.out.println("-----------------------------------"); t_recorrido=(dia+dia_1+dia_2)*semana; System.out.println("El tiempo recorrido de la semana es: "+ t_recorrido); } }
  10. 10. 9) Tres personas deciden invertir su dinero para fundar una empresa. Cada una de ellas invierte una cantidad distinta. Obtener el porcentaje que cada quien invierte con respecto a la cantidad total invertida. PSEINT: Proceso INVERTIRDINERO ESCRIBIR 'INGRESAR CANTIDAD DE LA PRIMERA PERSONA: ' LEER N1; ESCRIBIR '---------------------------' ESCRIBIR 'INGRESAR CANTIDAD DE LA SEGUNDA PERSONA: ' LEER N2; ESCRIBIR '---------------------------' ESCRIBIR 'INGRESAR CANTIDAD DE LA TERCERA PERSONA: ' LEER N3; ESCRIBIR '---------------------------' SUMA<-N1+N2+N3 PORCENTAJE_1<-N1*100/SUMA PORCENTAJE_2<-N2*100/SUMA PORCENTAJE_3<-N3*100/SUMA ESCRIBIR 'EL PORCENTAJE DE LA PRIMERA PERSONA ES : ',PORCENTAJE_1; ESCRIBIR 'EL PORCENTAJE DE LA SEGUNDA PERSONA ES: ',PORCENTAJE_2; ESCRIBIR 'EL PORCENTAJE DE LA TERCERA PERSONA ES : ',PORCENTAJE_3; ESCRIBIR '-------------------------------------------' MONTO<-N1+N2+N3 ESCRIBIR 'LOS 3 APORTE SUMA EL TOTAL DEL CAPITAL QUE VAN A INVERTIR EN EL NEGOCIO: ',MONTO; ESCRIBIR '-------------------------------------------' FinProceso
  11. 11. JAVA: publicclassinvertirdinero { //AUTOR: JESUS FRANCO RAMOS public static void main(String[] args) { // invertir dinero de una empresa double n1,n2,n3,suma,porcentaje_1,porcentaje_2,porcentaje_3,monto; System.out.print("Ingresar cantidad de la 1°persona: "); n1=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar cantidad de la 2°persona: "); n2=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar cantidad de la3°persona: "); n3=Entrada.real(); System.out.println("-----------------------------------"); suma=n1+n2+n3; porcentaje_1=n1*100/suma; porcentaje_2=n2*100/suma; porcentaje_3=n3*100/suma; System.out.println("El porcentaje de la 1°persona es : "+porcentaje_1); System.out.println("El porcentaje de la 2°persona es : "+porcentaje_2); System.out.println("El porcentaje de la 3°persona es : "+porcentaje_3); monto=n1+n2+n3; System.out.println("-----------------------------------"); System.out.println("La 3 aporte suma el total del capita que va a invertir es : " + monto); } }
  12. 12. 10) Un alumno desea saber cuál será su promedio general en las tres materias más difíciles que cursa y cuál será el promedio que obtendrá en cada una de ellas. Estas materias se evalúan como se muestra a continuación: PSEINT: Proceso PROMEDIOCURSOS ESCRIBIR 'INGRESAR NOTAS DE MATEMATICAS:' LEER N1, N2, N3 ESCRIBIR '**************************************' ESCRIBIR 'INGRESAR EXAMEN DE MATEMATICA' LEER EXAMM ESCRIBIR '**************************************' ESCRIBIR 'INGRESAR NOTAS DE FISICA:' LEER N_1, N_2, N_3 ESCRIBIR '**************************************' ESCRIBIR 'INGRSAR EXAMEN DE FISICA' LEER EXAMF ESCRIBIR '**************************************' ESCRIBIR 'INGRESAR NOTAS DE QUIMICA: ' LEER T_1,T_2,T_3 ESCRIBIR 'INGRESAR EXAMEN DE QUIMICA' LEER EXAMQ ESCRIBIR '**************************************' PROMEDIO_M<- (EXAMM*0.90+ (N1+N2+N3)/3*0.10) PROMEDIO_F<- (EXAMF*0.80+ (N_1+N_2+N_3)/2*0.20) PROMEDIO_Q<- (EXAMQ*0.85+ (T_1+T_2+T_3)/3*0.15) PROMEDIO_TOTAL<- ((PROMEDIO_M+PROMEDIO_F+PROMEDIO_Q)/3) ESCRIBIR 'EL PROMEDIO DE MATEMATICA ES:', PROMEDIO_M ESCRIBIR '**************************************' ESCRIBIR 'EL PROMEDIO DE FISICA ES:', PROMEDIO_F ESCRIBIR '**************************************' ESCRIBIR 'EL PROMEDIO DE QUIMICA ES:', PROMEDIO_Q ESCRIBIR '**************************************' ESCRIBIR 'EL PROMEDIO GENERAL ES: ', PROMEDIO_TOTAL ESCRIBIR '**************************************' FinProceso
  13. 13. JAVA: //AUTOR: JESUS FRANCO RAMOS publicclasspromediodelAlumno { publicstaticvoidmain(String[] args) { // promedio del alumno double n1,n2,n3,examM,n_1,n_2,n_3,examF,t_1,t_2,t_3,examQ,promedio_M,promedio_F,promedio_ Q,promedio_TOTAL; System.out.print("Ingresar notas de Matematica: "); n1=Entrada.real(); n2=Entrada.real(); n3=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar nota de Matematica: "); examM=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar notas de Fisica: "); n_1=Entrada.real(); n_2=Entrada.real(); n_3=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar nota de Fisica: "); examF=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar notas de Quimica: "); t_1=Entrada.real(); t_2=Entrada.real(); t_3=Entrada.real(); System.out.println("-----------------------------------"); System.out.print("Ingresar nota de Quimica: "); examQ=Entrada.real(); System.out.println("-----------------------------------"); promedio_M=(examM*0.90+ (n1+n2+n3)/3*0.10); promedio_F=(examF*0.80+ (n_1+n_2+n_3)/2*0.20); promedio_Q=(examQ*0.85+ (t_1+t_2+t_3)/3*0.15); promedio_TOTAL=((promedio_M+promedio_F+promedio_Q)/3); System.out.println("El promedio de matematica es: "+promedio_M); System.out.println("-----------------------------------"); System.out.println("El promedio de fisica es: "+promedio_F); System.out.println("-----------------------------------"); System.out.println("El promedio de quimica es: "+promedio_Q); System.out.println("-----------------------------------"); System.out.println("El promedio general es: "+promedio_TOTAL); System.out.println("-----------------------------------"); } }

×