Your SlideShare is downloading. ×
EJERCICIOS PROPUESTOS 4
1. Muestre los números del 1 al 100 utilizando la instrucción While

PSEINT:
Proceso ejercicio1
n<...
2. Muestre los números del 1 al 100 utilizando la instrucción do..while

PSEINT:
Proceso ejercicio2
n<-1
Repetir
escribir ...
3. Muestre los números del 1 al 100 utilizando la instrucción for

PSEINT:
Proceso ejercicio3
Para n<-1 Hasta 100 Con Paso...
4. Muestre los números del 100 al 1 utilizando la instrucción While

PSEINT:
Proceso ejercicio4
n<-101
Mientras n>1 Hacer
...
5. Muestre los números del 100 al 1 utilizando la instrucción do..while

PSEINT:
Proceso ejercicio5
n<-100
Repetir
escribi...
6.Muestre los números del 100 al 1 utilizando la instrucción for

PSEINT:
Proceso ejercicio6
Para n<-100 Hasta 1 Con Paso ...
7. Leer un número y mostrar su cuadrado, repetir el proceso hasta que se
introduzca un número negativo.

PSEINT:
Proceso e...
8. Escribir todos los números del 100 al 0 de 7 en 7.

PSEINT:
Proceso ejercicio8
n<-101
Mientras n>1 Hacer
n<-n-7;
escrib...
9.- En una fabrica de computadoras se planea ofrecer a los clientes un descuento
que dependerá del numero de computadoras ...
JAVA:
// ejercicio9
int n,p,t,d,tp;
System.out.print("ingresar cantidad : ");
n=entrada.entero();
System.out.print("ingres...
10.-Calcular el promedio de un alumno que tiene 7 calificaciones en la materia de
Programación Concurrente.

PSEINT:
Proce...
JAVA:
// ejercici10
System.out.println("Cuantas notas va a ingresar: ");
int numNotas=entrada.entero();
int []notas=new in...
Upcoming SlideShare
Loading in...5
×

Ejercicios propuestos

655

Published on

0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
655
On Slideshare
0
From Embeds
0
Number of Embeds
1
Actions
Shares
0
Downloads
29
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Transcript of "Ejercicios propuestos"

  1. 1. EJERCICIOS PROPUESTOS 4 1. Muestre los números del 1 al 100 utilizando la instrucción While PSEINT: Proceso ejercicio1 n<-0 Mientras n<100 Hacer n<-n+1; escribir n; FinMientras FinProceso JAVA: // ejercicio1 int n=0; while (n<100){ n=n+1; System.out.println(n); } } }
  2. 2. 2. Muestre los números del 1 al 100 utilizando la instrucción do..while PSEINT: Proceso ejercicio2 n<-1 Repetir escribir n; n<-n+1; Hasta Que (n=101) FinProceso JAVA: // ejercicio2 int n=1; do { System.out.println(n); n=n+1; } while (n!=101); } }
  3. 3. 3. Muestre los números del 1 al 100 utilizando la instrucción for PSEINT: Proceso ejercicio3 Para n<-1 Hasta 100 Con Paso 1 Hacer escribir n; FinPara FinProceso JAVA: //ejercicio3 for (int n=1;n<=100;n=n+1){ System.out.println(n); } } }
  4. 4. 4. Muestre los números del 100 al 1 utilizando la instrucción While PSEINT: Proceso ejercicio4 n<-101 Mientras n>1 Hacer n<-n-1; escribir n; FinMientras FinProceso JAVA: //ejercici4 int n=101; while (n>1){ n=n-1; System.out.println(n); } } }
  5. 5. 5. Muestre los números del 100 al 1 utilizando la instrucción do..while PSEINT: Proceso ejercicio5 n<-100 Repetir escribir n; n<-n-1; Hasta Que (n=0) FinProceso JAVA: // ejercicio5 int n=100; do { System.out.println(n); n=n-1; } while (n!=0); } }
  6. 6. 6.Muestre los números del 100 al 1 utilizando la instrucción for PSEINT: Proceso ejercicio6 Para n<-100 Hasta 1 Con Paso -1 Hacer escribir n; FinPara FinProceso JAVA: //ejercicio6 for (int n=100;n>0;n=n-1){ System.out.println(n); } } }
  7. 7. 7. Leer un número y mostrar su cuadrado, repetir el proceso hasta que se introduzca un número negativo. PSEINT: Proceso ejercicio7 n<-0 c<-0 escribir 'ingresar numero: ' leer n escribir '==============' Mientras n>=0 Hacer c<-n*n escribir 'el cuadrado del numero es: ',c escribir '===================' escribir 'ingresar otro numero: ' leer n FinMientras FinProceso JAVA: // ejercicio7 int n,c; System.out.print("ingresar numero:"); n=entrada.entero(); while(n>=0){ c=n*n; System.out.printf("el cuadrado de %d es: %d",n,c); System.out.println(); System.out.print("ingresar otro numero: "); n=entrada.entero(); } }
  8. 8. 8. Escribir todos los números del 100 al 0 de 7 en 7. PSEINT: Proceso ejercicio8 n<-101 Mientras n>1 Hacer n<-n-7; escribir n; FinMientras FinProceso JAVA: // ejercicio8 int n=100; while (n>=1){ System.out.println("el valor de x es: "+n); n=n-7;} System.out.println(n); n--; } }
  9. 9. 9.- En una fabrica de computadoras se planea ofrecer a los clientes un descuento que dependerá del numero de computadoras que compre. Si las computadoras son menos de cinco se les dará un 10% de descuento sobre el total de la compra; si el numero de computadoras es mayor o igual a cinco pero menos de diez se le otorga un 20% de descuento; y si son 10 o mas se les da un 40% de descuento. El precio de cada computadora es de $1000. PSEINT: Proceso ejercicio9 escribir 'ingresar cantidad de computadora:' leer n; escribir 'ingresar precio x cada computadora: ' leer p; Si n<5 Entonces c<-n*p; d<-c*0.10; tp<-c-d; Sino si n>=5 y n<10 Entonces c<-n*p; d<-c*0.20; tp<-c-d; Sino c<-n*p; d<-c*0.40; tp<-c-d; FinSi FinSi escribir 'el total de la compra es: ',c escribir 'el descuento es: ',d escribir 'el total a pagar de la computadora es: ',tp FinProceso
  10. 10. JAVA: // ejercicio9 int n,p,t,d,tp; System.out.print("ingresar cantidad : "); n=entrada.entero(); System.out.print("ingresar precio x cada computadora : "); p=entrada.entero(); if (n<5) { t=n*p; d=(int) (t*0.10); tp=t-d; } else { if (n>=5 && n<10) { t=n*p; d=(int) (t*0.20); tp=t-d; } else { t=n*p; d=(int) (t*0.40); tp=t-d; } } System.out.println("el total de la compra es: "+t); System.out.println("=================="); System.out.println("el descuento es: "+d); System.out.println("=================="); System.out.println("el total a pagar de la computadora es: "+tp); } }
  11. 11. 10.-Calcular el promedio de un alumno que tiene 7 calificaciones en la materia de Programación Concurrente. PSEINT: Proceso ejercicio10 Escribir 'Calcular promedio de un alummno:' leer nombre; Escribir '===============' n<-0 suma<-0 Mientras n<7 Hacer n<-n+1 Escribir 'Ingrese nota: ',n Leer nota suma<-suma+nota FinMientras prom<-suma/n Escribir '===============' Escribir 'El promedio es:',prom FinProceso
  12. 12. JAVA: // ejercici10 System.out.println("Cuantas notas va a ingresar: "); int numNotas=entrada.entero(); int []notas=new int[numNotas]; double promedio=0; double acumulado=0; for(int i=0;i<=numNotas-1;i++){ System.out.println("Ingrese la nota n° " +i ); notas[i]=entrada.entero(); acumulado=acumulado + notas[i]; } promedio=acumulado/numNotas; System.out.println("el promedio es :" + promedio); System.out.println("==========================="); } }

×