ED
Upcoming SlideShare
Loading in...5
×
 

ED

on

  • 439 views

ed

ed

Statistics

Views

Total Views
439
Views on SlideShare
439
Embed Views
0

Actions

Likes
0
Downloads
6
Comments
0

0 Embeds 0

No embeds

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

ED ED Presentation Transcript

  • Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices P C rogramación de omputadores
  • ARREGLOS Y MATRICES
    • Arreglos
    • Cadenas de Caracteres
    • Matrices
    Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • ARREGLOS Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • ARREGLOS
    • Definición: Espacio de memoria que permite almacenar una colección de datos de un mismo tipo.
    • Acceso: Nombre de variable e índice dentro de paréntesis cuadrados.
    • Ejemplo:
    20 -5 8 12 6 X = X[0] = 20 X[3] = 6 X[2] = 8 X[1] = -5 X[4] = 12 Nombre Indice 0 1 2 4 3 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • ARREGLOS
    • Formato de definición en seudo-lenguaje
    <Nombre> : arreglo[<tamaño>] de <tipo> Dimensión: Número de casillas que conforman el arreglo En el ejemplo anterior, la dimensión de X es 5 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • Inicializar un Arreglo con ceros EJEMPLO 1 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 1 t : arreglo[5 ] de entero m: entero para(m:=0 hasta 4) hacer t[m] := 0 fin_para PROGRAMA MEMORIA xxx xxx xxx xxx xxx xxx m t 0 1 2 3 4 0 t[0] 0 t[1] 0 t[2] t[3] t[4] 0 0 5 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 2 Inicializar un Arreglo con valores leídos Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 2 t : arreglo[5 ] de entero m: entero para(m:=0 hasta 4) hacer leer (t[m]) fin_para PROGRAMA MEMORIA t xxx m t[0] t[1] t[2] t[3] t[4] xxx xxx xxx xxx xxx 20 -5 8 6 12 xxx 0 1 2 3 4 5 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 3 Sumar los elementos de un arreglo Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 3 suma := 0 para(m := 0 hasta 4) hacer suma := suma+t[m] fin_para escribir (suma) PROGRAMA MEMORIA t m suma t[0] t[1] t[2] t[3] t[4] xxx xxx 0 1 2 3 4 5 xxx xxx 0 20 15 23 29 41 SALIDA Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 20 -5 8 12 6 41
  • EJEMPLO 4 Ordenar en forma ascendente un conjunto de números enteros almacenados en un arreglo Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 5 temp := 0 para(i:=0 hasta 2) hacer para(j:=i+1 hasta 3) hacer si (t[i]>t[j]) entonces temp := t[j] t[j] := t[i] t[i] := temp fin_si fin_para fin_para PROGRAMA MEMORIA 12 3 -2 7 xxx temp t xxx xxx i j 0 3 -2 3 7 0 1 2 3 1 2 3 4 2 3 4 3 4 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 12 12 3 12 3 12 3 3 -2 3 -2 3 -2 7 12 12 3 12 3 12 3 7 12 12 7 12 7 12
  • PROBLEMA ARREGLOS Leer un conjunto de datos enteros e imprimir los mismos datos en el orden inverso al leído. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • CADENAS DE CARACTERES
    • Definición: Arreglo de caracteres.
    • Características: Manejo de terminador de cadena ‘0’
    • Longitud: Número de símbolos antes del terminador de cadena.
    Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices c a s 0 a X = La longitud de X es 4
  • CADENAS DE CARACTERES
      • Formato de definición en seudo-lenguaje
    <Nombre> : arreglo[<tamaño>] de caracter Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • CADENAS DE CARACTERES
    • Especificación: Caracteres entre comillas dobles.
    • Operaciones:
      • compararCadena
      • copiarCadena
      • longitudCadena
      • concatenarCadena
      • leerCadena
      • escribirCadena
    Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • CONCATENAR Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • CADENAS DE CARACTERES X := “da” Y := “do” Z := concatenar(X,Y) PROGRAMA MEMORIA Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 0 XX XX XX XX X = Y = Z = 0 XX XX XX XX 0 XX XX XX XX d a 0 XX XX X = Y = Z = 0 XX XX XX XX 0 XX XX XX XX d a 0 XX XX X = Y = Z = d o 0 XX XX 0 XX XX XX XX d a 0 XX XX X = Y = Z = d o 0 XX XX d a d 0 o
  • PROBLEMA CADENAS Leer una cadena de caracteres y contar el número de espacios que se encuentran en ella . Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • MATRICES Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • MATRICES
    • Definición: Espacio de memoria que
    • permite almacenar una
    • colección de datos de
    • un mismo tipo
    Los elementos no están organizados linealmente sino que su organización es bidimensional, es decir, en filas y columnas. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • X = X[0] [0] = 120 X [2] [0] = -25 X [1] [2] = 34 X [0] [2] = 65 X[2] [1] = 49 Nombre Fila Columna Acceso: Nombre de variable y dos índices. Al primer índice se le llama índice de fila y al segundo índice de columna. Ejemplo: MATRICES Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 34 16 120 39 65 71 -25 82 49
  • MATRICES
      • Formato de definición en seudo-lenguaje
    <Nombre> : matriz [<N>][<M>] de <tipo> N : número de filas M : número de columnas Dimensión: es el número filas por el número de columnas. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 5 Llenar una matriz de tres por tres Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 5 mat: matriz [3][3] de entero para(i:=0 hasta 2 hacer) para(j:=0 hasta 2 hacer) mat[i][j] := i+j fin_para fin_para PROGRAMA MEMORIA j mat xxx i 0 1 2 3 xxx 0 1 2 3 0 1 2 3 0 1 2 3 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices xxx xxx xxx xxx xxx xxx xxx xxx xxx xxx xxx 0 xxx xxx xxx xxx xxx xxx xxx xxx 0 1 xxx xxx xxx xxx xxx xxx xxx 0 1 2 xxx xxx xxx xxx xxx xxx 0 1 2 1 xxx xxx xxx xxx 2 0 1 2 1 xxx xxx xxx 3 2 0 1 2 1 xxx xxx xxx 3 2 0 1 2 1 2 xxx xxx 3 2 0 1 2 1 2 xxx 3 3 2 0 1 2 1 2 4 3
  • EJEMPLO 6 Teniendo la matriz M de tres por tres, guardar en el arreglo t , la suma de los elementos de cada fila de la matriz inicial (e.d.: en t[0] se guarda la suma de la fila 0 de la matriz, en t[1] se guar- da la suma de la fila 1 de la matriz …) Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • EJEMPLO 6 xxx xxx xxx xxx suma := 0 para(j := 0 hasta 2) hacer para(i := 0 hasta 2) hacer suma := suma+M[j] [i] fin_para t[j]:=suma suma:=0 fin_para escribir (t[0],t [1], t [2]) PROGRAMA MEMORIA t j suma t[0] t[1] t[2] xxx 0 1 xxx xxx 0 0 SALIDA i i j 6 1 1 2 3 3 0 0 1 1 3 2 6 3 0 2 0 2 1 5 2 9 9 0 M Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 3 6 9
  • PROBLEMA MATRICES Realizar un programa que lea la dimensión de una matriz (número de filas y número de columnas) y los datos, e imprima la matriz en pantalla. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • CODIFICACIÓN EN C++ ARREGLOS Seudocódigo <NOMBRE> : arreglo [<N>] de <TIPO> C++ <TIPO> <NOMBRE>[<N>]; Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • CADENA DE CARACTERES Seudocódigo <NOMBRE> : arreglo [<N>] de carácter C++ char <NOMBRE>[<N>]; CODIFICACIÓN EN C++ Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • MATRICES Seudocódigo <NOMBRE> : matriz [<N>][<M>] de <TIPO> C++ <TIPO> <NOMBRE>[<N>][<M>]; CODIFICACIÓN EN C++ Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  • FIN Gracias por la atención prestada Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices