Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industrial  UN - Virtual 2008 Módulo 4  Arreglos, cadenas y ...
ARREGLOS  Y MATRICES <ul><li>Arreglos </li></ul><ul><li>Cadenas de Caracteres </li></ul><ul><li>Matrices </li></ul>Faculta...
ARREGLOS Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industrial  UN - Virtual 2008 Módulo 4  Arreglos, c...
ARREGLOS <ul><li>Definición:  Espacio de memoria que permite almacenar una colección de datos de un  mismo tipo. </li></ul...
ARREGLOS <ul><li>Formato de definición en seudo-lenguaje </li></ul><Nombre> : arreglo[<tamaño>] de <tipo> Dimensión:   Núm...
Inicializar un Arreglo con ceros EJEMPLO 1 Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industrial  UN - ...
EJEMPLO 1 t : arreglo[5 ] de entero m: entero para(m:=0 hasta 4) hacer t[m] := 0 fin_para PROGRAMA MEMORIA xxx xxx xxx xxx...
EJEMPLO 2 Inicializar un Arreglo con valores leídos Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industri...
EJEMPLO 2 t : arreglo[5 ] de entero m: entero para(m:=0 hasta 4)  hacer  leer (t[m]) fin_para PROGRAMA MEMORIA t xxx m t[0...
EJEMPLO 3 Sumar los elementos de un arreglo Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industrial  UN -...
EJEMPLO 3 suma := 0 para(m := 0 hasta 4)  hacer suma := suma+t[m] fin_para escribir (suma) PROGRAMA MEMORIA t m suma t[0] ...
EJEMPLO 4 Ordenar en forma ascendente un conjunto de números enteros  almacenados en un arreglo Facultad  Ingeniería Depar...
EJEMPLO 5 temp := 0 para(i:=0 hasta 2) hacer para(j:=i+1 hasta 3) hacer si (t[i]>t[j]) entonces  temp := t[j]   t[j] := t[...
PROBLEMA  ARREGLOS Leer un conjunto de datos enteros e  imprimir los mismos datos en el orden inverso al leído. Facultad  ...
CADENAS DE CARACTERES <ul><li>Definición:   Arreglo de caracteres. </li></ul><ul><li>Características:   Manejo de terminad...
CADENAS DE CARACTERES <ul><ul><li>Formato de definición en seudo-lenguaje </li></ul></ul><Nombre> : arreglo[<tamaño>] de c...
CADENAS DE CARACTERES <ul><li>Especificación:  Caracteres entre      comillas dobles. </li></ul><ul><li>Operaciones:  </li...
CONCATENAR Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industrial  UN - Virtual 2008 Módulo 4  Arreglos,...
CADENAS DE CARACTERES X := “da” Y := “do” Z := concatenar(X,Y) PROGRAMA MEMORIA Facultad  Ingeniería Departamento de Ingen...
PROBLEMA  CADENAS Leer una cadena de caracteres  y contar el número  de espacios que se encuentran en ella . Facultad  Ing...
MATRICES Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industrial  UN - Virtual 2008 Módulo 4  Arreglos, c...
MATRICES <ul><li>Definición: Espacio de memoria que </li></ul><ul><li>  permite almacenar una  </li></ul><ul><li>colección...
X =   X[0] [0] = 120 X [2] [0] = -25 X [1] [2] = 34 X [0] [2] = 65 X[2] [1] = 49 Nombre Fila Columna Acceso:   Nombre de v...
MATRICES <ul><ul><li>Formato de definición en seudo-lenguaje </li></ul></ul><Nombre> : matriz [<N>][<M>] de <tipo> N : núm...
EJEMPLO 5 Llenar una matriz de tres por tres Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industrial  UN ...
EJEMPLO 5 mat: matriz [3][3] de entero para(i:=0 hasta 2 hacer) para(j:=0 hasta 2 hacer) mat[i][j] := i+j fin_para  fin_pa...
EJEMPLO 6 Teniendo la matriz M de tres por tres, guardar en el arreglo  t , la suma de los  elementos de cada fila de la m...
EJEMPLO 6 xxx xxx xxx xxx suma := 0 para(j := 0 hasta 2)  hacer  para(i := 0 hasta 2) hacer suma := suma+M[j] [i] fin_para...
PROBLEMA MATRICES Realizar un programa que lea la  dimensión de una matriz (número de filas y  número de columnas) y los d...
CODIFICACIÓN EN C++ ARREGLOS Seudocódigo <NOMBRE> : arreglo [<N>] de <TIPO> C++ <TIPO> <NOMBRE>[<N>]; Facultad  Ingeniería...
CADENA DE CARACTERES Seudocódigo <NOMBRE> : arreglo [<N>] de carácter C++ char <NOMBRE>[<N>]; CODIFICACIÓN EN C++ Facultad...
MATRICES Seudocódigo <NOMBRE> : matriz [<N>][<M>] de <TIPO> C++ <TIPO> <NOMBRE>[<N>][<M>]; CODIFICACIÓN EN C++ Facultad  I...
FIN Gracias por la atención prestada Facultad  Ingeniería Departamento de Ingeniería de Sistemas e Industrial  UN - Virtua...
Upcoming SlideShare
Loading in …5
×

ED

421 views
371 views

Published on

ed

Published in: Education
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
421
On SlideShare
0
From Embeds
0
Number of Embeds
3
Actions
Shares
0
Downloads
9
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

ED

  1. 1. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices P C rogramación de omputadores
  2. 2. ARREGLOS Y MATRICES <ul><li>Arreglos </li></ul><ul><li>Cadenas de Caracteres </li></ul><ul><li>Matrices </li></ul>Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  3. 3. ARREGLOS Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  4. 4. ARREGLOS <ul><li>Definición: Espacio de memoria que permite almacenar una colección de datos de un mismo tipo. </li></ul><ul><li>Acceso: Nombre de variable e índice dentro de paréntesis cuadrados. </li></ul><ul><li>Ejemplo: </li></ul>20 -5 8 12 6 X = X[0] = 20 X[3] = 6 X[2] = 8 X[1] = -5 X[4] = 12 Nombre Indice 0 1 2 4 3 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  5. 5. ARREGLOS <ul><li>Formato de definición en seudo-lenguaje </li></ul><Nombre> : arreglo[<tamaño>] de <tipo> Dimensión: Número de casillas que conforman el arreglo En el ejemplo anterior, la dimensión de X es 5 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  6. 6. Inicializar un Arreglo con ceros EJEMPLO 1 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  7. 7. EJEMPLO 1 t : arreglo[5 ] de entero m: entero para(m:=0 hasta 4) hacer t[m] := 0 fin_para PROGRAMA MEMORIA xxx xxx xxx xxx xxx xxx m t 0 1 2 3 4 0 t[0] 0 t[1] 0 t[2] t[3] t[4] 0 0 5 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  8. 8. EJEMPLO 2 Inicializar un Arreglo con valores leídos Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  9. 9. EJEMPLO 2 t : arreglo[5 ] de entero m: entero para(m:=0 hasta 4) hacer leer (t[m]) fin_para PROGRAMA MEMORIA t xxx m t[0] t[1] t[2] t[3] t[4] xxx xxx xxx xxx xxx 20 -5 8 6 12 xxx 0 1 2 3 4 5 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  10. 10. EJEMPLO 3 Sumar los elementos de un arreglo Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  11. 11. EJEMPLO 3 suma := 0 para(m := 0 hasta 4) hacer suma := suma+t[m] fin_para escribir (suma) PROGRAMA MEMORIA t m suma t[0] t[1] t[2] t[3] t[4] xxx xxx 0 1 2 3 4 5 xxx xxx 0 20 15 23 29 41 SALIDA Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 20 -5 8 12 6 41
  12. 12. EJEMPLO 4 Ordenar en forma ascendente un conjunto de números enteros almacenados en un arreglo Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  13. 13. EJEMPLO 5 temp := 0 para(i:=0 hasta 2) hacer para(j:=i+1 hasta 3) hacer si (t[i]>t[j]) entonces temp := t[j] t[j] := t[i] t[i] := temp fin_si fin_para fin_para PROGRAMA MEMORIA 12 3 -2 7 xxx temp t xxx xxx i j 0 3 -2 3 7 0 1 2 3 1 2 3 4 2 3 4 3 4 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 12 12 3 12 3 12 3 3 -2 3 -2 3 -2 7 12 12 3 12 3 12 3 7 12 12 7 12 7 12
  14. 14. PROBLEMA ARREGLOS Leer un conjunto de datos enteros e imprimir los mismos datos en el orden inverso al leído. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  15. 15. CADENAS DE CARACTERES <ul><li>Definición: Arreglo de caracteres. </li></ul><ul><li>Características: Manejo de terminador de cadena ‘0’ </li></ul><ul><li>Longitud: Número de símbolos antes del terminador de cadena. </li></ul>Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices c a s 0 a X = La longitud de X es 4
  16. 16. CADENAS DE CARACTERES <ul><ul><li>Formato de definición en seudo-lenguaje </li></ul></ul><Nombre> : arreglo[<tamaño>] de caracter Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  17. 17. CADENAS DE CARACTERES <ul><li>Especificación: Caracteres entre comillas dobles. </li></ul><ul><li>Operaciones: </li></ul><ul><ul><li>compararCadena </li></ul></ul><ul><ul><li>copiarCadena </li></ul></ul><ul><ul><li>longitudCadena </li></ul></ul><ul><ul><li>concatenarCadena </li></ul></ul><ul><ul><li>leerCadena </li></ul></ul><ul><ul><li>escribirCadena </li></ul></ul>Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  18. 18. CONCATENAR Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  19. 19. CADENAS DE CARACTERES X := “da” Y := “do” Z := concatenar(X,Y) PROGRAMA MEMORIA Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 0 XX XX XX XX X = Y = Z = 0 XX XX XX XX 0 XX XX XX XX d a 0 XX XX X = Y = Z = 0 XX XX XX XX 0 XX XX XX XX d a 0 XX XX X = Y = Z = d o 0 XX XX 0 XX XX XX XX d a 0 XX XX X = Y = Z = d o 0 XX XX d a d 0 o
  20. 20. PROBLEMA CADENAS Leer una cadena de caracteres y contar el número de espacios que se encuentran en ella . Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  21. 21. MATRICES Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  22. 22. MATRICES <ul><li>Definición: Espacio de memoria que </li></ul><ul><li> permite almacenar una </li></ul><ul><li>colección de datos de </li></ul><ul><li>un mismo tipo </li></ul>Los elementos no están organizados linealmente sino que su organización es bidimensional, es decir, en filas y columnas. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  23. 23. X = X[0] [0] = 120 X [2] [0] = -25 X [1] [2] = 34 X [0] [2] = 65 X[2] [1] = 49 Nombre Fila Columna Acceso: Nombre de variable y dos índices. Al primer índice se le llama índice de fila y al segundo índice de columna. Ejemplo: MATRICES Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 34 16 120 39 65 71 -25 82 49
  24. 24. MATRICES <ul><ul><li>Formato de definición en seudo-lenguaje </li></ul></ul><Nombre> : matriz [<N>][<M>] de <tipo> N : número de filas M : número de columnas Dimensión: es el número filas por el número de columnas. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  25. 25. EJEMPLO 5 Llenar una matriz de tres por tres Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  26. 26. EJEMPLO 5 mat: matriz [3][3] de entero para(i:=0 hasta 2 hacer) para(j:=0 hasta 2 hacer) mat[i][j] := i+j fin_para fin_para PROGRAMA MEMORIA j mat xxx i 0 1 2 3 xxx 0 1 2 3 0 1 2 3 0 1 2 3 Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices xxx xxx xxx xxx xxx xxx xxx xxx xxx xxx xxx 0 xxx xxx xxx xxx xxx xxx xxx xxx 0 1 xxx xxx xxx xxx xxx xxx xxx 0 1 2 xxx xxx xxx xxx xxx xxx 0 1 2 1 xxx xxx xxx xxx 2 0 1 2 1 xxx xxx xxx 3 2 0 1 2 1 xxx xxx xxx 3 2 0 1 2 1 2 xxx xxx 3 2 0 1 2 1 2 xxx 3 3 2 0 1 2 1 2 4 3
  27. 27. EJEMPLO 6 Teniendo la matriz M de tres por tres, guardar en el arreglo t , la suma de los elementos de cada fila de la matriz inicial (e.d.: en t[0] se guarda la suma de la fila 0 de la matriz, en t[1] se guar- da la suma de la fila 1 de la matriz …) Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  28. 28. EJEMPLO 6 xxx xxx xxx xxx suma := 0 para(j := 0 hasta 2) hacer para(i := 0 hasta 2) hacer suma := suma+M[j] [i] fin_para t[j]:=suma suma:=0 fin_para escribir (t[0],t [1], t [2]) PROGRAMA MEMORIA t j suma t[0] t[1] t[2] xxx 0 1 xxx xxx 0 0 SALIDA i i j 6 1 1 2 3 3 0 0 1 1 3 2 6 3 0 2 0 2 1 5 2 9 9 0 M Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices 3 6 9
  29. 29. PROBLEMA MATRICES Realizar un programa que lea la dimensión de una matriz (número de filas y número de columnas) y los datos, e imprima la matriz en pantalla. Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  30. 30. CODIFICACIÓN EN C++ ARREGLOS Seudocódigo <NOMBRE> : arreglo [<N>] de <TIPO> C++ <TIPO> <NOMBRE>[<N>]; Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  31. 31. CADENA DE CARACTERES Seudocódigo <NOMBRE> : arreglo [<N>] de carácter C++ char <NOMBRE>[<N>]; CODIFICACIÓN EN C++ Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  32. 32. MATRICES Seudocódigo <NOMBRE> : matriz [<N>][<M>] de <TIPO> C++ <TIPO> <NOMBRE>[<N>][<M>]; CODIFICACIÓN EN C++ Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices
  33. 33. FIN Gracias por la atención prestada Facultad Ingeniería Departamento de Ingeniería de Sistemas e Industrial UN - Virtual 2008 Módulo 4 Arreglos, cadenas y matrices

×