• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Yui3.3.0 node
 

Yui3.3.0 node

on

  • 914 views

 

Statistics

Views

Total Views
914
Views on SlideShare
914
Embed Views
0

Actions

Likes
1
Downloads
3
Comments
0

0 Embeds 0

No embeds

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Yui3.3.0 node Yui3.3.0 node Presentation Transcript

    • YUI3.3.0 Node API
      霸先@F2E
    • Node
      node-base
      node-deprecated
      node-event-delegate
      node-event-html5
      node-event-simulate
      node-load
      node-pluginhost
      node-screen
      node-style
      align-plugin
      shim-plugin
    • node-base
      将原生dom封装为YUI3的Node和NodeList实例,并提供像操作dom一样来操作Node和NodeList的方法
      requires:['dom-base', 'selector-css2', 'event-base']
    • node-deprecated
      这个模块里放的是不推荐使用的方法,这些方法将在未来版本的YUI里移除
      requires:[‘node-base’]
    • node-deprecated
    • node-event-delegate
      让node支持事件代理delegate方法
      requires:['node-base', 'event-delegate']
    • node-event-delegate
    • node-event-html5
      让node支持html5事件
      requires:['node-base']
    • node-event-simulate
      在node上模拟指定事件
      requires:['node-base']
    • node-event-simulate
    • node-load
      可以使用io动态替换node内容
      requires:['node-base', 'io-base']
    • node-load
    • node-pluginhost
      node支持插件功能
      requires:['node-base', 'pluginhost']
    • node-pluginhost
    • node-screen
      node在屏幕上的一些属性
      requires:['dom-screen']
    • node-screen
    • node-style
      node操作样式相关js
      requires:['dom-style', 'node-base']
    • node-style
    • align-plugin
      对齐插件,将节点对齐到指定节点或者一个区域
      requires:['node-screen']
    • align-plugin
    • shim-plugin
      给指定节点添加shim
      requires:['node-style', 'node-pluginhost']
    • shim-plugin
    • END