ALGORITMO                     PSEUDOCODIGOENTRADA: Ingresar el radio de    INICIOel circulo.                              ...
ALGORITMO                   PSEUDOCODIGO                               INICIOENTRADA: Introducir cuatrocalificaciones que ...
ALGORITMO                     PSEUDOCODIGO                                 INICIOENTRADA: se ingresan dosvalores numericos...
Ejercicio " G " : dado el costo de un articulo vendido y la    cantidad de dinero entregada por el cliente, calcular e    ...
"   "         ALGORITMO                       PSEUDOCODIGOENTRADA: ingresar el nombre     INICIOdel dinosaurio, pero &    ...
Ejercicio ¨K¨ : dados los 3 lados de un triangulo, pueda    determinar su área.    Área= √S*(S-L1)*(S-L2)*(S-L3)    S= (L1...
Ejercicio "L" : calcular la distancia entre dos puntos dados como    dato las coordenadas de los puntos P1 & P2    D = √(X...
Ejercicio " B " : Realizar la conversion de:grados centigrados – grados farenheit →°C (1.8) + 32 = °F       ALGORITMO     ...
SI NO                                                          SI (num=7) ENTONCES                                        ...
   Algoritmo   Entrada:   sueldo: variable real para    guardar el sueldo inicial                                     ...
   Algoritmo                             Pseudocodigo   Entrada:                                          ESCRIBIR (“Da...
    Algoritmo                                          PseudocodigoEntrada:                              INICIO>variable...
   
Practicas (pseudocodigos & algoritmos)
Practicas (pseudocodigos & algoritmos)
Practicas (pseudocodigos & algoritmos)
Practicas (pseudocodigos & algoritmos)
Practicas (pseudocodigos & algoritmos)
Practicas (pseudocodigos & algoritmos)
Practicas (pseudocodigos & algoritmos)
Practicas (pseudocodigos & algoritmos)
Upcoming SlideShare
Loading in …5
×

Practicas (pseudocodigos & algoritmos)

1,581 views
1,460 views

Published on

Published in: Education
0 Comments
4 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
1,581
On SlideShare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
60
Comments
0
Likes
4
Embeds 0
No embeds

No notes for slide

Practicas (pseudocodigos & algoritmos)

  1. 1. ALGORITMO PSEUDOCODIGOENTRADA: Ingresar el radio de INICIOel circulo. ESCRIBIR (¨cuanto mide suPROCESO: guardar en la radio?¨)variable ¨área¨ la operaciónde tres punto catorce LEER (r)dieciséis por el radio al área← 3.1416 * radio²cuadrado, y en la variable perimetro←3.1416 *(radio¨perímetro¨ el tres punto + radio)catorce dieciséis por radiomas radio en paréntesis. ESCRIBIR (¨área, perímetro¨)SALIDA: Imprimir en pantallael valor del área & perímetro. FIN
  2. 2. ALGORITMO PSEUDOCODIGO INICIOENTRADA: Introducir cuatrocalificaciones que se deseen ESCRIBIR (“escriba cuatropromediar. calificaciones que desee promediar de su materia:”)PROCESO: sumar las cuatrocalificaciones y dividirlas LEER (C1, C2, C3, C4)entre cuatro. Suma ← C1+C2+C3+C4SALIDA: dar el resultado delpromedio. Promedio ← Suma / 4 ESCRIBIR (Promedio) FIN
  3. 3. ALGORITMO PSEUDOCODIGO INICIOENTRADA: se ingresan dosvalores numericos, que sin ESCRIBIR (“ingresa dosrepresentados por las letras A numeros: ”)y B. LEER (A, B)PROCESO: primeramente, losdos valores se suman, Suma ← A + Bdespues el numero semultiplica por si mismo y se Resultado ← (Suma *divide entre tres. Suma) /3SALIDA: se imprime el Total ← Resultadoresultado de todas lasoperaciones. ESCRIBIR (Total) FIN
  4. 4. Ejercicio " G " : dado el costo de un articulo vendido y la cantidad de dinero entregada por el cliente, calcular e imprimir el cambio que se debe entregar. ALGORITMO PSEUDOCODIGOENTRADA: ingresar el costo INICIOdel articulo vendido y eldinero con el que se pagó. ESCRIBIR (¨cual es el costo del producto que deseaPROCESO: determinar el adquirir?¨)cambio, restándole al dineroque pagó el costo del LEER (precio)producto. ESCRIBIR (¨Ingrese su pagoSALIDA: imprimir en pantalla a continuación: ¨)el cambio que deberárecibir. LEER (pago) Cambio ← pago – precio ESCRIBIR (cambio) FIN
  5. 5. " " ALGORITMO PSEUDOCODIGOENTRADA: ingresar el nombre INICIOdel dinosaurio, pero & ESCRIBIR (¨Como se llama ellongitud en libras y pies. dinosaurio?¨)PROCESO: convertir las libras LEER (nombre)en kilogramos, y los pies en ESCRIBIR (¨Ingrese su peso en libras: ¨)metros. LEER (peso)SALIDA: imprimir en pantalla ESCRIBIR (¨Ingrese su longitud enel nombre del dinosaurio y su pies: ¨)peso y longitud en kilogramosy metros. LEER (longitud) Kg ← peso / 0.454 M ← longitud / .3048 ESCRIBIR (Kg, M) FIN
  6. 6. Ejercicio ¨K¨ : dados los 3 lados de un triangulo, pueda determinar su área. Área= √S*(S-L1)*(S-L2)*(S-L3) S= (L1+L2+L3) / 2 ALGORITMO PSEUDOCODIGOENTRADA: Ingresar tres lados deun triangulo. INICIOPROCESO: primero, con los datos ESCRIBIR (¨Ingrese los tresdados, determinamos el valor de lados de un triangulo: ¨)¨S¨ sumando los tres lados, ydividiendo ese resultado entre LEER (L1, L2, L3)dos.Después determinamos el áreasacando la raíz cuadrada de ¨S¨ S ← (L1+L2+L3) /2por el resultado de ¨S¨ menos elprimer lado, lo que resulte lo Área √S*(S-L1)*(S-L2)*(S-multiplicamos por el resultado de L3)¨S¨ menos el lado dos, y eso lomultiplicamos por el resultado de ESCRIBIR (Área)¨S¨ por el lado tres. FINSALIDA: Imprimir en pantalla elresultado del área de esos treslados dados.
  7. 7. Ejercicio "L" : calcular la distancia entre dos puntos dados como dato las coordenadas de los puntos P1 & P2 D = √(X1 – X2)² + (Y1-Y2)² ALGORITMO PSEUDOCODIGO INICIOENTRADA: Ingresar los cuatrodatos de las dos ESCRIBIR (¨Dame los 4coordenadas. puntos de coordenadas: ¨)PROCESO: sacar la distancia LEER ( X1, X2, Y1, Y2)mediante la formula de la raizcuadrada del resultado de la D ← √(X1 – X2)² + (Y1-Y2)²resta de X1 – X2 al cuadradomas Y1 – Y2 al cuadrado. ESCRIBIR (D)SALIDA: Imprimir en pantalla FINla distancia.
  8. 8. Ejercicio " B " : Realizar la conversion de:grados centigrados – grados farenheit →°C (1.8) + 32 = °F ALGORITMO PSEUDOCODIGO INICIOENTRADA: se ingresa latemperatura en grados ESCRIBIR (“cuantos gradoscentigrados. centigrados desea convertir?”)PROCESO: los gradoscentigrados los multiplicas LEER (c)por 1.8 y les sumas 32. Fahrenheit ← (c * 1.8) +32SALIDA: se imprime latemperatura en grados ESCRIBIR (Fahrenheit)farenheit. FIN
  9. 9. SI NO SI (num=7) ENTONCES ESCRIBIR (“siete”) ALGORITMO:  Pseudocodigo SI NO INICIO SI (num=8) ENTONCES Entrada: Num: variable ESCRIBIR (“Escriba su ESCRIBIR (“ocho”) real para guardar el número”) SI NO LEER (num) numero SI (num=9) ENTONCES SI (num=1) ENTONCES Proceso: utilizar el SI, SI ESCRIBIR (“uno”) ESCRIBIR (“nueve”) NO y “ESCRIBIR” para SI NO SI (num=2) ENTONCES SI NO ESCRIBIR (“diez”) escribir los numeros con ESCRIBIR (“dos”) FIN SI letra SI NO FIN SI SI (num=3) ENTONCES Salida: Desplegar los ESCRIBIR (“tres”) FIN SI numeros con letra SI NO FIN SI SI (num=4) ENTONCES FIN SI ESCRIBIR (“cuatro”) FIN SI SI NO FIN SI SI (num=5) ENTONCES ESCRIBIR (“cinco”) FIN SI SINO FIN SI SI (num=6) ENTONCES FIN SI ESCRIBIR (“seis”) FIN
  10. 10.  Algoritmo Entrada: sueldo: variable real para guardar el sueldo inicial  Pseudocodigo Aumento: variable real para INICIO guardar aumento ESCRIBIR (“Cual es tu sueldo?”) Nvosueldo: variable real para LEER (sueldo) guardar el nuevo sueldo SI (sueldo < 1000) ENTONCES Proceso: si el sueldo es aumento← (sueldo*15)/100 menor a 1000, obtenemos el nvosueldo (aumento+sueldo) 15% del sueldo inicial. IMPRIMIR (nvosueldo) Salida:Imprimir el nuevo FIN SI sueldo ya con el aumento FIN
  11. 11.  Algoritmo  Pseudocodigo Entrada: ESCRIBIR (“Dame tres numeros“) Variable real NUM 1: para numero 1 Variable real NUM 2: para numero 2 LEER (num1, num2, num3) Variable real NUM 3: para numero 3 Si (num1>num2) ENTONCES mayor ← num1 Proceso: utilizar el SI SINO ENTONCES SINO para mayor ← NUM2 comparar ambos numeros FIN SI Salida:Imprimir cual numero SI (mayor>num3) Entonces es mayor Escribir (“Tu numero mayor es:“), mayor; Sino Escribir (“Tu numero mayor es:", num3; FinSi FinProceso
  12. 12.  Algoritmo  PseudocodigoEntrada: INICIO>variable real precio: para precio ESCRIBIR ("Cual es el precio de su producto“?) inicial LEER (precio)> Variable real desc: para SI (precio<600) ENTONCES descuento ESCRIBIR (PRECIO)>Variable Prefinal: para precio SI NO final SI (precio<900) ENTONCES desc← (precio*5)/100> Desc2: descuento para el 10% prefinal ← precio-desc) de descuento ESCRIBIR (prefinal)> Prefinal2: precio final 2 para el SI NO 10% de descuento desc2 ←(precio*10)/100Proceso: si el precio es mayor o prefinal2 ←(precio-desc2) = a 600 y menos que 900 IMPRIMIR (prefinal2) sacamos el 5% de FIN SI descuento, y si es mayor o = FIN SI hacemos un 10% de FIN SI descuentoSalida: imprimir el precio final 1, o 2,despendiendo del descuento y cantidad
  13. 13.  

×