Pseint   pseudocodigo
Upcoming SlideShare
Loading in...5
×
 

Like this? Share it with your network

Share

Pseint pseudocodigo

on

  • 543 views

Conceptos básicos Pseudocógico

Conceptos básicos Pseudocógico

Statistics

Views

Total Views
543
Views on SlideShare
519
Embed Views
24

Actions

Likes
1
Downloads
15
Comments
0

1 Embed 24

https://twitter.com 24

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

Pseint pseudocodigo Presentation Transcript

  • 1. PSEINT Programación con Pseudocódigo Eliana Navarro Julio
  • 2. DEFINICIÓN  Es una descripción informal1 de alto nivel de un algoritmo.  utiliza las convenciones estructurales de un lenguaje de programación verdadero.  Está diseñado para la lectura humana.  Independencia de cualquier lenguaje de programación. otro
  • 3. Lenguaje de programación se formula un computador. algoritmo  Ejecutar En un Llevar a cabo nuestro  Indicárselo siguiendo un conjunto de instrucciones y reglas que este entienda, y estas instrucciones son abstraídas.
  • 4. Programa Es un algoritmo codificado siguiendo un lenguaje de programación. Antes de aprender un lenguaje de programación  metodología de programación (Estrategias). Punto de partida: Algoritmo. ¿Cómo se representan? Pseudocódigo y diagramas de flujo.
  • 5. DF
  • 6. PSEUDOCÓDIGO
  • 7. lugares de memoria en los cuales se almacena algún tipo de Inf.
  • 8.  Nombre del programa.
  • 9. EJEMPLO NÚMEROS IGUALES Proceso Iguales Escribir "Digitel el primer número: "; Leer n1; Escribir "Digite el segundo número: "; Leer n2; Si n1 = n2 Entonces Escribir "Los números son iguales"; Sino Escribir "Los números son diferentes"; Fin Si FinProceso
  • 10. SUMA Y PRODUCTO DE DOS NÚMEROS Proceso SumaYProducto Escribir "Ingrese Nota 1"; Leer N1; Escribir "Ingrese Nota 2"; Leer N2; Suma<-N1+N2; producto<-N1*N2; Escribir "La suma de las notas es: " suma; Escribir "El producto de las notas es: " producto; FinProceso
  • 11. SALUDAR CON NOMBRE Proceso saludar Escribir "Hola, regálame tu nombre: "; Leer nombre; Escribir "Hola, Tu nombre es: ", nombre, ", es un placer saludarte."; FinProceso
  • 12. 19/02/14 PSEINT
  • 13. 19/02/14 SI - ENTONCES Condición que vamos a evaluar, para decidir que Acciones ejecutar. Acciones si la condición es verdadera. Acciones si la condición es falsa.
  • 14. EJEMPLO  Validar la IGUALDAD entre dos números. 10 puntos.
  • 15. SEGÚN HACER Variable a evaluar. Posibles valores de la variable numérica. Acciones si la condición es verdadera. Conjunto de acciones a ejecutar si el valor de la variable no coinciden con el conjunto de opciones
  • 16. EJEMPLO  Según el GRADO, definir la sección a la que pertenece 10 puntos.