Presentacion Pseint

  • 10,180 views
Uploaded on

 

  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Be the first to comment
No Downloads

Views

Total Views
10,180
On Slideshare
0
From Embeds
0
Number of Embeds
0

Actions

Shares
Downloads
155
Comments
0
Likes
1

Embeds 0

No embeds

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
    No notes for slide

Transcript

  • 1. Universidad José Antonio Paéz COMO REALIZAR ALGORITMOS UTILIZANDO PSEINT Yamilitza Camacho
  • 2. PSeInt es la abreviatura de Pseudo Intérprete, un editor de programación diseñado específicamente para estudiantes que quieran comprender la lógica de la programación sin conocimientos previos de la materia. PSeInt incluye en su editor diversas herramientas para que podamos crear y almacenar programas en este peculiar lenguaje, ejecutarlos directamente desde su interfaz, o incluso corregir posibles defectos que encontremos en su desarrollo. DEFINICIÒN
  • 3.
    • CARACTERÍSTICAS DE PSEINT:
      • Presenta herramientas de edición básicas para escribir algoritmos en pseudocodigo en español
    • Permite la edición simultánea de múltiple algoritmos
    • Presenta ayudas para la escritura
        • Autocompletado
    • Ayudas Emergentes
    • Plantillas de Comandos
    • Coloreado de Sintaxis
  • 4.
      • Puede ejecutar los algoritmos escritos
    • Permite ejecutar el algoritmo paso a paso controlando la velocidad e inspeccionando expresiones
    • Puede confeccionar automáticamente la tabla de prueba de escritorio
    • Determina y marca los errores de sintaxis y en tiempo de ejecución
    • Genera diagramas de flujo a partir del algoritmo escrito
    FUNCIONALIDADES DE PSEINT:
  • 5. Proceso sin_titulo // Juego simple que pide al usuario que adivine un numero en 5 intentos intentos<-5; num_secreto <- azar(100)+1; Escribir &quot;Adivine el numero (de 1 a 100):&quot;; Leer num_ingresado; Mientras num_secreto<>num_ingresado & intentos>0 Hacer Si num_secreto>num_ingresado Entonces Escribir &quot;Muy bajo&quot;; Sino Escribir &quot;Muy alto&quot;; FinSi Escribir &quot;Le quedan &quot;,intentos,&quot; intentos:&quot;; Leer num_ingresado; intentos <- intentos-1; FinMientras Si intentos=0 Entonces Escribir &quot;El numero era: &quot;,num_secreto; Sino Escribir &quot;Exacto! Usted adivino en &quot;,11-intentos,&quot; intentos.&quot;; FinSi FinProceso EJERCICIO A REALIZAR
  • 6. PANTALLA PRINCIPAL
  • 7. EJEMPLO EN PSEINT
  • 8. DIAGRAMA DE FLUJO CON PSEINT
  • 9. EJECUCIÒN DEL EJEMPLO
  • 10.