• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Funciones logicas y anidadas
 

Funciones logicas y anidadas

on

  • 20,490 views

 

Statistics

Views

Total Views
20,490
Views on SlideShare
20,488
Embed Views
2

Actions

Likes
1
Downloads
498
Comments
3

1 Embed 2

http://jessymedinfor.blogspot.com 2

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel

13 of 3 previous next Post a comment

  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Funciones logicas y anidadas Funciones logicas y anidadas Presentation Transcript

    • MICROSOFT EXCEL 20071 FUNCIONES LOGICAS Y ANIDADAS Computación e Informática Ingº Ernesto Nicho Córdova
    • FUNCIONES LÓGICAS SIDevuelve un valor si la condición especificada es VERDADERO y otro valor si dicho argumento es FALSO. Utilice SI para realizar pruebas condicionales en valores y fórmulas. Sintaxis SI(prueba_lógica;valor_si_verdadero;valor_si_falso) Prueba_lógica es cualquier valor o expresión que pueda evaluarse como VERDADERO o FALSO. Numero de personas atendidas en la Tiendas XYZ en una semana Sucursal Lunes Martes Miércoles Jueves Viernes Sábado Domingo Prom Estado Sucursal San Jose 45 30 50 35 70 85 75 Sucursal Balta 50 55 45 50 80 160 80 Sucursal Open Plaza 120 110 100 150 180 250 200 Sucursal Real plaza 150 160 130 160 170 300 250 Todas las sucursales que hallan atendido en promedio a mas de 60 personas, se les denominará "Eficiente", de lo contrario será "Deficiente" 2 Ing. Ernesto Nicho Córdova
    • FUNCIONES LÓGICAS Ejercicios adicionales Sucursal Miércoles Vendedor Sexo BonificaciónSucursal San Jose 50 Erlita FSucursal Balta 45 María FSucursal Open Plaza 100 Juan MSucursal Real plaza 130 Yuly FTodos los vendedores que han atendido 50 o mas personas el dia miercoles, se les dará unabonificación de 100 Soles, de lo contrario no tendran bonificación Sueldo Nuevo Sucursal Vendedor Sexo Semanal SueldoSucursal San Jose Erlita F 155.71Sucursal Balta María F 174.29Sucursal Open Plaza Juan M 258.57Sucursal Real plaza Yuly F 188.57Todas las vendedoras que hallan atendido en esta semana, tendrán una bonificación del 35%del sueldo semanal que percibe. Cuanto será el nuevo sueldo semanal. 3 Ing. Ernesto Nicho Córdova
    • FUNCIONES ANIDADAS Excelpermite el utilizar funciones como uno de los argumentos de otra función, esto se conoce como funciones anidadas. Por ejemplo:=SI(PROMEDIO(A1:A10)>50;SUMA(B1:B10);0)La siguiente función SI compara con 50 el resultado producido por la función PROMEDIO (función anidada), si es mayor a 50, invoca a la función SUMA (función anidada). 4 Ing. Ernesto Nicho Córdova
    • LÍMITES DEL NIVEL DE ANIDAMIENTOUna fórmula puede contener como máximo siete niveles de funciones anidadas.Si la Función B se utiliza como argumento de la Función A, la Función B es una función de segundo nivel. Por ejemplo, la función PROMEDIO y la función SUMA del ejemplo son ambas funciones de segundo nivel porque son argumentos de la función SI. Una función anidada dentro de la función PROMEDIO será una función de tercer nivel, etc. Primer Nivel=SI(PROMEDIO(A1:A10)>50;SUMA(B1:B10);0) Segundo Nivel 5 Ing. Ernesto Nicho Córdova
    • RESULTADOS VÁLIDOS Cuando se utiliza una función anidada como argumento, ésta deberá devolver el mismo tipo de valor que el que utilice el argumento.Ejm.=SI(PROMEDIO(A1:A10)>50;SUMA(B1:B10);0)La función PROMEDIO(A1:A10) deberá darnos como resultado un:“número” (ejem. 20, 70, etc.) X o un texto (ejem. PEDRO) 6 Ing. Ernesto Nicho Córdova
    • EJERCICIO Nº 1 Obtenerel promedio de los alumnos, solo de aquellos que no tengan 2 o mas notas desaprobadas (la nota aprobatoria debe ser mayor o igual a catorce Alumno Nota 1 Nota 2 Nota 3 Nota 4 PromedioJuan 15 14 18 12Pedro 12 18 13 15Maria 18 10 15 20Tomas 14 17 15 17Yuly 18 13 18 12Naomi 16 14 15 17Luis 13 16 10 16 7 Ing. Ernesto Nicho Córdova
    • EJERCICIO Nº 2 Todas los vendedores que hallan atendido en promedio a mas de 60 personas y son mujeres, tendrán una bonificación de 100 soles, de lo contrario tendrán una bonificación de 50 soles. Sucursal Vendedor Sexo Promedio Semanal Bonificación Sucursal San Jose Erlita F 55.71 Sucursal Balta Maria F 74.29 Sucursal Open Plaza Juan M 158.57 Sucursal Real plaza Yuly F 188.57 Condición principal SI Promedio semanal >= 60 Si cumple No cumple (Promedio >= 60) (Promedio < 60)Condición secundaria SI Sexo = “F” S/. 50 Si cumple No cumple (Sexo = “F”) (Sexo = “M”) 8 S/. 100 S/. 50 Ing. Ernesto Nicho Córdova
    • EJERCICIO Nº 2 Todas los vendedores que hallan atendido en promedio a mas de 60 personas y son mujeres, tendrán una bonificación de 100 soles, de lo contrario tendrán una bonificación de 50 soles. Sucursal Vendedor Sexo Promedio Semanal Bonificación Sucursal San Jose Erlita F 55.71 Sucursal Balta Maria F 74.29 Sucursal Open Plaza Juan M 158.57 Sucursal Real plaza Yuly F 188.57 Condición principal SI Promedio semanal >= 60 Si cumple No cumple =SI(D2>=60,SI(C2=“F”,100,50),50) (Promedio >= 60) (Promedio < 60)Condición secundaria SI Sexo = “F” S/. 50 Si cumple No cumple (Sexo = “F”) (Sexo = “M”) 9 S/. 100 S/. 50 Ing. Ernesto Nicho Córdova
    • FUNCIONES DE BÚSQUEDA BUSCARV – BUSCARH Busca un valor específico en la columna más a izquierda de una matriz y devuelve el valor en la misma fila de una columna especificada en la tabla. Utilice BUSCARV en lugar de BUSCARH cuando los valores de comparación se encuentren en una columna situada a la izquierda de los datos que desea encontrar. La V de BUSCARV significa "Vertical". Sintaxis BUSCARV(valor_buscado;matriz_buscar_en;indicador_columnas;ordenado) =BUSCARV(C10,C4:E7,2,FALSO) Es el valor que La matriz en la N de Columna Falso: Valor vamos a búscar y tabla, sin los en donde esta el exacto. que en la matriz esta encabezados valor asociado Verdadero: Valor en la columna de la aproximado extrema izquierda 10 Ing. Ernesto Nicho Córdova
    • FUNCIONES DE BÚSQUEDA 1 2 3 BUSCARV – BUSCARH Busca un valor específico en la columna más a izquierda de una matriz y devuelve el valor en la misma fila de una columna especificada en la tabla. Utilice BUSCARV en lugar de BUSCARH cuando los valores de comparación se encuentren en una columna situada a la izquierda de los datos que desea encontrar. La V de BUSCARV significa "Vertical". Sintaxis Se ingresa valor Insertar Función BuscarV Insertar Función BuscarV BUSCARV(valor_buscado;matriz_buscar_en;indicador_columnas;ordenado) =BUSCARV(C10,C4:E7,2,FALSO) Es el valor que La matriz en la N de Columna Falso: Valor vamos a búscar y tabla, sin los en donde esta el exacto. que en la matriz esta encabezados valor asociado Verdadero: Valor en la columna de la aproximado extrema izquierda 11 Ing. Ernesto Nicho Córdova
    • FUNCIONES DE BÚSQUEDA EjercicioParte a) Ingrese el nombre de la sucursal y muestre las personas atendidas el día miércolesParte b) Ingrese el día y muestre los atendidos en la sucursal Real Plaza Numero de personas atendidas en la Tiendas XYZ en una semana Sucursal Lunes Martes Miércoles Jueves Viernes Sábado Domingo Sucursal San Jose 45 30 50 35 70 85 75 Sucursal Balta 50 55 45 50 80 160 80 Sucursal Open Plaza 120 110 100 150 180 250 200 Sucursal Real plaza 150 160 130 160 170 300 250 Ingrese Sucursal: Atendidos el Miércoles Ingrese Día: 12 Atendidos Real Plaza Ing. Ernesto Nicho Córdova
    • FUNCIONES DE BÚSQUEDAFunción BuscarV – BuscarH… mas ejercicios Tabla de Productos Código Producto Precio Descto PR01 Pantalones 80 15% PR02 Camisas 55 5% PR03 Polos 25 10% PR04 Medias 5 0% Ingrese Código Ingrese Cantidad Total Compra Descuento Total a Pagar 13 Ing. Ernesto Nicho Córdova
    • EJERCICIO DE APLICACIÓN 14 Ing. Ernesto Nicho Córdova
    • INSTRUCCIONES DE LA APLICACIÓN CODIGO ITEM P/CAJA P001 CERVEZA CRISTAL S/. 48.00 P002 CERVEZA PILSEN S/. 45.00 P003 CERVEZA AREQUIPEÑA S/. 44.00 P004 CERVEZA CUSQUEÑA S/. 42.00 P005 GASEOSA COCA COLA S/. 25.00 P006 GASEOSA INKA COLA S/. 24.00 P007 GASEOSA KOLA REAL S/. 24.00 Transporte S/. 20.00 Descuento 8% I.G.V. 19% Con solo ingresar el código, el concepto y el precio del producto deben mostrarse, utilizar la tabla mostrada. Realizar las operaciones necesarias para obtener el importe, subtotal e IGV. Si el subtotal sobrepasa los S/. 100 y tiene descuento de 8%. Si transporte dice “Si”, se adicionará 20 soles al total de la factura. 15 Ing. Ernesto Nicho Córdova