Presentacion xlogo
Upcoming SlideShare
Loading in...5
×
 

Like this? Share it with your network

Share

Presentacion xlogo

on

  • 580 views

 

Statistics

Views

Total Views
580
Views on SlideShare
580
Embed Views
0

Actions

Likes
0
Downloads
3
Comments
0

0 Embeds 0

No embeds

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

Presentacion xlogo Presentation Transcript

  • 1. Universidad PedagogicaNacional Francisco MorazánPREUFOD
  • 2. PROCEDIMIENTOS¿Que es un procedimiento?En programación, es un tipo de subrutina. Porción decódigo dentro de un programa más grande, querealiza una tarea específica y es relativamenteindependiente del resto del código.En logo es una forma de enseñarle hacer algo.Los procedimientos al ser llamados ejecutan unaserie de instrucciones, almacenados ya sean de Logoo otros procedimientos.
  • 3. IMPORTANCIA• ¿En que ayudan los procedimientos?• Los procedimientos ayudan a agilizar la rapidez en laprogramación ya que almacena partes de códigos oprimitivas de uso frecuente.
  • 4. EJEMPLOPara cocinar un huevo nosotros debemos:Conectar la cocinaSacar la sarténPoner la sartén en la cocinaEncender el disco de la cocinaTomar un huevoRomperloEcharlo en una tasaDe la tasa a la sarténOpcionalmente echamos salEsperamos a que esté bien cocinadoDesconectamos el discoTomar la sartén por el mangoAcercar la sartén al plato donde colocaremos el huevoMover el huevo de la sartén al plato usando algún utensilio, como untenedorColocar la sartén en la cocina o bien en el fregaderoetc
  • 5. por supuesto, nosotros ya sabemos toda esa lista de instrucciones, noes necesario que nos las digan cuando quieren que cocinemos unhuevo, simplemente nos dicen "Cocinen un huevo". De manera similar,en Logo no es necesario darle todas las instrucciones cada vez quequeremos hacer algo. Para esto existen los procedimientos.
  • 6. Podemos hacer que logo aprenda nuevas primitivas, definiendoprocedimientos .Para definir procedimientos en logo se debe de iniciar con laprimitiva para seguido del nombre que se le dará al procedimientoeste nombre debe de estar en relación con lo que ejecutara.EJEMPLO:para elaborar un cuadrado introducimos en la caja de comandos losiguiente:para cuadradorepite 4[ avanza 100 giraderecha 90]finhemos definido un procedimiento con el nombre cuadrado que trazara enla pantalla principal en el area de dibujo.Para circulrepite 360[av 1 gd 1]finEJECUTANDO PROCEDIMIENTOS
  • 7. Para triangulargi 90 av 210 gd 120 av 210 gd 120 av 210finPara triangulargi 90 Repite 3[av 210 gd 120]fin
  • 8. Para romboTambiénpara rombo3repite 7[ gd 41 av 100 gd 45 av 100 gd 135 av 100 gd 45 av 100 gd145 ]
  • 9. SUB -PROCEDIMIENTOSSon procedimientos dentro de otros procedimientosAl combinar procedimientos se puede hacer queestos llamen a otrosEjemplo de cuadradoPrimero se define el primer procedimiento:Para cuadradoRepite 4 [avanza 100 gd 100]FinSe cuadradosRepite 10 [cuadrado gi 30]fin
  • 10. SUB -PROCEDIMIENTOS
  • 11. • Cuando tenemos que dibujar una figura varias veces pero condistintas dimensiones necesitaríamos muchos procedimientos, espor eso que necesitaríamos una forma mas fácil de definir eseprocedimiento y eso es posible por medio de las variables.VARIABLES PROCEDIMIENTOS CONARGUMENTOS
  • 12. Muchas veces se necesita dibujar una misma figura variasveces, pero con distintas dimensiones.Por ejemplo,si queremos dibujar un cuadrado de lado 100, otro de lado 200y un tercero de lado 50, con lo que sabemos hasta ahoranecesitaremos tres procedimientosdistintos:para cuadrado 1repite 4 [avanza 100 giraderecha 90]finpara cuadrado 2repite 4 [avanza 200 giraderecha 90]finpara cuadrado 3repite 4 [avanza 50 giraderecha 90]fin
  • 13. Es evidente que necesitamos una forma mas simple dehacerlo, y que deberá ser posible definir un únicoprocedimiento que, de algún modo,permitiera cambiar el argumento de la primitiva avanza,es decir, el lado del cuadrado.Ese es el papel de las variables.
  • 14. Primitivas asociadasDescripción Primitiva Ejemplo:Fíjate en la diferencia:Para definir la variable, se antepone “Para leer la variable, se precede de :(es la forma mas cómoda de las tres posibles)cosa "a, objeto "a y :a son notaciones equivalentes.
  • 15. Aunque lo detallaremos mas adelante, debemos comentarque XLogo trata de distinta forma los números, laspalabras y las frases.Para distinguir cuando una variable almacenada a un tipodistinto, debemos usar un vocabulario especifico:• Numero: Para guardar en la variable lado el valor 100:haz "lado 100• Palabra: Para guardar en la variable animal la palabraGATO:haz "animal "GATO• Frase: Para guardar en la variable descripción la fraseEl gato es gris:haz "descripción [El gato es gris]
  • 16. Si el valor que guarda la variable es un numero, puedeoperarse con ella igual que con un numero:Ejemplo:haz "lado 100avanza :ladoe incluso pueden usarse para definir otras:que dibuja un rectángulo de base doble que laaltura:
  • 17. Procedimientos con variablesRecuperando nuestro procedimiento cuadrado:Recuperando nuestro procedimiento cuadrado:para cuadradorepite 4 [avanza 100 giraderecha 90 ]FinIntroducir variables es muy simple:• Indicamos cual va a ser la variable, de nuevo, conun nombre adecuado : lado• Sustituimos el valor numérico que nos interesa porla variable.
  • 18. Utilizando Variable, El resultado es:para cuadradorepite 4 [ avanza 100 giraderecha 90 ]FinProcedimiento Cuadrado sin Variable:
  • 19. Que dibuja, como ya abras adivinado, un cuadrado.La diferencia esta en que ahora el lado es desconocido, ydebemos indicarle a la tortuga cuanto debe medir:cuadrado 30, cuadrado 50, cuadrado 250dibujaran cuadrados de:lados 30, 50 y 250, respectivamente:Podemos prever:=
  • 20. Conceptosacerca de variablesHay dos tipos de variables:Hay dos tipos de variables:• Variables globales: están siempre accesibles desdecualquier parte del programa.• Variables locales: solo son accesibles dentro delprocedimiento donde fueron definidas.
  • 21. • En esta implementación del lenguaje Logo, lasvariables locales no son accesibles desde otro subprocedimiento.• Al finalizar el procedimiento, las variables localesson eliminadas.Las primitivas asociadas son:
  • 22. • Supongamos que en el ultimo ejercicio de la secciónanterior quisiéramos controlar la separación entre ruedaspara evitar que se superpongan unas con otras.• Podremos hacer que distancia fuera siempre algo masdel doble que largo, para lo que planteamos dossubprocedimientos distintos:
  • 23. • Observa que se usan tres variables relacionadas con lalongitud: largo, radio y distancia.Al ejecutar el programa tecleando:Borra pantalla ruedas 3 100la tortuga lee largo, y le asigna el valor 100. Sin embargo,radio solo existe "mientras seesta ejecutando el procedimiento rueda y desaparece“ alfinalizar este.Puedes comprobarlo modificando el procedimiento
  • 24. Desde la Línea de Comandos• Los procedimientos pueden ser creados y borradosdesde la Línea de Comandos.• Igualmente, podemos determinar cuales han sido yadefinidos y cuales no o ejecutar una serie de ordenessin necesidad de crear un procedimiento asociado.
  • 25. La primitiva defineCrea un nuevo procedimiento sin usar el Editor. Para ellodebemos proporcionar el nombre, las variables y lasinstrucciones a ejecutar:•define nombre [variables] [instrucciones]Por ejemplo:define "cuadrado [lado] [repite 4 [ avanza :lado giraderecha90]]crea el procedimiento cuadrado con el que ya hemostrabajado antes.
  • 26. Las primitivas borra y borratodo• La primitiva borra elimina el procedimiento indicado.La sintaxis es:• borra nombrePor ejemplo:• borra "cuadradoElimina el procedimiento cuadrado definido antes.• Por su parte, borratodo, sin argumentos, eliminatodas las variables y procedimientos actuales.
  • 27. La primitiva texto• Si deseamos conocer la información asociada a unprocedimiento, tecleamos:escribe texto nombre_proc• La primitiva texto devuelve una lista que contiene toda lainformación asociada al procedimientoindicado.Concretamente, devuelve una lista que contiene sub{listas:• La primera lista contiene todas las variables fijas yopcionales del procedimiento.• Las demás sub-listas son las líneas del procedimiento.
  • 28. La primitiva listaprocs• Esta primitiva no necesita argumentos, y enumeratodos los procedimientos definidos hasta ese momentoen el Histórico de Comandos. Por compatibilidad conotros interpretes;• Logo, se admite imts (imprime todos) con la mismafunción.
  • 29. La primitiva ejecuta• Tecleando ejecuta [lista], las ordenes contenidas en listason ejecutadas consecutivamente.• Por ejemplo:giraizquierda 27ejecuta [ repite 5 [ repite 4[ avanza 100 giraizquierda90 ] giraderecha 72 ] ]proporciona:
  • 30. GRACIAS POR SUATENCION