• Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Be the first to comment
No Downloads

Views

Total Views
33,526
On Slideshare
0
From Embeds
0
Number of Embeds
0

Actions

Shares
Downloads
542
Comments
0
Likes
5

Embeds 0

No embeds

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
    No notes for slide

Transcript

  • 1. Leia um numero e calcule o seu fatorial.Algoritmo Fatorial;DeclareVar fat, n, i :inteiro;Inícioescreva (‘Digite um número para calcular seu fatorial’);leia (n);fat←1;para i←1 até n façafat←fat*i;fimpara;escreva (‘O fatorial de ’ , n , ‘ é ’ , fat);Fim.Ler 80 números e ao final informar quantos número(s) est(á)ão no intervalo entre 10 (inclusive) e 150(inclusive).1. Algoritmo;DeclareVar i, c :inteiro;Inícioc←0;para i←1 até 80 façaescreva (‘Digite um número ’);leia (n);se n >=10 e n<=150então c←c+1;fimse;fimpara;escreva (‘Estão no intervalo de 10 a 150 ’ , c , ‘ números’ );Fim.
  • 2. Faça um algoritmo que receba a idade de 75 pessoas e mostre mensagem informando “maior deidade” e “menor de idade” para cada pessoa. Considere a idade a partir de 18 anos como maior deidade.2. Algoritmo;DeclareVar i, idade :inteiro;Iníciopara i←1 até 75 façaescreva (‘Digite a idade ’);leia (idade);se n >=18então escreva (‘Maior de idade’ )senão escreva (‘Menor de idade’ );fimse;fimpara;Fim.Escrever um algoritmo que leia o nome e o sexo de 56 pessoas e informe o nome e se ela é homemou mulher. No final informe total de homens e de mulheres.3. Algoritmo;DeclareVar i, ch, cm :inteiro;nome, sexo :string;Inícioch←0;cm←0;para i←1 até 56 façaescreva (‘Digite o nome: ’);leia (nome);escreva (‘Digite o sexo: ’);leia (sexo);se sexo =”M”então ch←ch+1senão cm←cm+1;fimse;fimpara;escreva (‘Das 56 pessoas ’ , ch , ‘são homens’);escreva (‘Das 56 pessoas ’ , cm , ‘são mulheres’);Fim.
  • 3. Faça um algoritmo que receba o preço de custo e o preço de venda de 40 produtos. Mostre comoresultado se houve lucro, prejuízo ou empate para cada produto. Informe media de preço de custo edo preço de venda4. Algoritmo;DeclareVar pcusto, pvenda, lucro:real;i :inteiro;nomeproduto :string;Iníciopara i←1 até 40 façaescreva (‘Digite o nome do produto: ’);leia (nomeproduto);escreva (‘Digite o preço de custo: ’);leia (pcusto);escreva (‘Digite o preço de venda: ’);leia (pvenda);se pvenda >pcustoentão escreva (‘deu lucro ’)senão se pvenda = pcustoentão escreva (‘empate, nem lucro, nem prejuízo ’)senão escreva (‘prejuízo ’);fimse;fimse;fimpara;Fim.Escreva um algoritmo para imprimir os números de 1 (inclusive) a 10 (inclusive) em ordem crescente.5. Algoritmo;DeclareVar i :inteiro;Iníciopara i←1 até 10 façaescreva (i);fimpara;Fim.
  • 4. Escreva um algoritmo para imprimir os números de 1 (inclusive) a 10 (inclusive) em ordemdecrescente.6. Algoritmo;DeclareVar i,c :inteiro;Inícioc←10;para i←1 até 10 façaescreva (c);c←c-1;fimpara;Fim.Escreva um algoritmo para imprimir os 10 primeiros números inteiros maiores que 100.7. Algoritmo;DeclareVar i :inteiro;Iníciopara i←101 até 110 façaescreva (i);fimpara;Fim.
  • 5. Ler um valor N e imprimir todos os valores inteiros entre 1 (inclusive) e N (inclusive). Considere que oN será sempre maior que ZERO.8. Algoritmo;DeclareVar i, n :inteiro;Inícioescreva (‘Digite um número maior que zero’);leia (n);para i←1 até n façaescreva (i );fimpara;Fim.Modifique o exercício anterior para aceitar somente valores maiores que 0 para N. Caso o valorinformado (para N) não seja maior que 0, deverá ser lido um novo valor para N.9. Algoritmo;DeclareVar i, n, parada :inteiro;Inícioescreva (‘Digite um número maior que zero’);leia (n);se n>0entãopara i←1 até n façaescreva (i );fimpara;fimse;Fim.Escreva um algoritmo que calcule e imprima a tabuada do 8 (1 a 10).10. Algoritmo;DeclareVar i,res :inteiro;Iníciopara i←1 até 10 façares←i*8;escreva (i , ‘ x ’, 8 , ‘ = ’, res );fimpara;Fim.
  • 6. Ler um valor inteiro (aceitar somente valores entre 1 e 10) e escrever a tabuada de 1 a 10 do valorlido.11. Algoritmo;DeclareVar i,res :inteiro;Inícioescreva (‘Digite um número maior que zero’);leia (n);se n>=1 e n<=10então iníciopara i←1 até 10 façares←i*n;escreva (i , ‘ x ’, n , ‘ = ’, res );fimpara;fim;fimse;Fim.Seja o seguinte algoritmo:12. Algoritmo ABC;DeclareVar x, y, z : inteiro;inícioler (x) ;ler (y);z ← (x*y) + 5 ;se z <= 0então escreva (‘A’ )senão se z <= 100então escreva (‘B’ )senão escreva (‘C’ );fim_se;fim_se;fim.
  • 7. Faça uma simulação (ou teste de mesa) que complete o quadro a seguir para os seguintesvalores:VariáveisX Y Z Resposta3 2 11 B150 3 455 C7 -1 -2 A-2 5 -5 A50 3 155 C