Your SlideShare is downloading. ×
Zadanie Z Logo TróJkąTy I Kwadraty
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×

Saving this for later?

Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime - even offline.

Text the download link to your phone

Standard text messaging rates apply

Zadanie Z Logo TróJkąTy I Kwadraty

3,620
views

Published on

Zadanie konkursowe z programowania w języku LOGO

Zadanie konkursowe z programowania w języku LOGO

Published in: Education, Design, Business

0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
3,620
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
4
Comments
0
Likes
0
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. ZADANIE 1 KT (KWADRATY I TRÓJKĄTY) Napisz procedurę KT :bok, która utworzy rusunek przedstawiony poniżej. Parametr :bok określa długość boku większego kwadratu. 1. Najpierw napiszmy procedurę wiatrak : bok rysującą 4 trójkąty ja na rysunku. Przyprostokątne trójkąta mają długość 0.25* *BOK (0.25*:bok*pwk 2) oto wiatrak :bok kwadrat :bok pod np :bok/2 pw 90 np :bok/2 lw 90 opu powtórz 4[np :bok/2 lw 135 np 0.25*:bok*pwk 2 lw 90 np 0.25*:bok*pwk 2 lw 45] powtórz 4[ lw 10 pod np 10 opu ukm "czerwony zamaluj pod ws 10 pw 10 pw 90 opu] już 2. Następnie napiszmy procedurę kwadraty :bok rysującą 4 kwadraty w rogach większego kwadratu.
  • 2. oto kwadraty :bok powtórz 4[np :bok/2 pw 90 np :bok/4 kwadrat :bok/4 pw 10 pod np 10 opu ukm "zielony zamaluj pod ws 10 lw 10 opu ws :bok/4 lw 90 ws :bok/2 pw 90] już 3 . Zapiszmy w jednej procedurze procedury: wiatrak i kwadraty oto KT :bok wiatrak :bok kwadraty :bok już