Aula 9 - Resultado Operandos Matemáticos, Operadores Aritmeticos, Relacionais e Lógicos

4,934 views
4,656 views

Published on

Published in: Technology
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
4,934
On SlideShare
0
From Embeds
0
Number of Embeds
283
Actions
Shares
0
Downloads
106
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Aula 9 - Resultado Operandos Matemáticos, Operadores Aritmeticos, Relacionais e Lógicos

  1. 1. Aula 9 – Resultado de Operandos Matemáticos, Operadores Relacionais e Lógicos Prof. André Constantino da Silva LOGT1 – Lógica Noturno 11 de maio de 2012
  2. 2. Na aula anterior...• Variáveis• Tipos de Dados - Inteiro - Real - Caractere - Lógico• Operadores - Atribuição - Matemáticos• Exercícios para entregar
  3. 3. Dúvidas?1. Escreva um algoritmo que leia um númerointeiro do usuário e calcule y, sendo que y écalculado pela fórmula y = 2x2. Escrever um algoritmo que leia um númerointeiro digitado pelo usuário e informe aousuário se ele é par ou ímpar3. Escrever um algoritmo que leia o nome deum aluno e as notas das três provas que eleobteve no semestre. No final informar o nomedo aluno e a sua média (aritmética).
  4. 4. Operadores Matemáticos (Revisão) Símbolo Ação Exemplo + Soma Soma <- 5 + 2 - Subtração Sub <- 5 – 2 * Multiplicação M <- 5 * 2 ? 52 MOD ? 5 MOD 2 / ? 5/2 ^ ? 5^2
  5. 5. Operadores Matemáticos (Revisão) Símbolo Ação Exemplo + Soma Soma <- 5 + 2 - Subtração Sub <- 5 – 2 * Multiplicação M <- 5 * 2 Divisão Inteira 52 Cuidado para MOD Resto da divisão 5 MOD 2 Cuidado para não não confundir! / Divisão confundir! 5/2 ^ Potenciação 5^2
  6. 6. Na aula de hoje...• Resultados dos operadores matemáticos• Operadores - Relacionais - Lógicos• Comando de Decisão Múltipla
  7. 7. Operadores Matemáticos• Operadores: +, - e * - O resultado dependerá dos operandos - Se os operandos forem inteiros, resultadoserá inteiro - Se houver algum operando real, resultadoserá real Observação: Se o resultado for inteiro, elepode ser atribuído a uma variável do tipo real
  8. 8. Exemplosalgoritmo "calculos"var a, b : inteiro x, y : real Qual deverá serinicio o tipo das a <- 6 variáveis c, d, w, b <- 12 x <- 5.5 z? y <- 8 c <- b + a z <- a * b + 4 d <- a * x w <- b – a + yfimalgoritmo
  9. 9. Exemplos - Respostaalgoritmo "calculos"var a, b, c, z : inteiro x, y, d , y : realinicio a <- 6 b <- 12 x <- 5.5 y <- 8 c <- b + a z <- a * b + 4 d <- a * x w <- b – a + yfimalgoritmo
  10. 10. Operadores Matemáticos• Para o operador / - Resultado sempre real• Para os operadores e mod - somente operandos inteiros - resultado é inteiro, mas pode ser atribuído auma variável do tipo real• Para o operador ^ - Resultado sempre real
  11. 11. Exemplosalgoritmo "calculos"var a, b : inteiro x, y : realinicio Qual deverá ser a <- 6 o tipo das b <- 12 variáveis c, d, w, x <- 5.5 y <- 8 z, p, r? c <- b / a z <- b + x w <- b mod a d <- a x p <- x ^ x r <- (x ^ 2) mod afimalgoritmo
  12. 12. Exemplos - Respostaalgoritmo "calculos"var a, b, w : inteiro x, y, c, z, p : realinicio a <- 6 b <- 12 x <- 5.5 y <- 8 c <- b / a z <- b + x w <- b mod a d <- a x /* erro de compilação. X é real! */ p <- x ^ x r <- (x ^ 2) mod a /* erro de compilação. X é real! */fimalgoritmo
  13. 13. Qual o problema?Considere que a nota só pode ser um inteiro de 0 a 10algoritmo "media semestre"var nota1, nota2, nota3, soma, media: inteiroinicio escreva("Digite a primeira nota do aluno: ") leia(nota1) escreva("Digite a segunda nota do aluno: ") leia(nota2) escreva("Digite a terceira nota do aluno: ") leia(nota3) soma <- nota1 + nota2 + nota3 media <- soma / 3 escreva("A média do aluno é: ", media)fimalgoritmo
  14. 14. Qual o problema? - Resposta Considere que a nota só pode ser um inteiro de 0 a 10algoritmo "media semestre"var nota1, nota2, nota3, soma: inteiro media: realinicio escreva("Digite a primeira nota do aluno: ") leia(nota1) escreva("Digite a segunda nota do aluno: ") leia(nota2) escreva("Digite a terceira nota do aluno: ") leia(nota3) soma <- nota1 + nota2 + nota3 media <- soma / 3 escreva("A média do aluno é: ", media)fimalgoritmo
  15. 15. Operadores RelacionaisSímbolo Ação Exemplo Resutado = Igual 2=3 Falso > Maior 5>2 Verdadeiro < Menor 5<2 Falso >= Maior ou igual 3 >= 3 Verdadeiro <= Menor ou igual 2 <= 3 Verdadeiro <> diferente 5 <> 7 Verdadeiro
  16. 16. Operadores Relacionais• O resultado de um operador relacional sempre será um valor lógico (verdadeiro ou falso)
  17. 17. Exercícios1. Faça um algoritmo que receba um número emostre uma mensagem caso este número sejamaior ou igual a 10.2. Escrever um algoritmo que leia dois valoresinteiros distintos e informe qual é o maior.3. Faça um algoritmo que leia dois números eidentifique se são iguais ou diferentes. Casoeles sejam iguais imprima uma mensagemdizendo que eles são iguais. Caso sejamdiferentes, informe qual número é o maior, euma mensagem que são diferentes.
  18. 18. Operadores LógicosSímbolo Ação Exemplo Resutado ou Escolhe 7>5e2>5 Falso e Une 5> 7 ou 2 > 5 Verdadeiro nao Nega nao (5 > 2) Falso
  19. 19. Operadores Lógicos• O resultado de um operador lógico ou expressão lógica sempre será um valor lógico (verdadeiro ou falso)
  20. 20. Exercícios1. Faça um algoritmo que receba um número ediga se este número está no intervalo entre100 e 200.2. Faça um algoritmo que leia um número eemita as seguintes mensagens para osseguintes casos Condição Mensagem a exibir De 1 a 9 Um dígito Entre 10 e 99 Dois dígitos Entre 100 e 999 Três digítos Entre 1.000 e 9999 Quatro dígitos Maior que 10.000 Cinco ou mais dígitos
  21. 21. Esse algoritmo executa?algoritmo "calculos"var condicao: logico a, b: inteiroinicio leia(a) leia(b) condicao <- (a = b) se (condicao) entao escreva("Os dois numeros sao iguais") senao escreva("Os dois numeros sao diferentes") fimsefimalgoritmo
  22. 22. Esse algoritmo executa?algoritmo "calculos"var condicao: logico a, b: inteiroinicio Parte leia(a) duvidosa! leia(b) condicao <- (a = b) se (condicao) entao escreva("Os dois numeros sao iguais") senao escreva("Os dois numeros sao diferentes") fimsefimalgoritmo
  23. 23. Esse algoritmo executa?algoritmo "calculos"var condicao: logico a, b: inteiro Masinicio leia(a) funciona! leia(b) Teste! condicao <- (a = b) se (condicao) entao escreva("Os dois numeros sao iguais") senao escreva("Os dois numeros sao diferentes") fimsefimalgoritmo
  24. 24. O que é o “se-senao” e “se- senao-entao”?
  25. 25. Cuidado!“Se-senao” e “se-senao-entao” nãoexistem em portugol!As instruções são: - se-entao - se-entao-senaoSão os comandos de decisão simplese duplas, também conhecidos comodesvios condicionais
  26. 26. Próxima aula...• Comando de Decisão Múltipla• Comandos de Repetição

×