Your SlideShare is downloading. ×
なでしこで、なんか作ってみた
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×
Saving this for later? Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime – even offline.
Text the download link to your phone
Standard text messaging rates apply

なでしこで、なんか作ってみた

562
views

Published on

Published in: Entertainment & Humor

0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
562
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
2
Comments
0
Likes
0
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. 2010-04-15-YanoLab.LT なでしこで、なんか作ってみた M1 村上
  • 2. なでしこについて
    • なでしことは?
      • クジラ飛行机(くじらひこうづくえ)氏が制作した
      • 3. インタプリタ方式のスクリプト型の言語
      • 名前の由来はサッカー日本女子代表
      • 4. 「なでしこジャパン」より
      • 5. 同作者の「ひまわり」の後継言語
  • 6. なでしこの特徴
      日本語 でプログラミングできる
  • 7. たとえば・・・ #include<stdio.h> int main(void) { int x=0; puts(“x の値を入力” ); scanf(“%d”, &x); if(x == 1){ printf(“x は 1 です ”); }else{ printf(“x は 1 ではありません ”); } }
  • 8. なでしこで書くと xは0 「xの値を入力」と尋ねて、xに代入。 もし、xが「 1 」ならば   「 x は 1 です」と表示。 違えば   「 x は 1 ではありません」と表示。
  • 9. 比較 #include<stdio.h> int main(void) { int x=0; puts(“x の値を入力” ); scanf(“%d”, &x); if(x == 1){ printf(“x は 1 です ”); } else{ printf(“x は 1 ではありません ”); } } xは0 「xの値を入力」と尋ねて、xに代入。 もし、xが「 1 」ならば   「 x は 1 です」と表示。 違えば   「 x は 1 ではありません」と表示。
  • 10. 開発ゼミが楽しそうだったので
    • 電卓作ってみた
  • 11. いいわけ
    • 1 日で適当に作った。バグ勘弁
    • 12. ソースぐちゃぐちゃ
    • 13. ÷ 0って何?おいしいの?
  • 14. 感想
    • プログラム入門にはいいかも
    • 15. とりあえず全角半角混じりソース気持ち悪い
    • 16. 小学生とかに遊びとしてプログラム組ませたりも出来そう
    • 17. 開発環境が標準で用意されてる
    • 18. GUI が意外と充実してる
    • 19. Word や Excel と連携が取れるらしい
    • 20. でもやっぱりソース気持ち悪い
  • 21. まとめ
    • 興味があったらやってみてもいいかも
    • 22. 日本語でソースを書く気持ち悪さを
    • 23. 体験できる