• Like
TABLEUR Excel
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

TABLEUR Excel

  • 476 views
Published

 

Published in Education
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Be the first to comment
    Be the first to like this
No Downloads

Views

Total Views
476
On SlideShare
0
From Embeds
0
Number of Embeds
0

Actions

Shares
Downloads
55
Comments
0
Likes
0

Embeds 0

No embeds

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
    No notes for slide

Transcript

  • 1. Tableur Excel 1
  • 2. Initiation au tableur Excel ➲ Qu’est-ce qu’un tableur ?  Un tableur est un logiciel qui permet de faire des calculs à partir d'un tableau de données. ➲ Quelle utilité ?  Création de tableaux  Calculs mathématiques, statistiques et financiers sur les données  Construire des graphiques (courbes, histogrammes...)  Constituer une base de données (taille limitée)  Manipuler un grand nombre de données très rapidement ➲ Plusieurs tableurs  Excel (Suite Microsoft Office)  OpenOffice Calc (OpenOffice Suite)  Mêmes fonctionnalités 2
  • 3. Les composants • Les données (texte, nombres, dates, …) sont stockées dans des cellules. Référence de la cellule Classeur Cellule Colonne • Chaque cellule se trouve à l’intersection d’une ligne et d’une colonne dans une feuille de calcul. • Un classeur est un ensemble de feuilles de calcul. Ligne 3 Feuille de calcul
  • 4. Saisie de données sous Excel • Saisie direct dans la cellule • Saisie dans la zone de formule • Validation ou annulation 4
  • 5. Utilisation des fonctions de calcul • Pour effectuer un calcul dans un tableur, on utilise une « formule de calcul » que l’on saisit à l’intérieur de la cellule • Une formule de calcul commence toujours par le symbole = • Exemples: =25+3 =C9-45+B14 5
  • 6. Utilisation des fonctions de calcul • • • • • • • • Les calculs « simples » s’effectuent directement avec des symboles opératoires: Somme : =C4+E7 Différence : =C4-E7 Produit : =C4*E7 Division : =C4/E7 Puissance : =C4^E7 Pourcentage : =C4/E7% idem que =C4/(E7/100) Parenthèses : =C4+(E7-G6*5)/D9 6
  • 7. Utilisation des fonctions de calcul • Pour les calculs « complexes », on peut utiliser une fonction automatique • Une fonction automatique permet d’effectuer un calcul prédéfini à partir de différents « arguments » qui sont les paramètres d’utilisation de cette fonction • Exemple: la fonction SOMME =SOMME(nombre1;nombre2;...) 7
  • 8. Utilisation des fonctions de calcul • La syntaxe d’une fonction est toujours la même : =Fonction (arg1;arg2;…) Un nom de fonction qui désigne la fonction à appliquer Une série d’arguments entre parenthèses et séparés par des points-virgules qui permettent l’utilisation de la fonction 8
  • 9. Utilisation des fonctions de calcul • Avec la fonction SOMME la syntaxe est : = SOMME ( nombre1;nombre2 ;…) Additionne tous les nombres contenus dans une plage de cellules nombre1, nombre2, ... représentent de 1 à 30 arguments dont vous voulez calculer la valeur totale ou somme 9
  • 10. Utilisation des fonctions de calcul • Les fonctions sont accessibles dans Excel de différentes façons: – En saisie directe au clavier – Par le menu déroulant « Insertion / Fonctions » – Par la barre de formule (en cliquant sur fx) – Par la barre d’outils Standard Versions antérieures à Excel 2003 Version Excel 2003 10
  • 11. Les fonctions les plus utilisées Nom / Syntaxe Rôle Arguments SOMME Additionne tous les nombres contenus dans une plage de cellules nombre1, nombre2, ... représentent de 1 à 30 arguments dont vous voulez calculer la valeur totale ou somme Renvoie la moyenne (arithmétique) des arguments nombre1,nombre2, ... représentent les 1 à 30 arguments numériques dont vous voulez obtenir la moyenne =SOMME(nombre1;nombre2;...) MOYENNE =MOYENNE(nombre1;nombre2;...) 11
  • 12. Les fonctions les plus utilisées Nom / Syntaxe MIN =MIN(nombre1;nombre2;...) MAX =MAX(nombre1;nombre2;...) NB =NB(valeur1;valeur2;...) Rôle Arguments Renvoie le plus petit nombre de la série de valeurs nombre1, nombre2, … représentent les 1 à 30 nombres parmi lesquels vous souhaitez trouver la valeur minimale Renvoie le plus grand nombre de la série de valeurs nombre1, nombre2, … représentent les 1 à 30 nombres parmi lesquels vous souhaitez trouver la valeur la plus grande Détermine le valeur1,valeur2, ... nombre de représentent les 1 à 30 cellules contenant arguments qui peuvent des nombres dans contenir ou référer à différents types de données, mais seuls la liste des les nombres sont comptés arguments 12
  • 13. Utilisation des fonctions de calcul Les différentes catégories de fonctions • Excel compte 10 catégories regroupant 236 fonctions : – – – – – – – – – – Finances (16) Date & heure (14) Math & Trigo (50) Statistiques (80) Recherche & Matrices (18) Base de données (12) Texte (24) Logique (6) Informations (15) Personnalisées (1) 13
  • 14. Utilisation des fonctions de calcul • Utilisation de l’assistant (3 étapes) – Sélection de la fonction dans la liste – Saisie des différents arguments de la fonction (un par ligne) • Soit directement au clavier • Soit par sélection d’une ou plusieurs cellules (plage) en tant qu’argument grâce au bouton – Validation de la formule 14
  • 15. Utilisation des fonctions de calcul • Utilisation de l’assistant (Exemple de la fonction MOYENNE) 15
  • 16. La fonction SOMME • Les arguments de cette fonction sont soit des valeurs numériques, soit des références à des cellules ou à des plages de cellules. Résultat =SOMME(1;2;3) 6 =SOMME(C2;C7) 30 =SOMME(C2:C7) 72 16
  • 17. La fonction SOMME Utilisation du bouton Sur une plage sélectionnée au préalable: La fonction SOMME est ajoutée en bas de chaque colonne (valeurs sommées en colonnes) Sur une plage NON sélectionnée: La fonction SOMME est ajoutée automatiquement en bas de chaque colonne. Vous pouvez modifier la zone sommée à la souris le cas échéant Remarque : si les valeurs sommées sont en ligne la somme se place sur la cellule la plus à droite de chaque ligne 17
  • 18. La fonction MOYENNE • Cette fonction a le même type d’arguments que la fonction SOMME. Elle permet d’obtenir la moyenne des différentes valeurs saisies comme argument. Résultat =MOYENNE(1;2;3) 2 =MOYENNE(C2;C7) 15 =MOYENNE(C2:C7) 12 18
  • 19. La fonction NB • Cette fonction compte le nombre de valeurs numériques contenues dans les cellules concernées, c’est un COMPTEUR (autre nom de la fonction) • Elle ne tient aucun compte des cellules vides et des cellules contenant des valeurs de type alphanumérique (texte) =NB(A1;A7) =NB(A1:A7) Résultat 1 3 19
  • 20. Les fonctions MIN et MAX • • La fonction MIN donne la valeur numérique minimale parmi les valeurs données en argument (valeurs numériques ou valeurs contenues dans une ou plusieurs cellules) La fonction MAX donne la valeur numérique maximale parmi les valeurs données en argument (valeurs numériques ou valeurs contenues dans une ou plusieurs cellules) =MIN(14;5;6;9) =MAX(14;5;6;9) =MIN(C2:C7) =MAX(C2:C7) =MAX(C3;C5) Résultat 5 14 7 17 9 20
  • 21. Mettre en forme un tableau  Mettre en forme le contenu (les données)  Sélectionner la ou les cellules concernées  Menu Format/Cellule ou clic droit ou barre de mise en forme Format des données (nombres, pourcentages, dates, etc…) Format de la cellule (fusionner, fractionner, alignement horizontal, alignement vertical…) Police Etc…  Mettre en forme le contenant  Modifier la hauteur d’une ligne ou la largeur d’une colonne  Directement sur la feuille de calcul, pointer le curseur sur un bord dans la marge Pour appliquer la modification à plusieurs lignes ou colonnes, il faut les sélectionner au préalable  Menu Format/Ligne ou Colonne Possibilité d’ajuster automatiquement la hauteur ou la largeur au contenu  Mettre des bordures 21  Menu Format/Bordures et Trames ou raccourci barre des outils
  • 22. Mise en forme sous Excel • Menu Format/Cellule … 22
  • 23. Mises en forme automatiques Menu Format/Mise en forme automatique  Pour soigner et personnaliser votre tableau en fonction de modèles Menu Format/Mise en forme conditionnelle  Pour faire ressortir des données à l’intérieur d’un tableau  Ex : mettre en rouge toutes les notes inférieures à 10 23
  • 24. Créer un graphique • Exemple 24
  • 25. Imprimer un document Excel  ATTENTION !  Utiliser le mode « Aperçu avant impression » pour visualiser ce que vous allez imprimer (très souvent différent de ce qu’on voit à l’écran) Menu Fichier/Aperçu avant impression  Menu Fichier>Mise en page pour modifier les paramètres de l’impression  En-tête et pied de page 25
  • 26. Références relatives et références absolues • Définition – Par défaut, le tableur manipule les cellules d’une feuille selon des références relatives. Ainsi, bien que les arguments de la formule désignent a priori des cellules précises (A2, B7…), le tableur les interprète relativement à la cellule courante. Ainsi, la référence A2, lorsque la formule se trouve en B2, désigne « la cellule qui se trouve dans la colonne précédente sur la même ligne » – C’est ce qui explique que lorsqu’on copie une formule vers d’autres cellules, le tableur adapte automatiquement la formule copiée suivant les coordonnées des nouvelles cellules. – Il peut arriver que ce fonctionnement ne soit pas adapté. Par exemple, lorsqu’une cellule est utilisée par toutes les formules. Dans ce cas, il faut utiliser une notation de référence absolue. Pour cela, il suffit de mettre le signe « $ » devant la lettre de la colonne et devant le n ° de la ligne désignant la référence de la cellule à fixer. 26
  • 27. Références relatives et références absolues • Exemple 27
  • 28. Les fonctions Logiques La fonction SI • Syntaxe = SI ( test_logique ; valeur_si_vrai ; valeur_si_faux ) Test logique > supérieur < inférieur = égal à <> différent de >= supérieur ou égal <= inférieur ou égal Valeur de la cellule si la condition du test est VERIFIEE Valeur de la cellule si la condition du test N’EST PAS VERIFIEE 28
  • 29. Les fonctions Logiques La fonction SI • La fonction SI permet de définir le contenu d’une cellule (valeur) en fonction d’une condition • Exemples : =SI(B2>=10;‘‘Reçu(e)’’;‘‘Ajourné(e)’’) =SI(G4<>10;150;300) =SI(Commande=‘‘oui’’;G9+1;G9-1) 29
  • 30. Les fonctions Logiques La fonction SI • Imbrication de la fonction SI (3 possibilités) SI(Cond_1 ; ValeurSIVrai ; SI(Cond_2 ; ValeurSIvrai ; ValeurSIfaux)) • Exemple =SI(B2>0; "Positif";SI(B2<0; "Négatif";"Nul")) 30
  • 31. Les fonctions logiques Compléments de la fonction SI • Les fonctions logiques permettent de construire des expressions logiques à partir d’expressions conditionnelles. • Exemples : – ET : tous les critères doivent être satisfaits • La syntaxe : ET(valeurlogique1;valeurlogique2;…) – OU : un des critères doit être satisfait • La syntaxe : OU(valeurlogique1;valeurlogique2;…) 31
  • 32. Erreurs de formule (et traitement) ► #NOM? ► #VALEUR! ► #DIV/0 ► #REF ► #N/A Texte non reconnu dans la formule. Valeur non numérique dans la formule. Existence d’un diviseur nul. Suppression d’une référence dans la formule. Capacité de calcul dépassée. 32
  • 33. Merci de votre attention Bon courage ! 33