Algoritmos e programação - Aula 8
Upcoming SlideShare
Loading in...5
×
 

Algoritmos e programação - Aula 8

on

  • 1,816 views

Slides referentes a 8ª aula da disciplina de Algoritmos e Programação, realizadana no dia 11/03/2011.

Slides referentes a 8ª aula da disciplina de Algoritmos e Programação, realizadana no dia 11/03/2011.

Statistics

Views

Total Views
1,816
Views on SlideShare
1,783
Embed Views
33

Actions

Likes
1
Downloads
81
Comments
0

4 Embeds 33

http://thyagomaia.net 23
http://algoritmos.thyagomaia.net 6
http://ead.unipe.br 3
http://www.algoritmos.thyagomaia.net 1

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Algoritmos e programação - Aula 8 Algoritmos e programação - Aula 8 Presentation Transcript

    • Algoritmos e Programação Thyago Maia Tavares de Farias Aula 9
    • Sumário
      • Estruturas de Repetição;
        • Enquanto...faca ;
    • Enquanto...faca
      • Nesta estrutura, a expressão lógica é avaliada e, se ela for verdadeira, a lista de comandos é executada;
      • A execução da lista se repete até que a avaliação da condição resulte em FALSO ;
      • Também é uma estrutura de repetição, semelhante à estrutura repita...ate ;
      • Difere da estrutura repita...ate na execução da lista, que pode ser executada ou não ;
    • Enquanto...faca
      • Utilizamos as palavras reservadas enquanto e faca para formar o laço de repetição;
      • Forma geral:
      • enquanto (condição) faca
      • // Lista de instruções
      • fimenquanto
    • Enquanto...faca
      • Exemplo - Algoritmo que lê diversos números positivos e escreve, para cada um, sua raiz quadrada:
      • algoritmo “comEnquanto”
      • var numero: numerico
      • inicio
      • leia(numero)
      • enquanto (numero >= 0) faca
      • escreval(numero^0.5)
      • leia(numero)
      • fimenquanto
      • fimalgoritmo
    • Enquanto...faca
      • Exemplo 2 - Algoritmo que escreve os números entre 1 e 10:
      • algoritmo “Mostra10”
      • var numero: inteiro
      • inicio
      • numero <- 1
      • enquanto (numero <= 10) faca
      • escreva(numero)
      • numero <- numero + 1
      • fimenquanto
      • fimalgoritmo
    • Exercício
      • Faça um algoritmo que recebe um número inteiro e, enquanto um número negativo não for digitado, verifica se o mesmo é menor que 5;
      • Faça um algoritmo que sempre recebe números pares. Caso receba um número ímpar, sua execução deverá ser encerrada