Algoritmos e programação - Aula 8

1,664 views
1,557 views

Published on

Slides referentes a 8ª aula da disciplina de Algoritmos e Programação, realizadana no dia 11/03/2011.

Published in: Technology
0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
1,664
On SlideShare
0
From Embeds
0
Number of Embeds
37
Actions
Shares
0
Downloads
86
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Algoritmos e programação - Aula 8

  1. 1. Algoritmos e Programação Thyago Maia Tavares de Farias Aula 9
  2. 2. Sumário <ul><li>Estruturas de Repetição; </li></ul><ul><ul><li>Enquanto...faca ; </li></ul></ul>
  3. 3. Enquanto...faca <ul><li>Nesta estrutura, a expressão lógica é avaliada e, se ela for verdadeira, a lista de comandos é executada; </li></ul><ul><li>A execução da lista se repete até que a avaliação da condição resulte em FALSO ; </li></ul><ul><li>Também é uma estrutura de repetição, semelhante à estrutura repita...ate ; </li></ul><ul><li>Difere da estrutura repita...ate na execução da lista, que pode ser executada ou não ; </li></ul>
  4. 4. Enquanto...faca <ul><li>Utilizamos as palavras reservadas enquanto e faca para formar o laço de repetição; </li></ul><ul><li>Forma geral: </li></ul><ul><li>enquanto (condição) faca </li></ul><ul><li>// Lista de instruções </li></ul><ul><li>fimenquanto </li></ul>
  5. 5. Enquanto...faca <ul><li>Exemplo - Algoritmo que lê diversos números positivos e escreve, para cada um, sua raiz quadrada: </li></ul><ul><li>algoritmo “comEnquanto” </li></ul><ul><li>var numero: numerico </li></ul><ul><li>inicio </li></ul><ul><li>leia(numero) </li></ul><ul><li>enquanto (numero >= 0) faca </li></ul><ul><li>escreval(numero^0.5) </li></ul><ul><li>leia(numero) </li></ul><ul><li>fimenquanto </li></ul><ul><li>fimalgoritmo </li></ul>
  6. 6. Enquanto...faca <ul><li>Exemplo 2 - Algoritmo que escreve os números entre 1 e 10: </li></ul><ul><li>algoritmo “Mostra10” </li></ul><ul><li>var numero: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>numero <- 1 </li></ul><ul><li>enquanto (numero <= 10) faca </li></ul><ul><li>escreva(numero) </li></ul><ul><li>numero <- numero + 1 </li></ul><ul><li>fimenquanto </li></ul><ul><li>fimalgoritmo </li></ul>
  7. 7. Exercício <ul><li>Faça um algoritmo que recebe um número inteiro e, enquanto um número negativo não for digitado, verifica se o mesmo é menor que 5; </li></ul><ul><li>Faça um algoritmo que sempre recebe números pares. Caso receba um número ímpar, sua execução deverá ser encerrada </li></ul>

×