Algoritmos e Programação - Aula 8

3,401
-1

Published on

Algoritmos e Programação - Aula 8

Published in: Technology
0 Comments
5 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
3,401
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
119
Comments
0
Likes
5
Embeds 0
No embeds

No notes for slide

Algoritmos e Programação - Aula 8

  1. 1. Algoritmos e Programação Thyago Maia Tavares de Farias Aula 8
  2. 2. Sumário <ul><li>Estruturas de Repetição; </li></ul><ul><ul><li>Para...faca ; </li></ul></ul>
  3. 3. Para...faca <ul><li>Nesta estrutura, uma variável de controle é inicializada com um valor inicial. Para cada iteração, seu valor é comparado com um valor final; </li></ul><ul><li>A execução da lista de instruções se repete até que a variável de controle seja maior que o valor final; </li></ul><ul><li>Para cada iteração, a variável de controle é incrementada; </li></ul>
  4. 4. Para...faca <ul><li>Utilizamos as palavras reservadas para , de , ate , faca e fimpara para formar o laço de repetição; </li></ul><ul><li>Forma geral: </li></ul><ul><li>para variavel de val_inicial ate val_final faca </li></ul><ul><li>// Lista de instruções </li></ul><ul><li>fimpara </li></ul>
  5. 5. Para...faca <ul><li>Exemplo - Algoritmo que escreve os números entre 1 e 5: </li></ul><ul><li>algoritmo “Mostra5” </li></ul><ul><li>var i: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>para i de 1 ate 5 faca </li></ul><ul><li>escreva(i) </li></ul><ul><li>fimpara </li></ul><ul><li>fimalgoritmo </li></ul>
  6. 6. Para...faca <ul><li>Para alterarmos a forma de contagem do laço (crescente ou decrescente) e quanto a variável de controle vai ser incrementada ou decrementada, utilizamos a palavra reservada passo , seguida de um valor; </li></ul><ul><li>Forma geral: </li></ul><ul><li>para variavel de val_inicial ate val_final passo valor faca </li></ul><ul><li>// Lista de instruções </li></ul><ul><li>fimpara </li></ul>
  7. 7. Para...faca <ul><li>Exemplo - Algoritmo que escreve os números pares entre 1 e 10: </li></ul><ul><li>algoritmo “Mostra10par” </li></ul><ul><li>var i: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>para i de 2 ate 10 passo 2 faca </li></ul><ul><li>escreva(i) </li></ul><ul><li>fimpara </li></ul><ul><li>fimalgoritmo </li></ul>
  8. 8. Exercícios – Para...faca <ul><li>Faça um algoritmo que lê 30 números inteiros. O mesmo deve calcular e exibir a média aritmética deles. </li></ul><ul><li>Utilizando a estrutura para...faca, escreva um algoritmo que mostre todos os números pares entre 0 a 100. </li></ul>
  9. 9. Exercícios – Para...faca <ul><li>Faça um algoritmo que lê o nome, o peso e o sexo de um grupo de 20 pessoas e calcula: </li></ul><ul><ul><li>A quantidade total de homens; </li></ul></ul><ul><ul><li>A quantidade total de mulheres; </li></ul></ul><ul><ul><li>A média de peso do grupo; </li></ul></ul>
  10. 10. Exercícios – Para...faca <ul><li>Faça um algoritmo que a idade de 10 pessoas. Em seguida, o algoritmo deverá apresentar: </li></ul><ul><ul><li>A idade do mais velho; </li></ul></ul><ul><ul><li>A idade do mais novo; </li></ul></ul><ul><ul><li>A quantidade de adolescentes (de 12 a 17 anos); </li></ul></ul>
  1. A particular slide catching your eye?

    Clipping is a handy way to collect important slides you want to go back to later.

×