Algoritmos e   g Programação    g     çThyago Maia Tavares de Farias           Aula 7
SumárioEstruturas de Repetição;              Repetição;  Repita...ate;  Repita...ate;    p
Repita...ate               Repita ateNesta estrutura, todas as instruções sãoexecutadas e uma expressão lógica é avaliada;...
Repita...ate               Repita ateUtilizamos as palavras reservadas repita e ateppara formar o laço de repetição;      ...
Repita...ate               Repita ateExemplo - Algoritmo que escreve os númerosde 1 a 10:algoritmo “Mostra10”var numero: i...
Repita...ate                 Repita ateExemplo 2 - Algoritmo que escreve os númerosPARES entre 1 e 10:algoritmo “Mostra10”...
Repita...ate              Repita ateAtenção: Cuidado com laços infinitos! Devemos                             infinitos!no...
Repita...ate             Repita ateExemplo 3 – Algoritmo com um laço infinito:algoritmo “lacoInfinito”           “lacoInfi...
Repita...ate                   Repita ateExemplo 4 – Algoritmo com um menu:algoritmo “menu”           menuvar opcao: intei...
ExercíciosEscreva um algoritmo que some os númerosentre 1 e 10, escrevendo o resultado final;            ,FaçaF um algorit...
ExercíciosFaça um algoritmo que lê a idade de 15 pessoase mostre a quantidade de pessoas q possui           q             ...
ExercíciosFaça um algoritmo que executa a divisão entredois números reais digitados pelo usuário (o                      g...
ExercíciosFaça um algoritmo que implementa o seguinteqquestionário: “Você é a favor da pena de morte                      ...
Upcoming SlideShare
Loading in …5
×

Algoritmos e programação - Aula 7

1,313 views
1,208 views

Published on

Algoritmos e programação - Aula 7

Published in: Technology
0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
1,313
On SlideShare
0
From Embeds
0
Number of Embeds
34
Actions
Shares
0
Downloads
51
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Algoritmos e programação - Aula 7

  1. 1. Algoritmos e g Programação g çThyago Maia Tavares de Farias Aula 7
  2. 2. SumárioEstruturas de Repetição; Repetição; Repita...ate; Repita...ate; p
  3. 3. Repita...ate Repita ateNesta estrutura, todas as instruções sãoexecutadas e uma expressão lógica é avaliada; p gSua lista de expressões se repete até que aavaliação da condição resulte emVERDADEIRO;VERDADEIRO;Cada repetição da lista de instruções contidas naest utu a c a ada iteração;estrutura é chamada de iteração; te ação ação;A estrutura Repita...ate também é conhecidacomo l laço d repetição; de repetição; i ã
  4. 4. Repita...ate Repita ateUtilizamos as palavras reservadas repita e ateppara formar o laço de repetição; ç p çForma geral:F lrepita p // Lista de instruçõesate expressão lógica
  5. 5. Repita...ate Repita ateExemplo - Algoritmo que escreve os númerosde 1 a 10:algoritmo “Mostra10”var numero: inteiroinicio numero <- 1 <- repita escreva(numero) numero <- numero + 1 // contador <- ate numero > 10fimalgoritmo
  6. 6. Repita...ate Repita ateExemplo 2 - Algoritmo que escreve os númerosPARES entre 1 e 10:algoritmo “Mostra10”var numero: inteiroinicio numero <- 1 <- repita se (numero % 2 = 0) entao escreva(numero) fimse numero <- numero + 1 // contador <- ate numero > 10fimalgoritmo
  7. 7. Repita...ate Repita ateAtenção: Cuidado com laços infinitos! Devemos infinitos!nos certificar que em algum momento a ifi lexpressão lógica próxima a palavra reservada ateserá FALSA!
  8. 8. Repita...ate Repita ateExemplo 3 – Algoritmo com um laço infinito:algoritmo “lacoInfinito” “lacoInfinito” lacoInfinitovar contador: inteiroinicio repita contador <- 1 <- escreva(contador) contador <- contador + 1 <- ate contador = 10fimalgoritmofi l it
  9. 9. Repita...ate Repita ateExemplo 4 – Algoritmo com um menu:algoritmo “menu” menuvar opcao: inteiro opcao:inicio repita escreval(“Cadastro escreval(“Cadastro de Clientes”) escreval( escreval(“1 escreval( 1 - Incluir”) (“1 Incluir ) escreval(“2 escreval(“2 - Alterar”) escreval(“3 escreval(“3 - Consultar”) escreval(“4 - Excluir”) escreval(“4 l l i ”) escreval(“5 escreval(“5 - Sair”) leia(opcao) leia(opcao) ate opcao = 5fimalgoritmo
  10. 10. ExercíciosEscreva um algoritmo que some os númerosentre 1 e 10, escrevendo o resultado final; ,FaçaF um algoritmo que lê número pares l i úrepetidamente até que um número ímpar sejadigitado;
  11. 11. ExercíciosFaça um algoritmo que lê a idade de 15 pessoase mostre a quantidade de pessoas q possui q p que pidades entre 0 e 12 anos;
  12. 12. ExercíciosFaça um algoritmo que executa a divisão entredois números reais digitados pelo usuário (o g p (algoritmo deverá evitar a divisão por zero,repetindo a solicitação de um novo númeroenquanto o usuário digitar 0 para odenominador);d i d r)
  13. 13. ExercíciosFaça um algoritmo que implementa o seguinteqquestionário: “Você é a favor da pena de morte pno Brasil? Sim (s) ou Não (n)? Digite fim paraencerrar o algoritmo”. Após o encerramento da algoritmoleitura dos votos, o algoritmo deverá apresentara quantidade e a porcentagem de votos para tid d p r t d t p rcada opção;

×